1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

[How To] Root / Werkseinstellung / Systemupdate

Dieses Thema im Forum "Root / Custom-ROMs / Modding für Huawei Ascend Y200" wurde erstellt von det-happy, 31.05.2012.

  1. det-happy, 31.05.2012 #1
    det-happy

    det-happy Threadstarter Ehrenmitglied

    Beiträge:
    6,598
    Erhaltene Danke:
    3,153
    Registriert seit:
    26.04.2012
    Phone:
    Xiaomi Redmi 1S
    Tablet:
    Lenovo IdeaPad A8-50
    Das HowTo Root wurde zwischenzeitlich ins DroidWiki ausgelagert

    Huawei Y200/Root
     
    Zuletzt bearbeitet: 06.02.2013
    androrich, Habernatz, florian24 und 26 andere haben sich bedankt.
  2. det-happy, 31.05.2012 #2
    det-happy

    det-happy Threadstarter Ehrenmitglied

    Beiträge:
    6,598
    Erhaltene Danke:
    3,153
    Registriert seit:
    26.04.2012
    Phone:
    Xiaomi Redmi 1S
    Tablet:
    Lenovo IdeaPad A8-50
    Auf Werkseinstellung setzen.

    Hiermit wird das Telefon wieder auf dem Auslieferungszustand gesetzt.

    Das mag notwendig sein beim Wiederverkauf, bei Einsenden zur Werkstatt, wenn man sowohl Displaysperre als auch google Passwort vergessen hat, oder wenn man als root aus versehen die falsche Datei gelöscht hat.


    ACHTUNG: Hiermit gehen sämtliche persönlichen Daten (Kalender, Kontakte, Lesezeichen, Dokumente verloren. Auch ein rooting wird damit wieder entfernt)


    Variante 1: Factory Reset
    Anleitung im Wiki

    Variante 2: Firmware neu flashen

     

    Anhänge:

    Zuletzt bearbeitet: 03.07.2013
    Rauscher, klausl, florian24 und 9 andere haben sich bedankt.
  3. det-happy, 31.05.2012 #3
    det-happy

    det-happy Threadstarter Ehrenmitglied

    Beiträge:
    6,598
    Erhaltene Danke:
    3,153
    Registriert seit:
    26.04.2012
    Phone:
    Xiaomi Redmi 1S
    Tablet:
    Lenovo IdeaPad A8-50
    Platzhalter
     
    Zuletzt bearbeitet: 01.06.2012
  4. Einmaliger, anonymer Poster, 02.06.2012 #4
    Einmaliger, anonymer Poster

    Einmaliger, anonymer Poster Gast

    Feine Anleitung, aber muss im ersten Schritt eigentlich beides im Verzeihnis des y200, also auch activesync 4.5 (link darauf) installiert werden?

    Und nicht vergessen: im entpackten Paket "cwm-recovery.img" in "recovery.img" umbenennen, der Patch findet es sonst nicht :glare:


    Allerdings habe ich trotz befolgter Anweisung noch kein root! Hmmm ...


    a.z.
     
    Zuletzt von einem Moderator bearbeitet: 02.06.2012
  5. Ryuk, 02.06.2012 #5
    Ryuk

    Ryuk Android-Lexikon

    Beiträge:
    1,010
    Erhaltene Danke:
    207
    Registriert seit:
    19.09.2011
    wenn man die cwm-recovery flasht, dann brauch man su eigtl. nicht mehr unbedingt pushen, man kann auch einfach diese zip über "install zip from sd" in der cwm installieren...
     
  6. det-happy, 02.06.2012 #6
    det-happy

    det-happy Threadstarter Ehrenmitglied

    Beiträge:
    6,598
    Erhaltene Danke:
    3,153
    Registriert seit:
    26.04.2012
    Phone:
    Xiaomi Redmi 1S
    Tablet:
    Lenovo IdeaPad A8-50
    Zuletzt bearbeitet: 03.06.2012
  7. Strongman99, 03.06.2012 #7
    Strongman99

    Strongman99 Neuer Benutzer

    Beiträge:
    1
    Erhaltene Danke:
    0
    Registriert seit:
    03.06.2012
    hallo det-happy :)
    also ich muss zugeben ich hab einige probleme mit der anleitung...
    aaaaalso:
    1. "Es erscheint ein neues CD-Laufwerk, wo auch ein Ordner „drivers“ drin ist. Bitte den Treiber installieren" <--- welcher treiber ist da gemeint? wo finde ich diesen?
    2. "Lade dir das Paket runter und Entpacke es in einem Ordner auf dem PC" <--- gleiches problem... welches paket ist gemeint? wo finde ich dieses?

    bitte um schnelle antwort, dass ich mein android schnell rooten kann und mir endlich ein paar gute apps zulegen kann :)

    danke im vorraus und LG Strongman99
     
  8. det-happy, 03.06.2012 #8
    det-happy

    det-happy Threadstarter Ehrenmitglied

    Beiträge:
    6,598
    Erhaltene Danke:
    3,153
    Registriert seit:
    26.04.2012
    Phone:
    Xiaomi Redmi 1S
    Tablet:
    Lenovo IdeaPad A8-50
    Der Treiber ist dieser:

    Code:
    CD-ROM:\drivers\adb_driver
    Und unter dem ersten Beitrag von mir ist eine Datei angehängt
     
  9. lordover, 04.06.2012 #9
    lordover

    lordover Neuer Benutzer

    Beiträge:
    9
    Erhaltene Danke:
    0
    Registriert seit:
    08.05.2012
    Nachdem ich erfolgreich root habe, will ich Link2sd installieren mein Y200
    sagt nicht genügend Speicher vorhanden.
    Was muss ich jetzt tun?
    Danke für die Hilfe.
    LO
     
  10. det-happy, 04.06.2012 #10
    det-happy

    det-happy Threadstarter Ehrenmitglied

    Beiträge:
    6,598
    Erhaltene Danke:
    3,153
    Registriert seit:
    26.04.2012
    Phone:
    Xiaomi Redmi 1S
    Tablet:
    Lenovo IdeaPad A8-50
    D.h. das dein interner speicher zu voll ist, als das du noch Link2SD installieren kannst. Hau mal 2-3 Apps wieder runter und versuch es dann erneut.
     
  11. lordover, 04.06.2012 #11
    lordover

    lordover Neuer Benutzer

    Beiträge:
    9
    Erhaltene Danke:
    0
    Registriert seit:
    08.05.2012
    ich lade runter über goolg playstore Link2SD von Bulent Akpinar.
    Größe 684 KB, Telefon sagt datei gespeichert unter loadfile.apk dann erscheint sofort die Meldung Telefonspeicher voll.
    Vielleicht lade ich an der falschen quelle Link2SD runter?

    Der ursprüngliche Beitrag von 11:59 Uhr wurde um 12:02 Uhr ergänzt:

    hat funktioniert danke
     
  12. det-happy, 04.06.2012 #12
    det-happy

    det-happy Threadstarter Ehrenmitglied

    Beiträge:
    6,598
    Erhaltene Danke:
    3,153
    Registriert seit:
    26.04.2012
    Phone:
    Xiaomi Redmi 1S
    Tablet:
    Lenovo IdeaPad A8-50
    Freut mich.
    Da drück doch mal den Danke Button unter meine Beiträgen ;)
     
    Looxer und lordover haben sich bedankt.
  13. androi4fun, 04.06.2012 #13
    androi4fun

    androi4fun Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    1
    Registriert seit:
    22.05.2012
    Bin exakt nach Anleitung im Startposting vorgegangen. "Scheinbar" lief auch alles ordnungsgemäß durch.

    Der Root-Checker sagt mir aber nun ich ich habe keinen Root Zugriff.

    Wo kann der Fehler liegen ?
     
  14. lordover, 04.06.2012 #14
    lordover

    lordover Neuer Benutzer

    Beiträge:
    9
    Erhaltene Danke:
    0
    Registriert seit:
    08.05.2012
    Ich habe es auch erst im 2. Anlauf geschafft, du musst bei abspielen der
    Batchdatei sicherstellen das dein Handy unter Arbeitsplatz als Wechseldatenträger sichtbar ist, also quasi mit PC verbunden ist zum Zeitpunkt des Programmablaufes. Das Batchprogramm schreibt im Ausführfenster kopie erfolgreich andersfalls siehst du im Ausführfenster "fehler bei Kopie" oder so ähnlich..
     
  15. androi4fun, 04.06.2012 #15
    androi4fun

    androi4fun Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    1
    Registriert seit:
    22.05.2012
    Hallo,
    ich habe es nochmal versucht.
    Nach Einschalten+Plustaste bleibt das Bootlogo bereits nicht mehr stehen, sondern ich gelange dann sofort in das "ClockworkMod Recovery" Menü.
    Wenn dann der Batchfileprozess mit Enter bestätigt wird, erfolgen folgende Meldungen (siehe Spoiler) und dann is angeblich alles fertig. :unsure:
    Funzt aber nicht ....

    Bevor ich auf Enter drücke, ist das Handy natürlich per USB angesteckt und es werden zwei Laufwerksbuchstaben verbunden. Wenn ich im (PC)Windows-Explorer auf die Laufwerksbuchstaben klicke, bekomme ich allerdings keinerlei Inhalte angezeigt. Normal ?

    Bitte erst dann Bestõtigen auf ENTER druecken, wenn das Geraet im
    Recovery Modus gesstartet und wieder am USB angeschlossen ist

    Drücken Sie eine beliebige Taste . . .

    Installiere Superuser
    Nicht ³ber die ganzen Fehlermeldungen wundern

    Android Debug Bridge version 1.0.26

    -d - directs command to the only connected USB devic
    e
    returns an error if more than one USB device is
    present.
    -e - directs command to the only running emulator.
    returns an error if more than one emulator is r
    unning.
    -s <serial number> - directs command to the USB device or emulator w
    ith
    the given serial number. Overrides ANDROID_SERI
    AL
    environment variable.
    -p <product name or path> - simple product name like 'sooner', or
    a relative/absolute path to a product
    out directory like 'out/target/product/sooner'.

    If -p is not specified, the ANDROID_PRODUCT_OUT

    environment variable is used, which must
    be an absolute path.
    devices - list all connected devices
    connect <host>:<port> - connect to a device via TCP/IP
    disconnect <host>:<port> - disconnect from a TCP/IP device

    device commands:
    adb push <local> <remote> - copy file/dir to device
    adb pull <remote> [<local>] - copy file/dir from device
    adb sync [ <directory> ] - copy host->device only if changed
    (see 'adb help all')
    adb shell - run remote shell interactively
    adb shell <command> - run remote shell command
    adb emu <command> - run emulator console command
    adb logcat [ <filter-spec> ] - View device log
    adb forward <local> <remote> - forward socket connections
    forward specs are one of:
    tcp:<port>
    localabstract:<unix domain socket name>
    localreserved:<unix domain socket name>
    localfilesystem:<unix domain socket name>
    dev:<character device name>
    jdwp:<process pid> (remote only)
    adb jdwp - list PIDs of processes hosting a JDWP transport

    adb install [-l] [-r] [-s] <file> - push this package file to the device and i
    nstall it
    ('-l' means forward-lock the app)
    ('-r' means reinstall the app, keeping its data
    )
    ('-s' means install on SD card instead of inter
    nal storage)
    adb uninstall [-k] <package> - remove this app package from the device
    ('-k' means keep the data and cache directories
    )
    adb bugreport - return all information from the device
    that should be included in a bug report.

    adb help - show this help message
    adb version - show version num

    DATAOPTS:
    (no option) - don't touch the data partition
    -w - wipe the data partition
    -d - flash the data partition

    scripting:
    adb wait-for-device - block until device is online
    adb start-server - ensure that there is a server running
    adb kill-server - kill the server if it is running
    adb get-state - prints: offline | bootloader | device
    adb get-serialno - prints: <serial-number>
    adb status-window - continuously print device status for a specifie
    d device
    adb remount - remounts the /system partition on the device re
    ad-write
    adb reboot [bootloader|recovery] - reboots the device, optionally into the boo
    tloader or recovery program
    adb reboot-bootloader - reboots the device into the bootloader
    adb root - restarts the adbd daemon with root permissions
    adb usb - restarts the adbd daemon listening on USB
    adb tcpip <port> - restarts the adbd daemon listening on TCP on th
    e specified port
    networking:
    adb ppp <tty> [parameters] - Run PPP over USB.
    Note: you should not automatically start a PPP connection.
    <tty> refers to the tty for PPP stream. Eg. dev:/dev/omap_csmi_tty1
    [parameters] - Eg. defaultroute debug dump local notty usepeerdns

    adb sync notes: adb sync [ <directory> ]
    <localdir> can be interpreted in several ways:

    - If <directory> is not specified, both /system and /data partitions will be u
    pdated.

    - If it is "system" or "data", only the corresponding partition
    is updated.
    1397 KB/s (22364 bytes in 0.015s)
    2928 KB/s (843503 bytes in 0.281s)


    Fertig (hoffentlich)

    Drücken Sie eine beliebige Taste . . .

    EDIT:
    Wiederherstellung des Originalzustandes (entsprechend Anleitung V4.1) klappt leider auch nicht !
    Es erfolgt lediglich eine Meldung das auf Device gewartet wird.
    Offenbar kommt das Gerät nicht mehr in den Fastboot Modus ?
    Was läuft verkehrt ??? :ohmy:
     
    Zuletzt bearbeitet: 04.06.2012
  16. det-happy, 04.06.2012 #16
    det-happy

    det-happy Threadstarter Ehrenmitglied

    Beiträge:
    6,598
    Erhaltene Danke:
    3,153
    Registriert seit:
    26.04.2012
    Phone:
    Xiaomi Redmi 1S
    Tablet:
    Lenovo IdeaPad A8-50
    Ich habe mal die für den Benutzer umständlichere, aber dafür Ausführungstechnisch Sichere Version 5.1 im ersten Beitrag hochgeladen. Versuch damit mal
     
  17. androi4fun, 05.06.2012 #17
    androi4fun

    androi4fun Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    1
    Registriert seit:
    22.05.2012
    Also die Batchdatei findet nach wie vor kein Device (mehr), warum auch immer. :unsure:
    Da es bei meinem allerersten Versuch (mit V5.0) aber bereits bis zu diesem Punkt mal geklappt hatte, habe ich nun den Recovery-Modus aktiviert und habe wie beschrieben die Superuser Zip installiert.
    Root-Checker meldet nun endlich Erfolg. :biggrin:

    Wenn ich mir die einzelnen Auflistungen im Root-Checker anschaue, steht da nun Status Rooted etc., allerdings steht bei Busybox und Sudo Location jeweils Not found.
    Hat das Relevanz ? Und was/wofür wird Busybox u.U. benötigt ?

    Gruß androi4fun
     
  18. Primus Boxus, 05.06.2012 #18
    Primus Boxus

    Primus Boxus Android-Hilfe.de Mitglied

    Beiträge:
    106
    Erhaltene Danke:
    16
    Registriert seit:
    03.05.2012
    Busybox brauchst du z.b. wenn du Supercharger zum kugelsicher machen deines Launchers usw installieren willst. Link2SD läuft auch ohne Bussi-Bussi-Schmusi-Box.

    LG und Bussi :eek:

    Gesendet von meinem U8655-1 mit Tapatalk 2
     
  19. Morpheus_2001, 06.06.2012 #19
    Morpheus_2001

    Morpheus_2001 Android-Hilfe.de Mitglied

    Beiträge:
    127
    Erhaltene Danke:
    2
    Registriert seit:
    04.03.2011
    Ach Mensch, ich komme schon ganz am Anfang nicht weiter. Ich habe den "adb_driver" Treiber installiert, aber wenn ich die bat starte zeigt er mir kein Gerät zum flashen an. Ich bin natürlich an der Stelle, bei welcher das Boot-Logo stehen bleibt. Was mache ich nur falsch?

    Nachtrag: Also ich habe jetzt auch den "adb_driver" Treiber deinstalliert und wieder neu installiert. Und ich habe auch einen anderen USB-Port versucht (man kann ja nie wissen). Bringt alles nichts, die "root_v5.1.bat" findet mein Gerät nicht, zwischen den Linien steht einfach nichts. Aber Windows XP erkennt das Gerät beim einstecken als Android Phone mit Single ADB Interface. Muss ich noch einen Treiber installieren?

    Da kann mir doch bestimmt hier jemand helfen, oder?
     
    Zuletzt bearbeitet: 06.06.2012
  20. KatyB, 06.06.2012 #20
    KatyB

    KatyB Ehrenmitglied

    Beiträge:
    7,858
    Erhaltene Danke:
    1,888
    Registriert seit:
    06.09.2011
    Phone:
    BQ Aquaris M5
    Wenn das Y200 in Fastboot ist, öffne dann mal am PC den Gerätemanager und schaue wie da das Y200 erkannt/benannt wird. Bzw. Screen posten.
     

Diese Seite empfehlen