1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

[HowTo] Einrichtung von adb und fastboot für Windows (android-sdk_r13)

Dieses Thema im Forum "Anleitungen für HTC Incredible S" wurde erstellt von cargo, 24.11.2011.

  1. cargo, 24.11.2011 #1
    cargo

    cargo Threadstarter Gast

    USB Debugging unter Menü-> Einstellungen->Anwendungen->Entwicklung-> USB-Debugging muss aktiviert sein.

    Download:

    Im Ordner tools, befinden sich die erforderlichen adb und fastboot Dateien, welche für die Nutzung erforderlich sind. (Quelle: Android SDK | Android Developers)​
    Wie wird diese installiert?

    • USB Debugging muß am Incredible S eingeschaltet sein!

    • HTC Fastboot Treiber installieren:

    • Incredible S einschalten, per USB mit dem PC verbinden, und die Treiber installieren lassen

    Nun das Incredible S
    (mit angeschlossenem USB Kabel) in den Fastboot Modus starten:


    • Incredible S ausschalten (Schnellstart in den Telefoneinstellungen (falls vorhanden)vorher deaktivieren)

    • die Leisertaste drücken und halten + Powertaste drücken, bis das hboot Menü zusehen ist

    • Fastboot ist markiert, mit der Powertaste bestätigen

    • oben ist nun FASTBOOT USB zulesen, und es werden die fastboot Treiber auf dem PC installiert

    • wenn das fertig ist, mit der Leisertaste den Menüpunkt REBOOT markieren, und per Powertaste bestätigen und ausführen, das Incredible S startet nun neu

    • die adb_sdk_r13_tools_adb+fastboot.rar entpacken, und nur den darin enthaltenen Ordner 'tools', z.B. hierher kopieren:
    C:\Benutzer\(dein Anmeldename)\(hier steht dann tools)
    (Bsp.: C:\Benutzer\cargo\tools)
    • per Windowstaste+R die Eingabeaufforderung starten, und hier cmd eintippen
    • in der Eingabeaufforderung steht dann sowas "C:\Users\cargo>" (statt cargo steht da natürlich euer Benutzername)

    • nun cd tools eintippen (damit wird in den Ordner tools gewechselt)

    • dann kann (zum Test) adb devices eingetippt werden, es wird dann, wenn alles funktioniert, sowas ausgegeben:
    C:\Users\cargo\tools>adb devices
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    List of devices attached
    SHxxxxxxxx device (hier steht die Seriennummer deines Sensations)

    Wird die Seriennummer angezeigt, ist es geschafft.

    Es kann auch in den Fastboot Modus gestartet werden, und hier zum Test fastboot devices eingetippt werden.

    Dann wird das ausgegeben:

    C:\Users\cargo>cd tools
    C:\Users\cargo\tools>fastboot devices
    SHxxxxxxxxxx fastboot (hier steht die Seriennummer deines Sensations)
    C:\Users\cargo\tools>

    Hoffe damit wird ein wenig geholfen...:smile:
     

    Anhänge:

    Mmartin, P-A-O, acidcandy und eine weitere Person haben sich bedankt.
  2. Mmartin, 04.12.2011 #2
    Mmartin

    Mmartin Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    1
    Registriert seit:
    12.06.2011
    ich habe alles schritt für schritt durchgeführt, bei mir erscheint nur keine seriennummer bei dem letzten punkt, was soll/kann ich nun machen?
     
  3. cargo, 04.12.2011 #3
    cargo

    cargo Threadstarter Gast

    adb devices funktioniert?

    Für fastboot devices muss in den Fastboot Mode gestartet werden.
     
    Mmartin bedankt sich.
  4. Mmartin, 04.12.2011 #4
    Mmartin

    Mmartin Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    1
    Registriert seit:
    12.06.2011
    also es hat alles funktioniert wie du gesagt/beschrieben hast, nur das zum schluss in der eingabeaufforderung List of devices attached steht. Dadrunter steht bei mir keine Seriennummer. Die Zeile ist einfach frei gelassen. Was nun?

    --> Könnte man nicht einfach sich das neueste firmenupdate laden oder einfach auf werkseinstellungen klicken, damit es rückgängig ist oder wäre dieser gedanke schwachsinn?
     
  5. cargo, 04.12.2011 #5
    cargo

    cargo Threadstarter Gast

    Würdest du mal ein Bild/Screenshot hochladen?

    Und das Incredible S wurde in den fastboot Mode gestartet? Nicht HBOOT.

    USB Debugging wurde auch aktiviert?
     
    Mmartin bedankt sich.
  6. Mmartin, 04.12.2011 #6
    Mmartin

    Mmartin Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    1
    Registriert seit:
    12.06.2011
    in 10 min kann ich das bild hochladen, also usb debugging ist aktiviert, ich wiederhole jetzte den ganzen vorgang bis ich zu der stelle mit der eingabeaufforderung komme..
     
  7. Mmartin, 04.12.2011 #7
    Mmartin

    Mmartin Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    1
    Registriert seit:
    12.06.2011
    jetzt öffnet sich noch nicht mal mehr der bootloader, so ein mist, ich muss muss doch nur beim incredible s debugging aktivieren, fast boot deaktivieren, es an den pc anschließen, es ausschalten und dann die leisertast und gleichzeitig die power taste für 5 sekunden drücken!!! oder verstehe ich da etwas falsch?!?!
     
  8. Mmartin, 04.12.2011 #8
    Mmartin

    Mmartin Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    1
    Registriert seit:
    12.06.2011
    kann ich denn nicht eifach auf werkseinstellungen klicken oder ein aktuelles software update runterladen und dann ist alles auf werkseinstellungen oder geht das nicht!?!?
     
  9. Mmartin, 04.12.2011 #9
    Mmartin

    Mmartin Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    1
    Registriert seit:
    12.06.2011
    ich habe jetzt alle möglichkeiten durchprobiert und komme einfach nicht mehr in den bootloader wenn ich die leisertaste und die power taste drücke! ist das jetzt ein gutes zeichen, so das ich mit dem "[howto] unrooten" weitermachen kann oder wäre das tödlich für mein handy
     
  10. cargo, 05.12.2011 #10
    cargo

    cargo Threadstarter Gast

    Sorry konnte nicht früher Antworten, war auf Arbeit.

    Wenn dein Incredible S nicht mehr in den Bootloader startet, ist das natürlich oder leider kein gutes Zeichen.

    PS//
    Du hast doch bisher noch gar nichts gemacht oder geflasht? Oder?
    Schalte dein Gerät mal aus. Nimm den Akku heraus, trenn das USB Kabel und leg dann den Akku wieder ein, und versuch nochmal in den Bootloader zu starten.

    Leisertaste drücken dann nur kurz die Powertaste betätigen, keine 5 Sekunden.
     
    Zuletzt von einem Moderator bearbeitet: 05.12.2011
    Mmartin bedankt sich.
  11. Mmartin, 05.12.2011 #11
    Mmartin

    Mmartin Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    1
    Registriert seit:
    12.06.2011
    oke, werde das mal heute um halb zwölf versuchen, mal sehen ob es dann klappt.

    könnte man nicht einfach auf "werkseinstellungen" klicken oder ein aktuelles update direkt per handy laden, oder wäre diese aktion das aus für mein handy?
     
  12. cargo, 05.12.2011 #12
    cargo

    cargo Threadstarter Gast

    Du hast doch gerootet und S-OFF.
    Stellst du nun versuchen, per Telefonmenü auf Werkseinstellungen zurückzustellen, das mit einer Fehlermeldung enden, und unter Umständen startet dein Incredible S nicht mehr, bis evtl. im CustomRecovery gewiped wurde.

    Du kannst nicht auf Werkszustand zurück, wenn Systemteile (Software) wie HBOOT und Recovery Menü ausgetauscht wurden.
     
    Mmartin bedankt sich.
  13. Mmartin, 05.12.2011 #13
    Mmartin

    Mmartin Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    1
    Registriert seit:
    12.06.2011
    ich habe es jetzt nochmal ganz von vorne probiert und komme einfach nicht in den bootloader rein, auch nicht wenn ich den akku rausnehme.

    besteht jetzt noch die möglichkeit mein handy wieder original zu bekommen, also so das ich es auf werkseinstellungen zurück setzen kann?
     
  14. cargo, 05.12.2011 #14
    cargo

    cargo Threadstarter Gast

    Kannst du es noch normal starten?
     
    Mmartin bedankt sich.
  15. Mmartin, 05.12.2011 #15
    Mmartin

    Mmartin Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    1
    Registriert seit:
    12.06.2011
    ja klar, es sässt sich ganz normal starten nur halt ohne den bootloader, es kommt halt gleich das htc zeichen
     
  16. cargo, 05.12.2011 #16
    cargo

    cargo Threadstarter Gast

    Aha, das ist doch schonmal besser.
    Das heiß dein Inc S ist nicht gebrickt.

    Kann es evtl. sein, das deine Leisertaste nicht richtig/gar nicht funktioniert?

    Um in den Bootloader starten zu können mach das:
    - starte dein Inc S normal
    - USB Debugging aktivieren
    - per USB Kabel mit dem PC verbinden
    - in der Eingabeaufforderung in den tools Ordner wechseln

    das eintippen:
    - adb devices
    (Ausgabe der Seriennummer)
    - adb reboot-bootloader
    Das Inc S wird nun in den Bootloader gestartet, klappt es so??


    Was hast du nun eigentlich nochmal vor?
    Kannst du mir die Daten deines Gerätes schreiben?

    - Bootloader Version?
    - hatte es branding?
    - aktuelle Software Version?
    - welche Software Version war drauf? Versionsnummer?
     
    Mmartin bedankt sich.
  17. Mmartin, 05.12.2011 #17
    Mmartin

    Mmartin Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    1
    Registriert seit:
    12.06.2011
    ich bedanke mich schoneinmal für deine zeit, die du mir bereitstellst um mein problem zu lösen.


    Bootloader Version?
    --> Wenn du mir sagst wo ich die finde, kann ich es dir sagen.
    Branding?
    --> Nein, es ist komplett "neutral"
    Aktuelle software version?
    --> weiß auch nicht genau was du damit meinst, ich habe android version: 2.3.3, htc sense version: 2.1, baseband version ist ziemlich lank, software nummer: 2.12.405.7 und browser version: webkit/533.1

    ..
    was ich vorhabe: mein handy auf werkseinstellungen zurück stellen so das es software mäsig wie neu ist, ohne das es als briefbeschwärer endet. auch wenn es danach noch soff ist, das ist mir egal. dafür muss ich ja den anweisungen des forums [how to, unrooten] folgen, und da steht ja das ich erst diesen schritt durchführen muss.

    Hilft dir das weiter und kannst du mir sagen wo ich die restlichen angaben finde für die software, bzw. wie ich jetzt weiter verfahren soll??

    MFG
    Martin
     
  18. cargo, 05.12.2011 #18
    cargo

    cargo Threadstarter Gast

    Bootloader Version steht im Bootloader.

    Um in den Bootloader starten zu können mach das:
    - starte dein Inc S normal
    - USB Debugging aktivieren
    - per USB Kabel mit dem PC verbinden
    - in der Eingabeaufforderung in den tools Ordner wechseln

    das eintippen:
    - adb devices
    (Ausgabe der Seriennummer)
    - adb reboot-bootloader
    Das Inc S wird nun in den Bootloader gestartet, klappt es so??


    Was steht bei dir?

    Oben steht HBOOT-xxxxxx
    Und steht ganz oben VIVO PVT SHIP S-xx??
     
    Mmartin bedankt sich.
  19. Mmartin, 05.12.2011 #19
    Mmartin

    Mmartin Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    1
    Registriert seit:
    12.06.2011
    wenn ich dem fett-gedruckten deiner beschreibung folge, funktioniert es wie folgt:
    erst adb devices eintippen und mit enter bestätigen, dann kommt folgendes:
    * deamon not running. starting it now on port 5037 *
    * deamon started succesfully *
    List of devices attached
    (.. dann kommt ne lehrzeile und mehr nicht)

    wenn ich dann noch: "adb reboot-bootloader" eintippe erscheint folgendes:
    error: device not fount

    .. das wars, mehr erscheint da nicht ;(
     
  20. cargo, 05.12.2011 #20
    cargo

    cargo Threadstarter Gast

    USB Debugging ist aktiviert?
    Treiber wurden installiert?

    Du hast doch vorher geschrieben, das alles funktioniert, nur das mit dem fastboot devices nicht.?
     
    Mmartin bedankt sich.

Diese Seite empfehlen