1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

[HOWTO] VPN mit FritzBox

Dieses Thema im Forum "Allgemeine VPN-Probleme" wurde erstellt von tallica, 09.06.2011.

  1. tallica, 09.06.2011 #1
    tallica

    tallica Threadstarter Junior Mitglied

    Beiträge:
    43
    Erhaltene Danke:
    32
    Registriert seit:
    28.03.2011
    Moin,

    da einige sicherlich auch Fritzboxen zu Hause stehen haben, die ja leider keinen der Android VPN Standards können, hier mal ne kleine Anleitung. Ich übernehme keine Garantie und kann nur berichten, wie es bei mir geklappt hat, das Ganze war im Endeffekt ein Kinderspiel, im Vergleich zu meinen ersten Versuchen mit Freetz und PPTP...

    Verwendete ROM: Litening 1.2 (edit: ebenfalls getestet: Villain 2.0, Cognition 1.11, LeoMar 2.4)
    (mit anderen gerooteten ROMs sollte es auch funzen, da bei Samsung anscheinend die tun.ko immer dabei ist. root ist jedoch immer Voraussetzung)
    Verwendete Fritzbox: 3270 (sollte mit allen FritzBoxen gehn, die VPN können. Keine Firmware Modifikationen à la Freetz nötig!)

    sonstige Anforderungen: keine :thumbsup:

    1.) DynDNS in der Fritzbox einrichten, wie das geht erklärt euch google ;)

    2.) Die FritzBox wie hier beschrieben einrichten (dabei immer annehmen, dass man für iOS einrichtet):
    AVM - VPN-Verbindung mit Apple iOS (z.B. iPhone) bzw. Mac OS X zur FRITZ!Box (Client-LAN-Kopplung)

    3.) Im Market nach "VPNC Widget" suchen, die Beschreibung durchlesen (!) und dadurch verstehen, wie man mit dem Widget umgeht.

    4.) Dann einfach installieren und das Widget auf nem Homescreen platzieren.

    5.) In den Einstellungen (Doppelklick drauf, steht aber auch in der Beschreibung der App) und erstmal "Check Prerequisites" machen. Wenn das fehlschlägt, dann reichen die Anforderungen der ROM oder ähnlcihes nicht. Siehe Beschreibung der App!

    6.) Unter "Set Preferences" folgendes einstellen:

    IPSecGateway: hostname von DynDNS (z.B. blablubb.dyndns.org)
    IPSecId: die email Adresse vom Einrichtungsassistent der FritzBox
    IPSec Group Password: der Eintrag "key" aus der .cfg
    XAuthUsername: der xauth username aus der .cfg
    XAuthPasswort: das xauth passwort aus der .cfg
    other Vpnc Options: leer lassen!

    7.) Das SGS2 aus dem heimischen WLAN ausloggen, und z.B. per 3G ins Inet gehn.

    8.) Per Klick auf das Widget mit dem VPN verbinden.


    Ich hoffe, dass ich dem ein oder anderen durch diese Anleitung helfen konnte. In meinen Augen ist das die einfachste aller Methoden, zur FritzBox ein VPN aufzubauen, da nur root nötig ist. Bei anderen Methoden war kompliziertes Patchen mit nem Hex-Editor oder das Aufspielen einer alternativen Firmware für die FritzBox ("Freetz") nötig.

    Fragen versuche ich zu beantworten, kann jedoch leider kein Support für alle FritzBox-ROM Konstellationen anbieten ;)

    MfG
     
    Zuletzt bearbeitet: 08.08.2011
    MichaelG, black_bottom, besiqu und 26 andere haben sich bedankt.
  2. Senate, 11.06.2011 #2
    Senate

    Senate Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    19.05.2011
    Hallo talica,

    erstmal danke für die Mühe und die Anleitung.

    ich habe deine Anweisung befolgt... doch leider hat es bei mir nicht funktioniert.
    (am Passwort kann es nicht liegen, ich habe mit copy und paste gearbeitet und es sogar abgetippt)
    Die Frage stellt sich bei mir auch, was der Xauth username under das Xauth passwort ist?
    Beides ist in der Config File nicht enthalten.

    Desweiteren kann ich das VPNC Widget immer nur einmal ausführen danach wird mir immer der Status Off angezeigt. Sobald ich da drauf drücke komme ich in die App.
    Ich habe es dann jedesmal neu installieren müssen um verschiedene Konfigurationen zu testen.
    Mitlerweile finde ich das Widget auch nicht mehr im Market um weiter zu probieren.
    Was mache ich falsch?
     
  3. bswpt, 12.06.2011 #3
    bswpt

    bswpt Fortgeschrittenes Mitglied

    Beiträge:
    275
    Erhaltene Danke:
    45
    Registriert seit:
    06.03.2010
    Vermutung 1 - bitte checken: du gehst in die app rein anstatt, wie oben richtig beschrieben über den Homescreen-->Widget VPNC als Widget zu hinterlegen - app starten bringt nix

    Vermutung 2 - bitte checken: in der Fritz-cfg ist sehr wohl xauth....suche mal in deiner cfg nach dieser Stelle:

    use_cfgmode = no;
    xauth {
    valid = yes;
    username = "xyz";
    passwd = "xyz";
    }

    Dort, wo ich jetzt xyz geschrieben habe müßten die gefragten Daten stehen. Steht da nix, hast du die Fritz-cfg "noch" nicht korrekt konfiguriert.

    Wenn dem so ist, dann aus dem Ausgangspost Punkt 2) inhalieren....
     
    Senate bedankt sich.
  4. Senate, 13.06.2011 #4
    Senate

    Senate Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    19.05.2011
    Vermutung 1: Ich habe es als Widet auf dem HomeScreen gezogen und nicht die App.

    Vermutung 2: In der Fritzbox_dyndnsname_org.cfg steht nichts mit xauth{}.
    In der vpnuser_name_mail_com.cfg ebenfalls nicht. jedoch gibt es eine Variable mit dem namen use_xauth und der Wert ist auf "no" gestellt.
    use_xauth = no;

    Ich habe eine Frotzbox 7170
     
  5. Berenor, 13.06.2011 #5
    Berenor

    Berenor Neuer Benutzer

    Beiträge:
    1
    Erhaltene Danke:
    1
    Registriert seit:
    13.06.2011
    Wenn Du die Anleitung auf der AVM Seite, die oben unter Punkt 2 verlinkt ist befolgt hast, sollte der xauth username und passwort Eintrag aber von Dir eingefügt worden sein und auch der use_xauth Wert sollte dann auf yes stehen.
     
    Senate bedankt sich.
  6. Senate, 13.06.2011 #6
    Senate

    Senate Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    19.05.2011
    @Berenor genau das war mein Fehler.
    Ich hatte gedacht, dass ich das nicht nochmal durchgehen muss, da ich ja bereits einen VPN user eingerichtet hatte.

    Danke allen beteiligten für die klasse Unterstützung. :thumbsup: es läuft nun :).
     
  7. bugz, 16.06.2011 #7
    bugz

    bugz Android-Lexikon

    Beiträge:
    1,770
    Erhaltene Danke:
    116
    Registriert seit:
    21.11.2010
    Also bei connectet er einfach nicht... Es kommt immer sofort die Meldung "VPNC switched off". Habe alle Einträge ergänzt... Verwende eine FB7390.

    Edit:
    Nochmal deinstalliert und neu eingerichtet... jetzt funktioniert es.
     
    Zuletzt bearbeitet: 16.06.2011
  8. winni2001, 17.06.2011 #8
    winni2001

    winni2001 Android-Hilfe.de Mitglied

    Beiträge:
    87
    Erhaltene Danke:
    35
    Registriert seit:
    12.01.2010
    Hatte zu diesem Thema mal in nem anderen Beitrag folgende Anleitung geschrieben.
    Vielleicht kann ja jemand damit auch was anfangen:

     
    Pepinghege, canone14 und db_cooper haben sich bedankt.
  9. rauke, 19.06.2011 #9
    rauke

    rauke Android-Lexikon

    Beiträge:
    1,603
    Erhaltene Danke:
    193
    Registriert seit:
    05.11.2009
    Phone:
    Sony Xperia Z3 Compact
    Tablet:
    Sony Xperia Z3 Tablet Comact, Nexus 10
    Bei mir steht, dass die tun nicht geladen werden konnte. Ich vermute daher, dass die tun.ko bei S2 gar nicht mitgeliefert wurde und erst nachinstalliert werden muss.
     
  10. bugz, 19.06.2011 #10
    bugz

    bugz Android-Lexikon

    Beiträge:
    1,770
    Erhaltene Danke:
    116
    Registriert seit:
    21.11.2010
    Also bei mir hat es funktioniert... Ab und zu benötige ich zwei Anläufe, aber meistens klappt es dann.
     
  11. tallica, 22.06.2011 #11
    tallica

    tallica Threadstarter Junior Mitglied

    Beiträge:
    43
    Erhaltene Danke:
    32
    Registriert seit:
    28.03.2011
    stock rom? wenn ja, probier doch mal ein custom rom , vllt geht's damit...das villain rom kann ich empfehlen
     
  12. Vega82, 23.06.2011 #12
    Vega82

    Vega82 Android-Hilfe.de Mitglied

    Beiträge:
    100
    Erhaltene Danke:
    7
    Registriert seit:
    06.06.2011
    Also ich verzweifel auch dran ...

    bekomme "no response from target" ... Daten stimmen alle...hab die Anleitung beachtet, per PC funzt es.

    Hat noch jemand ne Idee ??
    Benutzt ne FB7170, wobei das ja unwichtig sein sollte.
     
  13. unam, 24.06.2011 #13
    unam

    unam Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    27.08.2010
    Es will einfach nicht. Das ist die Fehlermeldung. Sehr komisch. Jemand eine Idee?

    [​IMG]

    Edit: Nicht durch das WLAN Zeichen irritieren lassen. Bin in einem anderen Netzwerk und mit 3G hab ich es auch schon probiert :)

    Gesendet mit der Android-Hilfe.de-App
     
    Zuletzt bearbeitet: 24.06.2011
  14. Vega82, 24.06.2011 #14
    Vega82

    Vega82 Android-Hilfe.de Mitglied

    Beiträge:
    100
    Erhaltene Danke:
    7
    Registriert seit:
    06.06.2011
    Nach meinen nächtlichen Google erfolgen liegt das Problem, welches ich auch hab, wohl am NATing des Clients. Es gibt da ne Option die zu setzen ist, allerdings lässt sich das schlecht in der App machen.

    Hat einer nen Plan, wo die cfg abgelegt wird ??
     
  15. ralli1300, 24.06.2011 #15
    ralli1300

    ralli1300 Erfahrener Benutzer

    Beiträge:
    198
    Erhaltene Danke:
    25
    Registriert seit:
    12.12.2010
    Hallo zusammen,

    Hat schon jemand erfolgreich das Transformer per VPN mit einer Fritzbox verbunden ?

    Wenn ja, wie?
     
  16. cbeckstein, 26.06.2011 #16
    cbeckstein

    cbeckstein Fortgeschrittenes Mitglied

    Beiträge:
    252
    Erhaltene Danke:
    75
    Registriert seit:
    17.11.2010
    habe diesbezüglich schon den Autor kontaktiert
    Problem (war wohl der erste, der das gemeldet hat) hat wohl mit der busybox zu tun, die von CF root installiert wird (siehe sh Fehlermeldung im Log) oder von anderen Anwendungen (Better Terminal, Busybox Installer etc.)
    scheint aber nicht so einfach fixbar zu sein...
    Autor ist zur Zeit auch sehr busy...
    aber wenn das jetzt viele haben das Problem, vielleicht schiebt er da Zeit für den Fix ein...
    - Clemens
     
  17. husvun41, 26.06.2011 #17
    husvun41

    husvun41 Gast

    Hi all,

    habe das Problem das immer folgende Meldung kommt:
    quick mode response rejected: (ISAKMP_N_INVALID_MESSAGE_ID)(9)
    this means the concentrator did not like what we had to offer.
    Possible reasons are:
    * concentrator configured to require a firewall
    this locks out even Cisco clients on any platform expect windows
    which is an obvious security improvment. There is no workaround (yet).
    * concentrator configured to require IP compression
    this is not yet supported by vpnc.
    Note: the Cisco Concentrator Documentation recommends against using
    compression, expect on low-bandwith (read: ISDN) links, because it
    uses much CPU-resources on the concentrator

    Habe noch das StockRom, sollte aber egal
    VPNC Widget ist das neuste aus dem Market und zeigt auch an das alle Vorrausetzungen erfüllt sind.
    Die FritzBox 7390 lüft mit 84.05.04-20071.
    Hatte im cfg mal auf /comp-no/ geändert, war aber nutzlos dann ging es gar nicht mehr "no respone from host" nach S4.x

    Hat einer eine Idee?
    Schon mal danke im vorraus.
     
  18. unam, 28.06.2011 #18
    unam

    unam Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    27.08.2010
    Probier es doch mal mit root. Wird schon Sinn haben wenn der Threadstarter das dazu schreibt

    Gesendet mit der Android-Hilfe.de-App
     
  19. unam, 04.07.2011 #19
    unam

    unam Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    27.08.2010
    Hat niemand eine Lösung? Es muss doch irgendwie funktionieren :(

    Sent from my GT-I9100 using Tapatalk
     
  20. winni2001, 04.07.2011 #20
    winni2001

    winni2001 Android-Hilfe.de Mitglied

    Beiträge:
    87
    Erhaltene Danke:
    35
    Registriert seit:
    12.01.2010
    Man braucht auf alle Fälle root. Auch das VPNC Widget benötigt root.
     

Diese Seite empfehlen