1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

HTC Hero und WLAN (Probleme mit Verbindung)

Dieses Thema im Forum "HTC Hero / T-Mobile G2 Touch Forum" wurde erstellt von Chris87, 18.10.2009.

  1. Chris87, 18.10.2009 #1
    Chris87

    Chris87 Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    418
    Erhaltene Danke:
    27
    Registriert seit:
    18.10.2009
    Hallo,

    ich habe seit Freitag ein T-Mobile G2 Touch und bin sehr zufrieden mit dem Gerät. Vorher hatte ich ein iPhone 3G 16GB und mir gefällt das Hero um einiges besser, allerdings habe ich beim Hero Probleme mit dem WLAN.

    Als Router habe ich einen Linksys WRT160NL mit WPA2 Verschlüssleung (TKIP/AES).

    Wenn ich mich mit dem Hero mit dem WLAN verbinde, kann ich zunächst auch problemlos surfen usw, allerdings hält das nicht sehr lange an. Nach einiger Zeit habe ich keine Internetverbindung mehr, obwohl ich immer noch mit dem WLAN verbunden bin. Dann muss ich erst das WLAN auf dem Hero aus und wieder an schalten und dann habe ich kurzzeitig wieder Verbindung bis der Fehler wieder auftritt.

    Ich habe mir auch schon den WIFI Fixer heruntergeladen, allerdings hat der nicht wirklich was gebracht. Aber anscheinend bin ich nicht der einzige mit dem Problem oder?

    Ich bin mir trotzdem nicht 100% sicher ob es am Hero oder am Router liegt. Den Router habe ich erst seit ein paar Tagen und hatte am Anfang das Problem, dass einige PCs nach einiger Zeit keine IP-Adresse mehr zugewiesen bekommen haben (obwohl DHCP an ist), dann habe ich jedem PC über den Router eine feste IP zugewiesen und seitdem gibt es keine Probleme mehr. Ich habe auch schon dem Hero eine feste IP gegeben und das hat leider nichts geholfen.

    Stellt sich nun die Frage ob es am Hero oder am Router liegt.

    Gruß
    Chris
     
  2. Energiequant, 18.10.2009 #2
    Energiequant

    Energiequant Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    1
    Registriert seit:
    21.09.2009
    Bekommst Du denn eine Fehlermeldung? Wann tritt das Problem auf? (immer nach dem Standby?)

    Bei mir schien das Hero Probleme zu haben wenn 2 gleichnamige WLANs in Betrieb sind, seitdem ich eines davon umbenannt hatte sind die Probleme weg. Nach einem Neustart muss ich zudem manchmal 2-3 mal manuell das richtige Netzwerk auswählen, obwohl es dem Handy schon bekannt war und auch das Kennwort gespeichert wurde; danach klappt alles wie es sollte.


    Damit bist Du trotzdem vom DHCP des Routers abhängig. Gib die Daten versuchsweise mal manuell ein: (hab leider gerade nur die englischen Bezeichnungen zur Hand)

    In den WLAN-Einstellungen (die mit der Liste aller WLANs) die Menu-Taste drücken und "Advanced" wählen. Dann unter "IP Settings" Häkchen setzen bei "Use static IP" und dort entsprechend die IP-Adresse die Du auch über den Router fürs Handy eingetragen hattest eingeben. Netmask müsste 255.255.255.0 sein, bei Gateway und DNS 1 kommt jeweils die IP Deines Routers rein. Danach vielleicht nochmal trennen und neu verbinden.

    Das Hero schaltet übrigens sein WLAN standardmäßig nach kurzer Zeit im Standby wieder aus (3G ist vermutlich energiesparender?). Sollte es sich um ein Problem damit handeln, kannst Du auch versuchen ebenfalls unter "Advanced" die "Wi-Fi sleep policy" (2. Punkt) zu ändern.

    Wenn Du zwischen mehreren WLANs wechselst (oder die Telekom-Hotspots benutzt) ist das aber keine gute Lösung, da die Static IP scheinbar für alle Netze gleich ist und somit in anderen Netzen nicht funktionieren dürfte.


    Ich kanns mir nicht verkneifen, noch zu erwähnen, daß sowohl die Firmware als auch die Hardware von Linksys-Geräten meist nicht besonders ist. Vielleicht liegts also einfach am Router, besonders wenn auch die anderen Geräte im Netzwerk schon Probleme damit hatten.
     
  3. Chris87, 18.10.2009 #3
    Chris87

    Chris87 Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    418
    Erhaltene Danke:
    27
    Registriert seit:
    18.10.2009
    Danke für die Antwort. Das Problem tritt nicht erst nach dem Sleep auf, sondern auch direkt beim surfen, wenn ich dann einen Link anklicke, lädt die Seite nicht mehr und es erscheint eine Meldung, dass man sicherstellen soll, dass man mit einem Netzwerk verbunden ist etc...

    Auch wenn ich im Android-Market suche, tritt das Problem auf. Auf einmal erscheint dann die Meldung "keine Datenverbindung" oder so ähnlich. Dann kann man entweder auf "Erneut versuchen" oder auf "Abbrechen" klicken.

    Ich werde mal das mit der festen IP versuchen.
     
  4. Chris87, 18.10.2009 #4
    Chris87

    Chris87 Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    418
    Erhaltene Danke:
    27
    Registriert seit:
    18.10.2009
    Ich denke, dass die manuelle IP-Einstellung beim Hero direkt geholfen hat. Ich habe jetzt ne Weile gesurft und bisher ist die Verbindung nicht abgebroche. Da ich meistens das gleiche WLAN-Netz benutze, ist das auch nicht weiter schlimm.

    Falls ich das Problem noch feststellen sollte, werde ich wieder hier rein schreiben. Vielen Dank @Energiequant.

    Edit: Hat anscheinend doch nicht geholfen. Ich werde gleich mal wieder meinen alten Netgear Router anschließen und schauen, obs dann besser läuft.
     
    Zuletzt bearbeitet: 18.10.2009
  5. AST, 18.10.2009 #5
    AST

    AST Fortgeschrittenes Mitglied

    Beiträge:
    365
    Erhaltene Danke:
    121
    Registriert seit:
    09.08.2009
    Hallo Chris87,

    bei mir traten exakt die gleichen Symptome auf. Nach langer Suche habe ich unseren Fritz!Repeater als Übeltäter identifiziert. Ohne Repeater ist und bleibt alles in Ordnung, mit Repeater bricht die Verbindung des Heros irgendwann ab. (...Notebooks haben übrigens keine Probleme mit dem Repeater...)

    Wi-Fi settings / Advanced / Wi-Fi sleep policy auf "Never" zu setzen hat bei mir übrigens keinen Effekt...

    Viele Grüße
    AST
     
  6. gado, 18.10.2009 #6
    gado

    gado Ehrenmitglied

    Beiträge:
    3,545
    Erhaltene Danke:
    444
    Registriert seit:
    18.09.2009
    Phone:
    Nexus 6P
    Wearable:
    Pebble Steel
    Habe das gleiche Problem mit meinem Samsung 3210 Router. Alles geht, dann geht man auf eine Seite, dann gibts ein Timeout, dann erst WLAN abschalten und wieder einschalten.

    Aber das ist so selten, dass es nicht ganz so schlimm ist, aber ich hoffe, dass das in der nächsten Firmware beseitigt ist.
     
  7. Chris87, 18.10.2009 #7
    Chris87

    Chris87 Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    418
    Erhaltene Danke:
    27
    Registriert seit:
    18.10.2009
    Das Problem lag bei mir in der Tat am Linksys WRT160NL Router bzw. an der Kombination vom Hero und diesem Router. Zwar hatten auch andere Geräte (einige PCs) Probleme mit dem Router, aber diese konnte ich später lösen (durch feste IPs), allerdings hatte mein Hero immer noch Probleme mit dem Router. Sehr schade, ich hätte von Linksys mehr erwartet (eventuell ist das ja aber auch nur ein Einzelfall).

    Momentan läuft mein Netgear RangeMax Router wieder und es gibt keine Probleme mehr mit dem WLAN, allerdings hat dieser Router wiederum das Problem, dass er gespeicherte Einstellungen wie z.B. Port-Weiterleitungen nicht mehr anzeigt und man diese somit nicht mehr ändern kann (die Einstellungen sind aber trotzdem noch vorhanden).

    Vielleicht kann mir hier ja jemand einen anderen Router empfehlen.

    Vielen Dank.
     
  8. Energiequant, 31.10.2009 #8
    Energiequant

    Energiequant Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    1
    Registriert seit:
    21.09.2009
    Gerade im Market beim Durchblättern gefunden - hab ich nicht getestet (ich brauchs nicht) aber klingt erstmal gut. Soll wohl mehrere statische IPs speichern können und dann einen schnelleren Wechsel erlauben:

    Wifi Static (Homepage, androlib.com)

    Könnte praktisch sein, wenn man vom Router zur manuellen Eingabe von statischen IPs gezwungen wird aber zwischen verschiedenen Access Points/Routern wechselt. Dachte ich poste das hier mal, falls Ihr das brauchen solltet. :)
     
    Zuletzt bearbeitet: 31.10.2009
  9. Mr.Schrotti, 01.11.2009 #9
    Mr.Schrotti

    Mr.Schrotti Android-Experte

    Beiträge:
    522
    Erhaltene Danke:
    36
    Registriert seit:
    23.10.2009
    Phone:
    OnePlus One
    Tablet:
    Nexus 7 (2013)
    das Problem habe ich bei meinem Notebook manchmal auch. Dort konnte ich das Problem lösen in dem ich einen anderen W-Lan Channel genutzt habe. Ich habe bei mir immer wieder das Problem das ein Kanal doppelt oder gar 3 oder 4 fach genutzt wird (wohne in der Stadt) da kommt es zwangsweise ab und zu mal zu Paket Kollisionen und zu Störungen. Ein kanal wechsel hilft da jedoch immer wieder.

    Gruß
    Mr.Schrotti
     

Diese Seite empfehlen