1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Huawei Ascend Y200 Rooten / Backup / Zurücksetzen

Dieses Thema im Forum "Root / Custom-ROMs / Modding für Huawei Ascend Y200" wurde erstellt von Firebolt, 04.05.2012.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Firebolt, 04.05.2012 #1
    Firebolt

    Firebolt Threadstarter Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    0
    Registriert seit:
    04.05.2012
    Hoila,

    kann man das Y200 rooten und wenn ja geht das mit der folgenden Anleitung?

    http://www.android-hilfe.de/root-cu...169828-anleitung-huawei-sonic-u8650-root.html

    --

    Ich möchte gerne ein System Backup machen, sowie danach die SD als RAM -Speicher nutzen.

    - Clockwork Recovery
    - Link2SD

    Dies wären die Anfangsprogs, aber auch System auslesen wie Proz-Taktung usw. sollten kein Prob sein, habe gelesen, dass für viele Progs root-Zugriff notwendig sei, wie bei ZDBox.

    Was haltet ihr von Avast Util oder besser die 2 Norton Produkte, alles free.

    Da ich nicht sicher bin, was sich genau beim Aufspielen von Clockwork Rec ändert, frage ich vorher.

    Wird dieses Programm in das ROM transferiert oder/und greift es in das vorhandene OS ein? Das Handy ist im Auslieferungszustand, wie verhält es sich nun damit?

    Gibt es auch die Möglichkeit, jegliche Änderungen wieder zurückzusetzen, nach Clockwork install usw. oder bleibt das permanent.

    Z.B. durch das Zurückspielen der DAtei HUAWEI_U8655-1_Android_2.3_V100R001C169B880SP02_Germany.zip


    Bevor ich das alles mache will ich einfach wissen wie stark die Eingriffe sind und welche Rücksetzmöglichkeiten es gibt.

    Vielen Dank im Voraus für die Hilfe.

    Ciao
    Firebolt
     
  2. Buju, 04.05.2012 #2
    Buju

    Buju Erfahrener Benutzer

    Beiträge:
    227
    Erhaltene Danke:
    50
    Registriert seit:
    17.01.2012
    also ich wäre da vorsichtig was das einspielen des CWR betrifft. Dieses wird in die Recoverypartition des Telefons geflashed. Das musst du dir grob so vorstellen: Das Telefon hat mehrere Partitionen von denen es starten kann. Die eine bootet das System normal, die andere die Recovery und eventuell eine die ein Fastboot bootet. Wenn jetzt die Systemarchitektur des y200 nicht die gleiche ist wie die des Telefons auf das das CWR angepasst ist (partitionierung, Prozessor usw) wird das CWR schlicht nicht tun. Das ist erst mal nicht so schlimm Dein Telefon würde ja noch normal booten, aber Du würdest kein Recovery mehr machen können (Tastenkombination beim booten) mit welchen Du neue ROMs oder updates einspielen könntest. Du müsstest wenns schief gelaufen ist das orginal (oder ein funktionierendes eben) Recovery zurückflashen. Da es aber zurzeit keinerlei Firmwares gibt aus dem man das stibitzen könnte siehts da schlecht aus. (auslesen müsste theoretisch auch gehn - aber ich habs grad nicht da zum testen)
     
  3. Ryuk, 04.05.2012 #3
    Ryuk

    Ryuk Android-Lexikon

    Beiträge:
    1,010
    Erhaltene Danke:
    207
    Registriert seit:
    19.09.2011
    versuchs mal hiermit:
    http://www.android-hilfe.de/3074491-post171.html

    da wird die cwm-recovery nicht geflasht, sondern nur gebootet...
    ist zwar fürs x3 gemacht, dürfte theoretisch aber auch beim y200 funktionieren...
    da kann man erstmal ein backup erstellen, wo die komplette rom inkl. original recovery gesichert wird...außer dem baseband...

    fürs rooten lädst du dir das file runter und schiebst es auf die sd-karte:
    https://rapidshare.com/#!download|765tl5|2244779298|su.zip|296|R~6AD0CDE59A825624D0B4EA592A9F8C71|0|0

    anschließend wählt man in der gebooteten cwm-recovery "install zip from sd-card" und wählt die su.zip aus...nach dem installieren "reboot system now"...dann dürfte man root haben...
    ist zwar noch eine ältere superuser-version, find die aktuelle grad nicht, aber man kann die app über den market aktualisieren und über die app die binary...
     
  4. det-happy, 04.05.2012 #4
    det-happy

    det-happy Ehrenmitglied

    Beiträge:
    6,597
    Erhaltene Danke:
    3,151
    Registriert seit:
    26.04.2012
    Phone:
    Xiaomi Redmi 1S
    Tablet:
    Lenovo IdeaPad A8-50
    Wer traut sich, das zu testen? :crying:
     
  5. Xer0, 04.05.2012 #5
    Xer0

    Xer0 Android-Experte

    Beiträge:
    649
    Erhaltene Danke:
    121
    Registriert seit:
    20.03.2012
    naja trauen sollte sich jeder können, alles mit fastboot ist quasi unbrickbar ^^
    es sind wohl aber noch nicht so viele Geräte in Developerhand...
     
  6. chrisrue, 04.05.2012 #6
    chrisrue

    chrisrue Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    2
    Registriert seit:
    19.09.2011
    Phone:
    Huawei X3, Y200, Honor7
    Tablet:
    SM-P900
     
  7. Xer0, 05.05.2012 #7
    Xer0

    Xer0 Android-Experte

    Beiträge:
    649
    Erhaltene Danke:
    121
    Registriert seit:
    20.03.2012
    adb die lokale Verbinung erlaubt / Firewall mal ausgemacht?
     
  8. chrisrue, 05.05.2012 #8
    chrisrue

    chrisrue Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    2
    Registriert seit:
    19.09.2011
    Phone:
    Huawei X3, Y200, Honor7
    Tablet:
    SM-P900
    nach einem Neustart ergab ein neuer Versuch einen Teilerfolg:

    D:\unzipped\cwm-recovery\CWM Recovery>adb -d reboot bootloader

    D:\unzipped\cwm-recovery\CWM Recovery>fastboot boot .img
    < waiting for device >


    wahrscheinlich passt das cwm-recovery.img nicht.

    Der ursprüngliche Beitrag von 02:24 Uhr wurde um 03:09 Uhr ergänzt:

    der URL funzt leider nicht.
     
  9. Ryuk, 05.05.2012 #9
    Ryuk

    Ryuk Android-Lexikon

    Beiträge:
    1,010
    Erhaltene Danke:
    207
    Registriert seit:
    19.09.2011
    liegt sicher nicht an der recovery...der adb-server wartet einfach aufs phone...normalerweise startet sich das phone nach paar sekunden neu und lädt die cwm-rec, nachdem man die recovery.bat ausgeführt hat...

    entweder sind die treiber noch nicht installiert (das war beim x3 teilweise schon nervig) oder du aktivierst mal usb-debugging (beim x3 war das unter einstellungen->anwendungen->entwicklung)...
    und evtl. mal noch den schnellstart deaktivieren, falls es das beim y200 gibt...

    kp warum der rapi-link zur su.zip bei dir nicht funzt, bei mir geht der einwandfrei...zuminest mit firefox...mit chrome und opera gehts irgendwie nicht...
     
    Zuletzt bearbeitet: 05.05.2012
  10. chrisrue, 05.05.2012 #10
    chrisrue

    chrisrue Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    2
    Registriert seit:
    19.09.2011
    Phone:
    Huawei X3, Y200, Honor7
    Tablet:
    SM-P900
    Also ich bin kein Experte, versuche aber genau nach "Rezept" zu arbeiten. So habe ich schon zwei X3 erfolgreich gerootet; dank lowskill: "Automatic Root Enabler - Von 0 auf Root in 40 Sekunden" ein Kinderspiel. Ich will damit sagen, dass alle Einstellungen und Treiber richtig und vorhanden waren.

    Mit dem bat-File komme ich, wie gezeigt, nur zum Booten des Y200 aber nicht in den fastboot modus.

    Aber das Y200 läßt sich sich auch nicht mit "Vol+ und Vol- und Poower" gleichzeitig gedrückt in den fastboot modus bringen, es friert mit magentafarbenen Bildschirm ein, nur mit Akku raus zu beenden.

    Gerade habe ich festgestellt, dass mit "Vol- allein und Poower" gleichzeitig gedrückt ich doch in den fastboot modus komme.

    Jetzt müßte ich das Notwendige auf die SD-Karte schieben. Bitte was ist das Notwendige?

    Beim Anklicken des obigen rapi-links zur su.zip kommt bei mir mit Iron, einem Chrome-Ableger, folgende Fehlermeldung:

    Die Seite auf https://rapidshare.com says :

    *File not found - 404
    !download.html?tcv=de1336042857


    Ja mit Firefox war der Link kein Problem.

    Ich bin zuversichtlich, dass mit dem geballten Expertenwissen hier, es gelingen wird, den ersehnten Root hinzubekommen. Das Y200 ist es wert - in zwei Benchmarks ist es doppelt so schnell wie das X3.
     
    Zuletzt bearbeitet: 05.05.2012
  11. syscrh, 05.05.2012 #11
    syscrh

    syscrh Android-Ikone

    Beiträge:
    5,091
    Erhaltene Danke:
    1,810
    Registriert seit:
    05.05.2012
    Also ich hab das jetzt mal versucht: Es zeigt die ganze Zeit nur an "Waiting for device". :confused2:
     
  12. Xer0, 05.05.2012 #12
    Xer0

    Xer0 Android-Experte

    Beiträge:
    649
    Erhaltene Danke:
    121
    Registriert seit:
    20.03.2012
    wo hast du diese den her... oder ist das eine vom X3?
    ich glaub nicht das die miteinander kompatibel sind

    versuch mal USB-Debugging unter Einstellungen/Apps zu aktivieren
    und dann den Automatic Root Enabler Lite ohne CWM

    oder gar die su.bin manuell per ADB puschen?
     
  13. chrisrue, 05.05.2012 #13
    chrisrue

    chrisrue Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    2
    Registriert seit:
    19.09.2011
    Phone:
    Huawei X3, Y200, Honor7
    Tablet:
    SM-P900
    das cwm-recovery.img
    vorläufig ist alles vom X3.

    Automatic Root Enabler Lite ohne CWM
    bleibt auch bei < waiting for device > hängen.

    oder gar die su.bin manuell per ADB puschen
    dazu brauche ich das "Rezept", ich lerne noch, bin aber willig!

    Das Y200 habe ich jetzt im fastboot modus mit dem PC verbunden und für das
    Android Phone
    Android Bootloader
    Interface geladen.
    Wie könnte es jetzt weitergehen, wenn überhaupt?
     
  14. Buju, 05.05.2012 #14
    Buju

    Buju Erfahrener Benutzer

    Beiträge:
    227
    Erhaltene Danke:
    50
    Registriert seit:
    17.01.2012
    geht nicht:
    Code:
    D:\download\_android\adb>adb remount
    remount failed: Operation not permitted
    
    D:\download\_android\adb>adb push su /system/xbin/su
    failed to copy 'su' to '/system/xbin/su': Read-only file system


    Der ursprüngliche Beitrag von 16:54 Uhr wurde um 17:01 Uhr ergänzt:

    wir sollten von dem aktuellen eine boot.img haben. Jemand mit nen bissel linuxmagic sollte uns die als rw machen. Dann das Ding via fastboot flashen. Dann die su und superuser.apk drauf und alles sollte schick sein.

    Nur woher die boot.img nehmen? Und wer kann die anpassen? (zumindest wo ist beschrieben wie ....)
     
  15. Ryuk, 05.05.2012 #15
    Ryuk

    Ryuk Android-Lexikon

    Beiträge:
    1,010
    Erhaltene Danke:
    207
    Registriert seit:
    19.09.2011
    versteh ich grad nicht...^^

    das pushen geht glaub ich auch nur mit root, weil man da root-rechte braucht um die partitionen schreibbar zu mounten...


    @chrisrue
    wenn du das y200 im fastboot-mode am rechner hast, dann geh mal in den "cwm-recovery" ordner, öffne die recovery.bat mit dem text-editor und entferne die erste zeile, so dass nur "fastboot boot cwm-recovery.img" drin steht...
    dann speicherst du sie wieder ab und führst sie aus...
    was passiert dann?
     
    Zuletzt bearbeitet: 05.05.2012
  16. chrisrue, 05.05.2012 #16
    chrisrue

    chrisrue Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    2
    Registriert seit:
    19.09.2011
    Phone:
    Huawei X3, Y200, Honor7
    Tablet:
    SM-P900
    Folgendes am PC:

    D:\unzipped\cwm-recovery>fastboot boot cwm-recovery.img
    < waiting for device >


    nichts am Y200.
     
  17. syscrh, 05.05.2012 #17
    syscrh

    syscrh Android-Ikone

    Beiträge:
    5,091
    Erhaltene Danke:
    1,810
    Registriert seit:
    05.05.2012
    Genau den Fehler a hab ich auch. :confused:
    Außerdem bekomme ich es jetzt nicht mehr in den Fast-boot-Modus (Vol- + An). :cursing:
     
  18. Ryuk, 05.05.2012 #18
    Ryuk

    Ryuk Android-Lexikon

    Beiträge:
    1,010
    Erhaltene Danke:
    207
    Registriert seit:
    19.09.2011
    glaub ja fast, dass die treiber fehlen...
    wenn ihr das phone ganz normal an den pc stöpselt (also wenn android gebootet ist), dann müsste eigtl. auch ein cd-laufwerk erscheinen...dort müsste es einen ordner mit "drivers" und darin einen mit "adb_driver" geben...den treiber evtl. mal installieren...nennt sich "Handset WinDriver.exe"

    hab aber vorns mal das upgrade fürs y200 runtergeladen, entpackt und die recovery.img versucht auf dem x3 zu booten, ging leider nicht...aber da es ja nur gebootet wurde, passiert halt auch nichts und mein x3 funzt nach wie vor...

    für den fastboot-mode muss man die tastenkombi so ca. 10-15s gedrückt halten...

    im gerätemanager müsste dann ein "adb interface" -> "fastboot interface" aufgelistet sein, wenn das phone im fastboot-mode am pc hängt...
     
    Zuletzt bearbeitet: 05.05.2012
  19. Buju, 05.05.2012 #19
    Buju

    Buju Erfahrener Benutzer

    Beiträge:
    227
    Erhaltene Danke:
    50
    Registriert seit:
    17.01.2012
    also ich hab meines mal in den Fastbootmodus versetzt. (ausschalten, Akku raus, "Power" & "-", Akku rein, beim ersten vibrieren die Tasten loslassen, das Ascend Logo bleibt stehen)
    Code:
    ..\CWM Recovery>fastboot boot cwm-recovery.img
            downloading 'boot.img'... OKAY [  1.093s]
                           booting... OKAY [  0.107s]
    finished. total time: 1.202s
    dann passiert genau mal garnix. ich dacht reboot ich gleich via fastboot:
    Code:
    ..\CWM Recovery>fastboot reboot
    < waiting for device >
    also das Telefon ist nicht mehr im Fastboot modus. Fazit: die cwm geht nicht. (zumindest nicht so)
     
  20. Xer0, 05.05.2012 #20
    Xer0

    Xer0 Android-Experte

    Beiträge:
    649
    Erhaltene Danke:
    121
    Registriert seit:
    20.03.2012
    klingt nach nem Henne-Ei-Problem -> kein Root ohne Root


    kann mal einer der erfolgreich in die ADB Shell kommt folgendes testen?
    cat /dev/mtd/mtd1 > /sdcard/mtd1.img


    (Hmpf, ich brauch mal ein eigenes Y200...)
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen