1. Möchtest Du unser Team im Android OS-Bereich unterstützen? Details dazu findest du hier!

ICS 4: Wlan + Speedport W502V Problem

Dieses Thema im Forum "Android 4.0.x (Ice Cream Sandwich)" wurde erstellt von Ma3a, 29.01.2012.

  1. Ma3a, 29.01.2012 #1
    Ma3a

    Ma3a Threadstarter Erfahrener Benutzer

    Beiträge:
    232
    Erhaltene Danke:
    21
    Registriert seit:
    28.01.2012
    Hallo,

    die SuFu hat mir zu meinem Problem keine Lösung geliefert, deswegen ein neues Thema.

    Die Sachlage:

    Tablet (EEEpad) mit ICS 4.03 soll per WLAN mit Router T-home Speedport W502V verbunden werden.
    Routeroptionen 1:
    - Netzwerk versteckt
    - MAC Filterung aktiviert
    - WEP
    - DHCP
    Routeroption 2:
    - Netzwerk sichtbar
    - MAC Filterung deaktiviert
    - WEP
    - DHCP
    - Manuelle IP Vergabe an Tablet - Router auf DHCP

    Einstellungsmöglichkeiten:

    Wechseln der Verschlüsselung sollte vermieden werden, sowie große Änderungen am Router.

    Die Problematik:
    Routeroptionen 1:
    Manuelle Eingabe des Netzwerks -> Netzwerk gefunden.
    Verbinden mit Netwerk -> IP Adresse wird abgerufen
    Ab hier passiert nichts mehr (Lösung auch aus dem ellenlangen Thread im Samsung Forum nicht ersichtlich)
    Der Log des Router DHCP sagt mir, das das Tablet mit der IP des letzten per MAC Filterung angemeldeten Gerätes (meiner PS3) versucht zu verbinden. (192.168.2.107 hat die PS3 - Will Tablet haben). Enferne ich die PS3 so versucht Android mit der Adresse darunter (.106 - mein PC) zu connecten.
    Der Name des Tablets wird mit Android - X353X35135 (Zahlen so in etwa) angezeigt.

    Fazit: IP Adresse wird abgerufen - klappt aber nicht

    Routeroption 2: feste IP
    Die Einstellungen Sichtbarkeit und MAC Filter ändern nichts grundlegendes an der Problematik, das Netz findet er ja.
    Gebe ich dem Tablet eine feste IP Verbindet es mit dem Router - so sagt es mir Android zumindest. Ich habe jedoch keinen Zugriff aufs Internet oder auf den Router, also so wie es aussieht auch keinen Netzwerkzugriff. (DNS wird auf ::1 gesetzt/ Netzwerkpräfix auf 24)

    Fazit: Mit IP Adresse mit dem Netz verbunden, aber anscheinend doch nicht verbunden.

    Ich bitte euch, mir bei diesem Problem zu helfen!
     
  2. mittelhessen, 31.01.2012 #2
    mittelhessen

    mittelhessen Android-Guru

    Beiträge:
    3,016
    Erhaltene Danke:
    336
    Registriert seit:
    27.11.2010
    1. Eine versteckte SSID bringt bekanntermaßen keinen Sicherheitsgewinn. Trotzdem habe ich unter ICS mit verstecker SSID keine Probleme. Bis zur Lösungsfindung würde ich sie trotzdem aktivieren!

    2. Ein MAC-Filter wird mit dem Problem wahrscheinlich nichts zu tun haben wenn er richtig konfiguriert ist, trotzdem ebenfalls bis zur Problemfindung ausschalten!

    3. WEP-Verschlüsselung ist potentiell unsicher und sollte heutzutage eigentlich nicht mehr verwendet werden. Trotzdem ist ein falsch eingegebener Schlüssel oft Ursache für Verbindungsprobleme. Sonderzeichen können zwar die Sicherheit erhöhen, sorgen aber auch oft für Inkompatibilitäten. Deshalb sollte man sich (zumindest anfangs) auf einen Schlüssel aus dem Standardzeichensatz beschränken, d. H. 0-9, a-z, A-Z. In dem Fall glaube ich aber nicht an einen falschen Schlüssel, weil das Handy m. M. noch sonst nicht bis zum IP-Bezug käme.

    4. Wenn du die Adressen via DHCP vergibst, dann schau nach ob die Anzahl der möglichen Clients u. U. zu stark eingeschränkt wurde. Man kann DHCP z. B. so einstellen, dass nur 10 Adressen vergeben werden. Das geht einerseits über die direkte Anzahl der Clients, andererseits über eine vorgebebene Range.

    5. Wenn du die Adresse am Smartphone manuell vergibst, sollte sie im gleichen Subnetz (i. d. R. /24 bzw. 255.255.255.0) sein wie die anderen Clients damit es mit den anderen Clients kommunizieren kann. Das kann dann allerdings zu IP-Konflikten kommen, wenn der DHCP-Server die gleiche IP an einen anderen Client vergibt wie du manuell auf dem Handy eingestellt hast. Lösen könntest du das, wenn du eine manuelle IP aus einem anderen Subnetz wählst. Weiterhin ist es natürlich notwendig die DNS-IP UND die Gateway-IP mit einzutragen die in dem Fall identisch sind und der IP des Routers (meistens 192.168.1.1 od. 192.168.2.1) entsprechen!

    6. Hast du die Möglichkeit beim Router staticDHCP zu verwenden?
     
  3. Ma3a, 31.01.2012 #3
    Ma3a

    Ma3a Threadstarter Erfahrener Benutzer

    Beiträge:
    232
    Erhaltene Danke:
    21
    Registriert seit:
    28.01.2012
    Herzlichen Dank schonmal für die ausführliche Antwort.

    Ich werde das mal überprüfen!
     
  4. thearea51, 01.02.2012 #4
    thearea51

    thearea51 Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    2
    Registriert seit:
    06.09.2011
    Würde mal die Verschlüsselung deaktivieren und schauen ob es dann geht.

    Kleiner Tipp noch, die Telekom Router sind der letzte Müll, die haben Probleme bei der Verschlüsselung sowie mit dem DHCP!

    Auf WPA2 stellen und IP Adresse selbst vergeben Mac würde ich nicht aktivieren.

    Kauf dir eine Fritz Box, kosten nicht soviel zumindest die kleineren nicht und du hast keine Probleme mehr....

    Gesendet mit meinem Galaxy Note via Tapatalk
     
  5. mittelhessen, 01.02.2012 #5
    mittelhessen

    mittelhessen Android-Guru

    Beiträge:
    3,016
    Erhaltene Danke:
    336
    Registriert seit:
    27.11.2010
    Zur Fehlereingrenzung kann man das gerne mal ausprobieren! Damit vermeidet man z. B. einen falsch eingegebenen Schlüssel oder etwa einen inkompatiblen Zeichensatz (bei der Verwendung von Sonderzeichen).

    Dieser Verallgemeinerung kann ich leider nicht viel abgewinnen! Ich kenne durchaus Speedports die mit der (aktuellen) original-Firmware völlig problemlos laufen. Die original-Firmware ist oft nur vom Funktionsumfang her sehr spartanisch, aber es kann auf vielen Speedports auch die Fritz!-Firmware (auf AVM-baugleichen Speedports) oder andere alternative Firmwares (Bitswitcher, OpenWrt, ...) verwendet werden. Beim hier verwendeten W502V sieht es da aber auf den ersten Blick eher schlecht aus, aber sowas sollte man sowieso nur in Betracht ziehen, wenn man sich der Sache halbwegs sicher ist.

    Soweit waren wir schon! Die Empfehlung für WPA2 habe ich bereits gegeben, aber zur Fehlereingrenzung wäre es eher vorteilhaft die Verschlüsselung (kurzzeitig!) komplett zu deaktivieren.

    Ich denke, dass er das Problem mit einer anderen Hardware umgehen kann wird ihm auch klar sein. :) Bevor man immer "neu kauft", kann man aber doch erstmal versuchen das Problem zu lösen?!
     

Diese Seite empfehlen