1. Möchtest Du unser Team im Android OS-Bereich unterstützen? Details dazu findest du hier!
  2. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

ICS deaktiviert WLAN/3G automatisch -> unerwünschter Nebeneffekt

Dieses Thema im Forum "Android 4.0.x (Ice Cream Sandwich)" wurde erstellt von julioo, 22.07.2012.

  1. julioo, 22.07.2012 #1
    julioo

    julioo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    282
    Erhaltene Danke:
    20
    Registriert seit:
    30.01.2012
    Hallo,

    wenn ichs richtig sehe, hat ICS als Stromsparmaßnahme ein Feature eingeführt, das WLAN und 3G nach einer längeren Zeit der Inaktivität automatisch schlafen legt. Zumindest erscheint beim Einschalten des Screens das entsprechende Symbol in der Statusleiste erst nach ca. einer Sekunde, was in GB nicht der Fall war.

    Mein Problem liegt nun bei einer Wecker-App, die ein Feature "Sprechende Uhr" mit Zeit-/Temp./Wettervorhersage anbietet, welches aber zum Weck-Zeitpunkt online die Daten beziehen muss. Vor ICS hat das einwandfrei gefunzt, seit ICS nicht mehr. Heute dann vor dem Wecker aufgewacht und am Phone gesurft, et voila, die Sprechende Uhr lief wieder (da sie Internet hatte).

    Mich interessiert nun, ob man die autom. Abschaltung als ICS-Feature irgendwo deaktivieren kann. Wem noch eine bessere Lösung einfällt, gerne her damit!
     
    Zuletzt bearbeitet: 22.07.2012
  2. julioo, 22.07.2012 #2
    julioo

    julioo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    282
    Erhaltene Danke:
    20
    Registriert seit:
    30.01.2012
    ...
     
    Zuletzt bearbeitet: 23.07.2012
  3. haselchen, 23.07.2012 #3
    haselchen

    haselchen Android-Experte

    Beiträge:
    499
    Erhaltene Danke:
    43
    Registriert seit:
    07.07.2012
    Phone:
    Samsung Galaxy S6
    Tablet:
    Samsung Galaxy Tab S
    Ist wohl doch eher ICS spezifisch. Und zwar kann man beim Energiesparmodus benutzerdefiniert einstellen was passieren soll. U.a. gehört da auch WLAN zu , wenn es nicht verbunden ist, dass es ausgeschaltet wird.
    Ich weiss leider nicht wie es vor ICS war , weil ich mein S2 sofort upgedatet habe ohne GB auszuprobieren.
     
  4. julioo, 23.07.2012 #4
    julioo

    julioo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    282
    Erhaltene Danke:
    20
    Registriert seit:
    30.01.2012
    Hey haselchen, danke für den Hinweis mit den Energieeinstellungen!
    Unter Einstellungen -> Power -> Akkuverbrauch -> WLAN kommt man zu den Nutzungsdetails mit der Punkt: "WLAN bei Nichtverwendung oder Nichtverfügbarkeit deaktivieren" => Hier liegt auf jeden Fall der Hase im Pfeffer! Während die Einstellung bei Nichtverfügbarkeit von AccessPoints sinnvoll ist, ist die Deaktivierung bei Nichtverwendung genau der Punkt den ich ändern will/muss. Anscheinend hat Google hier aber vergessen eine Änderungsmöglichkeit einzufügen. Der Button WLAN führt einfach nur weiter zu der Seite mit aufgelisteten Access Points, wo sich aber nichts ändern lässt.

    [​IMG]


    Für Tips wie man an der Schraube drehen kann, wär ich super dankbar. Vermisse die Sprachansage beim Wecker :(
     
  5. haselchen, 24.07.2012 #5
    haselchen

    haselchen Android-Experte

    Beiträge:
    499
    Erhaltene Danke:
    43
    Registriert seit:
    07.07.2012
    Phone:
    Samsung Galaxy S6
    Tablet:
    Samsung Galaxy Tab S
    Kannst Du auf "Energieverbrauch anpassen" drücken?
    (Eine Zeile über dem WLAN Button)
     
  6. julioo, 24.07.2012 #6
    julioo

    julioo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    282
    Erhaltene Danke:
    20
    Registriert seit:
    30.01.2012
    moin :)
    :(
    du etwa?
     
  7. haselchen, 24.07.2012 #7
    haselchen

    haselchen Android-Experte

    Beiträge:
    499
    Erhaltene Danke:
    43
    Registriert seit:
    07.07.2012
    Phone:
    Samsung Galaxy S6
    Tablet:
    Samsung Galaxy Tab S
    Ich hab anscheinend andere Einstellmöglichkeiten mit meinem ICS aufm S2.
    Ich kann bei Einstellungen --> Ernergiesparmodus --> benutzerdefiniertes Ernergiesparen --> "WLAN ausschalten, wenn nicht verbunden" anklicken oder den Haken wegmachen.
    Andere Möglichkeiten gibt es dort auch noch. GPS ausschalten wenn... Bluetooth ausschalten wenn....
    Auch kann man Energiesparen bei 10,20 bis 50% Akkuleistung einstellen.

    Genau das dachte ich, wäre Dein Problem, dass sowas bei Deinem Handy angeschaltet ist.
     
  8. Denner, 24.07.2012 #8
    Denner

    Denner Android-Experte

    Beiträge:
    455
    Erhaltene Danke:
    43
    Registriert seit:
    25.04.2012
    Bei mir

    Einstellungen
    WLAN
    Erweitert -> WLAN aktiv bei Standby -> an oder abschalten


    Ps: ich nehme Alarmdroid kostenlos, der schaltet morgens das WLAN ein und ist eh der beste Wecker für Android.

    Gesendet von meinem A500 mit Tapatalk 2
     
  9. julioo, 24.07.2012 #9
    julioo

    julioo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    282
    Erhaltene Danke:
    20
    Registriert seit:
    30.01.2012
    Da wünscht man sich glatt wieder ein einheitliches OS...
    Bei meinem HTC Evo 3D ist bei ICS Einiges in Sachen Energiesparmodus verändert worden (evtl. weggefallen?). Bei Unterschreitung einer Grenze (~20%) ist im Popup-Fenster der Button "Energissparmodus" durch sowas wie "Akkuverbrauch" ersetzt worden.

    Die Einstellung bei beim S2 habe ich einfach nicht. Unter Einstell. gehts mit "Power" weiter...

    @Denner: Unter WLAN -> erweitert habe ich sowas ähnliches:
    "WLAN im Standby-Modus aktiviert belassen" -> "Immer" ist gewählt. Hier hatte ich anfangs die Lösung auch vermutet, allerdings ist die Einstell. ja anscheinend korrekt gewählt oder? Statt "Immer" gibts noch "Nur wenn angeschlossen" und "Nie (erhöht den Datenverbrauch)"

    PS: Genau die AlarmDroid-App hab ich auch und leider schaltet die App das WLan nicht autom. ein. Dennoch sehe ich das Problem nicht dort sondern bei ICS
     
    Zuletzt bearbeitet: 24.07.2012
  10. DroydFreak, 26.07.2012 #10
    DroydFreak

    DroydFreak Android-Lexikon

    Beiträge:
    1,836
    Erhaltene Danke:
    328
    Registriert seit:
    12.01.2012
    Phone:
    Sony Xperia Z3C
  11. Denner, 27.07.2012 #11
    Denner

    Denner Android-Experte

    Beiträge:
    455
    Erhaltene Danke:
    43
    Registriert seit:
    25.04.2012
    uploadfromtaptalk1343378333952.jpg

    Bei mir schaltet sich das WLAN mit dem Wecker an, obwohl ich beim ins Bett gehen WLAN manuell deaktiviert habe.


    Gesendet von meinem A500 mit Tapatalk 2
     
  12. Juwi97, 27.07.2012 #12
    Juwi97

    Juwi97 Erfahrener Benutzer

    Beiträge:
    212
    Erhaltene Danke:
    7
    Registriert seit:
    10.08.2010
    Phone:
    S6 Edge
    Einen sonnigen Morgen,

    Die Einstellungen des Galaxy 2 findest du bei der HTC Version vom ICS unter "Einstellungen -> WLAN -> Menü-Button -> Erweitert -> WLAN im Standy-Modus aktiviert belassen"

    -Julius
     
  13. julioo, 27.07.2012 #13
    julioo

    julioo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    282
    Erhaltene Danke:
    20
    Registriert seit:
    30.01.2012
    Wie gesagt, die Einstellung dort steht bei mir auf "immer". Dennoch schaltet es sich nach einiger Zeit ab, Einstellung ist also unwirksam.
     
  14. Denner, 27.07.2012 #14
    Denner

    Denner Android-Experte

    Beiträge:
    455
    Erhaltene Danke:
    43
    Registriert seit:
    25.04.2012
    Ich habe bei mir die Option, nur wenn Strom genommen.

    Mich wundert es nur, dass sich dein WLAN nicht aktiviert, wenn eine Applikation das anfordert. Hat du den Haken im Wecker gemacht?

    uploadfromtaptalk1343386920618.jpg

    Gesendet von meinem A500 mit Tapatalk 2
     
  15. julioo, 27.07.2012 #15
    julioo

    julioo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    282
    Erhaltene Danke:
    20
    Registriert seit:
    30.01.2012
  16. Denner, 27.07.2012 #16
    Denner

    Denner Android-Experte

    Beiträge:
    455
    Erhaltene Danke:
    43
    Registriert seit:
    25.04.2012
    Bei mir sieht es so aus, immer ist immer

    uploadfromtaptalk1343387632671.jpg

    Gesendet von meinem A500 mit Tapatalk 2
     
  17. julioo, 27.07.2012 #17
    julioo

    julioo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    282
    Erhaltene Danke:
    20
    Registriert seit:
    30.01.2012
    Jo bei HTC ICS siehts exakt genauso aus. Hab wie gesagt "immer" gewählt, d.h. eig. sollte dann WLAN nie ausgehen, auch nicht nach längerer Nichtnutzung. Dem ist aber nicht so.
     
  18. Krizzah, 06.12.2012 #18
    Krizzah

    Krizzah Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    06.12.2012
    hatte genau das selbe Problem das sich das Wlan immer ca 2-5 sec nach der Tastatursperre ausgeschaltet und ca 1 sek nach entriegelung wieder eingeschaltet hatte , ziemlich nerfig wenn man auf nachrichten wie emails oder von whtsapp wartet.
    hatte die einstellung nach einem root kassiert, selbst nach werkseinstellung war sie noch vorhanden ( was beim handykauf plus update auf ICS 4.0.4 komischerweisse nicht der fall war )

    wie dem auch sei.

    jetzt wirds lächerlich: einstellungen -> Wifi (wo die ganzen netze aufgelistet sind) -> dann die kontextmenütaste drücken :w00t00: (sofern du eine hast^^) -> erweitert -> Wifi im Standby-Modus Aktiviert lassen -> immer

    hab das LG P940 Prada 3. hat insgesammt 4 tasten unterm bildschirm. unter anderem auch die kontextmenütaste, gekennzeichnet durch ein viereck. andere handys haben soviel ich weis zb nur 3 tasten.


    Im endeffekt die selbe lösung wie Juwi97 vorgeschlagen hat, allerdings konnt ich mir nichts unter der menütaste vorstellen und hab daher probiert bis zum erbrechen bis ich zufällig mal die taste gedrückt hab. so ein fail

    die lösung übrigends nicht mit der der energieverwaltung verwechseln, das eine hat mit dem anderen nichts zu tun
     
    Zuletzt bearbeitet: 06.12.2012

Diese Seite empfehlen