1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

init.d script startet nicht

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy S" wurde erstellt von JobbeDeluxe, 26.06.2012.

  1. JobbeDeluxe, 26.06.2012 #1
    JobbeDeluxe

    JobbeDeluxe Threadstarter Android-Experte

    Beiträge:
    594
    Erhaltene Danke:
    99
    Registriert seit:
    19.07.2011
    Hallo, ich wollte den dcim ordner von der externen sd card auf der internen mounten. Damit das auch bei einem reboot der fall ist wollte ich mir einen script in init.d kopieren. dieser wird aber nicht gestartet und ich weiss nicht wo der fehler ist. google brachte nur ergebnise für linux aber nix wirklich für android oder besser gesagt für das Galaxy S.

    Mein script sieht so aus:

    #!/system/xbin/sh
    # 23dcimmount
    busybox mount /emmc/.DCIM /sdcard/DCIM

    der . bei der externen ist mit absicht da damit die bilder nicht doppelt in der galerie auftauchen.

    Ich habe die rechte gesetzt und trozdem ging es nicht. Dan habe ich ein vorhandenes script aus einer update.zip genommen und habe dort mein inhalt reingeschrieben und es im recovery geflashed. Auch ohne ergebnis. Was mache ich Falsch?

    EDIT: Ich habe die AOKP Build 40 drauf mit semaphore kernel 1.2.5 fals das wichtig ist

    Gruss Jobbe
     
    Zuletzt bearbeitet: 26.06.2012
  2. jna, 27.06.2012 #2
    jna

    jna Ehrenmitglied

    Beiträge:
    7,398
    Erhaltene Danke:
    1,299
    Registriert seit:
    28.01.2011
  3. Weissi46, 27.06.2012 #3
    Weissi46

    Weissi46 Android-Experte

    Beiträge:
    496
    Erhaltene Danke:
    106
    Registriert seit:
    07.11.2011
    Phone:
    Oneplus One
    Versuch mal /mnt/emmc/.DCIM und /mnt/sdcard/DCIM

    Gesendet von meinem GT-I9000 mit Tapatalk 2
     
  4. JobbeDeluxe, 28.06.2012 #4
    JobbeDeluxe

    JobbeDeluxe Threadstarter Android-Experte

    Beiträge:
    594
    Erhaltene Danke:
    99
    Registriert seit:
    19.07.2011
    Das ändern des Pfades hat nicht geklappt. Das Programm von den devs geht auch nicht. In ich habe die Ordner eingetragen und manuell gestartet, alles gut. Ich dann habe ich Start beim boot eingeschaltet und neu gestartet. Da War kurz zu sehen das das Programm startet. Ich aber kurz darauf habe ich einen FC von dem Programm bekommen. Ich anschauen konnte ich es nicht mehr starten. Ich sofort FC, als es dann ging War meine Ordner Einstellung weg. Ich also leider such nicht das was ich brauche. Ich auch wenn der Ansatz richtig War.
     
  5. extralife, 28.06.2012 #5
    extralife

    extralife Android-Guru

    Beiträge:
    2,217
    Erhaltene Danke:
    818
    Registriert seit:
    22.09.2010
    Kann so nicht starten.

    #! /system/xbin/busybox sh


    Gesendet von meinem GT-I9300 mit Tapatalk 2
     

Diese Seite empfehlen