1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

initramfs Fehler

Dieses Thema im Forum "Toshiba AC100 Forum" wurde erstellt von benjohnwie, 19.12.2011.

  1. benjohnwie, 19.12.2011 #1
    benjohnwie

    benjohnwie Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    19.12.2011
    Moin moin :)

    Ich hab hier ein kleines Problem.:unsure:
    Ich habe schon das internet und die Foren durchforstet und lediglich die Andeutung:
    gefunden.
    Ein paar Postings vorher finde ich nichts (oder überlese ich da was?)... Wie lässt sich das Problem lösen? Tritt es nur vereinzelt oder öfters auf?

    Hier noch meine Fehlermeldung:
    Code:
    $ sudo update-initramfs -u
    update-initramfs: Generating /boot/initrd.img-2.6.38-1001-ac100
    Could not find an Android boot partition on a MMC device
    run-parts: /etc/initramfs/post-update.d//zz-flash-kernel exited with return code 1
    Vielen dank Für Infos!

    MfG Ben
     
  2. pibach, 20.12.2011 #2
    pibach

    pibach Gesperrt

    Beiträge:
    910
    Erhaltene Danke:
    107
    Registriert seit:
    13.02.2011
    ja.
    Durchsuch mal meine Postings vorher nach diesem Keyword....
    Evtl hast Du aber auch eine andere Ursachen...?
     
  3. benjohnwie, 20.12.2011 #3
    benjohnwie

    benjohnwie Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    19.12.2011
    Sorry @ pibach :D als ich
    gelesen hab, bin ich nicht weit genug zurück gegangen und hab die suchfunktion wohl unterschätzt.:crying:

    Achtung bitte den Ganzen beitrag lesen wer das gleiche Problem hat! Ich bin mir nicht ganz sicher was genau ich gemacht habe, deshalb halte ich die Anleitung nicht zwangsläufig für richtig! Am besten setzt ihr euch mit den beiträgen unten und http://www.android-hilfe.de/toshiba-ac100-forum/122023-ubuntu-netbook-linux-auf-ac100-8.html auseinander.


    Also folgendes hat bei mir geklappt:


    Code:
    sudo abootimg -u /dev/mmcblk0p2(hier kann auch was anderes stehen z.B. mmcblk3p6 ... checkt das am besten mit sudo fdisk -l ) -c "(Das Anführungszeichen ist notwendig!) Hier die Zeilen aus /boot/bootimg.cfg 
    danach strg+c... komme sonst nicht raus? bringt das dann was :D eigl beende ich dann den vorgang ja wieder.. aber iwas muss sich ja verändert haben.

    und dann
    Code:
    sudo apt-get update
    und danach
    Code:
    sudo update-initramfs -u
    es sollte
    Code:
    update-initramfs: Generating /boot/initrd.img-2.6.38-1001-ac100
    Flashing kernel and initramfs to /dev/mmcblk0p2... done.
    
    Als Meldung kommen.


    Man sollte sich auf jedenfall nochmal hiermit auseinandersetzen

    und


     
  4. pibach, 20.12.2011 #4
    pibach

    pibach Gesperrt

    Beiträge:
    910
    Erhaltene Danke:
    107
    Registriert seit:
    13.02.2011
    ich glaube der Befehl abootimg bla muss nicht unbedingt selber direkt aufgerufen werden, wird wohl durch normales update getriggert sobald neuer Kernel vorliegt.
     
  5. Phasenspringer, 20.12.2011 #5
    Phasenspringer

    Phasenspringer Gast

    "sudo apt-get install abootimage" hat bei mir gereicht, soweit ich mich noch recht erinnere.
    vielleicht noch "sudo apt-get install flash-kernel" zur Sicherheit:winki: mehr war es bei mir aber nicht. Wobei bei letzterem wohl nur die Nachricht kam, das da das aktuellste Paket schon installiert sei.

    Mit anderen Worten: nach Reinstallation von "abootimage" war bei mir seinerzeit alles wieder im Lot!
     
    Zuletzt von einem Moderator bearbeitet: 20.12.2011
  6. benjohnwie, 21.12.2011 #6
    benjohnwie

    benjohnwie Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    19.12.2011
    war nicht möglich, da
    Code:
    sudo apt-get install abootimg
    nicht ausgeführt werden konnte. Hatte bei jedem .deb und bei jedem apt-get eine fehlermeldung, dass initramfs fehlschlägt.
     

Diese Seite empfehlen