1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Interner Speicher nur noch readonly

Dieses Thema im Forum "Root / Custom-ROMs / Modding für Lenovo IdeaPad K1" wurde erstellt von pmedia, 22.04.2012.

  1. pmedia, 22.04.2012 #1
    pmedia

    pmedia Threadstarter Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    22.04.2012
    Hallo,

    ich hoffe, es nimmt mir niemand übel, dass ich in diesem Forum poste, obwohl mein Gerät nicht Lenovo K1 heißt; es handelt sich um das Medion Lifetab P9516 / MD99100, das nach meinen Recherchen technisch baugleich zum Lenovo K1 ist. Soviel zur Begründung der Forenwahl.

    Nun zu meinem Problem:
    Wir haben das Gerät zum Erscheinungstag Ende März erworben und waren damit bislang recht glücklich, da Medion am Vanilla-Android erfreulich wenige Modifikationen vorgenommen hat, im Gegensatz zB zu HTC mit Sense.
    Bislang lief alles super, doch nachdem das Gerät ausgeschaltet 3 Tage am Ladegerät hing, staunte ich nicht schlecht, dass nach dem Einschalten ersteinmal ein dutzend Anwendungen abstürzte (die wohl aufgrund des OnBoot-Listeners mitgestartet wurden).

    Auch WLAN ließ sich nicht aktivieren, Screenshots ließen sich nicht anfertigen und schon gar nicht ließ sich das Gerät für den Zweck nutzen, für den es angeschafft wurde - und zwar selbstentwickelte Apps zu testen. ADB lieferte allerdings auch einen Anhaltspunkt, warum die Anwendung nicht auf das Gerät kopiert werden konnte: der interne Speicher des Gerätes, der von /dev/fuse nach /mnt/sdcard gemountet ist, ist read-only.

    Via adb shell ließ sich die Symptomatik nachstellen, es ist kein Schreibzugriff möglich. Zudem stürzen Anwendungen, die offensichtlich Schreibversuche machen, direkt ab.

    Gemäß "mount" wurde jedoch offenbar zumindest versucht, die devices als rw zu mounten:
    Code:
    $ mount
    rootfs / rootfs ro,relatime 0 0
    tmpfs /dev tmpfs rw,nosuid,relatime,mode=755 0 0
    devpts /dev/pts devpts rw,relatime,mode=600 0 0
    proc /proc proc rw,relatime 0 0
    sysfs /sys sysfs rw,relatime 0 0
    debugfs /sys/kernel/debug debugfs rw,relatime 0 0
    none /acct cgroup rw,relatime,cpuacct 0 0
    tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0
    tmpfs /mnt/obb tmpfs rw,relatime,mode=755,gid=1000 0 0
    none /dev/cpuctl cgroup rw,relatime,cpu 0 0
    /dev/block/mmcblk0p3 /system ext4 ro,relatime,barrier=1,data=ordered 0 0
    /dev/block/mmcblk0p7 /data ext4 ro,nosuid,nodev,noatime,barrier=1,data=ordered 0 0
    /dev/block/mmcblk0p4 /cache ext4 rw,nosuid,nodev,noatime,barrier=1,data=ordered 0 0
    /dev/block/mmcblk0p8 /data/temp ext4 rw,nosuid,nodev,noatime,barrier=1,data=ordered 0 0
    /dev/fuse /mnt/sdcard fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=1023,default_permissions,allow_other 0 0
    Auch ist der Speicher nicht voll:
    Code:
    $ df
    Filesystem             Size   Used   Free   Blksize
    /dev                   363M    32K   363M   4096
    /mnt/asec              363M     0K   363M   4096
    /mnt/obb               363M     0K   363M   4096
    /system                413M   236M   176M   4096
    /data                   24G    11G    13G   4096
    /cache                 123M    16M   107M   4096
    /data/temp               2G   217M     2G   4096
    /mnt/sdcard             24G    11G    13G   4096
    
    Ein remount via adb schlägt aufgrund mangelnder Rechte jedoch fehl.
    dmesg zeigt folgendes:
    Code:
    [...]
    <4>[   34.550016] mmc2:0001:1: pending IRQ with no handler
    <4>[   34.550179] mmc2:0001:1: pending IRQ with no handler
    <4>[   34.661186] wifi_set_power = 0
    <4>[   34.979982] wifi_set_carddetect = 0
    <6>[   35.180495] mmc2: card 0001 removed
    
    Hier weiß ich allerdings nicht, wie ich die Ausgabe zu deuten habe.

    Auch habe ich bereits versucht, das Gerät in den Werkszustand zurückzusetzen doch - oh Wunder - auch die Einstellungsanwendung stürzt ab, bei dem Versuch, den Datenschutz-Reiter, in dem sich die Option befindet, zu öffnen.

    Auch habe ich mir gedacht, ist es bei vielen Geräten so, dass man beim booten gleichzeitig beide Tasten der Lautstärkewippe betätigt und in einen Bootmanager gelangt; was tatsächlich passiert, ist ein schwarzer Bildschirm mit leuchten der beiden LEDs, wobei die obere zeitweilig inaktiv ist.

    Daher meine Frage:
    Was kann ich tun, um den Speicher wieder in einen schreibbaren Zugriff zu bringen?
    Aufgrund des Alters des Gerätes glaube ich nicht, dass der Flashspeicher erschöpft sein könnte; liegt ggf. ein technischer Defekt vor?

    // edit 19:21
    Ergänzung: Das Gerät ist ungerootet und wurde bislang nahezu ausschl. zum Test der eigenen App verwendet; andere Testgeräte zeigen das Problem nicht.
     
    Zuletzt bearbeitet: 22.04.2012
  2. Edgar62, 03.06.2012 #2
    Edgar62

    Edgar62 Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    1
    Registriert seit:
    13.04.2011
    Hallo,

    ich bin durch die Suche auf diesen Beitrag gestoßen. Das Lifetab meiner Frau hat seit gestern genau dieses von dir geschilderte Problem. Der interne Speicher (/mnt/sdcard) ist offensichtlich read-only geschaltet.

    Nach meinen Beobachtungen passiert das aber erst nach dem Start von irgendeiner Schadsoftware (welche, weiß ich noch nicht). Denn kurz nach dem Start kann man noch Anwendungen zum Beispiel deinstallieren oder (vom PC aus) per play-Market installieren lassen. So habe ich es noch geschafft, eine Backup-Software zu installieren.

    Meine Frage: Hast du seit April noch weitere Fortschritte erzielt und erfahren, woran es lag? Oder wie ging es weiter?

    MfG

    Edgar
     
  3. pmedia, 03.06.2012 #3
    pmedia

    pmedia Threadstarter Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    22.04.2012
    Hallo Edgar,

    nein, da es sich um ein Firmeninternes Testgerät handelte, habe ich da selbst nichts mehr herumgebastelt.
    Und bei uns handelte es sich in aller Wahrscheinlichkeit auch nicht um eine Schadsoftware, da auf diesem Gerät nur unsere selbst entwickelte App getestet wurde.

    Wie es weiterging?
    Nun, nach einem Mail-Wechsel mit dem E-Mail-Support und einer zunächst generischen Antwort ("Bitte Gerät zurücksetzen") von Medion haben wir das Gerät eingeschickt, wo ein Softwarefehler entdeckt wurde. Zusätzlich wurde der Flash-Speicher ausgetauscht und ein Firmwareupdate eingespielt; das Gerät erreichte uns nach 1.5 Wochen in wieder funktionsfähigem Zustand und läuft seitdem tadellos.

    Ich hoffe, ich habe dir hiermit helfen können :)
     

Diese Seite empfehlen