1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Java verhält sich auf zwei Rechnern unterschiedlich

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von AquaBall, 12.03.2012.

  1. AquaBall, 12.03.2012 #1
    AquaBall

    AquaBall Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    121
    Erhaltene Danke:
    2
    Registriert seit:
    29.02.2012
    Ich entwickle auf meinem PC und LapTop gleichzeitig ein AndroidProgramm
    dazu kopiere ich einfach den ganzen Paketordner, (nachdem ich anfangs das Projekt manuell angelegt habe).
    Doch offensichtlich sind Einstellungen nich identisch.
    Ich verwende z.B. die Klasse TextWatcher: private class SyncedTextWatcher implements TextWatcher {
    Die beinhaltet u.a. die Methode: public void afterTextChanged(Editable s)
    die für die Verwendung logischerweise "overrided" werden muss.
    Am PC VERLANGT Eclipse konsequenterweise die Annotation @OVERRIDE (ohne gehts nicht)
    am LapTop moniert er aber diese Annotation als überflüssig, und läuft nur OHNE sie fehlerfrei.

    Welche Einstellung fehlt mir da am Laptop?
    Ist das wesentlich und handle ich mir FolgeProbleme ein, wenn ich den LapTop so lasse?
     
  2. the_alien, 12.03.2012 #2
    the_alien

    the_alien Android-Lexikon

    Beiträge:
    1,559
    Erhaltene Danke:
    184
    Registriert seit:
    04.05.2009
    Java 1.5 auf dem Laptop und 1.6 auf dem Pc.
     
  3. AquaBall, 13.03.2012 #3
    AquaBall

    AquaBall Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    121
    Erhaltene Danke:
    2
    Registriert seit:
    29.02.2012
    hmm. am LapTop hab ich 1.6.31
    und PC kann ich gerade nicht prüfen, weil ich z.Zt. in der Klinik bin.
    Aber in 1-2 WOchen werd ich das checken.
     
  4. Fonsi, 14.03.2012 #4
    Fonsi

    Fonsi Erfahrener Benutzer

    Beiträge:
    178
    Erhaltene Danke:
    15
    Registriert seit:
    08.07.2011
    Es geht um den Java Compiler für dein Eclipse-Projekt selbst ;-)
     
    the_alien bedankt sich.
  5. the_alien, 14.03.2012 #5
    the_alien

    the_alien Android-Lexikon

    Beiträge:
    1,559
    Erhaltene Danke:
    184
    Registriert seit:
    04.05.2009
    @Override an Interace Methoden die implementiert werden ist unter Java 6 zwingend erforderlich, unter Java 5 führt es zu einem Fehler. Umgekehrt genau so. Also kontrolliere dein Compilerlevel in Eclipse.
     
  6. v Ralle v, 14.03.2012 #6
    v Ralle v

    v Ralle v Android-Lexikon

    Beiträge:
    913
    Erhaltene Danke:
    199
    Registriert seit:
    27.08.2010
    Seit wann ist bitte @Override erforderlich?! Habe es direkt vor mir und das ist definitiv nicht der Fall. Das bei 1.5 ein Fehler geworfen wird, ist klar, aber bei 1.6 ist es definitiv nicht zwingend...

    Für mich persönlich gehört es zum guten Stil die Annotation hinzuzufügen, dennoch muss man es nicht.
     
  7. the_alien, 14.03.2012 #7
    the_alien

    the_alien Android-Lexikon

    Beiträge:
    1,559
    Erhaltene Danke:
    184
    Registriert seit:
    04.05.2009
    Gibt das in Java 6 nur eine Compiler Warning?
     
  8. v Ralle v, 14.03.2012 #8
    v Ralle v

    v Ralle v Android-Lexikon

    Beiträge:
    913
    Erhaltene Danke:
    199
    Registriert seit:
    27.08.2010
    Ich glaube noch nicht mal das, bzw. bin ich mir ziemlich sicher.
     
  9. Kranki, 14.03.2012 #9
    Kranki

    Kranki Ehrenmitglied

    Beiträge:
    3,831
    Erhaltene Danke:
    814
    Registriert seit:
    19.07.2009
    Tablet:
    Samsung Galaxy Tab 3 7.0 Lite
    Normalerweise nicht, die Annotation ist optional. Das kann man in Eclipse aber konfigurieren unter Preferences -> Java -> Compiler -> Errors/Warnings -> Annotations.
    Ich vermute, dass das hier das Problem ist.
     
  10. AquaBall, 22.03.2012 #10
    AquaBall

    AquaBall Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    121
    Erhaltene Danke:
    2
    Registriert seit:
    29.02.2012
    Hallo! Bin zurück aus dem Krankenhaus.
    Und konnte jetzt testen.

    Auf dem Laptop ist zwar 1.7 installiert, aber im Projekt ist Java-Erstellungspfad JRE1.6 eingetragen.

    Offensichtlich gibts da ein Problem mit Projekt übertragen durch einfaches Kopieren (Besseren Weg hab ich aber noch nicht.)

    Hab das nun geändert unter Projekt/RechtKlick/Eigenschaften/Java-Erstellungspfad/Bibliotheken//BibliothekHinzufügen/JRE-SystemBibliothek.

    ... und alles läuft harmonisch.
     

Diese Seite empfehlen