1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

kann nichts mehr flashen

Dieses Thema im Forum "Samsung Galaxy S Plus (I9001) Forum" wurde erstellt von bommelid, 27.07.2012.

  1. bommelid, 27.07.2012 #1
    bommelid

    bommelid Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    27.07.2012
    Hallo,

    ich habe seit ein paar Tagen Probleme mit meinem SGS+.
    Nachdem zuerst die Email-App nicht mehr funktionierte, kamen weitere Dinge hinzu. Updates sind nach dem Neustart des Telefons wieder weg. Die letzte SMS wird immer wieder als neu angezeigt. Einige Apps verweigern die Arbeit und Apps auf der externen SD-Card funktinieren nicht mehr. Telefonieren geht noch.
    Ich habe schon versucht, mittels ODIN (4.43) und auch mit Feamod (5.0.0.27) eine neue Firmware zu flashen. Beides ohne Erfolg. Egal ob ich versuche, eine komplette Firmware oder nur ein neues Recovery zu flashen. Es funktioniert nicht. /data wipen funktioniert übrigens auch nicht. Da kommt die Meldung "error formatting /sdcard/.android_secure". Gibt es eine Möglichkeit über adb den Speicher neu zu partitionieren oder zu prüfen? Wenn ich per adb mit parted /dev/block/mmcblk0 öffne und print eingebe, kommt die Meldung "Error: Can't have a partition outside the disk!".
    Bin inzwischen relativ ratlos. Hat jemand eine Idee?

    Gruß
    bommelid
     
  2. Cynob, 27.07.2012 #2
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,732
    Erhaltene Danke:
    919
    Registriert seit:
    17.04.2011
    Hallo :)
    Also wenn ich das jetzt richtig verstehe kommst du aber noch ins System? mmcblk0 würde ich nicht unbedingt formatieren ;) das ist das rootfs
    Da die Partitionen anscheinend ja noch erkannt werden würde ich die eher mal mit 0en überschreiben - also sowas wie dd if=/dev/null of=/dev/block/mmcblk0p15 um die Systempartition zu leeren z.b.
     
  3. bommelid, 27.07.2012 #3
    bommelid

    bommelid Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    27.07.2012
    Ich wollte mmcblk0 auch nicht formatieren, sondern mir die Partitionstabelle ausgeben lassen. Das funktioniert aber nicht.
    Habe Bedenken, /dev/block/mmcblk0p15 einfach mit Nullen zu füllen. Flashen klappt ja nicht mehr, was nicht an der Partition 15 liegt, denke ich. Kann ja nicht einmal mehr ein neues Recovery flashen. Wahrscheinlich sitze ich dann mit einer leeren Part15 da. Als letzten Ausweg merke ich mir das aber mal vor.
     
  4. Cynob, 27.07.2012 #4
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,732
    Erhaltene Danke:
    919
    Registriert seit:
    17.04.2011
    was grad eingehängt ist siehst du mithilfe des mount Befehls. Ein neues recovery solltest du auf mmcblk0p13 spielen können ;)
     
  5. bommelid, 27.07.2012 #5
    bommelid

    bommelid Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    27.07.2012
    Mit mount hatte ich schon geschaut. Da waren /system, /cache und /data eingehängt.
    Kannst Du mir den genauen Befehl (die Vorgehensweise) zum Schreiben der Recovery-Partition geben. Muss das recovery.img vorher auf die sdcard?
    Bin zwar skeptisch, dass das klappt, da es mit ODIN und auch von Feamod nicht geht aber ich werde es versuchen.
     
  6. Cynob, 27.07.2012 #6
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,732
    Erhaltene Danke:
    919
    Registriert seit:
    17.04.2011
    warum sollte es denn nicht gehen :D
    also zuerst holst du dir irgendwoher n recovery.img ( aus ner Rom oder update.zip oder so) das dann auf die interne SDKarte kopieren. Ein Terminal öffnen und eigeben:

    $su
    #dd if=/mnt/sdcard/recovery.img of=/dev/block/mmcblk0p13

    Nach nem Neustart dann wird das neue recovery aktiv sein.
     
  7. bommelid, 27.07.2012 #7
    bommelid

    bommelid Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    27.07.2012
    Habe folgendes gemacht:

    ~ # dd if=/sdcard/recovery.img of=/dev/block/mmcblk0p13
    8168+0 records in
    8168+0 records out
    4182016 bytes (4.0MB) copied, 1.359466 seconds, 2.9MB/s

    Kopieren hat also funktioniert. Trotzdem kommt nach dem Reboot das alte Recovery. Woran kann das liegen? Beim Flashen ist es ja auch so. Keine Fehlermeldung und trotzdem ist die alte Firmware drauf.
     
  8. Maniaxx, 29.07.2012 #8
    Maniaxx

    Maniaxx Android-Experte

    Beiträge:
    495
    Erhaltene Danke:
    36
    Registriert seit:
    11.10.2011
    Phone:
    Samsung Galaxy S4 LTE+
    Mach das im CWM, nicht im OS.
     
  9. Cynob, 29.07.2012 #9
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,732
    Erhaltene Danke:
    919
    Registriert seit:
    17.04.2011
    und was macht das für einen unterschied? Maniaxx
     
  10. bommelid, 29.07.2012 #10
    bommelid

    bommelid Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    27.07.2012
    Das hatte ich im CWM gemacht.
    Anscheinend ist der interne Speicher komplett schreibgeschützt.
    Wenn ich die externe SDCard unmounte kann ich im OS auch keine Apps mehr entfernen. Die "Bearbeiten"-Funktion ist nicht anwählbar.
     
  11. Cynob, 29.07.2012 #11
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,732
    Erhaltene Danke:
    919
    Registriert seit:
    17.04.2011
    :D ok eigentlich kann das alles nicht so sein....

    tipp mal bitte ins Terminal ein:

    mount > /sdcard/mnt.txt

    Dann kopierste den inhalt dieser Textdatei bitte hier mal her ( oder pastebin o.ä.)
    Is leichter als Abtippen :D
     
  12. bommelid, 29.07.2012 #12
    bommelid

    bommelid Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    27.07.2012
    Ja. Habe mir auch schon öfter gesagt, dass das alles nicht sein kann. Bringt nur nichts. Die mnt.txt auf sdcard konnte nicht erstellt werden. nur auf der externen. Wobei die auf der sdcard bis zum Unmounten nach Verbindung mit dem PC schon zu sehen war. Nur nach dem Unmount eben nicht mehr.

    Code:
    rootfs / rootfs ro,relatime 0 0
    tmpfs /dev tmpfs rw,relatime,mode=755 0 0
    devpts /dev/pts devpts rw,relatime,mode=600 0 0
    proc /proc proc rw,relatime 0 0
    sysfs /sys sysfs rw,relatime 0 0
    none /acct cgroup rw,relatime,cpuacct 0 0
    tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0
    tmpfs /mnt/obb tmpfs rw,relatime,mode=755,gid=1000 0 0
    none /dev/cpuctl cgroup rw,relatime,cpu 0 0
    /dev/block/mmcblk0p15 /system ext4 ro,relatime,barrier=1,data=ordered 0 0
    /dev/block/mmcblk0p17 /data ext4 rw,nosuid,nodev,noatime,errors=continue,barrier=1,data=ordered 0 0
    /dev/block/mmcblk0p12 /persist ext4 rw,nosuid,nodev,relatime,barrier=0,data=ordered 0 0
    /dev/block/mmcblk0p16 /cache ext4 rw,nosuid,nodev,noatime,errors=continue,barrier=1,data=ordered 0 0
    /dev/block/mmcblk0p27 /efs ext4 rw,nosuid,nodev,relatime,barrier=0,data=writeback 0 0
    /dev/block/vold/179:28 /mnt/sdcard vfat rw,dirsync,nosuid,nodev,noexec,noatime,nodiratime,uid=1000,gid=1015,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
    /dev/block/vold/179:33 /mnt/sdcard/external_sd vfat rw,dirsync,nosuid,nodev,noexec,noatime,nodiratime,uid=1000,gid=1015,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
    /dev/block/vold/179:33 /mnt/secure/asec vfat rw,dirsync,nosuid,nodev,noexec,noatime,nodiratime,uid=1000,gid=1015,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
    tmpfs /mnt/sdcard/external_sd/.android_secure tmpfs ro,relatime,size=0k,mode=000 0 0
     
  13. Cynob, 29.07.2012 #13
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,732
    Erhaltene Danke:
    919
    Registriert seit:
    17.04.2011
    Ok das ist aber schonmal gut zu wissen das die Interne SD auch die gleichen Ausfallerscheinungen zeigt - daran kannst du gut testen ohne das System irgendwie zu beeinflussen.
    Sichere mal deine Daten wo drauf sind :D
     
  14. bommelid, 29.07.2012 #14
    bommelid

    bommelid Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    27.07.2012
    Daten und /efs Partition sind gesichert.
     
  15. Cynob, 29.07.2012 #15
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,732
    Erhaltene Danke:
    919
    Registriert seit:
    17.04.2011
    ja ich mein den Inhalt deiner /sdcard
    Wenn du schon keine Datei dort anlegen kannst....
    Dein Dateisystem ist soweit ichs da oben sehen kann ja sauber gemountet - du solltest also Dateien anlegen können.

    Versuch mal die interne SD zu formatieren (entweder über die einstellungen oders Terminal = mkfs.vfat -v -n sdcard /dev/block/vold/179:28 )
     
  16. bommelid, 29.07.2012 #16
    bommelid

    bommelid Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    27.07.2012
    Über die Einstellungen kommt keine Fehlermeldung. Bringen tut es aber nichts.
    Im Terminal kommt, dass der Zugriff verweigert wurde:

    mnt.vfat: can't open '/dev/block/vold/179:28': Permission denied

    unmounten der sdcard geht auch nicht. (failed.)
     
  17. Cynob, 29.07.2012 #17
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,732
    Erhaltene Danke:
    919
    Registriert seit:
    17.04.2011
    vorher mal n "su" ins Terminal eingegeben für root rechte?
    und die sdcard mit: umount /sdcard ausgehängt?
     
  18. bommelid, 29.07.2012 #18
    bommelid

    bommelid Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    27.07.2012
    Ok, den su-Befahl hatte ich vergessen. Ging von root-Rechten aus.
    Also su, umount /sdcard und dann formatiert. Keine Fehlermeldung. Anscheinend wurde die Card tatsächlich formatiert. Nach dem Reboot ist aber wieder alles da. Bin ratlos.
     
  19. Cynob, 29.07.2012 #19
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,732
    Erhaltene Danke:
    919
    Registriert seit:
    17.04.2011
    wie? der inhalt der sdkarte ist wieder da nach nem reboot??!? aber nach dem Formatieren war alles weg?
    hast du mkfs.ext2 auf deinem Handy? also die busybox installiert? wenn ja formatier mal die sdkarte zu ext2 - dürfte dann nach nem starten nichtmehr einzuhängen sein vom system - also es müsste irgend ne Fehlermeldung kommen zumindest....
     
  20. bommelid, 29.07.2012 #20
    bommelid

    bommelid Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    27.07.2012
    Ok, werde morgen mal probieren, auf ext2 zu formatieren.
    format in Feamod lief normal durch. Hat auch ein paar Sekunden gedauert. Keine Fehlermeldung. Trotzdem ist alles noch da.
     

Diese Seite empfehlen