1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Kein Backup mit NVFlash möglich [gelöst]

Dieses Thema im Forum "Anleitungen für HANNspree HANNSpad (SN10T1)" wurde erstellt von SHORTY-NR1, 24.10.2011.

  1. SHORTY-NR1, 24.10.2011 #1
    SHORTY-NR1

    SHORTY-NR1 Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    342
    Erhaltene Danke:
    52
    Registriert seit:
    30.08.2011
    Problem mit NVFlash kein Backup möglch!​


    Wenn ihr auch mit NVFlash keinen Backup durchführen könnt, kann es an der entsprechen Partition liegen wo es nicht mehr weiter geht (nvflash bleibt einfach stehen).
    Habe das Problem so gelöst, das ich die entsprechende Partition mit NVFlash formatiert habe.


    Hier noch eine kurze Anleitung wie ihr es auch machen könnt:

    Die Batchdatei die ihr unter NVFlash zum erstellen eines Backups ausführt editieren wir, und ändern es so das die Partition die nicht gesichert werden konnte formatiert wird.

    Bei mir heist die Batchdatei "backup_hannspad.bat".

    So sieht die datei aus ohne änderungen:

    "nvflash.exe" --bl bootloader.bin --getbct --bct hanns.bct --go
    "nvflash.exe" -r --getpartitiontable partition.txt
    "nvflash.exe" -r --read 2 part-2.img
    "nvflash.exe" -r --read 3 part-3.img
    "nvflash.exe" -r --read 4 part-4.img
    "nvflash.exe" -r --read 5 part-5.img
    "nvflash.exe" -r --read 6 part-6.img
    "nvflash.exe" -r --read 7 part-7.img
    "nvflash.exe" -r --read 8 part-8.img
    "nvflash.exe" -r --read 9 part-9.img
    "nvflash.exe" -r --read 10 part-10.img
    "nvflash.exe" -r --read 11 part-11.img
    "nvflash.exe" -r --read 12 part-12.img
    "nvflash.exe" -r --read 13 part-13.img
    "nvflash.exe" -r --read 14 part-14.img

    Alle Zeilen mit "nvflash.exe"....part** entfernen, und die Partition die nicht gesichert werden konnte (bei mir part10) formatieren wir in dem wir eine neue Zeile einfügen ("nvflash.exe" -r --format_partition 10). Ihr könnt die Datei mit "Speicher unter" unter einem neuen Namen abspeichern, so bleibt die original Datei erhalten!

    So sollte die Batchdatei aussehen.

    "nvflash.exe" --bl bootloader.bin --getbct --bct hanns.bct --go
    "nvflash.exe" -r --getpartitiontable partition.txt
    "nvflash.exe" -r --format_partition 10


    Das Formatieren der Partition hat das Problem gelöst und bedeutet nicht das ihr dann auch gleich eine Sicherung machen solltet. Nach dem formatieren der Partition müsst ihr das Hannspad neu Flashen. Erst dann könnt ihr hoffentlich eine Sicherung ohne Probleme durchführen!
    Damit ihr nicht nach dem formatieren erneut einen Rom flaschen braucht, solltet ihr vor dem formatieren mit NVFlash, einen Backup unter CWM durchführen.
    Nachdem formatieren der Partition mit NVFlash, einfach das Backup unter CWM zurück spielen. Dann könnt ihr auch eine Sicherung mit NVFlash machen.
    Danke an ELexONE (siehe unten)!


    Eins muss noch geklärt werden, welche Partitionen kann man ohne bedenken Formatieren und welche nicht (vielleicht die recovery Partition nicht und welche ist das?).
    Hier sind die Experten gefragt (vielleicht user gurkensalat?). Weiss einer von euch was die einzelnen Partitionen bedeuten?

    Und einen DANK an marcero , ohne ihn hätte ich nicht herausgefunden wie man das durchführt. Endlich kann ich wieder eigene Backups mit NVFlash machen!!!!!!
     
    Zuletzt bearbeitet: 17.12.2011
    fmcheetah und AntonZilwicki haben sich bedankt.
  2. gurkensalat, 24.10.2011 #2
    gurkensalat

    gurkensalat Android-Hilfe.de Mitglied

    Beiträge:
    65
    Erhaltene Danke:
    7
    Registriert seit:
    11.08.2011
    Beim normalen Hannspads mit 14 Partitionen ist die neunte Partition die Recovery-Partition. Beim den Hannspads mit 12 Partitionen ist es Partition 7, aber das muss leider nicht immer stimmen.

    Etwas OT ich habe heute noch ein bisschen mit dem APX-Modus gespielt. Ich schaffe es nicht die Partitionierung zu ändern. Ich glaube ich bin dem Problem aber auf der Spur. Ich glaube man bräuchte das originale BCT des Hannspads. Denn wenn man sich das vorhandene mal ansieht stellt man fest das da kryptische Zeichen aber derer nicht all zu viele drin sind. Ich habe mir verschiedene BCTs direkt von NVIDIA angesehen die enthalten weitaus mehr Information. Leider passt keines der Harmony BCTs. Das Hannspad basiert auf einem der Harmony Entwicklerkits, verwendet auch den gleichen NAND-SPeicher aber andere Rambausteine. Natürlich habe ich trotzdem einen Versuch mit einem sehr ähnlichen BCT gewagt. Ergebnis nvflash hängt beim initialiesieren des Bootloaders.
     
  3. marcero, 25.10.2011 #3
    marcero

    marcero Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    Hab mal alle Partitionen durchgetestet, daher wusste ich das ich die formatieren kann. Ich stell die Ergebnisse davon bei Zeiten mal online.
     
  4. Patrick19, 29.10.2011 #4
    Patrick19

    Patrick19 Android-Hilfe.de Mitglied

    Beiträge:
    64
    Erhaltene Danke:
    7
    Registriert seit:
    02.09.2011
    Also ich hatte eben das gleich Problem.

    Ich habe dann einfach wie oben beschrieben (Danke dafür :smile:) einfach den part 10 formatiert und habe es dann einfach hochfahren lassen.Anders als in der Beschreibung oben, habe ich also den Bereich 10 nicht neu drauf geladen.
    Scheint alles ohne Probleme zu laufen.

    Habe dann nochmal das NVFlash Backup probiert und lief jetzt ohne Probleme durch und die Part10 Datei hat ca. 16MB

    BTW: Habe das Hannspad SN10T130R1653

    Gruß, Patrick
     
  5. muhviehstarr, 29.10.2011 #5
    muhviehstarr

    muhviehstarr Android-Hilfe.de Mitglied

    Beiträge:
    122
    Erhaltene Danke:
    22
    Registriert seit:
    03.10.2011
    funzt bei mir leider nicht, Partition 10 ist das Problem.


    D:\hans\test>"nvflash.exe" -r --format_partition 10
    Nvflash started
    [resume mode]
    Formatting partition 10 please wait.. done!

    backup danach:

    D:\hans\test>"nvflash.exe" -r --read 10 part-10.img
    Nvflash started
    [resume mode]
    receiving file: part-10.img, expected size: 33554432 bytes
    / 33292288/33554432 bytes receiveddata receive failure NvError 0x120000
    command failure: read failed


    Hochfahren tut es nach dem format auch normal, daher habe ich nicht neu flashen (müssen)
     
    jo253 bedankt sich.
  6. Patrick19, 29.10.2011 #6
    Patrick19

    Patrick19 Android-Hilfe.de Mitglied

    Beiträge:
    64
    Erhaltene Danke:
    7
    Registriert seit:
    02.09.2011
    hmm deine partition 10 scheint größer zu sein wie meine .. Ich kenn mich jetzt nicht so super aus... weiß nicht ob du die formatieren sollst/kannst ?!?
     
  7. ELexONE, 17.12.2011 #7
    ELexONE

    ELexONE Android-Hilfe.de Mitglied

    Beiträge:
    65
    Erhaltene Danke:
    10
    Registriert seit:
    30.11.2011
    Hallo,

    ich hatte das selbe Problem mit der Part 10
    bei mir ist sie 16 MB groß.

    Als erstes habe ich über den Clockworkmode ein Backup erstellt ( Clockworkmod vorausgesetzt )
    Nach der Formatierung der Patition funktionierte mein Touchscreen nicht mehr.
    Ich habe also Über den Clockworkmode einen Restore des Backups durchgeführt.
    Siehe da alles läuft.
    Nun läuft auch das Backup mit NVFlash komplett durch.
     
    Amina und SHORTY-NR1 haben sich bedankt.
  8. SHORTY-NR1, 17.12.2011 #8
    SHORTY-NR1

    SHORTY-NR1 Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    342
    Erhaltene Danke:
    52
    Registriert seit:
    30.08.2011

    Hey prima, das wird ich mal mit aufnehmen.
    Zuerst eine Sicherung über CWM, dann Partition formatieren, und die Sicherung zurück spielen.
    So braucht man nicht mehr erneut zu flashen!
     
  9. fmcheetah, 30.03.2012 #9
    fmcheetah

    fmcheetah Android-Hilfe.de Mitglied

    Beiträge:
    84
    Erhaltene Danke:
    21
    Registriert seit:
    14.09.2011
    Phone:
    Xiaomi Mi3
    Tablet:
    Samsung Galaxy Tab 8.9 / 10.1
    Hallo Mitglieder,
    Erst mal herzlichen Dankfür die vielen Tipps.
    Bei mir hat das formatieren der Partition 10 geholfen.
    Hab kein restore über CWM gebraucht. Nun konnte ich endlich mit NVflash ein Backup erstellen. :sneaky:
     

Diese Seite empfehlen