1. daniello, 09.05.2012 #1
    daniello

    daniello Threadstarter Erfahrener Benutzer

    Hi .. ich hab cyanogenmod7.2 auf meinem ideos .. und würde gerne debug-meldungen mitschneiden. Dummerweise zeigen weder catlog noch acatlog was an. Was kann ich tun?

    Help!
     
  2. ElTonno, 09.05.2012 #2
    ElTonno

    ElTonno Android-Lexikon

    Die offiziele ROM (2.3.5) draufziehen, in den ServiceMode gehen und Log aktivieren, anschließend wieder CM7 installieren.
    Jetzt müsste auch das loggen funktionieren
     
  3. daniello, 09.05.2012 #3
    daniello

    daniello Threadstarter Erfahrener Benutzer

    Echt?! .. ich mache also ein Nandroid vom gesamten System .. spiele dann das ursprüngliche Nandroid vom Originalrom drauf .. mache o.g. Einstellung (ist das eine Einstellung .. oder wie kommt man in den ServiceMode?) .. und spiele dann mein CM7 nandroid zurück? ... Das ist ja verrückt ... ich dachte nandroid macht alles platt.
     
  4. Ryuk, 09.05.2012 #4
    Ryuk

    Ryuk Android-Lexikon

    es dürfte auch reichen, nur die originale boot.img zu booten und das logging im service-menü zu aktivieren...
    wenn das booten nicht reicht, die originale boot.img flashen, logging aktivieren und dann die boot.img der cm zurückflashen...

    hm...obwohl, ich glaub in cm fehlt diese mmitest_II.apk...
    dann wohl doch so wie eltonno beschrieben hat...
    kannst ja vorher über cwm ein komplettes backup machen und das zurückspielen...
    oder ist das logging dann wieder weg?
    ach, ich weiß grad auch nich :D
     
    Zuletzt bearbeitet: 09.05.2012
  5. daniello, 09.05.2012 #5
    daniello

    daniello Threadstarter Erfahrener Benutzer

    Ok .. also .. Ablauf noch unklar .. und was ist denn dieser Servicemode .. ist das eine Einstellung in den Einstellungen .. und ganz offensichtlich?
     
  6. Ryuk, 09.05.2012 #6
    Ryuk

    Ryuk Android-Lexikon

    servicemode war im dialer: *#*#2846579#*#*
    fürs logging dann: projectmenu -> background setting -> log setting -> log switch

    du kannst es ja erstmal mit der originalen boot.img versuchen, vllt. klappt das ja schon, weiß halt nicht, ob man da ins service-menü kommt...
    ansonsten dann wie es eltonno beschrieben hat...
     
  7. daniello, 09.05.2012 #7
    daniello

    daniello Threadstarter Erfahrener Benutzer

    cool .. probier ich morgen aus .. danke schonmal .. jedweder input ist noch willkommen :)
     
  8. daniello, 10.05.2012 #8
    daniello

    daniello Threadstarter Erfahrener Benutzer

    So .. meine ersten Erlebnisse:
    - boot.img zurückgespielt .. neu booten kein Problem.
    - Eingabe des codes funktioniert im Dialer nicht .. bei der letzten Ziffer wird der String gelöscht (so verhält es sich auch bei CM7.2 boot)
    - Vollbackup von 2.3.5 zurückspielen wollen -> MD5 fehler :-(
    - Manuelles korrigieren der MD5 Hashwerte im Nandroid-Hashfile führt nicht zum gewünschten erfolg. Ist das File (also die Hashes) case sensitive ???
    - Nun hab ich die MD5-Zeilen für die 0-Byte Files entfernt .. geht aber auch nicht.

    Hmm .. weiter probieren.
     
  9. daniello, 11.05.2012 #9
    daniello

    daniello Threadstarter Erfahrener Benutzer

    So fertig! Es funzt genau so wie ElTonno das geschrieben hat!
    Meine ganzen MD5-Probleme haben daher gerüht, dass ich den Backup-Verzeichnissen sprechende Namen hintergesetzt hatte .. dummerweise mit Leerzeichen.

    Also Nachwelt .. wer loggen will .. das Rezept oben ist prima.

    DANKE!