1. markok, 29.05.2010 #1
    markok

    markok Threadstarter Junior Mitglied

    Hi Leute,
    da ich weder hier im Forum noch sonst eine Antwort gefunden habe, eröffne ich doch mal einen Thread.
    Ich habe das Problem:
    Immer wenn ich ein App > 10 mb installieren will, sagt er mir folgende Meldung: "Kein freier Speicher vorhanden
    HN2010 konnte nicht geprüft werden. Bereinigen Sie den Speicher Ihres Telefons und versuchen Sie es erneut."
    Das ist jedoch völliger Quatsch, da mein freier interner Speicher bei ca. 50 MB liegt und ich sowieso App2SD laufen habe.
    Wie kann ich diesen Fehler beheben oder gibt es eine Möglichkeit die Überprüfung zu deaktivieren?
    Vielen Dank
    Lg Marko
     
  2. Denowa, 29.05.2010 #2
  3. Kuni, 29.05.2010 #3
    Kuni

    Kuni Fortgeschrittenes Mitglied

  4. markok, 29.05.2010 #4
    markok

    markok Threadstarter Junior Mitglied

    Okay ich hatte nach "kein freier Speicher vorhanden" gesucht :rolleyes: , da der Fehler bei mir ja generell auftritt, nicht nur bei Marketapps. Also wenn ich das so lese, liegt es am Cache. mein Cache ist aber lediglich zu zu 16% in use und es sind noch 25 Mb frei?!Soll ich den Dalvik Cache trotzdem verlegen?wenn ja nehme ich updateJITdalvikVM.zip odeR?
    Danke Euch schon mal :)
     
  5. Kuni, 30.05.2010 #5
    Kuni

    Kuni Fortgeschrittenes Mitglied

    Wenn du noch 25mb frei hast sollte das eher nicht das Problem sein. Da denk ich nicht, dass es was mit dem cache zu tun hat.
    Weiter muss ich passen, da geb ich an jemanden ab der Ahnung davon hat ;)
     
  6. markok, 30.05.2010 #6
    markok

    markok Threadstarter Junior Mitglied

    Okay ^^ Danke Dir trotzdem noch für Deine Antwort habe gerade probiert den cache mit der genannten Methode zu verlegen aber bekam ein Fehler beim cachemounten und im Endeffekt konnte ich dann nicht mehr booten. Naja habe jetzt den Cache gewiped jetzt läuft es wieder.
    Komisch komisch das ganze ...Ui ich habe jetzt nochmal geschaut und habe plötzlich eine Cacheauslastung von 99%?!Also jetzt verstehe ich die Welt nicht merh :-D Ich werde nochmal versuchen den Cash umzulegen :)

    Edit: Also wenn ich die Befehle eingebe, komme ich lediglich bis zum Mounten des /cache dort bekomme ich eine Fehlermeldung, dass der cache busy ist.
    Jemand eine Idee???
    Danke Euch :)
     
    Zuletzt bearbeitet: 30.05.2010
  7. Luemel, 30.05.2010 #7
    Luemel

    Luemel Android-Lexikon

    Was mir geholfen hatte, bsp bei IGO war unter Anwendungen die Daten bei Packet-Installer zu löschen. Vielleicht hilft es dir ja
     
  8. Denowa, 30.05.2010 #8
    Denowa

    Denowa Android-Guru

    Wenn ich das richtig verstanden habe muss die ganze Aktion über das Recovery laufen. Hast Du das gemacht, oder im laufendem System versucht? Ansonsten mal direkt an Chriddel wenden ....
     
  9. Kuni, 30.05.2010 #9
    Kuni

    Kuni Fortgeschrittenes Mitglied

    ich habs damals im laufenden System gemacht und bei irgendeinem Mount hatte ich auch einen Fehler, hab aber einfach weiter runter getippt und das Problem war trotzdem behoben...
     
  10. markok, 30.05.2010 #10
    markok

    markok Threadstarter Junior Mitglied

    Im laufenden System habe ich es noch nicht versucht. Ich habe es lediglich im Recovery eingetippt und schon bei Mounten des Caches gab es einen Fehler, dass Cache wohl beschäftigt wäre. Naja ich hab dann auch weiter getippt und dann einen Reboot gemacht und dann ist es leider nicth mehr hochgefahren ^^. Komische Sache das Ganze, wobei es mittlerweile einleuchtend wäre, da ich eine Auslastung von 99% habe, was ich sehr komisch finde ;).
    Zusätzlich stand doch dabei, wenn ich JIT flashe, verschiebt er den Cache automatisch. Naja ich habe dann updateJITdalvikVM geflashed und naja, es ist wieder nicht hochgefahren. Mit der JIT5.0.7 habe ich es noch nicht versucht.
    Danke Euch trotzdem schon mal :)
    Lg

    Edit: Niemand noch eine Idee :/ ?
     
    Zuletzt bearbeitet: 30.05.2010
  11. markok, 30.05.2010 #11
    markok

    markok Threadstarter Junior Mitglied

    Also ich beschreibe es mal detailliert!
    Ich gebe ein:
    mount /data -> funktioniert (zumindest kein Fehler)

    mount /cache -> mount: mounting /dev/block/mtdblock4 on /cache failed: Device or resource busy

    mount /system/sd -> mount: can't find /system/sd in /etc/fstab :)confused: wie kommt er darauf in dem Ordner /etc/fstab zu sucheN???)

    rm -rf /data/dalvik-cache -> funktioniert (zumindest kein Fehler)

    rm -rf /cache/dalvik-cache -> funktioniert (zumindest kein Fehler)

    ln -s /system/sd/dalvik-cache /data/dalvik-cache -> funktioniert (zumindest kein Fehler)

    ln -s /system/sd/dalvik-cache /cache/dalvik-cache -> funktioniert (zumindest kein Fehler)

    rm /system/sd/dalvik-cache/* -> rm: cannot remove '/system/sd/dalvik-cache/*' : No such file or directory

    sync -> funktioniert (zumindest kein Fehler)

    Ich hoffe das hilft vielleicht iwie weiter, sodass jemand auf die Lösung kommt ^^ , wäre super :) !
    Danke Euch vielmals
    Lg Marko
     
  12. ChriDDel, 31.05.2010 #12
    ChriDDel

    ChriDDel Android-Lexikon

    Um welchens ROM geht es denn jetzt?
    bei 5.0.7 ist es etwas anders als bei 4.2.15.
    Ich Probier das Problem mal einzugrenzen.

    Hab jetzt nen Termin, also bis später ;-)
     
  13. Steppo, 31.05.2010 #13
    Steppo

    Steppo Android-Lexikon

    Lese mal seine Signatur - Hilfreiche Informationen :rolleyes:;)
     
  14. ChriDDel, 31.05.2010 #14
    ChriDDel

    ChriDDel Android-Lexikon

    Deswegen frag ich ja. Die Lösung galt für 4.2.15.
    Ob die jetzt noch gültigkeit hat ist eben die Frage.
     
  15. markok, 31.05.2010 #15
    markok

    markok Threadstarter Junior Mitglied

    Also es geht um 5.0.7 :p Kuni hatte doch auch 5.0.7 und bei ihm gings wohl.
    Also ich habe vorhin Cyanogen nochmal neu geflashed. Jetzt habe ich nur 6% Cacheuse. Frei sind ca. 28mb und ich habe trotzdem schon wieder Probleme bspw. beim Installieren von Copilot zeigt er mir wieder den genannten Fehler.
    Solangsam nervt es mich :D.
    Naja vielleicht fällt euch ja was ein ;)
    Danke
     
  16. ChriDDel, 31.05.2010 #16
    ChriDDel

    ChriDDel Android-Lexikon

    Ich glaube eher, dass es bei Kuni zufall war.
    Der Cache ist bei mir auch groß genug, aber der Fehler kann trotzdem auftreten.
    Es gibt da ein Rennspiel in einer Demo mit 20 MB. Das kann ich nicht installieren.
    Egal, wie ich den cache bearbeite. Die meldung ist immer "nicht genug Speicher"
     
  17. a.woellert, 31.05.2010 #17
    a.woellert

    a.woellert Erfahrener Benutzer

    Nur so als Tipp nebenbei.
    Mit DroidExplorer lässt sich alles installieren, egal wie groß das App ist.
    Ich hatte auch immer das Problem bei zu großen Apps.
    Aber jetzt installier ich die einfach per PC.
    Ok viiiel Spaß noch


    MfG
    Andi
     
  18. Kuni, 31.05.2010 #18
    Kuni

    Kuni Fortgeschrittenes Mitglied

    Ne so ist das nicht ganz richtig, ich kam vom CM4.2.x und wechselte auf HTCCLAYs CSDI Remix glaube ich...
     
  19. markok, 01.06.2010 #19
    markok

    markok Threadstarter Junior Mitglied

    Okay dann hatte ich mich geirrt ^^
    Hi Andi, für DroidExplorer muss ich nur das Programm an sich und die busybox installieren oder?Hast du die busybox im recovery oder im Terminal emu installiert???
    Danke Dir schon mal
    Lg
     
  20. Haunter1982, 01.06.2010 #20
    Haunter1982

    Haunter1982 Android-Experte

    dann ist der Mountpoint von /system/sd falsch!

    der müsste jetzt dann /sd-ext heißen oder irre ich mich da?

    also ersetze einfach das "/system/sd" duch "/sd-ext" und schon sollte es funktionieren.

    auf /etc/fstab greift er zu weil darin die "mountpoints" für den Befehl mount festgelegt sind. Da es aber im Cyano5.0.7 kein mountpoint mit dem Namen /system/sd gibt kommt die Fehlermeldung und es geht auch nichts.

    Allerdings ist das ziel ja den Dalvik-Cache zu verlegen. Dieser ist allerdings beim Cyano schon Standardmäßig auf /sd-ext.

    Zur Erklärung warum das System nicht mehr startet.

    Du hast den Cache in einen Ordner verlinkt den es nicht gibt ("/system/sd" Fehler beim mounten). D.h. Android kann keinen Cache anlegen und somit seine Programme nicht ausführen. = Startet nicht.
    Selbst wenn durch das Booten ein Ordner /system/sd angelegt wird, steht dem Dalvik-Cache nur der rest der System-Partition also ca. 5mb zur Verfügung = Startet nicht
     
    Zuletzt bearbeitet: 01.06.2010
    markok bedankt sich.

Besucher kamen mit folgenden Begriffen auf unsere Seite:

  1. kein freier speicher vorhanden android