1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Keine Schreibrechte

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy S Plus" wurde erstellt von Neoon, 12.03.2012.

  1. Neoon, 12.03.2012 #1
    Neoon

    Neoon Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    12.03.2012
    Hallo!
    bin noch Anfänger, und hab es geschaft mein Handy zu rooten. :thumbsup:
    Jetzt wollte ich mit der app "Absolut System" die bootani ändern.
    Ging aber nicht. habe jetzt über "Root Explorer" rausgefunden, daß ich keine schreibrechte habe, bzw der Ordner oder Datei schreibgeschützt ist. Den schreibschutz kann ich auch nicht mit "Root Explorer" ändern. Muss ich nochwas am handy ändern um schreibrechte zu vergeben? Ich dachte das wäre nach dem rooten erledigt.

    rgds Eric
     
  2. change63, 12.03.2012 #2
    change63

    change63 Fortgeschrittenes Mitglied

    Beiträge:
    352
    Erhaltene Danke:
    96
    Registriert seit:
    11.06.2011
    bei root explorer schon mal versucht oben auf mount R/W (read/write) zu tippen, standart ist der R/O (read/only) modus.
     
    martintt und Neoon haben sich bedankt.
  3. Neoon, 12.03.2012 #3
    Neoon

    Neoon Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    12.03.2012
    Erstmal danke für die schnelle Hilfe.
    Hab jetzt die alte bootanimation gelöscht und die neue reinkopiert.
    Kommt aber immernoch die alte von Samsung. Jetzt versteh ich erstmal nixmehr! system/media <-----da gehört sie ja rein denke ich.


    rgds Eric
     
  4. change63, 12.03.2012 #4
    change63

    change63 Fortgeschrittenes Mitglied

    Beiträge:
    352
    Erhaltene Danke:
    96
    Registriert seit:
    11.06.2011
    Soweit ich das weiß brauchst du einen Kernel der samin.zip bootanimationen unterstützt, z.B. feacore.
    Dann einfach die Bootanimation.zip in sanim.zip umbenennen und in system/media reinkopieren und beim nächsten boot solltest du die neue animation bewundern können^^.

    BTW:
    Du kannst auch den Bootsound unter etc/PowerOn.wav verändern, oder ausschalten (einfach umbenennen z.b. PowerOn.(wav) )
     
    Neoon bedankt sich.
  5. crybert, 13.03.2012 #5
    crybert

    crybert Android-Experte

    Beiträge:
    685
    Erhaltene Danke:
    602
    Registriert seit:
    08.01.2012
    Naja eigentlich braucht man für die CustomBootanimation 3 Dinge (dies ist zumindest für das S Plus so):

    1. Die bootanimation binary welche in /system/bin/ platziert werden muss

    2. Einen Kernel der diese binary beim booten lädt. Dies geschieht ganz leicht durch einen modifizierten Eintrag in der Ramdisk des boot.img. Deswegen sind theoretisch auch stock Kernel dazu in der Lage.

    3. Eine sanim.zip in /system/media mit der richtigen Auflösung. Ist diese nicht vorhanden wird eine vordefinierte bootanimation, welche in der binary enthalten ist, geladen.

    Wenn du magst, kannst du dir mal das zip Package aus folgendem Thread via FeaModRecovery flashen: http://forum.xda-developers.com/showthread.php?t=1376388
    Dies ist der StockKernel der KQ7 mit bootanimation und init.d-Unterstützung.
     
    Zuletzt bearbeitet: 13.03.2012
    Neoon bedankt sich.
  6. Neoon, 14.03.2012 #6
    Neoon

    Neoon Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    12.03.2012
    Hallo.
    Ja ich habe ein S-Plus. Ich werd heut Abend wenn ich zuhause bin mal die zip draufspielen und ausprobieren. Ich sag dann bescheid ob es geklappt hat. Nochmals Danke für die schnelle Hilfe. Das Forum hier ist wirklich klasse für Anfänger wie mich.
    :thumbsup:

    rgds Eric

    Also die animation hat sich geändert. Und zwar in einen schwarzen Bildschirm.:blushing:
    Vieleicht die falsche Auflösung?
    Ich werd mal suchen, ob ich was für`s Plus finde.


    rgds Eric
     
    Zuletzt von einem Moderator bearbeitet: 14.03.2012
  7. MrNilsson, 14.03.2012 #7
    MrNilsson

    MrNilsson Android-Experte

    Beiträge:
    717
    Erhaltene Danke:
    253
    Registriert seit:
    11.01.2012
    Zuletzt bearbeitet: 14.03.2012
    Neoon bedankt sich.
  8. Neoon, 14.03.2012 #8
    Neoon

    Neoon Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    12.03.2012
    Wunderbar. hat wohl an der auflösung gelegen. klappt wunderbar.


    rgds Eric
     

Diese Seite empfehlen