1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Kleiner Test zum Thema Hardware-Tastatur

Dieses Thema im Forum "Motorola Milestone 2 Forum" wurde erstellt von Filo, 30.06.2011.

  1. Filo, 30.06.2011 #1
    Filo

    Filo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    446
    Erhaltene Danke:
    77
    Registriert seit:
    05.01.2011
    Phone:
    Samsung Galaxy S5 Neo
    Guten Morgen!

    ..gebe mich ja immer noch nicht mit der Tatsache zufrieden, dass ich den Stein unter Umständen eunschicken sollte, wenn das mit der Hardwaretastatur so weitergeht...

    Daher habe ich jetzt mal probiert, ob Teile des Fehlers nicht vielleicht doch mit Motorola-Software zusammenhängen. Leider steht mir kein Titanium Backup pro zur Verfügung, so dass ich grad nur wenige Sekunden mit einem Taskkiller testen kann, aber die Ergebnisse sind interessant.

    Ich MEINE, dass das Stoppen (bei mir kurzzeitiges Killen) des Tasks

    -com.motorola.spellingcheckservice

    bei ausgeschalteter Debounce-App zu einer funktionierenden Tastatur führt bei mir.
    Kann das nicht vielleicht mal jemand von Euch testen, der die Möglichkeit hat, diese Dienste länger als ein paar Sekunden zu freezen? Oder kennt jemand eine kostenlose App für mich dafür?

    Danke und Grüße,
    Martin.
     
    Zuletzt bearbeitet: 03.07.2011
  2. Rennert, 30.06.2011 #2
    Rennert

    Rennert Android-Lexikon

    Beiträge:
    1,859
    Erhaltene Danke:
    207
    Registriert seit:
    07.11.2010
    Autorun manager kann prozesse vom startvorgang ausschliessen.
    Testen kann ich es nicht, da meine tastatur seit ueber nem halben jahr perfekt funktioniert.
     
    Filo bedankt sich.
  3. ChrisH, 30.06.2011 #3
    ChrisH

    ChrisH Fortgeschrittenes Mitglied

    Beiträge:
    277
    Erhaltene Danke:
    24
    Registriert seit:
    27.12.2010
    Phone:
    Motorola Milestone 2
    Dürfte den gleichen Effekt haben, wie alle Rechtschreibkorrektur-Funktionen abzuschalten, das wurde hier ja schon öfter empfohlen.
     
  4. Filo, 30.06.2011 #4
    Filo

    Filo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    446
    Erhaltene Danke:
    77
    Registriert seit:
    05.01.2011
    Phone:
    Samsung Galaxy S5 Neo
    @Chris: Nee, icht ganz. Trotz Abschalten im Menu bleibt der zugehörige Dienst aktiv.
     
  5. shakezebeer, 30.06.2011 #5
    shakezebeer

    shakezebeer Android-Hilfe.de Mitglied

    Beiträge:
    123
    Erhaltene Danke:
    8
    Registriert seit:
    13.01.2011
    Ich kann mir nicht vorstellen, dass irgendeine softwareseitige Veränderung an der Tastatur des Milestones etwas verbessern kann. Motorola hat einfach Mist gebaut. Bei mir gehen viele tasten beim normalen Drücken gar nicht und einige klatschen sich dann gleich drei mal hin. Hatte bei drei MS2 große Unterschiede. zwei hatten den Bug extrem, bei einem ging es. Also befürchte ich einen Hardwaredefekt, der mit Glück bei einigen Geräten nicht vorhanden ist. Oder vlt hat es auch nur mit Pech zu tun, immer ein defektes zu bekommen. Aber da zwei der drei Handys "refurbished" Austauschgeräte waren, ist auch zu erklären wieso diese dann auch wieder den Fehler haben.
     
  6. Filo, 30.06.2011 #6
    Filo

    Filo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    446
    Erhaltene Danke:
    77
    Registriert seit:
    05.01.2011
    Phone:
    Samsung Galaxy S5 Neo
    Ich kann die Sache mit der Hardware aber nicht zu 100% unterschreiben. Wenn bei mir z.B. das Handy frisch gestartet ist, habe ich mit der Leertaste überhaupt kein Problem. Nach ca. 30 Sekunden ist der Spaß dann Vorbei und die doppelten Buchstaben fangen an.

    Auch würde ich auf die Hardware allein tippen, wenn bei jedem von 50 gefühlt gleich ausgeführten Tastendrücken jeder den Effekt bringt. Aber mal doppelte oder fehlende Buchstaben und mal nicht?
    Gestern nach einem Werksreset konnte ich fehlerfrei mein Blur-Passwort zur und bei der Ersteinrichtung tippen. Danach beim WLAN-Passwort waren doppelte Buchstaben drin.

    Das Problem ist einfach zu komplex, als dass man es auf die Hardware allein schieben könnte.

    Grüße,
    Martin!
     
  7. WenniePooh, 30.06.2011 #7
    WenniePooh

    WenniePooh Android-Hilfe.de Mitglied

    Beiträge:
    75
    Erhaltene Danke:
    4
    Registriert seit:
    27.11.2010
    Phone:
    LG G2
    Also ich würde einen Hardwaredefekt auch erst einmal ausschließen. Nach einem Werksreset scheint die Tastatur ja erst einmal wunderbar zu funktionieren (bei mir auch nach dem letzten Update) und dann fangen die doppelten Buchstaben, oder das nicht-Reagieren auf Tastendrücke langsam an und werden dann immer schlimmer. Vor 2 Wochen konnte ich noch ohne Probleme SMS mit der Hardwaretastatur schreiben, heute ist das nur noch ätzend und ich muss dauernd meine Eingabe kontrollieren und korrigieren. Es ist sogar so schlimme, dass Buchstaben nun schon 3-mal bei einem Tastendruck geschrieben werden...
    Wenn das ein Softwarebug seitens Motorola ist, finde ich das wirklich sehr arm, dass das bis jetzt noch nicht gefixt worden ist. Die HW-Tastatur ist nunmal ein essentielles Teil des MS2 und wenn sowas nicht funktioniert wirft das ein ganz dunkles Licht auf die Produkte von Motorola...

    Das scheint zu funktionieren. Für die paar Sekunden, die der Task deaktiviert ist, treten keine doppelten Buchstaben auf. Wenn es jetzt eine Möglichkeit gibt, diesen Task ohne Root dauerhaft zu deaktivieren, wäre ich für Infos darüber sehr dankbar...

    Gruß WenniePooh
     
    Zuletzt bearbeitet: 30.06.2011
  8. ChrisH, 30.06.2011 #8
    ChrisH

    ChrisH Fortgeschrittenes Mitglied

    Beiträge:
    277
    Erhaltene Danke:
    24
    Registriert seit:
    27.12.2010
    Phone:
    Motorola Milestone 2
    Das ist ein Systemdienst, ohne Root kommst du dem wohl nicht bei.
     
  9. gu1lty, 30.06.2011 #9
    gu1lty

    gu1lty Junior Mitglied

    Beiträge:
    28
    Erhaltene Danke:
    1
    Registriert seit:
    14.02.2011
    @Filo funktioniert bei dir das App nicht?
    Oder suchst du nur nach einer anderen Lösung?
     
  10. Filo, 30.06.2011 #10
    Filo

    Filo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    446
    Erhaltene Danke:
    77
    Registriert seit:
    05.01.2011
    Phone:
    Samsung Galaxy S5 Neo
    @Gu1lty:
    Du meinst die Debounce-App? Die war genial! Hat eine Woche lang alles schick gemacht!
    Dann fing es wieder an. Danach ging es dann mit Debounce und Werksreset eine weitere Woche gut.

    Mittlerweile habe ich alle möglichen Einstellungen bei den Millisekunden durch und bekomme ein gemischtes Ergebnis: Einige Male geht ein Buchstabe gar nicht und dann wiederum doppelt, mit der gleichwn Einstellung. Auch verzögert die App die Eingabe, weshalb man nicht einfach im Fluss tippen kann, ist halt ein gewollter kleiner Lag.

    Ich hab insgesamt dreimal einen Werksreset gemacht, jedes mal ging es erst besser und je mehr Apps und Einstellungen ich wiederhergestellt hatte, desto schlimmer wurde es mit den Tasten...

    Interessant ist noch folgendes, vielleicht beobachtet Ihr das ja auch:

    Im Browser ist ein anderes Verhalten der Tasten als z.B. beim Schreiben einer SMS. Bei der SMS geht das I kaum, im Browser kommt es dreimal. Die Leertaste geht beim Browser schwer, bei der SMS recht zuverlässig. Für mich noch ein Indiz, dass es nicht an der Hardware liegen kann und die Debounce-App schon in die richtige Richtung geht. Es muss aber irgendwo noch etwas "begraben" sein, fragt sich nur, was...

    Grüße,
    Martin!
     
    Zuletzt bearbeitet: 30.06.2011
  11. jacek1980, 02.07.2011 #11
    jacek1980

    jacek1980 Android-Hilfe.de Mitglied

    Beiträge:
    75
    Erhaltene Danke:
    3
    Registriert seit:
    26.04.2011
    Hm ich wollte es am Anfang nicht glaube aber bei mir scheint das ganz zu funktionieren. Und meine Tastatur war schon richtig mies, Leertaste ging fast gar nicht mehr und andere Buchstaben musste man auch fast durch das Handy drücken damit sie erscheinen. Doppelte Buchstaben hatte ich schon dank der Milestone Debounce App im Griff.
     
  12. Filo, 02.07.2011 #12
    Filo

    Filo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    446
    Erhaltene Danke:
    77
    Registriert seit:
    05.01.2011
    Phone:
    Samsung Galaxy S5 Neo
    Jacek, was hast Du jetzt noch zusätzlich gemacht? Den Spellingcheck-Service?
    Hab mit dem Gemini-App-Manager noch ein paar Autostart-Einstellungen von Apps (z.B. Maps) deaktiviert und das Tastenbrett wird zusehends besser!

    Allerdings bleibt so natürlich aus, GENAU zu sagen, warum es besser wird...

    Grüße,
    Martin!
     
  13. jacek1980, 02.07.2011 #13
    jacek1980

    jacek1980 Android-Hilfe.de Mitglied

    Beiträge:
    75
    Erhaltene Danke:
    3
    Registriert seit:
    26.04.2011
    ja habe das com.motorola.spelingcheck oder wie das genau heisst ausgeschaltet und die Tastatur funktioniert schon fast perfekt. nur die leertaste streikt manchmal, darf da nicht so in die mitte drücken sondern ehe aussen dann wird das auch immer angenommen.
    habe aber auch das argen2stone 1.9 drauf.
     
  14. Filo, 02.07.2011 #14
    Filo

    Filo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    446
    Erhaltene Danke:
    77
    Registriert seit:
    05.01.2011
    Phone:
    Samsung Galaxy S5 Neo
    Klasse! Ich hab dazu noch die Autoruns von Maps und Weather deaktiviert mit dem Gemini, bin bei fast konstant 170 MB freiem Speicher und hab kaum bis gar keine Aussetzer bei den Tasten mehr. Es wird :)
     
  15. jacek1980, 02.07.2011 #15
    jacek1980

    jacek1980 Android-Hilfe.de Mitglied

    Beiträge:
    75
    Erhaltene Danke:
    3
    Registriert seit:
    26.04.2011
    Ja aber auch wenn das alles so funktioniert, es müsste ja auch ohne das ganze funktionieren wenn Motorola es richtig gemacht hätte. :/
     
  16. shakezebeer, 02.07.2011 #16
    shakezebeer

    shakezebeer Android-Hilfe.de Mitglied

    Beiträge:
    123
    Erhaltene Danke:
    8
    Registriert seit:
    13.01.2011
    Es kann ja nicht der Sinn der Sache sein, das Smartphone zusammenzustutzen um es fehlerfrei bedienen zu können. Irgendwo hört der Spaß dann auf. Ist schon fast lächerlich, dass in einer Zeit, in der es für alles eine App gibt das installieren von Apps zu Problemen führt. Wo bleibt da der eigentliche Zweck des Smartphones?
     
  17. Filo, 02.07.2011 #17
    Filo

    Filo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    446
    Erhaltene Danke:
    77
    Registriert seit:
    05.01.2011
    Phone:
    Samsung Galaxy S5 Neo
    Naja... nicht das Installieren der Apps, vielmehr die bereits mitgelieferten Apps sind es, die hier die Problemchen zu machen scheinen. Und mal im Ernst, bei Windows optimiere ich Systeme ja auch dahingehend, dass unnütze Anwendungen oder Dienste nicht mehr automatisch im Hintergrund laufen. Neue Apps hab ich hier auch unzählige nebenbei installiert, die scheinen aber die Tastatur eben nicht zu beinträchtigen.

    Grüße,
    Martin!
     
  18. stargo, 03.07.2011 #18
    stargo

    stargo Junior Mitglied

    Beiträge:
    36
    Erhaltene Danke:
    37
    Registriert seit:
    19.05.2011
    Phone:
    Motorola Photon Q
    So, ich habe mal das Debounce-Modul aktualisiert: Wenn "0" als Delay eingestellt wird, wird das Debouncing deaktiviert (Motoroloa aktiviert es mit Wert 0). Evtl. wird so sowohl das Problem mit den doppelten Buchstaben als auch das mit den nicht erkannten Buchstaben gelöst. Da ich letzteres nicht habe und das Modul gerade nur kurz (ohne Doppler) getestet habe bräuchte ich dafür Rückmeldungen von Euch.

    Das neue APK gibts unter: http://rmdir.de/~michael/ms2-fixes/MS2Debounce-release.apk
     
    Filo bedankt sich.
  19. Filo, 03.07.2011 #19
    Filo

    Filo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    446
    Erhaltene Danke:
    77
    Registriert seit:
    05.01.2011
    Phone:
    Samsung Galaxy S5 Neo
    Danke, dass Du weiter daran bastelst Stargo. Bin am Testen und melde dann.
     
  20. Filo, 03.07.2011 #20
    Filo

    Filo Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    446
    Erhaltene Danke:
    77
    Registriert seit:
    05.01.2011
    Phone:
    Samsung Galaxy S5 Neo
    Sodele. Erster Test mit deer neeuen App vvom Starrgo.... einngesttelllltt sind "0" Millseekunden... siieht fies aaus ;)

    Edit: Jetzt hab ich wieder 8ms eingestellt und fühl mich wohler ;-)
     

Diese Seite empfehlen