1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Könnte jemand mein Spiel auf einem Motorola testen?

Dieses Thema im Forum "Android Spiele Entwicklung" wurde erstellt von daywalker, 20.12.2010.

  1. daywalker, 20.12.2010 #1
    daywalker

    daywalker Threadstarter Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    28.09.2009
    Hallo,
    nach langer Zeit mal wieder hier im Forum.

    Ich habe ein Spiel namens MathJumper geschrieben und mehrere BugReports im Market Interface erhalten.
    Diese bezogen sich ausschließlich auf Motorola Handies, sowohl Cliq als auch Droid:

    "java.lang.NullPointerException
    at com.google.android.gles_jni.GLImpl.glTexCoordPointer(GLImpl.java:976)
    at com.into.engine.polaris2d.Font.render(Font.java:141)"

    Dummerweise habe ich zum Testen nur HTC Dream/Magic/Desire/Wildfire...

    Nun habe ich einen leeren Try-Catch-Block um gl.glTexCoordPointer(2, GL10.GL_FLOAT, 0, ...); gelegt.


    Falls jemand ein Motorola Handy hat, könntet ihr bitte MathJumper LITE aus dem Market laden und einmal spielen?
    Mich interessiert, ob es weiterhin zu Abstürzen kommt und ob die Texte immer lesbar sind oder zeitweise nicht gerendert werden.

    Hier noch ein Links mit einigen Infos zum Spiel:
    http://intostudios.com/mathjumper

    Danke für eure Hilfe,
    Florian
     
  2. Sabian, 21.12.2010 #2
    Sabian

    Sabian Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    2
    Registriert seit:
    21.12.2010
    Heyo,
    Also erstmal: sehr schönes Spiel :). Gute Arbeit.
    Ich habe es eben auf meinem Motorola Milestone(2.1) getestet.
    Läuft eigentlich alles soweit. Nur auf höheren Ebenen zeigt er manchmal die Gleichung nicht richtig an glaube ich!? Oder gehört das so? Bei mir kommt etwas wie "20 _ "
    Ansonsten keine Probleme.
     
  3. daywalker, 21.12.2010 #3
    daywalker

    daywalker Threadstarter Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    28.09.2009
    Hi,
    danke dass du es mit einem Motorola getestet hast.

    Zu den Gleichungen: Kann es sein, dass du die 2. Schwierigkeit gewählt hast und dass die Gleichung z.B. so aussah: 20 _ 5 = 4 ?
    In dem Fall hättest du dividieren müssen - ein "/" zeichnen :winki.

    Gruß,
    Florian
     
  4. Sabian, 21.12.2010 #4
    Sabian

    Sabian Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    2
    Registriert seit:
    21.12.2010
    Hey,
    ja genau, habe die 2. Schwierigkeit gewählt.
    Nein leider nicht, es stand eben nur "20 _ " . Habe dann geraten und ein + war die Lösung.
     
  5. daywalker, 23.12.2010 #5
    daywalker

    daywalker Threadstarter Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    28.09.2009
    Hallo Sabian, würdest du bitte nochmal das Update auf 1.2 machen und es nochmal probieren?
    Ich denke, ich habe das Problem gefunden und beheben können, es wurde tatsächlich ein invalider Buffer an glTexCoords übergeben, was Qualcomm und Pixelflinger Devices aber egal ist.

    Gruß,
    Florian
     
  6. Sabian, 23.12.2010 #6
    Sabian

    Sabian Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    2
    Registriert seit:
    21.12.2010
    Ah okay,
    jo, bin gerade noch in der Uni, wenn ich daheim bin, teste ich das nochmal.
    bis dann
     
  7. Sabian, 23.12.2010 #7
    Sabian

    Sabian Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    2
    Registriert seit:
    21.12.2010
    So, also habs nochmal getestet. Der bug is weg! Sehr gut.
     
    daywalker bedankt sich.

Diese Seite empfehlen