1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Komme nicht über "not allow" hinaus

Dieses Thema im Forum "Root / Hacking / Modding für T-Mobile G1" wurde erstellt von mathiase, 02.03.2010.

  1. mathiase, 02.03.2010 #1
    mathiase

    mathiase Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.12.2009
    Hi,

    ich bin langsam echt verzweifelt ... Was ich jetzt an Tutorials gelesen und YouTube Videos geschaut habe geht auf keine Kuhhaut. Was ich auch mache, ich komme nicht über diesen Regenbogen-Bootloader und die Message "not allow" hinaus.

    Das ist was ich mache:

    1) G1 Dream per USB anschließen
    2) dd if=/dev/zero of=/dev/sdb
    3) fdisk /dev/sdb und eine pimäre Partition erstellen
    4) mkfs.vfat -F 32 /dev/sdb1
    5) mount /dev/sdb1 /mnt
    6) cp DREAIMG.NBH /mnt
    7) sync && umount /mnt
    8) dd if=goldcard.img of=/dev/sdb
    9) USB Stecker ziehen
    10) Power Off
    11) Kamera + Power Off drücken
    12) weinen weil wieder "not allow" kommt

    Ich habe mit aus unterschiedlichen Quellen das DREAIMG.NBH gezogen und mindestens 10 Mal meine CID und meine Methode die Bytes zu vertauschen überprüft.

    Jedes Mal kommt mein G1 wieder mit foldenen Eigenschaften hoch:

    Model Number: T-Mobile G1
    Firmware Version: 1.6
    Baseband Version: 62.50S.20.17U_2.22.19.26I
    Kernel: 2.6.29-00479-g3c7df37
    Build Number: DRC92

    Kenn mir irgendjemand helfen??

    cu
    mathiase
     
  2. winne, 02.03.2010 #2
    winne

    winne Android-Guru

    Beiträge:
    3,788
    Erhaltene Danke:
    644
    Registriert seit:
    09.05.2009
    Phone:
    S60
    Wearable:
    Pebble schwarz
  3. ChriDDel, 03.03.2010 #3
    ChriDDel

    ChriDDel Android-Lexikon

    Beiträge:
    1,368
    Erhaltene Danke:
    177
    Registriert seit:
    08.10.2009
    Manche SD Karte wollen auch partu nicht.
    Ich würde das mit der Primären Partition mal weglassen
    und die Karte übers Menü im G1 formatieren.
    Dann einfach das IMG einspielen.

    Ich habe bei Versuchen mit einem Rootingtool die erfahrung gemacht, dass eine im Windows formatierte Karte nach dem beschreiben mit dem IMG unleserlich wurde. (Dateisystem defekt).
    Nach nem Formatieren im G1 und dem IMG einspielen ging es Problemlos.
     
    mathiase bedankt sich.
  4. mathiase, 03.03.2010 #4
    mathiase

    mathiase Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.12.2009
    Hi,

    das mit der SD Karte, die nicht will hab ich auch schonmal gelesen. Hab mir direkt ne neue gekauft - hilft aber nix.

    Die neue CID hab ich aus /sys/class/mmc_host/mmc1/mmc1:aaaa/cid:

    035333535530384780712e3191009bd8

    Dann hab ich die Bytes umgedreht:

    d89b0091312e71804738305553335303

    Und alles 100 Mal gecheckt. Das goldcard Image von dem angegbenen Link geholt. Die SD Karte hab ich sicherheitshalber nochmal um ihren MBR erleichtert

    dd if=/dev/zero of=/dev/sdb bs=512 count=1

    und sie dann von Android formatieren lassen. Per USB dann das DREAIMG.NBH rüberkopiert und im Astro File Manager nochmal gecheckt, dass das Ding auch wirklich lesbar ist. Danach in Android geunmountet und
    mit

    dd if=goldcard.img of=/dev/sdb

    die Goldcard draufgespielt. Diese Geschichte mit dem HexEditor macht ja nichts anderes oder?

    Danach kam wieder "not allow". Irgendwas mach ich noch falsch. Aber was nur?

    cu
    mathiase
     
  5. winne, 03.03.2010 #5
    winne

    winne Android-Guru

    Beiträge:
    3,788
    Erhaltene Danke:
    644
    Registriert seit:
    09.05.2009
    Phone:
    S60
    Wearable:
    Pebble schwarz
    Offensichtlich ist das Ergebnis doch ein anderes, denn damit geht es. ;)
     
  6. ChriDDel, 04.03.2010 #6
    ChriDDel

    ChriDDel Android-Lexikon

    Beiträge:
    1,368
    Erhaltene Danke:
    177
    Registriert seit:
    08.10.2009
    evtl musst du bei dd die Blocksize 512 auch beim schreiben setzen.
    Aber ich glaube das war der Defaultwert.

    Probier doch mal den HXD.
     
  7. mathiase, 04.03.2010 #7
    mathiase

    mathiase Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.12.2009
    Hi,

    ich habs geschafft! Es irgendwie hat sich die CID nochmal geändert nachdem ich sie zum ersten Mal abgeschrieben habe. Ab da hab ich einfach mit einer falschen Goldcard gearbeitet.

    Ich hab jetzt CyanogenMode 4.2.14.1 drauf. 4.2.15 hat sich 2 Mal aufgehängt. Diese optional-Geschichte im Tutorial hab ich nicht mehr gemacht. Würdet ihr mir empfehlen das doch noch zu tun?

    Wie finde ich heraus, ob ich wirklich root bin? Im Terminal Emulator "id" eingeben zeigt mir die uid 10034 und die gid 10034. Das wifi-tethering tool, das man von googlecode bekommt sagt es kann das Tethering nicht starten. Eine Warnung, dass ich nicht root habe gibts aber nicht.

    cu
    mathiase
     
  8. ChriDDel, 04.03.2010 #8
    ChriDDel

    ChriDDel Android-Lexikon

    Beiträge:
    1,368
    Erhaltene Danke:
    177
    Registriert seit:
    08.10.2009
    Gib mal im terminal auf dem G1 su ein.
    Wenn es geht hast du root.

    Da du aber schon Cyanogen installiert hast, hast du sicher root rechte.
     
  9. mathiase, 04.03.2010 #9
    mathiase

    mathiase Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.12.2009
    Hi,

    leider nicht. Im Terminal Emulatur bringt mit "su" ein "permission denied" ... Das gibts doch nicht ...

    Was jetzt?

    cu
    mathiase
     
  10. ChriDDel, 04.03.2010 #10
    ChriDDel

    ChriDDel Android-Lexikon

    Beiträge:
    1,368
    Erhaltene Danke:
    177
    Registriert seit:
    08.10.2009
    Aktuelles Cyanogen drauf?
    Was sagt das App Superuser Permissions? Das müsste mit drauf sein.
     
  11. mathiase, 04.03.2010 #11
    mathiase

    mathiase Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.12.2009
    Diese app ist nicht drauf und ich finde sie auch nicht im Market ...
     
  12. ChriDDel, 04.03.2010 #12
    ChriDDel

    ChriDDel Android-Lexikon

    Beiträge:
    1,368
    Erhaltene Danke:
    177
    Registriert seit:
    08.10.2009
  13. schlüpferknoten, 04.03.2010 #13
    schlüpferknoten

    schlüpferknoten Android-Experte

    Beiträge:
    624
    Erhaltene Danke:
    36
    Registriert seit:
    15.03.2009
    Phone:
    Nokia Lumia 930
    ich denke, du hast das cyanogen rom in den 2 schritten geflasht oder? ich glaube dann hast du den gleichen fehler wie ich damals. (cyanogen in 2 schrittten geflasht und danach ein normales rom ohne rootrechte draufgehabt) kugg mal in den einstellungen-> systeminformationen ob da iwo was von cyanogen dransteht.
    wenn nicht darfst du alles nochmal machen und da empfehle ich dir eine fullversion von Kranki zu flashen.
     
  14. Steppo, 04.03.2010 #14
    Steppo

    Steppo Android-Lexikon

    Beiträge:
    1,894
    Erhaltene Danke:
    247
    Registriert seit:
    19.02.2010
    Ich hab das so gemacht, ist (Voraussetzung) für Cyanogen. Wenn du das App Super Permission nicht hast, dann fehlt da was?! Wenn du die DRC83_base_defanged drauf hast, einfach übers Recovery Cyanogen nochmals flashen, ansonsten (wenn du kein FullUpdate geflasht hast) neu machen! :D ;)
     
  15. mathiase, 04.03.2010 #15
    mathiase

    mathiase Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.12.2009
    Hi,

    also das sind meine aktuellen Phone Infos:

    Model Number: T-Mobile G1
    Firmware version: 1.6
    Baseband version: 63.50S.20.17U_2.22.19.26I
    Kernel Version: 2.6.29-cm42
    Mod Version: CyanogenMod-4.2.14.1
    Build Number: DRC83

    @ChriDDel: Ich glaube von der Website habe ich den das ROM schon her.

    Was ist eine fullversion im Vergleich zu dem was ich da habe? Und wer oder was ist Kranki? Das sind alles noch keine Begriffe für mich ...

    cu
    mathiase
     
  16. Steppo, 04.03.2010 #16
    Steppo

    Steppo Android-Lexikon

    Beiträge:
    1,894
    Erhaltene Danke:
    247
    Registriert seit:
    19.02.2010
    Schön :rolleyes: dann passt ja alles! Flash übers Recovery nochmals dein CyanogenMod, reboot dann müsste es funktionieren ;)

    Kranki ist einer unserer *besten* User, wenn du verstehst was ich meine :p:D:cool:

    Der hat die CyanogenMod noch verbessert.
     
  17. mathiase, 04.03.2010 #17
    mathiase

    mathiase Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.12.2009
    Hi,

    was ich jetzt nochmal gemacht habe:

    cm-4.2.14.1-remix-r1.zip und cm-4.2.14.1-remix-r2.zip auf die SD Karte gelegt, power off, power on mit home gedrückt. r2 wollte nicht flashen (da meinte er nur "bad"), r1 ging. Aber keine Änderung zu vorher.

    Was das was du mit "Flash übers Recovery nochmals dein CyanogenMod" gemeint hast?

    cu
    mathiase
     
  18. Steppo, 04.03.2010 #18
    Steppo

    Steppo Android-Lexikon

    Beiträge:
    1,894
    Erhaltene Danke:
    247
    Registriert seit:
    19.02.2010
    Jop, ich persönlich habe das Remix noch nicht drauf, Standard währt besser ;) Aber werde es bald ausprobieren. Da ich auch noch relativ neu bin, und Kranki's Version noch nie in irgend einer weise mir angesehen habe, weiß ich nicht, was du dort flashen sollst (müsste aber im Tut etc. vorhanden sein).
    Übers Recovery hast du das dann auch gemacht, richtig! ;)
    Wenn du keine Änderung zu vorher hast, dann solltest du einen Full Wipe machen, DRC83 + Kranki's Version dann flashen. Hoffe du hast dich vorher mit dieser Version von Cyanogen beschäftigt, wegen SPL, Radio etc... :D
    Viel Erfolg!
     
  19. mathiase, 04.03.2010 #19
    mathiase

    mathiase Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.12.2009
    Hi,

    ah der wipe hats gebracht. Wifi Tether geht jetzt. Allerdings bekomme ich im Market ständig

    "The process com.google.process.gapps has stopped unexpectedly. Please try again."

    Nochmal versuchen hilft natürlich nie was ^^ Was nun? Ich hab nach der Meldung gegooglet aber da gibts nur bug reports statt Lösungen ...

    cu
    mathiase
     
  20. ChriDDel, 04.03.2010 #20
    ChriDDel

    ChriDDel Android-Lexikon

    Beiträge:
    1,368
    Erhaltene Danke:
    177
    Registriert seit:
    08.10.2009
    Kranki hat ne Bug in den Roms.
    Deswegen solltest du ohne Wipe einspielen.
    Zieh dir ne alte Kranki version und flashe die.
    Danach flashst du die neue.
    Die Gibts alle unter dem Link, den ich gepostet habe.
     

Diese Seite empfehlen