1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Ladestrom?

Dieses Thema im Forum "Motorola Defy Forum" wurde erstellt von Spatz, 10.04.2012.

  1. Spatz, 10.04.2012 #1
    Spatz

    Spatz Threadstarter Junior Mitglied

    Beiträge:
    37
    Erhaltene Danke:
    2
    Registriert seit:
    26.12.2011
    Moin,

    als ich noch mein iPhone hatte habe ich mir ein Ladegerät für das Teil selber gebaut. Dabei merkt das iPhone anhand der Spannungen zwischen den Datenpins und den Spannungspins des USB-Steckers, ob 1. ein Apple-kompatibles :lol: Ladegerät angeschlossen wurde, und 2. welchen Ladestrom das Gerät zur Verfügung stellen kann.

    Wie ist das beim Defy? Lädt es immer mit maximalem Ladestrom (wie hoch ist der?) oder muss man das Defy irgendwie dazu überzeugen, mehr als die erlaubten 500 mA der USB-Buchse zu ziehen. Ich meinte mal gelesen zu haben, dass man die beiden Datenpins kurzschließen muss, aber das war bei Androiden von HTC.

    Mir kommt es nämlich so vor, als würde mein Defy an meinem Selbstbau deutlich langsamer laden, obwohl der Output des Spannungswandlers bei maximal 3 Ampere liegt.

    Ciao,

    Spatz
     
  2. maniac103, 10.04.2012 #2
    maniac103

    maniac103 Android-Lexikon

    Beiträge:
    1,237
    Erhaltene Danke:
    1,157
    Registriert seit:
    24.01.2011
    Das ist richtig und auch bei Motorola so. Ich weiß nicht genau, wie hoch der maximale Ladestrom in diesem Fall ist, aber es ist deutlich mehr als 1A (Labornetzteil gab nicht mehr her).

    Sent from my Defy
     
  3. Meister-Ade, 12.04.2012 #3
    Meister-Ade

    Meister-Ade Neuer Benutzer

    Beiträge:
    9
    Erhaltene Danke:
    1
    Registriert seit:
    12.04.2012
    Die beiden Datenleitungen dürfen zueinander max. 200 Ohm haben. Ist für Geräte die seit 2007 in Entwicklung waren genormt (vorrausgesetzt der Hersteller hält sich daran).

    Genaueres hier: IPod Ladegerät - Mikrocontroller.net

    Wie hoch der Ladestrom ist weis ich nicht. Habe mit einem 5V 1A Linearregler und einem 60 Ohm Widerstand zwischen den Datenleitungen gute Erfahrungen gemacht. Auf dem 230V Ladegerät stehen ja 1,1 A. Bekomme die Woche wieder Bauteile rein und soll noch 2 Ladegeräte für Kumpels bauen. Werde dann mit meinem 2A Labornetzteil messn (das kann man ja direkt auf 5V einstellen). Die Messergebnisse werde ich dann posten oder dir per PM zukommen lassen ;)
     
    Zuletzt bearbeitet: 12.04.2012
  4. Spatz, 12.04.2012 #4
    Spatz

    Spatz Threadstarter Junior Mitglied

    Beiträge:
    37
    Erhaltene Danke:
    2
    Registriert seit:
    26.12.2011
    Das ist doch super! Ich werde denk ich auch nochmal eine Messreihe machen, in der ich die Ladezeiten von verschiedenen Konfigurationen mittels Badass Battery Monitor vergleiche.

    Dann können wir ja beides hier posten!
     
  5. crobe, 12.04.2012 #5
    crobe

    crobe Android-Experte

    Beiträge:
    503
    Erhaltene Danke:
    60
    Registriert seit:
    17.03.2011
    Baust du das frei Schnauze oder hast du einen Beispielschaltplan?

    /edit: Mist, hab den Link oben übersehen.

    rob
     
    Zuletzt bearbeitet: 12.04.2012
  6. Meister-Ade, 12.04.2012 #6
    Meister-Ade

    Meister-Ade Neuer Benutzer

    Beiträge:
    9
    Erhaltene Danke:
    1
    Registriert seit:
    12.04.2012
    Als Beispiel kannst du die Schaltung in dem Link von mir oben nehmen. Je nachdem was du als Spannungsquelle nimmst kannst du dann entsprechendes wegfallen lassn. Z.B. wenn du schon eine Konstantspannungsquelle hast mit z.B. 12V dann brauchst du nur noch einen Spannungsregler und die entsprechenden kleinen Kondensatoren zur Spannungstabilisation. Am einfachsten geht es mit einen Konstantspannungsregler (Linearregler) mit 5V Ausgangsspannung. Da kannst du dann meistens bis zu 32V an die Eingangsseite legen. Im Datenblatt des Reglers sind dann auch die empfohlenen Kondensatoren vermerkt. Die 4 Widerstände vorm USB Port kannst du durch einen bis max. 200 Ohm ersetzen zwischen den beiden Datenpins. Je näher an den 200 Ohm desto besser das belastet dann den Spannungsregler weniger und es bleibt mehr Leistung zum Laden.

    ..........................

    Wie hoch der Ausgangsstrom vom Regler sein muss versuchen wir gerade herauszufinden. Er muss irgendwo zwischen den normalen 500mA aus einem USB-Anschluss liegen und dem 850mA vom originalen Ladegerät (Hab mich vorher vertan die 1,1A waren von meinen alten LG).

    Mit einem 1A Regler hatte ich noch keine Probleme. Werde aber heute meinen Akku ganz leer machen und dann eine Messung machen wieviel Strom der Ladevorgang benötigt. Gut das bei uns DSL ausgefallen ist und ich schon den ganzen Tag per WLAN-Hotspot ins Netz gehe da wird der Akkus schnell leer ohne Ladung
     
    Zuletzt von einem Moderator bearbeitet: 12.04.2012
    crobe bedankt sich.
  7. RainerBer, 12.04.2012 #7
    RainerBer

    RainerBer Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    1
    Registriert seit:
    05.04.2011
    Ich habe das vor ein paar Wochen mit einem 5V Netzteil ausprobiert, da ich für mein Moped einen 5V Anschluß fürs Navi oder Defy vorsehen will.
    Der Strom lag bei leerem Akku knapp unter 1 A, was mit dem Aufdruck auf dem org. Netzteil hinkam.
    Die Stromaufnahme reduziert sich dann mit zunehmendem "Füllstand" des Akku's.

    Rainer
     
  8. Meister-Ade, 12.04.2012 #8
    Meister-Ade

    Meister-Ade Neuer Benutzer

    Beiträge:
    9
    Erhaltene Danke:
    1
    Registriert seit:
    12.04.2012
    Meine Messung läuft gerade. Die Tendenz das mit steigendem Füllstand der Strom sinkt kann ich bestätigen. Allerdings habe ich bei ganz leeren Akku für ca. 30 sec einen Ladestrom von 1,2A der aber dann rasch auf 900mA sinkt und dann kontinuierlich weiter runter geht. Aktuell ist er bei 850mA (Akku zu 35% voll).

    Welche ROM verwendest du und welche Version? Hätte gedacht das der Ladevorgang vom Kernel selbst geregelt wird und da dieser beim Defy gelockt ist auch immer die selben Werte liefert. Aber anscheinend gibt es Unterschiede. Werde wenn mein Defy wieder voll ist ein Diagramm vom Ladevorgang hochladen.

    EDIT: Anbei das Diagramm vom Ladestrom. Hatte die Batterystats gelöscht da es ein Update meiner ROM gab deswegen der lange Ladevorgang. Der Anstieg zum Schluss kommt vom WLAN-Hotspot Betrieb. Wie man aus dem Diagramm erkennen kann sollte ein 1A Regler reichen weniger gingen auch aber die 1A sind am gängisten und günstigsten. Die nächste Stufe mit 500mA sind schon fast wieder zu wenig. :smile:
     

    Anhänge:

    • 2.png
      2.png
      Dateigröße:
      135 KB
      Aufrufe:
      505
    Zuletzt bearbeitet: 13.04.2012
  9. Spatz, 13.04.2012 #9
    Spatz

    Spatz Threadstarter Junior Mitglied

    Beiträge:
    37
    Erhaltene Danke:
    2
    Registriert seit:
    26.12.2011
    Oha, das ist ja wirklich Super! Weisst du welchen Ladestand der Akku bei 22:34 hatte, also da, wo es den Knick gibt? Im Flugzeugmodus wäre das ganze Gefrickel weg, oder? Aber auch mal Interessant zu sehen, dass sich das Defy eventuell benötigte Mehrleistung auch direkt aus dem Netz ziehen kann.

    Meint ihr, man könnte das Gerät irgendwie überzeugen, schneller zu laden?
     
  10. Meister-Ade, 13.04.2012 #10
    Meister-Ade

    Meister-Ade Neuer Benutzer

    Beiträge:
    9
    Erhaltene Danke:
    1
    Registriert seit:
    12.04.2012
    Beim Knick waren es ungefähr 65% Ladezustand. Ich muss dazu sagen das mein Akku nicht mehr der Beste ist. Unter starker Last oder längeren surfen wird er sehr warm und "duftet" dann nach Zigarettenrauch. Werde ihn bald wechseln. Gestern beim Laden hing der Ladezustand ca. eine halbe Stunde bei 86%. Nach dem außerplanmäßigen löschen der Batteriestats ging es wieder weiter auf der Anzeige. Strom hat er sich schon in der Zeit genehmigt. Werde heute nochmal die Stats bei 100% löschen und neu kalibrieren.

    Mit dem Flugzeugmodus hast du recht. Mit dieser Methode kann man auch schön die Wirkung vom Undervolting messen. Denn anscheinend wenn der Akku voll ist und an der Ladeleitung hängt holt sich das Defy den Strom zum "überleben" aus der Leitung und denn kann man leicht messen.

    Kleiner Vergleich: Stromaufnahme mit Standardwerte 800Mhz/58 600Mhz/48 300Mhz/33 (up_threshold bei 86%) nicht unter 70mA im Standby und Flugzeugmodus an
    Stromaufnahme mit Undervolting 1000Mhz/49 600Mhz/29 300Mhz/16 (up_threshold bei 89%) geht bis auf 48mA runter :cool2:

    Glaube nicht das man den Akku schneller im Handy drin laden kann er genehmigt sich auch nicht mehr es waren die ganze Zeit bei meiner Messung 2A verfügbar aber mehr als 1,1A flossen nicht. Eins ist mir noch aufgefallen am Anfang wo der Strom noch über den 850mA vom originalen Netzteil war ist der Ladevorgang merklich schneller gewesen.

    Aber wie gesagt mein Akku hat schon einen weg kann bei jedem anders sein.


    Aber nochmal zurück zu deinem Eingangspost. Denke du haste eine Schaltung wie diese im Einsatz: http://www.loncarek.de/pages/Articles/IpodChargerMod . Am USB-Anschluss am PC kommen auch nicht immer 500mA sonder vorerst 100mA erst wenn der Bus die Berechtigung dazu gibt werden 500mA freigeben. Könnte natürlich sein das dein Defy mit der Schaltung ausgeht das es noch keine Freigabe hat und holt sich dann nur die 100mA und dann dauert das Laden entsprechend länger. Wie du im Diagramm siehst sind die 100mA gleich erreicht (in höheren Ladezuständen wenn du nur den Display anmachst). Versuche mal deine Schaltung auf die max. 200 Ohm zwischen den Datenpins zu verändern und versuch es nochmal.

    Hoffe das reicht vorerst. ;)
     
    Zuletzt bearbeitet: 13.04.2012
  11. Spatz, 15.04.2012 #11
    Spatz

    Spatz Threadstarter Junior Mitglied

    Beiträge:
    37
    Erhaltene Danke:
    2
    Registriert seit:
    26.12.2011
    Na und ob das reicht! :thumbsup:

    Ich denke dass Dank deiner Messungen und Erläuterungen alles geklärt sein dürfte.

    Achja, ich verwende übrigens einen 5V-Spannungsregler mit 3A, da hängen zwei USB-Buchsen dran, eine für Android und eine für iPhone... Spannungsquelle ist ein Block aus 6x AA-Batterien.
     
  12. Meister-Ade, 18.04.2012 #12
    Meister-Ade

    Meister-Ade Neuer Benutzer

    Beiträge:
    9
    Erhaltene Danke:
    1
    Registriert seit:
    12.04.2012
    War länger nicht da und hab erst jetzt wieder Zeit. Wie sind denn die Batterien geschaltet? Gehen tut eigentlich nur in Reihe und eine parallel. Denke aber alle 6 in Reihe. Das würde aber bedeuten das ein Großteil der Spannung am Regler verheizt würde. Sind die Batterien Akkus mit 1,2V oder normale mit 1,5V?
    Intresannt für dich ust evtl. das hier: IPod Ladegerät - Mikrocontroller.net

    Könnte eine längere Haltbarkeit der Batterien bedeuten. Bekomme die Woche einen neuen 1800mAh Akku und werde eine neue Messung machen diesmal auch bei ausgeschalteten Handy um ein möglichst genaues Ergebnis zu haben.
     
  13. crobe, 18.04.2012 #13
    crobe

    crobe Android-Experte

    Beiträge:
    503
    Erhaltene Danke:
    60
    Registriert seit:
    17.03.2011
    Welchen Akku hast du bestellt? Nen 1800er China Teil?
     
  14. Meister-Ade, 18.04.2012 #14
    Meister-Ade

    Meister-Ade Neuer Benutzer

    Beiträge:
    9
    Erhaltene Danke:
    1
    Registriert seit:
    12.04.2012
    Nein einen originalen für das Defy+. Der hat 1800mAh und meine verwendete ROM standardmäßig den Fix um den Akku auch über 85% aufzuladen.
     
  15. crobe, 18.04.2012 #15
    crobe

    crobe Android-Experte

    Beiträge:
    503
    Erhaltene Danke:
    60
    Registriert seit:
    17.03.2011
    Ohne klugscheissen zu wollen hat der Original Defy+ 1700mAh, deswegen fragte ich.
     
  16. Meister-Ade, 18.04.2012 #16
    Meister-Ade

    Meister-Ade Neuer Benutzer

    Beiträge:
    9
    Erhaltene Danke:
    1
    Registriert seit:
    12.04.2012
    Ups da habe ich mich vertan. Hab mir einen HF5X gekauft mit wie von dir schon gesagt 1700 mAh und nicht 1800 mAh. Hatte falsche Werte im Kopf ;) Als ich den Akku heute auspackte gab es einen Ahhaeffekt :)
     

Diese Seite empfehlen