1. Möchtest Du unser Team im Android OS-Bereich unterstützen? Details dazu findest du hier!
  2. Wir haben diesmal 2 Gewinnspiele zeitgleich für euch - Gewinne einmal ein UMI Plus E - Beim 2ten könnt ihr ein Nomu S30 gewinnen!
  1. Paolo22, 16.05.2016 #1941
    Paolo22

    Paolo22 Android-Hilfe.de Mitglied

    Ich wäre auch für Tipps empfänglich.
    Ich kann mit dem Totalcommander auf der ext4 Partition Dateien erstellen etc. aber eine Verlinkung mit Link2sd funktioniert doch nicht richtig.
    Mal hat es ein apk kopiert und was nach dalvik-cache geschrieben. Aber nach dem Neustart war die App doch weg.
    Aber meistens mosert es was mit "Package Invalid" beim Versuch einen Link zu erstellen.
    Also insgesamt unbefriedigend. :winki:

    Switel S4015D / MT6572 / Android 4.4.2,
     
  2. email.filtering, 17.05.2016 #1942
    email.filtering

    email.filtering Threadstarter Android-Ikone

    Der App-Entwickler hat doch eine Webseite für Link2SD; da sollte doch nachzulesen sein, ob die App auch noch bei Android 6.x funktioniert.
     
  3. Stonaged, 12.06.2016 #1943
    Stonaged

    Stonaged Erfahrener Benutzer

    Hat hier noch jemand das Problem, dass nach dem Erstellen der 2. Partition auf der SD-Karte, die 1. Partition nun anders/falsch eingebunden wird?

    Die 1. Partition heißt bei mir dann "mnt/extsd/179_1"
    statt wie bisher "mnt/extsd", wo sie noch die einzige Partition auf der SD Karte war.

    Ich habe Android Version 4.4.2.

    Ich kann Link2sd nicht voll einsetzen, weil mit der 2. Partition sonst einige Programme die externe SD-Karte (1. Partition, also mnt/extsd) nicht wirklich finden, da diese dann ja auf mnt/extsd/179_1 liegt.

    Das ist kein Link2Sd spezifisches Problem. Das Problem stellt sich also auch bei anderen Apps für die man eine 2. Partition braucht.

    Was kann man da tun?

    Ich hatte vor einiger Zeit schon mal was dazu geschrieben. Siehe
    Link2SD: Einrichtung und Probleme
    und folgende
     
  4. easyline001, 20.06.2016 #1944
    easyline001

    easyline001 Fortgeschrittenes Mitglied

    Auf SD Karte verlinken' und 'Auf SD Karte verschieben...
    Was macht da mehr Sinn, b.z.w. was entlastet den internen Speicher wirklich
     
  5. email.filtering, 20.06.2016 #1945
    email.filtering

    email.filtering Threadstarter Android-Ikone

    Lies Dich doch einfach mal auf der Webseite zur App schlau! ;) Dann weißt Du, dass Du nur mit "verlinken" (und der Plus-Version auch wirklich) alles auf die Speicherkarte verfrachten kannst und in der Datenpartition nur mehr die entsprechenden Links (zur zweiten Partition der Speicherkarte) vorhanden sind.
     
  6. easyline001, 20.06.2016 #1946
    easyline001

    easyline001 Fortgeschrittenes Mitglied

    Plus-Version habe ich... Und danke für den Tip mit der Webseite.
    Nur mein Englisch ist leider bescheiden...
    Und die übersetzung, na ja besser als nix. Aber gut ist was anderes.

    Noch ne andere Frage:
    Die Karte die ich drin habe ist ext3 (2.patition)
    Wenn ich mir nun ne grössere zulegen möchte, kann ich die "Daten" in die vergrößerte 2. Patition irgentwie rüber kopieren ?
    Und ginge das auch wenn ich die neue mit ext4 formatiere ?
    Oder muss alles zurückverschoben werden, neue (grössere) rein und dann alles neu "verlinken" ?

    frage deshalb, weil Speicherplatz könnte bald mal eng werden, und ext4 ist vielleicht bessser als ext3, da auf der Webseite, wie ich das "gelesen" habe die 4er Version beschrieben wurde.
     
  7. det-happy, 21.06.2016 #1947
    det-happy

    det-happy Ehrenmitglied

    Rüberkopieren geht leider nicht.
    Workaround: Titanium Backup, alle Apps sichern
    Neue Ext. Partition anlegen
    Bei Titanium "verweiste Daten" löschen, danach die fehlenden Apps "wiederherstellen"
     
  8. Stonaged, 10.07.2016 #1948
    Stonaged

    Stonaged Erfahrener Benutzer

    Ich habe einen Workaround gefunden für mein Problem :
    Die 1. Partition heißt bei mir leider "mnt/extsd/179_1"
    statt wie bisher "mnt/extsd", sprich alle Daten waren in den Unterordner 179_1 > Sehr sehr ärgerlich!
    Link2SD: Einrichtung und Probleme

    Unter /etc/install-recovery.sh
    hängte ich folgende Zeilen ein:
    Code:
    unmount /mnt/extsd
    Sleep 2
    mount -t vfat -o rw /dev/block/vold/179:1 /mnt/extsd
    mount -t vfat -o rw /dev/block/mmcblk1p1 /mnt/extsd 
    und nun sehe ich bei zwei Partitionen auf der externen SD-Karte wieder wie gehabt "mnt/extsd".


    Kleiner Schönheitsfehler:
    Ich kann das Script von Link2SD nicht finden, welches jedoch funktioniert und sein Log-File schreibt.
    Wo könnte das noch sein?
     
  9. Stonaged, 12.07.2016 #1949
    Stonaged

    Stonaged Erfahrener Benutzer

    Jetzt habe ich das script gefunden.
    Es ist die Datei /system/bin/debuggerd und hat bei mir folgenden Inhalt:
    Code:
    #!/system/bin/sh
    #added by link2sd
    LOG=/data/link2sd-debuggerd.log
    set +e
    echo "$(date) mounting..." > $LOG
    sleep 2
    mount -t ext2 -o rw /dev/block/vold/179:2 /data/sdext2 1>>$LOG 2>>$LOG
    
    mount -t ext2 -o rw /dev/block/mmcblk0p2 /data/sdext2 1>>$LOG 2>>$LOG
    
    mount >> $LOG
    echo "$(date) mount finished" >> $LOG
    chmod 773 /data/dalvik-cache
    echo debuggerd.bin launched >> $LOG
    exec /system/bin/debuggerd.bin
     
  10. dautz, 18.07.2016 #1950
    dautz

    dautz Neuer Benutzer

    Hallo zusammen,

    auf meinem Tablet (Archos 101d Neon) ist Kitkat 4.4.2 installiert. Da ich gerne meine Apps auf der SD-Karte hätte, habe ich das Tablet gerootet (Kingroot), die SD-Karte partitioniert und Link2SD installiert. Klappt alles ohne Probleme, die Apps werden ohne Fehlermeldung verschoben.
    Was mich aber stört ist, dass ich andere Dateien, wie z.B. mp4-Videos, nicht abspielen kann, wenn sie sich auf der größeren der beiden Partitionen befinden (egal mit welchem Player, habe verschiedene ausprobiert). Auf der kleineren Partition werden die Dateien abgespielt, aber da sollen sie nicht hin.
    Wie bekomme ich es hin, dass ich Video-Dateien auf der größeren Partition abspielen kann? Müssen die in einen bestimmten Ordner rein?
    Laut Link2SD lauten die Pfade zu den Partitionen:
    1. Partition: /mnt/media_rw/sdcard1
    2. Partition: /data/sdext2

    Vielen Dank und Gruß
    dautz
     
  11. det-happy, 19.07.2016 #1951
    det-happy

    det-happy Ehrenmitglied

    Das kann Link2SD nur in der Pro Version, Alternative wäre "Folder Mount"
     
    dautz bedankt sich.
  12. dautz, 20.07.2016 #1952
    dautz

    dautz Neuer Benutzer

    OK. Ich denke du meinst Link2SD Plus.
    Weißt du zufällig, ob ich dann beliebige Ordner egal wo auf der zweiten Partition erstellen kann, wo ich dann meine Videos verschieben kann oder gibt es dabei etwas zu beachten?
     
  13. det-happy, 20.07.2016 #1953
    det-happy

    det-happy Ehrenmitglied

    Das kann Link2SD Plus glaub ich nicht. Macht auch keinen Sinn.

    Lass Videos auf der 1. Partitionen der SD-Karte. Link2SD kann dir aber zum Beispiel extra nachgelade Spielgrafiken oder Navigon Karten verschieben, alles was sonst als Dateien auf dem internen Speicher landet

    Auch zum Beispiel den Whatsapp Media Ordner.

    Siehe mal in unseren Wiki nach unter

    FAQ: Android und Gerätespeicher
     
    dautz bedankt sich.
  14. dautz, 20.07.2016 #1954
    dautz

    dautz Neuer Benutzer

    Oh, da hab ich mich verschrieben, ich meinte auch die 1. Partition, also die größere.
    Hast mir weitergeholfen, dann besorg ich mir mal die Plus-Version. Danke.
     
  15. dautz, 23.07.2016 #1955
    dautz

    dautz Neuer Benutzer

    Habe mir heute die Plus-Version gekauft. Auf die 1. Partition habe ich dann testweise verschiedene Dateien rüberkopiert.
    Fotos werden NUR mit dem internen Bildbetrachter vom ES Datei Explorer geöffnet. Musik wird ebenfalls NUR mit dem Player des Explorers wiedergegeben.
    Videos im mp4-Format laufen aber gar nicht (egal ob mit VLC oder dem player vom ES Datei Expl., und anderen playern).
    PDF-Dateien hingegen konnten geöffnet werden.
    Hat einer ne Idee was die Ursache dafür sein könnte?
     
  16. Stonaged, 29.07.2016 #1956
    Stonaged

    Stonaged Erfahrener Benutzer

    Meine externe SD-Karte hat zwei primäre Partitionen. Die zweite, eine ext2 wird von einem Link2sD-script eingebunden.
    Die erste erscheint nun leider als
    /mnt/extsd/179_1

    Binde ich nun die erste Partitionen analog in einem script, welches in /etc/install-recovery.sh aufgerufen wird ein:
    mount -t vfat -o rw /dev/block/vold/179:1 /mnt/extsd
    mount -t vfat -o rw /dev/block/mmcblk1p1 /mnt/extsd
    Dann ergibt sich Bild Scr4.jpg. Hier mangelt es dann an den Permissions
    mounting...
    __
    rootfs / rootfs ro,seclabel,relatime 0 0
    tmpfs /dev tmpfs rw,seclabel,nosuid,relatime,mode=755 0 0
    devpts /dev/pts devpts rw,seclabel,relatime,mode=600 0 0
    proc /proc proc rw,relatime 0 0
    sysfs /sys sysfs rw,seclabel,relatime 0 0
    selinuxfs /sys/fs/selinux selinuxfs rw,relatime 0 0
    none /sys/fs/cgroup tmpfs rw,seclabel,relatime,mode=750,gid=1000 0 0
    tmpfs /mnt/secure tmpfs rw,seclabel,relatime,mode=700 0 0
    tmpfs /mnt/asec tmpfs rw,seclabel,relatime,mode=755,gid=1000 0 0
    tmpfs /mnt/obb tmpfs rw,seclabel,relatime,mode=755,gid=1000 0 0
    none /dev/cpuctl cgroup rw,relatime,cpu 0 0
    debugfs /sys/kernel/debug debugfs rw,relatime 0 0
    /dev/block/by-name/system /system ext4 ro,seclabel,relatime,user_xattr,barrier=1,data=ordered 0 0
    /dev/block/by-name/cache /cache ext4 rw,seclabel,nosuid,nodev,noatime,user_xattr,barrier=1,nomblk_io_submit,data=ordered 0 0
    /dev/block/by-name/databk /databk ext4 rw,seclabel,nosuid,nodev,noatime,user_xattr,barrier=1,nomblk_io_submit,data=ordered 0 0
    /dev/block/by-name/data /data ext4 rw,seclabel,nosuid,nodev,noatime,user_xattr,barrier=1,nomblk_io_submit,data=ordered,noauto_da_alloc 0 0
    /dev/block/vold/179:2 /data/sdext2 ext2 rw,seclabel,relatime,user_xattr,barrier=1 0 0
    ___
    mount: No such file or directory
    rootfs / rootfs ro,seclabel,relatime 0 0
    tmpfs /dev tmpfs rw,seclabel,nosuid,relatime,mode=755 0 0
    devpts /dev/pts devpts rw,seclabel,relatime,mode=600 0 0
    proc /proc proc rw,relatime 0 0
    sysfs /sys sysfs rw,seclabel,relatime 0 0
    selinuxfs /sys/fs/selinux selinuxfs rw,relatime 0 0
    none /sys/fs/cgroup tmpfs rw,seclabel,relatime,mode=750,gid=1000 0 0
    tmpfs /mnt/secure tmpfs rw,seclabel,relatime,mode=700 0 0
    tmpfs /mnt/asec tmpfs rw,seclabel,relatime,mode=755,gid=1000 0 0
    tmpfs /mnt/obb tmpfs rw,seclabel,relatime,mode=755,gid=1000 0 0
    none /dev/cpuctl cgroup rw,relatime,cpu 0 0
    debugfs /sys/kernel/debug debugfs rw,relatime 0 0
    /dev/block/by-name/system /system ext4 ro,seclabel,relatime,user_xattr,barrier=1,data=ordered 0 0
    /dev/block/by-name/cache /cache ext4 rw,seclabel,nosuid,nodev,noatime,user_xattr,barrier=1,nomblk_io_submit,data=ordered 0 0
    /dev/block/by-name/databk /databk ext4 rw,seclabel,nosuid,nodev,noatime,user_xattr,barrier=1,nomblk_io_submit,data=ordered 0 0
    /dev/block/by-name/data /data ext4 rw,seclabel,nosuid,nodev,noatime,user_xattr,barrier=1,nomblk_io_submit,data=ordered,noauto_da_alloc 0 0
    /dev/block/vold/179:2 /data/sdext2 ext2 rw,seclabel,relatime,user_xattr,barrier=1 0 0
    /dev/block/vold/179:1 /mnt/extsd vfat rw,relatime,fmask=0077,dmask=0077,codepage=cp437,iocharset=ascii,shortname=mixed,errors=continue 0 0
    mount finished

    Was läuft falsch?
    Was kann man da noch tun?
     

    Anhänge:

    • Scr1.jpg
      Scr1.jpg
      Dateigröße:
      31.3 KB
      Aufrufe:
      32
    • Scr2.jpg
      Scr2.jpg
      Dateigröße:
      30.3 KB
      Aufrufe:
      42
    • Scr3.jpg
      Scr3.jpg
      Dateigröße:
      30.6 KB
      Aufrufe:
      30
    • Scr4.jpg
      Scr4.jpg
      Dateigröße:
      27.9 KB
      Aufrufe:
      37
    • Scr5.jpg
      Scr5.jpg
      Dateigröße:
      30.6 KB
      Aufrufe:
      40
  17. Stonaged, 29.07.2016 #1957
    Stonaged

    Stonaged Erfahrener Benutzer

    Nachtrag: Ich habe die Fat-Partition nun versuchsweise bereits im Link2sd-Script gemountet mit genau denselben Ergebnis (Scr4.jpg)
    Auch das mounten auf /data/sdext1 bringt dieselben Rechte+UID+GUI wie in Scr4.jpg.

    Ein ändern der Rechte per TotalCommander wird ignoriert

    Die vom Link2SD script eingebundene EXt2 Partition schaut dagegen besser aus: Scr5.jpg
     
  18. franc, 29.07.2016 #1958
    franc

    franc Android-Lexikon

    Ich habe nun doch auf Marshmallow (CM13) upgedatet und erlebt dass Link2SD nicht mehr geht. Schade aber muss auch ohne gehen :(
     
  19. dautz, 31.07.2016 #1959
    dautz

    dautz Neuer Benutzer

    Hat keiner eine Vermutung?
     
  20. franc, 01.08.2016 #1960
    franc

    franc Android-Lexikon

    Klingt nach einem Berechtigung Problem
     

Diese Seite empfehlen

Besucher kamen mit folgenden Begriffen auf unsere Seite:

  1. /data/sdext2 konnte nicht