Logcat vom Handy

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von unfug, 12.09.2011.

  1. unfug, 12.09.2011 #1
    unfug

    unfug Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    8
    Registriert seit:
    01.12.2009
    Phone:
    T-Mobile Pulse
    Hi beisammen,
    die App, die ich gerade entwickle arbeitet im Emulator gut. In meinem Pulse-Handy stuerzt die App jedoch ab. Versuche, einen Logcat zu erhalten, scheiterten bisher. Ueber adb shell kann ich problemlos auf mein Handy zugreifen nur bei logcat passiert nichts. In Eclipse erscheint das Handy in der Device-Ansicht auch
    Wenn ich da aber das Handy fuer den Logcat auswaehle, kriege ich folgende Meldung in der Console-Ansicht:
    Hat jemand einen Plan?

    Ach ja, um Rootzugriff zu haben, habe ich das Custom-Rom FLB 1.7 drauf.

    Gruss unfug
     
  2. Kranki, 12.09.2011 #2
    Kranki

    Kranki Ehrenmitglied

    Beiträge:
    3,831
    Erhaltene Danke:
    814
    Registriert seit:
    19.07.2009
    Tablet:
    Samsung Galaxy Tab 3 7.0 Lite
    Schonmal in der Konsole versucht? adb lolcat?
     
  3. unfug, 12.09.2011 #3
    unfug

    unfug Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    8
    Registriert seit:
    01.12.2009
    Phone:
    T-Mobile Pulse
    @Kranki:
    Ja, sowohl mit adb logcat direkt als auch in der adb shell. Auch die entsprechenden device-dateien mit cat auslesen auf einer handy-shell hab ich probiert.
     
  4. Kranki, 12.09.2011 #4
    Kranki

    Kranki Ehrenmitglied

    Beiträge:
    3,831
    Erhaltene Danke:
    814
    Registriert seit:
    19.07.2009
    Tablet:
    Samsung Galaxy Tab 3 7.0 Lite
    Wenn das alles nicht funktioniert ist möglicherweise das Log in deinem ROM deaktiviert. Ich versteh zwar nicht, warum, aber ich weiß, dass manche Entwickler das machen. Vielleicht machst du dich in der Richtung mal kundig.
     
  5. unfug, 12.09.2011 #5
    unfug

    unfug Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    8
    Registriert seit:
    01.12.2009
    Phone:
    T-Mobile Pulse
    OK, zuerst mal die config-dateien auf'm handy durchsehen und vielleicht doch mal fibblesan kontaktieren.
    Vielleicht weiss ja auch einer von den hardcore-rom-bastlern, welche config zustaendig ist ?

    Gruss unfug
     
  6. fleckdalm, 13.09.2011 #6
    fleckdalm

    fleckdalm Android-Experte

    Beiträge:
    700
    Erhaltene Danke:
    55
    Registriert seit:
    13.09.2010
    Probier vielleicht mal catlog aus dem market dann hättest den log zumindest am smartphone;)
     
  7. unfug, 14.09.2011 #7
    unfug

    unfug Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    8
    Registriert seit:
    01.12.2009
    Phone:
    T-Mobile Pulse
    Hab's ausprobiert. Geht auch nicht. Das Device /dev/log/main ist zwar auf'm Handy da, aber es loggt einfach nicht. Ist wohl irgendwo in den Systemeinstellungen deaktiviert. Bloß wo ?:confused2:

    Gruss unfug
     

Diese Seite empfehlen