1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Magnetsensoren verstimmt

Dieses Thema im Forum "Motorola Milestone Forum" wurde erstellt von Belsatzar, 12.01.2010.

  1. Belsatzar, 12.01.2010 #1
    Belsatzar

    Belsatzar Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    15
    Registriert seit:
    02.01.2010
    hey, ich hab grad gemerkt dass die magnetsensoren in meinem milestone irgendwie verstimmt sind. entsprechend ist der kompass nicht mehr funktionsfähig, weil der magnetsensor permanent und richtungsunabhängig ein magnetisches feld halluziniert, welches stärker ist als das erdmagnetfeld. ich habe daraufhin die wunderbare tricorder app benutzt, und siehe da, in der magnetfeldanzeige ist ein permanenter aussschlag nach "rechts oben" zu bemerken, und zwar wie gesagt (weitgehend) von der ausrichtung des gerätes.
    figure-8-pattern hab ich schon probiert (zumindest so wie ich das verstanden habe); gibts andere möglichkeiten zur kalibrierung von denen ihr wisst, oder welchen grund kann diese abweichung haben?
     
  2. Bausparfuchs, 13.01.2010 #2
    Bausparfuchs

    Bausparfuchs Erfahrener Benutzer

    Beiträge:
    189
    Erhaltene Danke:
    15
    Registriert seit:
    12.12.2009
    Hm, wenn das Milestone mehrere Hallsensoren hat ist vielleicht einer hinüber? Da hilft wohl einschicken. In meinem GPS kann ich den Kompass kalibrieren indem ich das Gerät in der Waagerechten hin und her bewege. Den milestonekompass hab ich aber ehrlich gesagt noch nie gesehn geschweige denn benutzt. Kommt bestimmt bald noch. Andere Idee wäre, du hast das ding einfach neben nem Magneten abgelegt? Oder dein Nachbar macht irgendwelche ominösen Wechselstromexperimente ;-)?
     
  3. Belsatzar, 13.01.2010 #3
    Belsatzar

    Belsatzar Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    15
    Registriert seit:
    02.01.2010
    :D
    nee, seit dieser rumänische physiker ausgezogen is war eigentlich ruhe...

    was meinst du mit "neben einem magneten abgelegt"? in wiefern kann das probleme verursachen?
    maaaan...einschicken...hat da jmd erfahrung mit amazon?
     
  4. Keija, 13.01.2010 #4
    Keija

    Keija Erfahrener Benutzer

    Beiträge:
    171
    Erhaltene Danke:
    2
    Registriert seit:
    08.11.2009
    Hast du ihn zumbeispiel auf nem nicht abgeschirmten lautsprecher abgelegt? (Btw, nutzt kopfhoerer, um dem media und car modus zu aktivieren, dass erstaunt die leute ;) )
    Vielleich hab sich ja irgendein teil in deinem milestone magnetisiert ... aber kp welche teile dafuer dann verantwortlich sein koennten, oder ob ueberhaupt materialien im milestone sind, die sich so einfach permanent magnetisieren lassen
     
  5. Belsatzar, 13.01.2010 #5
    Belsatzar

    Belsatzar Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    15
    Registriert seit:
    02.01.2010
    ja, daran hab ich auch schon gedacht. das würde erklären warum er zwar noch magnetfelder wahrnimmt, aber trotzdem einen von der ausrichtung unabhängigen ausschlag anzeigt. aber das wäre doch ein bisschen seltsam, oder?
    also gibts keine möglichkeit die sensoren wirklich zu resetten?
     
  6. Syrabane, 13.01.2010 #6
    Syrabane

    Syrabane Android-Experte

    Beiträge:
    537
    Erhaltene Danke:
    103
    Registriert seit:
    30.11.2009
    Schau mal in den Market und lad dir die App "Compass" (von Snaptic). Da gibt es eine Kalibrierungsfunktion, wie sie Bausparfuchs mit seinem GPS beschrieben hat.
    Weiß zwar nicht, ob das hilft, aber einen Versuch ist es sicher wert.
     
    Zuletzt bearbeitet: 13.01.2010
  7. proandi, 13.01.2010 #7
    proandi

    proandi Android-Experte

    Beiträge:
    546
    Erhaltene Danke:
    89
    Registriert seit:
    13.12.2009
    Ist nicht arg. Hatte mein N97 eingeschickt und auch schon wieder bekommen. Für Motorola gilt zum Glück der selbe Vorgang: Serviceanzeige (pdf) ausfüllen, ausdrucken und mit Rechnung einschicken. Paketkosten bekommst du ersetzt.
     
  8. Belsatzar, 13.01.2010 #8
    Belsatzar

    Belsatzar Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    15
    Registriert seit:
    02.01.2010
    danke, ja, hab ich probiert...hat nix gebracht. :(

    ja aber wie lang dauert das? bin leider wirklich bereits ziemlich abhängig von den diversen funktionen, email, kalender etc...

    sonst halte ich mich an das... :)
     
  9. Belsatzar, 14.01.2010 #9
    Belsatzar

    Belsatzar Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    15
    Registriert seit:
    02.01.2010
    hat niemand eine idee für mich? :(

    krieg ich n ersatzgerät wenn ich das einschicke?

    soll ichs direkt an amazon schicken?
     
  10. derHaifisch, 14.01.2010 #10
    derHaifisch

    derHaifisch Android-Lexikon

    Beiträge:
    1,640
    Erhaltene Danke:
    254
    Registriert seit:
    09.12.2009
    Ich mein, dass Amazon auf der Seite stehen hat, dass Handies von bestimmten Herstellern direkt an den Hersteller geschickt werden sollen. Motorola fällt da auch mit drunter.
    Dennoch würde ich das darüber abwickeln, sofern das denn geht. Unter Mein Konto kann man sich ja die Bestellung suchen und "Artikel zurückschicken" anklicken.
    Kann aber dann sein, dass die nichts anderes machen, als das Handy weiter an Motorola schicken, sodass Du noch ein paar Tage länger auf ein neues Gerät warten musst.
    Ein Ersatzgerät ist nicht üblich.
     
  11. proandi, 14.01.2010 #11
    proandi

    proandi Android-Experte

    Beiträge:
    546
    Erhaltene Danke:
    89
    Registriert seit:
    13.12.2009
    w-support.com GmbH
    Niederfrohnaer Weg 2
    DE 09232 Hartmannsdorf
    ist das GSM ServiceCenter für Amazon.de und für folgende Hersteller: SonyEricsson, Nokia, LG, Samsung und Motorola :cool:

    Ich hatte mein N97 am 23.12 hingeschickt, am 29.12 wurde es repariert und am 4. oder 5.1 hatte ich es wieder. Wenn man die ganzen Feiertage in Betracht nimmt, war das recht schnell. Quasi 5 Arbeitstage. ;)

    Wie derHaifisch richtig bemerkt, läuft das recht easy via Button bei der entsprechen Bestellung auf der Amazon-Seite.
    Leider hat derHaifisch auch Recht, bezüglich Leihgerät :( - ist nicht üblich
     
  12. mawosch, 14.01.2010 #12
    mawosch

    mawosch Junior Mitglied

    Beiträge:
    34
    Erhaltene Danke:
    17
    Registriert seit:
    14.01.2010
    Hallo,

    ich habe zwar kein Problem mit einem verstimmten Magnetsensor sondern mit dem Magnetsensor an sich.

    Ich nutze eine Krusell Tasche, welche mit einem Magneten geschlossen wird. Dadurch schaltet sich das Display ab und zu an. Die Tastensperre funktioniert zwar, aber wenn man es aus der Tasche (Horizontaltasche) zieht, ist es erst mal auf Landscape Mode. Braucht erst bis es in Hochformat umschaltet.
    Das nervt. Und kostet sicher unnötig Akkuleistung.

    Gibt es eine Möglichkeit diesen Magnetsensor auszuschalten oder zu deaktivieren?

    Gruß
    Matthias
     
  13. Belsatzar, 14.01.2010 #13
    Belsatzar

    Belsatzar Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    15
    Registriert seit:
    02.01.2010
    derHaifisch, proandi, danke für die tips.
    ich hab jetz mal das telefon zurückgesetzt, zähneknirschend, und dann tricorder wieder installiert, und zuerst hat er auch wieder einen ausschlag angezeigt, viel stärker diesmal, und direkt nach rechts (also 3 uhr); dann, während das app lief, war er auf einmal weg, und kein ausschlag mehr da bis auf die standardmässigen normalen ausschläge. prompt auf kompass geschaltet, und, siehe da: auf einmal gehts wieder problemlos, als wäre nie etwas gewesen.

    freut mich natürlich, klar, aber jetzt: das kann doch nicht mit dem zurücksetzen zu tun haben, oder?
    klingt das nicht eher nach einer art wackelkontakt im sensor?
     
  14. Bausparfuchs, 14.01.2010 #14
    Bausparfuchs

    Bausparfuchs Erfahrener Benutzer

    Beiträge:
    189
    Erhaltene Danke:
    15
    Registriert seit:
    12.12.2009
    Du bist im Falschen Thread gelandet. Dein "Magnetsensor" wird ein Reedkontakt sein. Das Hat mit dem Hallsensor für den Kompass nix zu tun.
    Es gab hier neulich die gleiche Frage und wenn ich mich recht erinnere, war der Tenor, dass es nicht möglich ist (ohne root) dieses Dockingdisplay (denn was anderes meinst du doch bestimmt nicht, oder?) abzuschalten.
     
  15. phiberoptik, 14.01.2010 #15
    phiberoptik

    phiberoptik Junior Mitglied

    Beiträge:
    41
    Erhaltene Danke:
    0
    Registriert seit:
    02.12.2009
    Phone:
    Nexus One
    Ich hatte kürzlich ein ähnliches Problem. Nachdem das
    Teil 1/4 h in diesem Tischhalter (Multimedia-Irgendwas)
    lag ging der Kompass wieder. Sollte der Sensor wirklich
    hinüber sein dann hilft das allerdings vermutlich wenig.
     
  16. Fluck, 14.01.2010 #16
    Fluck

    Fluck Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    7
    Registriert seit:
    14.12.2009
    Phone:
    Motorola Milestone
    Falsch Falsch Falsch. Sowas macht man heutzutage (bzw früher bei V50 auch) alles mit Hallsensoren und Magneten. Damit umgeht man verschleiß durch vershchmutzte Kontakte
     
  17. mawosch, 07.02.2010 #17
    mawosch

    mawosch Junior Mitglied

    Beiträge:
    34
    Erhaltene Danke:
    17
    Registriert seit:
    14.01.2010
    So ich habe eine Lösung für das Problem mit Taschen welche magnetisch geschlossen werden.
    Bericht über DockBlocker auf meiner Webseite.
    Dock Blocker fürs Milestone bei Taschen mit Magnetverschluss

    Gruß
    Matthias
     

Diese Seite empfehlen