1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

MapView in meiner App funktioniert nicht, Google Maps nicht

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von HectorSavage, 14.09.2009.

  1. HectorSavage, 14.09.2009 #1
    HectorSavage

    HectorSavage Threadstarter Junior Mitglied

    Beiträge:
    37
    Erhaltene Danke:
    0
    Registriert seit:
    11.09.2009
    hallo,

    ich versuche seit geraumer Zeit eine MapView in meine App einzubauen. Leider funktioniert das nicht. Die vorinstallierte Google Maps App funktioniert aber einwandfrei.(Sowohl auf dem Avd Emulator als auch auf einem Samsung Galaxy tritt dieses Phänomen auf).

    Ich habe mir sowohl einen DebugKey über die Kommandozeile als auch den entsprechenden Fingerprint über die Google Seite erstellen lassen. Meine MapView funktioniert aber weder mit dem einen noch dem anderen Key.

    Die MapView möchte ich in meinem TabHost anzeigen lassen. Theoretisch funktioniert das, aber es wird dann nur ein graues Grid-Netz angezeigt.
    Woran könnte das liegen?
    Hier ist mein Code:
    XML-Datei:
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <RelativeLayout xmlns:android="http://schemas.android.com/apk/res/android"
                    android:id="@+id/mainlayout"
                    android:orientation="vertical"
                    android:layout_width="fill_parent"
                    android:layout_height="fill_parent" >
    
                    <com.google.android.maps.MapView
                        android:id="@+id/mapview"
                        android:layout_width="fill_parent"
                        android:layout_height="fill_parent"
                        android:clickable="true"
                        android:apiKey="mein_google_key"
                    />
    
                    <LinearLayout
                        android:id="@+id/zoomview"
                        android:layout_width="wrap_content"
                        android:layout_height="wrap_content"
                        android:layout_alignBottom="@id/mapview"
                        android:layout_centerHorizontal="true"
                    />
    
    </RelativeLayout>
    
    
    Manifest.xml:
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <manifest xmlns:android="http://schemas.android.com/apk/res/android"
          package="tab.tab"
          android:versionCode="1"
          android:versionName="1.0">
          
            <uses-permission android:name="android.permission.INTERNET"/>
            <uses-permission android:name="android.permission.ACCESS_FINE_LOCATION"/> 
          
        <application android:icon="@drawable/icon" android:label="@string/app_name">
            <uses-library android:name="com.google.android.maps"/>
            
            <activity android:name=".TabAct"
                      android:label="@string/app_name">
                <intent-filter>
                    <action android:name="android.intent.action.MAIN" />
                    <category android:name="android.intent.category.LAUNCHER"/>
                </intent-filter>
            </activity>
            
            <activity 
                android:name=".Map"
                android:label="@string/app_name">
            <intent-filter>
                <action android:name="android.intent.action.VIEW" />
                <category android:name="android.intent.category.EMBED" />
            </intent-filter>
            </activity>
            
        </application>
        <uses-sdk android:minSdkVersion="3" />
    </manifest> 
    
    
    theoretisch sollte es also funktionieren... ^^
     
  2. HectorSavage, 14.09.2009 #2
    HectorSavage

    HectorSavage Threadstarter Junior Mitglied

    Beiträge:
    37
    Erhaltene Danke:
    0
    Registriert seit:
    11.09.2009
    Hier noch ein kurzer Auszug der LogCat, nachdem ich die MapView aufgerufen habe.

    09-14 17:41:10.396: INFO/MapActivity(6984): Handling network change notification:CONNECTED

    darauf folgen einige unknownHosExceptions, bis ich die activity beende...:

    09-14 17:41:50.426: INFO/InetAddress(6984): Unknown host Google, throwing UnknownHostException
     
  3. goto, 14.09.2009 #3
    goto

    goto Android-Hilfe.de Mitglied

    Beiträge:
    91
    Erhaltene Danke:
    8
    Registriert seit:
    01.05.2009
    Ich glaube es liegt an einem falschen apiKey, hast du mal mit absicht einen falschen apiKey eingesetzt und geschaut ob du die gleiche Fehlermeldung bekommst?
    Eventuell hilft dir das: Obtaining a Maps API Key - Google Projects for Android
    Oder bist du schon nach der Anleitung vorgegangen?
     
    HectorSavage bedankt sich.
  4. HectorSavage, 15.09.2009 #4
    HectorSavage

    HectorSavage Threadstarter Junior Mitglied

    Beiträge:
    37
    Erhaltene Danke:
    0
    Registriert seit:
    11.09.2009
    Ok danke, ich habe mir aus meinem DebugKey mit einem anderen GoogleAccount einen anderen Schlüssel erstellt und der funktioniert jetzt. Danke!
     

Diese Seite empfehlen