1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

"Massenspeichermodus" in Ubuntu

Dieses Thema im Forum "Motorola Defy Forum" wurde erstellt von M1cha, 27.02.2011.

  1. M1cha, 27.02.2011 #1
    M1cha

    M1cha Threadstarter Android-Experte

    Beiträge:
    842
    Erhaltene Danke:
    178
    Registriert seit:
    13.01.2011
    Hi,

    ich versuche, das Handy im Massenspeichermodus an einen Ubuntu(10.10)-Rechner anzuschließen.
    Unter "Rechner" steht ein Laufwerk mit dem Namen "MB525" aber beim Doppelklick darauf passiert nichts.
    Die Laufwerksverwaltung zeigt das Gerät an, aber sagt, es wurde kein Speicher erkannt(wie wenn eine HDD keine Partitionen hat).

    Habt ihr schon Erfahrung damit gemacht?
    Gruß, M1cha
     
  2. BadRandolph, 27.02.2011 #2
    BadRandolph

    BadRandolph Fortgeschrittenes Mitglied

    Beiträge:
    359
    Erhaltene Danke:
    37
    Registriert seit:
    21.12.2010
    probiers gleich aus, hab mein netbook grade hochgefahren
     
  3. BadRandolph, 27.02.2011 #3
    BadRandolph

    BadRandolph Fortgeschrittenes Mitglied

    Beiträge:
    359
    Erhaltene Danke:
    37
    Registriert seit:
    21.12.2010
    Also: eig müsstest du es wie ein laufwerk einfach anschließen, dann kannst du darauf zugreifen wie auf eine festplatte etc.
    voraussetzung ist, du stellst das defy auch auf massenspeicher ein, wenn du das hast versuch mal beim defy die verbindungsart kurz zu wechseln, vllt tut sich dann was
     
  4. M1cha, 27.02.2011 #4
    M1cha

    M1cha Threadstarter Android-Experte

    Beiträge:
    842
    Erhaltene Danke:
    178
    Registriert seit:
    13.01.2011
    Habe ich alles schon probiert. Ich wundere mich, woher er überhaupt weiß, dass ein Handy angeschlossen ist, da ein Massenspeicher für ihnein USB-Stick ein müsste.
    Mein SatReciever erkennt den Speicher übrigens auch nicht.
     
  5. BadRandolph, 27.02.2011 #5
    BadRandolph

    BadRandolph Fortgeschrittenes Mitglied

    Beiträge:
    359
    Erhaltene Danke:
    37
    Registriert seit:
    21.12.2010
    welche firmware hast du drauf?
     
  6. mdefycp, 27.02.2011 #6
    mdefycp

    mdefycp Junior Mitglied

    Beiträge:
    38
    Erhaltene Danke:
    3
    Registriert seit:
    29.12.2010
    Hallo,

    verbinde das Handy nochmal neu mit den PC und poste dann mal die letzten 10 Zeilen von dmesg.

    Gruß
    Christian
     
  7. M1cha, 27.02.2011 #7
    M1cha

    M1cha Threadstarter Android-Experte

    Beiträge:
    842
    Erhaltene Danke:
    178
    Registriert seit:
    13.01.2011
    Code:
    [ 5194.543521] usb 2-1.3: new high speed USB device using ehci_hcd and address 12
    [ 5194.650218] scsi6 : usb-storage 2-1.3:1.0
    [ 5195.653515] scsi 6:0:0:0: Direct-Access     Motorola MB525            0001 PQ: 0 ANSI: 2
    [ 5195.654220] sd 6:0:0:0: Attached scsi generic sg2 type 0
    [ 5195.655841] sd 6:0:0:0: [sdc] Attached SCSI removable disk
    [ 5226.745457] usb 2-1.3: USB disconnect, address 12
    [ 5227.093965] usb 2-1.3: new high speed USB device using ehci_hcd and address 13
    [ 5227.324479] usbcore: registered new interface driver cdc_acm
    [ 5227.324482] cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters
    [ 5544.123188] usb 2-1.2: USB disconnect, address 10
    [ 5549.469589] usb 2-1.2: new low speed USB device using ehci_hcd and address 14
    [ 5549.595434] input: HID 04b4:0033 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/input/input14
    [ 5549.595547] generic-usb 0003:04B4:0033.0006: inpu
    
     
  8. BadRandolph, 27.02.2011 #8
    BadRandolph

    BadRandolph Fortgeschrittenes Mitglied

    Beiträge:
    359
    Erhaltene Danke:
    37
    Registriert seit:
    21.12.2010
    sorry, das übersteigt meine fähigkeiten.
     
  9. mdefycp, 27.02.2011 #9
    mdefycp

    mdefycp Junior Mitglied

    Beiträge:
    38
    Erhaltene Danke:
    3
    Registriert seit:
    29.12.2010
    So sieht es bei mir aus, wenn ich es auf Speicherkartenzugriff eingestellt habe.
    Code:
    [ 3168.060132] usb 1-2: new high speed USB device using ehci_hcd and address 2
    [ 3168.194515] scsi5 : usb-storage 1-2:1.0
    [ 3169.197970] scsi 5:0:0:0: Direct-Access     Motorola MB525            0001 PQ: 0 ANSI: 2
    [ 3169.201602] sd 5:0:0:0: Attached scsi generic sg2 type 0
    [ 3169.204447] sd 5:0:0:0: [sdc] 3842048 512-byte logical blocks: (1.96 GB/1.83 GiB)
    [ 3169.205306] sd 5:0:0:0: [sdc] Write Protect is off
    [ 3169.205311] sd 5:0:0:0: [sdc] Mode Sense: 03 00 00 00
    [ 3169.205315] sd 5:0:0:0: [sdc] Assuming drive cache: write through
    [ 3169.216687] sd 5:0:0:0: [sdc] Assuming drive cache: write through
    [ 3169.216702]  sdc: sdc1
    [ 3169.222809] sd 5:0:0:0: [sdc] Assuming drive cache: write through
    [ 3169.222815] sd 5:0:0:0: [sdc] Attached SCSI removable disk
    
    Habe alle Modi durchprobiert. Aber deine dmesg-Meldungen kann ich noch nicht nachvollziehen.

    Ich habe Kubuntu 10.10 am laufen...

    So wie es aussieht ist dein Defy irgendwie im Modem Modus, Kann es sein das du USB Tethering aktiviert hast?
    (Einstellungen -> Drathlos und Netzwerke -> Mobile Netzwerke -> Internet-Tethering)
     
    Zuletzt bearbeitet: 27.02.2011
  10. M1cha, 27.02.2011 #10
    M1cha

    M1cha Threadstarter Android-Experte

    Beiträge:
    842
    Erhaltene Danke:
    178
    Registriert seit:
    13.01.2011
    1) Habe die ROM von Pay drauf
    2) Tethering und USB-Debugging sind aus
    2) Der Log von grade war im falschen Modus, hier der richtige:
    Code:
    [ 6571.384362] usb 2-1.5: USB disconnect, address 18
    [ 6575.963328] usb 2-1.5: new high speed USB device using ehci_hcd and address 19
    [ 6576.072613] scsi11 : usb-storage 2-1.5:1.0
    [ 6577.072331] scsi 11:0:0:0: Direct-Access     Motorola MB525            0001 PQ: 0 ANSI: 2
    [ 6577.073102] sd 11:0:0:0: Attached scsi generic sg2 type 0
    [ 6577.076666] sd 11:0:0:0: [sdc] Attached SCSI removable disk
    
    Dennoch geht es nicht, auch als root, kann ich nicht drauf zugreifen.
    Es scheint wirklich so, als hätte die SD-Karte keine Partitionen, denn es existiert "/dev/sdc", aber kein "dev/sdc1". Gemountet wurde auch nichts.
     
  11. mdefycp, 27.02.2011 #11
    mdefycp

    mdefycp Junior Mitglied

    Beiträge:
    38
    Erhaltene Danke:
    3
    Registriert seit:
    29.12.2010
    Was sagt den cfdisk zu /dev/sdc?
     
  12. mdefycp, 27.02.2011 #12
    mdefycp

    mdefycp Junior Mitglied

    Beiträge:
    38
    Erhaltene Danke:
    3
    Registriert seit:
    29.12.2010
    Den letzten dmesg-Mitschnitt kann ich reproduzieren:
    Code:
    [ 4460.768119] usb 1-2: new high speed USB device using ehci_hcd and address 9
    [ 4460.902074] scsi11 : usb-storage 1-2:1.0
    [ 4461.902442] scsi 11:0:0:0: Direct-Access     Motorola MB525            0001 PQ: 0 ANSI: 2
    [ 4461.906014] sd 11:0:0:0: Attached scsi generic sg2 type 0
    [ 4461.913606] sd 11:0:0:0: [sdc] Attached SCSI removable disk
    
    Das ist der "Nur laden"-Modus. Hast du schonmal einen Reboot vom Defy gemacht?

    Ich habe noch die 2.51.1 drauf. Hatte überlegt die Finnland SBF zu flashen, aber wenn dann kein Massenspeichermodus mehr funktioniert muss ich mir das nochmal überlegen.
     
    M1cha bedankt sich.
  13. M1cha, 27.02.2011 #13
    M1cha

    M1cha Threadstarter Android-Experte

    Beiträge:
    842
    Erhaltene Danke:
    178
    Registriert seit:
    13.01.2011
    Code:
    FATALER FEHLER: Konnte nicht auf die Festplatte zugreifen
                       Eine Taste drücken, um cfdisk zu beenden
    Klingt ja sehr fatal^^

    Das hat doch tatsächlich geholfen. Ich habe das eigentlich ausgeschlossen, da ich erst kürzlich einen machte und seitdem nichts mehr gemacht habe - vor allem nicht mit Root-Rechten.

    Manchmal sind die einfachsten Lösungen doch die besten.
    Danke, M1cha
     

Diese Seite empfehlen