1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Memhack entfernen schlägt fehl

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von MarJu, 14.07.2010.

  1. MarJu, 14.07.2010 #1
    MarJu

    MarJu Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    416
    Erhaltene Danke:
    52
    Registriert seit:
    30.01.2010
    Phone:
    Samsung Galaxy S4
    Tablet:
    Nexus 7 (2013)
    Hallo zusammen,
    ich hab zwar die Suche bemüht aber nichts gefunden.
    Ich hab über die Open Recovery von Timeturn den Memhack installiert und wollte mal ausporbieren den Hack über die entfernen Option rückgängig zu machen.
    Wenn ich dann neustarte bekomme ich nach dem Entsperren aber nur unendlich viele FCs der Apps. Bin grad etwas ratlos.
    Habt ihr eine Lösung?
    Mfg
     
  2. meilstone, 15.07.2010 #2
    meilstone

    meilstone Erfahrener Benutzer

    Beiträge:
    212
    Erhaltene Danke:
    11
    Registriert seit:
    31.05.2010
    Phone:
    Nexus 5
    also wenn ich den memhack installier oder entferne krieg ich auch FCs ich klick die aber so lange durch bis die weg sind.
    oder du hast vieleicht beim übertaten was falsc gemacht mit der mot_boot_mode ist mir schonmal passiert. ich hab manuell übertaktet mit der anleitung aus dem forum und hab dann die Variante gewählt, die ohne memhack war, da ich uz der zeit keinen mmemhack brauchte. Dann hab ich mir dann ach einer weile seperat installiert und schwupps gab es das problem mit FCs die nicht enden.
    Ichmusste dann den overclock rückgängig machen-> die schritte rückwärts gehen. bis wieder normalzustand war. dann hab ich den memhack instlliert und danach seperat overclockt.
     
  3. MarJu, 15.07.2010 #3
    MarJu

    MarJu Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    416
    Erhaltene Danke:
    52
    Registriert seit:
    30.01.2010
    Phone:
    Samsung Galaxy S4
    Tablet:
    Nexus 7 (2013)
    Könnte sein. Ich hatte zuerst den Memhack. Als OC möglich war hab ich das manuell über änderung der mot_boot_mode gemacht. Danach dann über das OR Script.
    Ich entferne OC mal über das Timeturn OR Script und dann den Memhack. Mals sehen was dann passiert.
     
  4. MarJu, 15.07.2010 #4
    MarJu

    MarJu Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    416
    Erhaltene Danke:
    52
    Registriert seit:
    30.01.2010
    Phone:
    Samsung Galaxy S4
    Tablet:
    Nexus 7 (2013)
    Ne, das brachte auch nichts. Kann 30 minuten FCs wegklicken. Oder muß ich vorher irgendwas in der mot_boot_mode ändern?
    Will den Memhack zwar behalten, mache das nur aus Interesse ;-D
     
  5. eybee1970, 15.07.2010 #5
    eybee1970

    eybee1970 Android-Ikone

    Beiträge:
    5,390
    Erhaltene Danke:
    4,990
    Registriert seit:
    19.01.2010
    Phone:
    HTC One M9
    Nur so aus Neugierde :): warum willste denn memhack und OC entfernen? Nur mal so zum probieren od. gibts dafür handfeste Gründe?
     
  6. MarJu, 15.07.2010 #6
    MarJu

    MarJu Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    416
    Erhaltene Danke:
    52
    Registriert seit:
    30.01.2010
    Phone:
    Samsung Galaxy S4
    Tablet:
    Nexus 7 (2013)
    Ne, handfeste Gründe hab ich nicht. Hab seit einiger Zeit die OR drauf und da es dort die Option gibt, wollte ich es mal ausprobieren.
    Rumfummeln ftw... Dadurch lernt man ja wieder was dazu.
     
    eybee1970 bedankt sich.
  7. TimeTurn, 16.07.2010 #7
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,114
    Erhaltene Danke:
    2,895
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Probier mal den Dalvik-Cache zu löschen - der wird ja durch Memhack umgebogen. Entfernen von Memhack bedeutet einfach nur das löschen der Datei "/system/bin/mot_boot_mode.memh", der Rest bleibt wie er ist.
     
  8. MarJu, 16.07.2010 #8
    MarJu

    MarJu Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    416
    Erhaltene Danke:
    52
    Registriert seit:
    30.01.2010
    Phone:
    Samsung Galaxy S4
    Tablet:
    Nexus 7 (2013)
    So, hab mal die mot_boot_mode.memh gelöscht und gebootet. Danach kommen wieder unendlich viele Fcs. Hab die ne Weile weggeklickt, aber es kommen immer wieder welche (auch von den gleichen apps).

    Danach hab ich aus der OR den Dalvik-Cache gelöscht. Jetzt bootet des MS nicht mehr, bleibt allerdings nicht beim MOTO Logo, sondern beim Android-Logo hängen.

    edit: wenn ich dann noch den Cache lösche, bleibts beim Moto-Logo hängen :p
     
    Zuletzt bearbeitet: 16.07.2010
  9. TimeTurn, 16.07.2010 #9
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,114
    Erhaltene Danke:
    2,895
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Kann ich mir ehrlich keinen Vers drauf machen, denn Memhack wird so identisch von LMF und anderen Mods verwendet. Ist besagte mot_boot_mode.memh.

    Ich entferne Memhack bei mir auch gerade mal testweise... ist bei mir genau dasselbe wie bei Dir - immer nur FCs. Ich hab auch den Dalvik-Cache gelöscht, mag auch bei mir nicht... Auch memhack wieder installieren nebst Dalvik leeren und Cache leeren half nicht.

    Werde die Option zum deinstallieren wohl besser ausbauen, bis ich genau weis war um das nicht geht. Solang bleibt nur: memhack nicht deinstallieren.

    Das einzigste was den Stein wieder zum Leben erweckt ist leider ein kompletter Wipe oder einspielen eines Nandroids.
     
  10. MarJu, 16.07.2010 #10
    MarJu

    MarJu Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    416
    Erhaltene Danke:
    52
    Registriert seit:
    30.01.2010
    Phone:
    Samsung Galaxy S4
    Tablet:
    Nexus 7 (2013)
    Mh, okay. Dann hatte mein Versuch ja immerhin den positiven Effekt, dass du mitbekommen hast, dass da was nicht funktioniert.
     
  11. TimeTurn, 16.07.2010 #11
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,114
    Erhaltene Danke:
    2,895
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    yepp - werde das erstmal rausnehmen und eine Warnung bei der Installation einbauen, die darauf aufmerksam macht, das das ein One-Way-Ticket ist.
     
  12. -FuFu-, 16.07.2010 #12
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    also, wenn der memhack entfernt werden soll, reicht nicht alleine nur die mot_boot_mode.memh zu löschen...
    hier mal eine genaue anleitung, was noch gemacht werden muß und wie man es am besten macht:
    - zuerst in die Recovery booten und dann die OpenRecovery per "apply update.zip" starten
    - den Stein per USB mit dem PC verbinden
    - die ADB shell starten und die folgenden befehle eingeben:
    mount /system
    mount /data
    rm /system/bin/mot_boot_mode.61.memh
    (namen je nach dem anpassen)
    rm /data/dalvik-cache
    mkdir /data/dalvik-cache
    chmod 771 /data/dalvik-cache


    Dann rebooten und alles sollte so sein wie es muß... eventuell kann es noch nötig sein ein chown auf den ordner zu setzten, das wäre das der folgende befehl noch:
    chown 1000.1000 /data/dalvik-cache

     
    MarJu bedankt sich.
  13. MarJu, 16.07.2010 #13
    MarJu

    MarJu Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    416
    Erhaltene Danke:
    52
    Registriert seit:
    30.01.2010
    Phone:
    Samsung Galaxy S4
    Tablet:
    Nexus 7 (2013)
    Super. Das werd ich heute abend mal ausprobieren. Hab grad keine Zeit.
    Aber das könnte man ja auch in das Script einbauen, oder?
     
  14. -FuFu-, 16.07.2010 #14
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    also in meiner OR ist es im script genau so drin ;) und irgendwo hier im Forum fliegt noch nen anderes script von mir rum, welches nur den memhack installiert oder deinstalliert ;)

    es kann eben wie gesagt sein, das der chown befehl noch mit rein muß, hab das ganze nie wirklich getestet, da ich mein stein derzeit brauch und nicht rumtesten kann
     
  15. MarJu, 17.07.2010 #15
    MarJu

    MarJu Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    416
    Erhaltene Danke:
    52
    Registriert seit:
    30.01.2010
    Phone:
    Samsung Galaxy S4
    Tablet:
    Nexus 7 (2013)
    Danke Fufu, hab die Methode grad ausprobiert und es hat funktioniert. Auch ohne chwon. Allerdings hat das Booten ziemlich lang gedauert, Handy war ziemlich lange beim Android Logo. Aber jetzt weiß ich, wie ich im Falle eines Falles den Memhack wieder entfernen kann...

    edit: Kleine Zusatzinfo: Hab den mamhack dann wieder mit deinem OR Script installiert und wieder deinstalliert. Klappt problemlos.
     
    Zuletzt bearbeitet: 17.07.2010
  16. TimeTurn, 17.07.2010 #16
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,114
    Erhaltene Danke:
    2,895
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Hab inzwischen selbst eine funktionierende Lösung gefunden und ins Script eingebaut - habe es vorhin ausprobiert: Nach entfernen von Memhack fährt der Stein normal hoch ohne irgendwelche FCs :D

    Script uppe ich demnächst hier: http://www.android-hilfe.de/root-ha...meturn-milestone-mod-script-openrecovery.html

    Oder (einfacher zu merken: chown system.system) :D

    Hab irgendwie den Teil überlesen beim basteln :D - kein wunder das das nich ging. Naja nu geht es ja :D
     
    Zuletzt bearbeitet: 17.07.2010
  17. -FuFu-, 17.07.2010 #17
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    teste mal chown system.system in der recovery ;) irgendwie will er da immer die zahlen haben :D und sicher ist sicher ^^
     
  18. TimeTurn, 17.07.2010 #18
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,114
    Erhaltene Danke:
    2,895
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Im ADBrecovery hab ich schon lange nicht mehr was getippt, daher hab ich das nicht mitbekommen :eek:
     
  19. redlabour, 22.07.2010 #19
    redlabour

    redlabour Android-Hilfe.de Mitglied

    Beiträge:
    146
    Erhaltene Danke:
    5
    Registriert seit:
    27.07.2009
    Phone:
    Sony Xperia Z
    Tablet:
    Sony Xperia Tablet Z2
    chown 1000.1000 /data/dalvik-cache = No such User 1000

    :cool:
     
  20. -FuFu-, 22.07.2010 #20
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    tja, also in der OpenRecovery geht 1000.1000 ;)
    ansonsten gibt es noch die möglichkeit system.system zu nutzen...
     

Diese Seite empfehlen