1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Merkwürdiges GPS Problem - CM 7.2 RC2

Dieses Thema im Forum "Custom-ROMs für Motorola Defy" wurde erstellt von Boostar, 16.05.2012.

  1. Boostar, 16.05.2012 #1
    Boostar

    Boostar Threadstarter Android-Experte

    Beiträge:
    530
    Erhaltene Danke:
    99
    Registriert seit:
    06.05.2012
    Phone:
    Sony Xperia Acro S
    Hallo!

    ich habe mit meinem Defy eigentlich schon immer mehr oder weniger große Schwierigkeiten mit der Positionsbestimmung. Ich nutze es im Auto als Navi mit Navigon. Das hatte ich mir gekauft, weil unter Froyo die Google Navigation eigentlich gar nicht funktioniert hat.

    Wie gesagt, unter Froyo hatte ich ständig Ortungen neben der Straße oder auf einer Parallelstraße, so dass dann öfter mal auf der Autobahn "Bitte wenden", oder "jetzt rechts abbiegen" kam.. Irgendwann bin ich dann auf CM 7.1 gegangen.. Da ging es dann - meistens zumindest.

    Jetzt bin ich auf CM 7.2 RC2 und habe seit länger Zeit mal wieder navigieren wollen, eine echte Katastrophe. Auf einer Strecke von 3,5 km kam das 5 Mal vor (bin grad losgefahren und habs nochmal ausprobiert, nachdem ich verschiedenes versucht habe, was alles nichts ändert). Richtig schlimm wirds, wenn man mal nicht so fährt, wie es das Navi gerne hätte, dann passiert erst gar nichts, dannach wird man dann schon fast in einem anderen Stadteil positioniert.. Bei der Google Navigation ist es übrigens noch besser: Im Stand bekomme ich GPS Fix, Route wird berechnet, sobald ich mich bewege fängt das GPS Logo oben an zu blinken, GPS ist weg bis ich das nächste mal anhalte. Dann gibts wieder einen Fix, wenn ich Glück habe.

    Jetzt ist mir gerade etwas wirklich merkwürdiges aufgefallen. Wenn ich GPS Status im Vordergrund laufen habe, dann zeigt mir das ständig eine Genauigkeit von 4-9 Metern an. Sollange das läuft machen auch beide Navi Programme ihren Job ausgezeichnet. Zumindest stimmt das, was die Sprachausgabe von sich gibt zu 100%. Sobald ich wieder das Navi nach vorne hole fängt bei der Google Navigation das GPS Symbol in der Statusleiste das blinken an und Navigon spinnt.

    Es ist also definitiv kein Hardwareproblem. Ich hatte schon überlegt, mir eine externe Bluetoothmaus zu besorgen, aber die Genauigkeit, die ich mit GPS Status bekomme sollte ja für Navigation dicke ausreichen. Es muss also ein Softwareproblem sein. Evtl. gibt es das seit CM 7.2, da ich mir da aber nicht sicher bin, weil ich Google Maps extra zum Testen geladen hab, und Navigon auch mit CM 7.1 gelegentlich (aber sehr viel seltener) Probleme gemacht hab möchte ich erstmal keinen Bugreport einreichen.

    Hat hier jemand einen Lösungsansatz? Ich habe bereits einiges versucht, im XDA Forum gibt es lokal abgestimmte Configdateien, die hatte ich bei 7.1 drauf, bringen hier aber nichts. Genausowenig wie das Tool Faster Fix.
     
  2. renegat51, 17.05.2012 #2
    renegat51

    renegat51 Android-Hilfe.de Mitglied

    Beiträge:
    122
    Erhaltene Danke:
    8
    Registriert seit:
    09.05.2010
    Nun hat man dich wegen deiner custom Rom hierhergeschoben, aber ich denke daß es daran nicht liegt.

    Ich hatte bis vor kurzem ein Huawei X3 in Gebrauch, bei dem die GPS Probleme ständig zunahmen, egal ob mit Stock- oder custom Rom. Ich hatte auch diverse Tools ausprobiert ohne duchschlagenden Erfolg. Mal fand das Teil ein paar Satelliten, mal überhaupt keine mehr und auch wenn es eine Position mal hatte, verlor es sie ständig wieder.

    Das X3 hat jetzt meine Frau, für das Auto hat sie ein richtiges Navi, und ich habe jetzt mein altes Defy wieder, welches mit der Stockrom aber auch keine Position finden wollte. Daraufhin habe ich mal die CM 7.2 draufgemacht und schon war nach einer halben Minute ein Fix da. Ich werde die Sache jetzt mal weiter beobachten.

    Ob das Android Probleme sind oder die Empfangseigenschaften unserer Smartphones so grottig sind, daß die Soft schnell an ihre Grenzen kommt, kann ich auch nicht sagen. Bei meinen Hand GPS kenne ich sowas jedenfalls nicht.

    Gruß Hans
     
  3. Boostar, 17.05.2012 #3
    Boostar

    Boostar Threadstarter Android-Experte

    Beiträge:
    530
    Erhaltene Danke:
    99
    Registriert seit:
    06.05.2012
    Phone:
    Sony Xperia Acro S
    Nachdem mein Problem ja nicht allzuoft vorzukommen scheint werde ich mal einen Full Wipe versuchen, wollte ich eh seit längerem mal machen, weil man als Neuling, der ich war (und in manchen Sachen auch immernoch bin ^^), ja doch ganz schön viel am System rumspielt. Ich werde berichten.
     
  4. Jannek, 17.05.2012 #4
    Jannek

    Jannek Erfahrener Benutzer

    Beiträge:
    237
    Erhaltene Danke:
    25
    Registriert seit:
    07.01.2011
    Phone:
    HTC One X
    Ich denke ein Full Wipe ist eine gute Idee. Bei mir läuft die Navigation unter CM7.2 fehlerfrei. Wenn der Wipe nichts bringt würde ich vermuten, dass es ein Hardware defekt ist.
     
  5. Boostar, 17.05.2012 #5
    Boostar

    Boostar Threadstarter Android-Experte

    Beiträge:
    530
    Erhaltene Danke:
    99
    Registriert seit:
    06.05.2012
    Phone:
    Sony Xperia Acro S
    Also der Fullwipe hat nur bedingt etwas gebracht. Auf gerader Strecke hatte ich jetzt keine Aussetzer mehr, beim Abbiegen dann aber doch.
    Navigon läuft übrigens nicht nur gut, wenn GPS Status im Vordergrund läuft, sondern allgemein, wenn Navigon im Hintergrund läuft. Das bringt mich zu der Vermutung, dass das Defy mit seiner Rechenleistung an seine Grenzen stößt. Man merkt z.B. beim Abbiegen auch, dass die Kartenansicht "lagt" und dann kann es eben passieren, das man auf einer Parallelstraße geortet wird. Aber was man so liest läuft es auf langsameren Geräten auch vernünftig..
    An einen Hardwaredefekt glaube ich übrigens nicht. GPS Status zeit stabil eine Verbindung zu mindestens 4 Satelliten, Genauigkeit wie gesagt bei 4-9 Meter, was für ein Smartphone eigentlich recht ordentlich ist.

    Edit: Vielleicht liegt das Problem ja wo ganz anders. Womöglich verbrät irgendwas CPU, sobald das Telefon aktiv ist. Ich habe nach dem Fullwipe natürlich zumindest einen Teil meiner Anwendungen aus dem Titaniumbackup wieder hergestellt. In den Akkustatistiken und in Spare Parts ist aber nichts auffälliges zu sehen. Ich habe jetzt erstmal den AVG Virenscanner deinstalliert.
     
    Zuletzt bearbeitet: 17.05.2012
  6. Dirk64, 17.05.2012 #6
    Dirk64

    Dirk64 Android-Ikone

    Beiträge:
    4,457
    Erhaltene Danke:
    3,035
    Registriert seit:
    27.04.2011
  7. Boostar, 17.05.2012 #7
    Boostar

    Boostar Threadstarter Android-Experte

    Beiträge:
    530
    Erhaltene Danke:
    99
    Registriert seit:
    06.05.2012
    Phone:
    Sony Xperia Acro S
    Danke für den Tipp. Ich kenn das Problem auch noch von Froyo her, das was ich jetzt mit cm7 habe ist mit Sicherheit was anderes...
     
  8. Dirk64, 17.05.2012 #8
    Dirk64

    Dirk64 Android-Ikone

    Beiträge:
    4,457
    Erhaltene Danke:
    3,035
    Registriert seit:
    27.04.2011
    Probier mal eine Nightly von maniac103 aus. Die offizielle 7.2 hat auf meinem Defy keine Stunde überlebt.

    Sent from my Defy...
     
  9. Boostar, 18.05.2012 #9
    Boostar

    Boostar Threadstarter Android-Experte

    Beiträge:
    530
    Erhaltene Danke:
    99
    Registriert seit:
    06.05.2012
    Phone:
    Sony Xperia Acro S
    Ich glaube, ich habe das Problem gefunden: Ich hab ein Autoradio mit Bluetooth und das Defy natürlich damit gekoppelt. Vorhin hab ich nochmal etwas rumprobiert - Navigon hat gezickt, google navigation ging wieder gar nicht, also hab ich überlegt, was noch Rechenzeit beanspruchen könnte und habe den Musikplayer sowie Bluetooth ausgemacht - danach ging es wesentlich besser. Muss mal ausprobieren, wie es geht, wenn ich das Defy via Kabel ans Radio anschliesse.
    Wäre aber gut möglich, dass das den Unterschied zu CM 7.1 macht, seitdem wurde an den Bluetoothprofilen ja noch etwas geschraubt. Hab mich schon gefreut, dass mein Autoradio jetzt auch immer den aktuellen Titel anzeigt...
     
  10. gedhe, 21.05.2012 #10
    gedhe

    gedhe Moderator Team-Mitglied

    Beiträge:
    746
    Erhaltene Danke:
    254
    Registriert seit:
    18.08.2011
    Phone:
    Samsung S7
    Also ich hatte bisher weder unter 7.1 noch unter 7.2 Probleme mit GPS.
    Was allerdings bis zur letzten Nightly noch derbe Faxen gemacht hat, war Navigon. Unter 7.1 hatte ich nur FCs und seit der letzten Nightly von Maniac läuft es sowas von rund und GPS-Fix habe ich innerhalb von max. 50 Sekunden!

    Was Du noch versuchen kannst, ist über Einstellungen->CyanogenMod->Leistung->Größe VM-Heap dort die Größe etwas anzuheben. Für die Navigation sollten es schon 32MB sein.

    Rein haun,
    David
     
  11. Boostar, 21.05.2012 #11
    Boostar

    Boostar Threadstarter Android-Experte

    Beiträge:
    530
    Erhaltene Danke:
    99
    Registriert seit:
    06.05.2012
    Phone:
    Sony Xperia Acro S
    Hey,

    VM-Heap hatte ich auch schon im Verdacht, der ist bei CM 7.2 allerdings von Haus aus auf 48 MB. Das ganze scheint übrigens ziemlich von der "Tagesform" abzuhängen. Heute liefs trotz Bluetooth und Musikplayer vergleichsweise gut.. Nur beim Warten an der Ampel ists mal weggesprungen..

    Ich habe mir mal einen Bluetooth GPS Empfänger (Jentro BT-GPS-8, soll recht gut sein) in der Bucht geschossen. Wenns damit auch haken sollte, kann ich zumindest den GPS Empfang ausschliessen, dann probier ich mal die Nightly..

    OT: Wisst ihr, ob manicas Arbeit mit in die offizielle CM einfliesst, oder machen das nur Eppy und Quarx? Hab mich bisher immer etwas davor gescheut, Nightlies auszuprobieren, weswegen ich gerne auf die Final von 7.2 warten würde..
     
  12. maniac103, 21.05.2012 #12
    maniac103

    maniac103 Android-Lexikon

    Beiträge:
    1,237
    Erhaltene Danke:
    1,157
    Registriert seit:
    24.01.2011
    Ja sicher - von uns dreien bin ich glaub ich derjenige, der am aktivsten an den offiziellen Builds mitarbeitet. Quarx reicht so gut wie gar nix ein, das machen ich und Epsylon3.

    Da wirst du - abgesehen vom Namen - keine großen Unterschiede finden. In CM7 tut sich nicht mehr viel.


    Gesendet von meinem MB525 mit Tapatalk 2
     
    gedhe und Boostar haben sich bedankt.
  13. Boostar, 21.05.2012 #13
    Boostar

    Boostar Threadstarter Android-Experte

    Beiträge:
    530
    Erhaltene Danke:
    99
    Registriert seit:
    06.05.2012
    Phone:
    Sony Xperia Acro S
    Bevor ich wieder mit dem Auto los musste hab ich noch fix die aktuelle offizielle Nightly vom 20. geflashed und tatsächlich, keine Sprünge und Hänger mehr mit Navigon. Danke, maniac ;-)

    PS: was mach ich jetzt mit dem GPS Empfänger, der in den nächsten Tagen kommt? ;-)

    Gesendet von meinem MB525 mit der Android-Hilfe.de App
     
  14. gedhe, 21.05.2012 #14
    gedhe

    gedhe Moderator Team-Mitglied

    Beiträge:
    746
    Erhaltene Danke:
    254
    Registriert seit:
    18.08.2011
    Phone:
    Samsung S7
    Sach ich doch!
     
  15. Boostar, 25.05.2012 #15
    Boostar

    Boostar Threadstarter Android-Experte

    Beiträge:
    530
    Erhaltene Danke:
    99
    Registriert seit:
    06.05.2012
    Phone:
    Sony Xperia Acro S
    So, der Jentro GPS Emfpänger kam heute. Ich werde den zur Navigation doch benutzen. Bekomme damit im Haus eine Peilung auf 10m genau, wo der Defy Emfpänger gar keinen Fix bekommt. Auch wenn Navigon mit Maniacs aktueller Nightly wesentlich besser läuft, hab ich doch immer mal wieder (wenn auch viel seltener) falsche Ortungen mit dem eingebauten GPS. Vielleicht hat die Antenne nen Hau weg, keine Ahnung.
     

Diese Seite empfehlen