1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Milestone neustart dauert ewig / Widgets hängen sich auf / Apps gehen nicht

Dieses Thema im Forum "Motorola Milestone Forum" wurde erstellt von loveboatcaptain, 05.01.2010.

  1. loveboatcaptain, 05.01.2010 #1
    loveboatcaptain

    loveboatcaptain Threadstarter Android-Experte

    Beiträge:
    599
    Erhaltene Danke:
    621
    Registriert seit:
    23.12.2009
    Phone:
    HTC Desire S
    Hallo ihr,

    ich habe gerade folgendes problem festgestellt und nach einigen suchversuchen hier im forum, die leider keine passende ergebnisse brachten, bitte ich euch nun direkt um hilfe.

    falls dieses thema doch schon existiert bitte mal hier verlinken oder verschieben.

    es geht um folgendes:

    wenn ich das milestone neu starte, also komplett ausmache, warte und dann wieder einschalte, dann dauert der neustart echt ewig lange.

    in vielen widgets steht nur "loading". ich benutze die curvefish widgets zum toggeln der ganzen funktionen, ein retro clock/date widget und das neue news und wetter widget vom nexus one.

    man kann da echt nix machen.... selbst mit geduld kommt man nicht weiter. habs mal einfach ne viertel stunde liegen lassen und hab gedacht es wird sich schon einkriegen, aber selbst nach der zeit wahren noch 50% der widgets nicht geladen und irgendwelche apps sprechen nicht mehr an, also starten nicht.

    ich benutze im hintergrund ein auto-task-killer, der bei ausgeschaltetem display die hintergrundprozesse killt. diesen habe ich zum testen an und ausgeschalten, mit gleichem ergebnis. also immernoch hängt alles. mit dem "ES-task-manager" das gleiche ergebnis.

    manchmal hilft das gut, da das milestone ja beim booten standartmäßig ersteinmal alle apps im hintergrund startet, sowie netzwerk- und googledienste startet. das kann man ja bekanntlich nicht abschalten.

    meine vermutung geht in die richtung, dass der arbeitsspeicher einfach randvoll ist beim booten und der neustart von apps einfach nich geht, weil kein speicher mehr zur verfügung steht. so wars jedenfalls noch damals zu MS-DOS zeiten, wenn der arbeitsspeicher voll war ging halt nix mehr und die speicherverwaltung damals war ja auch noch nich so prall wie heutzutage.

    ist das ein gängiges android problem? ich kenne mich da noch nicht so genau aus, wie da alles genau abläuft. aber das OS rühmt sich ja damit das alles im hintergrund weiterläuft um schnelleren zugang zu programmen und diensten zu erlangen.

    es ist jedenfalls ziemlich nerfig, wenn das phone doch mal ausgeht mangels akkupower oder man es wirklich mal neu booten muss.

    es hat fast ne halbe stunde gedauert bis sich alles eingekriegt hat.
    mußte ein paar widgets neu auf dem HS legen bzw. im menü mal wlan und bluetooth an und aus zu machen um alles in ruhe wieder nutzen zu können.

    einzig das batterie widget von curvefish ließ sich nur durch neu anlegen auf dem HS zu einer anderen anzeige als "loading" bewegen. die toggel-switches sprangen dann doch nach manuellen einstellungen im menü an.

    muss ich mir jetzt nen zettel schreiben, was ich in welcher reinfolge machen muss nach nem neustart? liegt es nur an den widgets (obwohl teilweise verschiedene hersteller im spiel sind)? oder ist das android OS nicht das beste um ständig neu gebootet zu werden?

    bin für jeden hinweis/tipp von euch dankbar. oder ihr sagt mir bei euch is alles ok, dann hab ich doch wieder nen faules ei erwischt. is nämlich schon das 2. milestone... das erste hatte den viel diskutierten "gesprächsbug" . mit dem 2. kann man endlich sorgenfrei telefonieren.... es wäre sau ärgerlich, wenn es auch diesmal wieder ein geräteproblem ist.

    denke aber eher das es an der software liegt, oder der menge der widgets/programme die auf dem HS liegen. denn wenn ich alles deinstalliere startet das milestone völlig normal. aber sinn und zweck der 3 homescreens ist ja die vollzupacken, oder? :p

    gruß

    der stephan
     
  2. futschi28, 05.01.2010 #2
    futschi28

    futschi28 Android-Hilfe.de Mitglied

    Beiträge:
    48
    Erhaltene Danke:
    5
    Registriert seit:
    30.12.2009
    Phone:
    Nexus One
    Hatte ich heute morgen auch zwar hat es nicht so lange gedauert bis alles wieder funktionierte aber es hat extrem genervt. Woran es lag kann ich noch nicht sagen aber die anfängliche Begeisterung lässt leider mehr und mehr nach :-(
     
  3. SirOfDefault, 05.01.2010 #3
    SirOfDefault

    SirOfDefault Android-Hilfe.de Mitglied

    Beiträge:
    76
    Erhaltene Danke:
    8
    Registriert seit:
    19.12.2009
    Phone:
    Motorola Milestone
    habt ihr rein zufälligerweise vorher noch software geupdatet???
     
  4. loveboatcaptain, 05.01.2010 #4
    loveboatcaptain

    loveboatcaptain Threadstarter Android-Experte

    Beiträge:
    599
    Erhaltene Danke:
    621
    Registriert seit:
    23.12.2009
    Phone:
    HTC Desire S
    also heute und gestern gab es keine updates für meine apps

    vielleicht stelle ich auch echt viel zu hohe ansprüche an den stein... aber ein vernünftigen bootvorgang bei nutzung aller funktionen + ein paar apps sollte echt drin sein.

    langsam vergeht mir auch mit dem stein... was ich für zeit verbraten habe in den letzen wochen um mich mit support von moto, o2 und sonstwem auseinanderzusetzen, geht echt auf keine kuhhaut :-(

    aber wie gesagt... fehlerhafte apps schließe ich einfach mal aus, weil das vorher eigentlich vernünftig funktioniert hat.

    auf meinem galaxy habe ich die gleichen apps (ausnahme das nexus one wetter/news widget) drauf und da funzt der bootvorgang ohne probleme
     
  5. taho, 05.01.2010 #5
    taho

    taho Erfahrener Benutzer

    Beiträge:
    231
    Erhaltene Danke:
    24
    Registriert seit:
    09.11.2009
    Hatte die selben Probleme. Nach dem killen des Phone Portals funzt wieder alles wie gewohnt.
     
  6. loveboatcaptain, 05.01.2010 #6
    loveboatcaptain

    loveboatcaptain Threadstarter Android-Experte

    Beiträge:
    599
    Erhaltene Danke:
    621
    Registriert seit:
    23.12.2009
    Phone:
    HTC Desire S
    thx @taho

    rein subjektiv ging es etwas schneller.. aber die curvefish toggles glänzen trotzdem nur mit der info "loading".

    es sind vor allem die toggles für wifi, bluetooth und gps.

    ich hab jetzt mal wieder das tolle "onboard" widget von 2.0 drauf gemacht und nutze nur die 4 toggles von curvefish die das android widget nicht beinhaltet.

    aber das killen des phone portal - tasks hat glaub ich nix gebracht. nur rein subjektiv... einzige änderung ist, dass das baterie widget von curve ohne neues einrichten auf dem HS angesprungen ist.

    update:

    mal ganz ohne curvefish toggles gestartet... null probleme

    sehr schade, aber es liegt vielleicht doch an den widgets. die passen so gut zu dem 2.1 style des wetter/news widgets von nexus one und den retro clock/date widgets. verdammt...

    weiß jemand ob man das toggle widget vom nexus one aufs milestone bekommt? das ist nämlich schwarz und nicht weiß und passt irgendwie besser zum edlen loock des steins.
     
    Zuletzt bearbeitet: 05.01.2010
  7. chrissi77, 06.01.2010 #7
    chrissi77

    chrissi77 Android-Lexikon

    Beiträge:
    1,898
    Erhaltene Danke:
    181
    Registriert seit:
    27.11.2009
    Phone:
    Samsung Galaxy S7 Edge Black
    Was meinst du mit curvefish toggles?
     
  8. loveboatcaptain, 06.01.2010 #8
    loveboatcaptain

    loveboatcaptain Threadstarter Android-Experte

    Beiträge:
    599
    Erhaltene Danke:
    621
    Registriert seit:
    23.12.2009
    Phone:
    HTC Desire S
    ich mein die apps von curvefish.

    das sind widgets mit denen man alle möglichen sachen an und aus machen kann, wie wifi, bluetooth, gps, 2g/3g, silent/vibration, rotation, lockscreen usw
     
  9. justanewbienick, 06.01.2010 #9
    justanewbienick

    justanewbienick Android-Hilfe.de Mitglied

    Beiträge:
    126
    Erhaltene Danke:
    6
    Registriert seit:
    19.11.2009
    Ich verstehe deine Einstellung nicht gegenüber dem Stein, um ehrlich zu sein.

    Das Ding ist kein Handy mehr zum telefonieren, sondern ist nichts anderes als ein Desktoprechner, der eben nebenbei eine Telefonfunktion beinhaltet.
    Wenn ich ein Problem damit habe, dann bleibt mir kaum etwas anderes übrig als auf Werkszustand zurück zu setzen, und sehen ob es immernoch besteht, mein Stein lief im AUslieferungszustand tadellos!

    Wenn sich dann im Verlauf des gebrauchs durch Apps oder WIdgets (Taskkiller stehen hier ganz oben auf der Liste) etwas ins negative dreht, dann ist doch nicht Motorola oder o2 schuld? Bei windows ist doch auch nicht Dell (als PC hersteller) dafür schuld, wenn ein Programm von irgendwem schlecht programmiert wurde.

    Die Menge an Apps ist ein segen, so lange sie funktionieren, aber es bleibt dabei: viele sind sträflich programmiert, schlecht in der performence und machen das ganze system instabil.

    Wie gesagt: das ist kein Problem von Motorola, sondern eines derer, die die Software schreiben!
     
  10. loveboatcaptain, 06.01.2010 #10
    loveboatcaptain

    loveboatcaptain Threadstarter Android-Experte

    Beiträge:
    599
    Erhaltene Danke:
    621
    Registriert seit:
    23.12.2009
    Phone:
    HTC Desire S
    wenn du meine erfahrungen durchgemacht hättest würdest du meine einstellung verstehen.

    lies einfach mal hier im forum meine anderen posts.

    momentan weiß ich echt nicht mehr was ein softwarebug von apps sein könnte oder ein fehler im androidsystem oder in der moto-firmware.

    ich bin intelligent genug zu wissen das es meißtens an den apps selbst liegt, aber was ich hier im forum schon übers milestone gelesen hab macht mich einfach verrückt, wenn ma lwas nich richtig läuft.

    jedenfalls konnte ich das problem lösen

    also bitte /closed draus machen bevor hier wieder leute anfangen sich mit "steinen" zu bewerfen

    gruß
    stephan
     
  11. klosmasse, 06.01.2010 #11
    klosmasse

    klosmasse Android-Experte

    Beiträge:
    540
    Erhaltene Danke:
    79
    Registriert seit:
    03.01.2010
    Phone:
    iPhone 6Plus

    Der größte Fehler fuer ein System sitzt immer vorm Geraet selbst!

    Das ist hier auch ne Hilfeseite, wo dir geholfen werden soll. Wenn du ne "Lobseite" aufmachst, dann wuerden dort mehr Posts stehen ;)
     
  12. garak, 06.01.2010 #12
    garak

    garak Ehrenmitglied

    Beiträge:
    8,270
    Erhaltene Danke:
    4,795
    Registriert seit:
    12.12.2009
    Und woran lag's?
     
  13. loveboatcaptain, 19.01.2010 #13
    loveboatcaptain

    loveboatcaptain Threadstarter Android-Experte

    Beiträge:
    599
    Erhaltene Danke:
    621
    Registriert seit:
    23.12.2009
    Phone:
    HTC Desire S
    es liegt wohl an dem news und wetter widget vom nexus one glaube ich...

    wenn ich das widget entfernt habe startet das milestone etwas schneller, aber ich glaube die toggles von curvefish hängen sich beim neustart immer mal wieder auf...

    ich muss immer das bluetooth und den autosync widget neu auf dem HS ablegen und einmal mit nem task killer nach dem booten alle tasks killen um überhaupt eine app zu starten...

    komplizierte lösung, aber es geht so wenigstens

    gruß
     
  14. relaxo, 19.01.2010 #14
    relaxo

    relaxo Erfahrener Benutzer

    Beiträge:
    151
    Erhaltene Danke:
    11
    Registriert seit:
    03.12.2009
    ich hatte ein ähnliches verhalten als ich den home++ HS genutzt hab, mit panda oder android-standard zum glück nicht mehr vorhanden.
     
  15. psychoxl, 19.01.2010 #15
    psychoxl

    psychoxl Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    0
    Registriert seit:
    19.01.2010
    Phone:
    Motorola Milestone
    Kenn ich irgendwoher...

    Als ich meinen Stein neu hatte lief alles super, hab dann verschiedenste home apps getestet und diverse Tools und noch dies und das. Schleichend wurde das ganze immer langsamer, irgendwann dauerte das booten ewig und ein 'force close' nach dem anderen. Nach 4 Minuten booten musste ich dann erst einmal alle apps abschießen damits wieder lief. 3x Neustarten am Tag normal. :mad:

    Naja dann hab ich mal n Hardwarreset gemacht und nur die apps installiert die auch was taugen. Seitdem keinerlei Probleme mehr und ich hab sicher inzwischen wieder um die 40 Apps drauf incl. den Spielereien vom Nexus und Home++.

    Am Ende wars doch nur ne Kombination aus schlecht programmierten 'Systemtools' und ich denke die vorinstallierten Motorola Apps machen da keine Ausnahme. ( Typisch Moto - Gute Hardware - schreckliche Software )

    Probiers doch mal mit nem Hardreset und nur die wichtigen Apps neu drauf. Ich bin seitdem wieder absolut glücklich mit dem Stein. Keine Lags, (fast) keine Force Closes und die Apps von 2.1 sehen echt schick aus. :cool:
     
  16. gergab, 19.01.2010 #16
    gergab

    gergab Android-Hilfe.de Mitglied

    Beiträge:
    77
    Erhaltene Danke:
    5
    Registriert seit:
    31.12.2009
    Ich bin mir dessen bewusst, dass hier schon einige Diskussionen über den Sinn von Taskmanagern laufen, aber:
    meine Erfahrung ist, dass seit ich die Prozessverwaltung Android überlasse und auch nicht die Mediengalerie und die Galerie (aus 2.1?) gleichzeitig installiert habe, mein Steinchen wirklich bestens läuft.
    Auch home++ läuft übrigens ohne Probleme, das hatte ich immer in Verdacht!

    Ist für Euch vielleicht einen Versuch wert!

    Good luck, gergab
     
  17. moppelg, 20.01.2010 #17
    moppelg

    moppelg Android-Experte

    Beiträge:
    751
    Erhaltene Danke:
    155
    Registriert seit:
    24.11.2009
    Wenn's mit den Apps und Widget hängts, einfach mal mit nem Taskmanger alle Programme schließen. Dann tauchen die auch wieder auf.
    Ist nur ne Notlösung, werde meine Stein reseten nachdem ich es gerootet, bzw. geupdatet habe.
     
  18. Archer, 20.01.2010 #18
    Archer

    Archer Android-Experte

    Beiträge:
    450
    Erhaltene Danke:
    81
    Registriert seit:
    17.07.2009
    Für die halbwegs Linux-kundigen: adb shell top und adb logcat helfen auch ungemein ;)
     
  19. Compufreak, 20.01.2010 #19
    Compufreak

    Compufreak Android-Experte

    Beiträge:
    464
    Erhaltene Danke:
    59
    Registriert seit:
    11.07.2009
    Phone:
    Motorola Milestone
    Direkt am Device geht's mit dem Programm "aLogcat" ;)
     

Diese Seite empfehlen