1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

mount SDCard?

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von n4rrOx, 27.06.2010.

  1. n4rrOx, 27.06.2010 #1
    n4rrOx

    n4rrOx Threadstarter Junior Mitglied

    Beiträge:
    43
    Erhaltene Danke:
    7
    Registriert seit:
    13.04.2010
    Hi zusammen,

    hab neuerdings folgendes Problem:
    Meine 8GB SD Karte wird beim Start nichtmehr gemountet. K.A. wieso.
    Zudem hab ich beim Start ebenfalls reboots...d.h. wenn er die 2 Bootlogos angezeigt hat springt er wieder zurück zum zweiten bootscreen...wenn die PIN Eingabe kommt.
    Ohne SD Karte im Gerät macht er das ohne Ende. Mit SD Karte schaff ich es soweit, dass ich irgendwann den PIN eingeben kann.

    Eine andere SD Karte wurde aber ohne Probleme gemountet. Es liegt also irgendwie an dieser. Hab mal im root explorer nachgeschaut und da standen die Permissions auf -----------
    Die Daten auf der SD sind aber noch vorhanden.

    In den letzten Tagen hab ich auch nichts groß am System verändert....keine Hacks, Mods, etc.

    Nur einige Programme installiert / aktuallisiert (Fancy Widget, Hero Clock, ADW, Netmonitor, Opera Mini).

    Hat jemand nen Tipp?
     
  2. s!Le, 27.06.2010 #2
    s!Le

    s!Le Android-Guru

    Beiträge:
    2,923
    Erhaltene Danke:
    270
    Registriert seit:
    09.12.2009
    Phone:
    Sony Xperia Z5 Compact
    Die Karte formatieren, davor aber evtl. die Daten sichern. Manchmal brauchen die das.

    Gruß
     
  3. TimeTurn, 27.06.2010 #3
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,106
    Erhaltene Danke:
    2,891
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Kannst natürlich (so die noch erkannt wird im Kartenleser) den Inhalt vorher aufm PC sichern, dann am besten Karte richtig putzen. Dazu im Stein in den "Einstellungen" unter "SD-Karte und Telefonspeicher" die Karte "Entnehmen" antippen. Anschließend sollte "SD-Karte formatieren" auswählbar sein. Das dann machen.

    Kann der Sten die nicht formatieren, dann muss sie in den Kartenleser am PC. Unter Windows Vista und 7 dann den Befehl "diskpart" nutzen um die zu bügeln (unter XP kann diskpart nicht auf Wechselmedien zugreifen, da geht es nicht). Dazu also folgende Schritte ausführen:

    • Start-> Ausführen-> cmd.exe -> OK clicken
    Kommandozeile öffnet sich - dort dann alle nachfolgenden Kommandos eingeben
    • diskpart
    • list disk
    Die Datenträgernummer der SD-Karte merken (die mit 78xx MB sollte es sein. bei mir ist nur eine Platte im PC und kein weiterer Datenträger angeschlossen, daher ist es bei mir die 1, ändere das entsprechend in den nächsten Zeilen auf Deine Nummer:

    • select disk 1
    • clean
    • exit
    VORSICHT! Der Clean-Befehl macht gnadenlos alles Platt, was auf dem Datenträger ist, denn er löscht Inhaltsverzeichnis, MBR und auch alle Partitionstabellen. Danach ist die Karte völlig unformatiert.

    Nun sollte der Stein beim hochfahren von sich aus fragen, ob er die Karte formatieren soll - ansonsten wie oben beschrieben "Entnehmen" und dann "Formatieren" tippen.

    Geht auch das nich, ist die SD-Karte vermutlich platt.
     
  4. n4rrOx, 27.06.2010 #4
    n4rrOx

    n4rrOx Threadstarter Junior Mitglied

    Beiträge:
    43
    Erhaltene Danke:
    7
    Registriert seit:
    13.04.2010
    Habs mal genau so gemacht wie TimeTurn es geschrieben hat.
    Anschließend noch mit Fat32 formatiert und wieder in den Stein eingelegt.

    Allerdings nichts...kann und konnte nicht in den Einstellungen auf "SD Karte entnehmen" drücken, weil die Karte nicht erkannt wird.
    Am Rechner funktioniert sie ohne Probleme. Was mich auch so verwundert sind die ganzen Reboots in Verbindung mit diesem Fehler.

    Sehr komisch....kann es sein, dass beim Systemstart irgendwo ein Fehler beim Mounten auftritt????
     
  5. TimeTurn, 27.06.2010 #5
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,106
    Erhaltene Danke:
    2,891
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Der Witz an der Sache ist ja gerade, das der Stein die Karte formatieren soll :eek:

    Hatte solche Reboot-Schleifen mit der SD auch mal - da hat es mit formatieren der Karte auch nicht gefunzt - aber 'nen versuch ist das natürlich immer erst wert, denn der nächste Schritt der bei mir geholfen hat war ein Wipe - also Werkseinstellungen. Danach lief alles wieder fein.
     
  6. Try4Ce, 27.06.2010 #6
    Try4Ce

    Try4Ce Android-Lexikon

    Beiträge:
    1,104
    Erhaltene Danke:
    285
    Registriert seit:
    15.03.2010
    Hmm das gleiche Problem hatte ich auch mal. Das bei jedem mal wenn die SD Karte gemountet werden sollte ein reboot kam. Formatieren am PC oder im Stein selbst ging auch nicht bzw half nicht.
    Ich musste ein Factory Reset machen... SBF neu flashen sollte auch gehen...
    Sorry aber nur so hab ich den Fehler bei MIR behoben... Soll nicht heißen das es zwangshaft für jeden anderen gilt.
     
  7. TimeTurn, 27.06.2010 #7
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,106
    Erhaltene Danke:
    2,891
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Sach ich doch das ein Wipe helfen sollte ^ :p
     
  8. iloads, 27.06.2010 #8
    iloads

    iloads Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    27.06.2010
    Diese Speichermedium in extrem unsicher. Deshalb immer Datensicherung machen. Die Karte oder USB Stick melden sich nicht mehr mehr der verbaute interne Controller defekt ist. Das geht ganz schnell durch zu frühes rausziehen oder Überspannung. Wenn man die Daten noch benötigt gibt es hier Hilfe: Datenrettung SD, SDHC, MMC, MS, MC, XD, USB-Stick
     
  9. TimeTurn, 28.06.2010 #9
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,106
    Erhaltene Danke:
    2,891
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Normalerweise ist es gar nicht möglich, die Karte "zu früh" aus dem Stein zu ziehen, da der Akku davor sitzt - ist also sehr unwahrscheinlich das die Karte geschossen ist - und wie gesagt - zwei hier im Thread (mich eingeschlossen) hatten den Fehler auch schon und ein Wipe (Werkseinstellungen) hat geholfen - meine Karte funktionierte danach wieder tadellos - bis heute. zum befüllen muss man die Karte normalerweise nicht rausnehmen, da die USB-Geschwindigkeit des Steins völlig ausreicht zum befüllen.

    Und sooo empfindlich sind SD-Karten nun auch wieder nich - ich hab es bisher nie geschafft, eine zu töten. Ich benutze schon seit jahren SD-Karten und deren derivate - angefangen bei der MMC in "Siemens SX1" über eien miniSD im Nokia N80 und diverse microSDs beim N95, N96 bis hin zum Milestone. natürlich auch in diversen Kameras - bisher ist nie eine geschrottet.

    Karte einfach am PC in Kartenleser - dort sollte diese problemlos zugreifbar sein - war bei mir auch so.
    .
     
    Zuletzt bearbeitet: 28.06.2010

Diese Seite empfehlen