1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Musik / mp3 auf SD-Karte werden teilweise nicht erkannt

Dieses Thema im Forum "Motorola Milestone Forum" wurde erstellt von judge99, 27.02.2010.

  1. judge99, 27.02.2010 #1
    judge99

    judge99 Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    27.02.2010
    Hallo zusammen!

    Ich habe eine Weile gegoogelt, aber leider nirgends einen Lösungsansatz gefunden. Ich habe über USB eine ganze Reihe von Alben in ein Verzeichnis "Music" auf der SD-Karte kopiert. Die ID3-Tags waren bei allen Dateien identisch (ID3V2.3). Das merkwürdige ist, dass einige Alben vom Player erkannt werden und einige nicht. Wenn ich inb Astro in die Verzteichnisse gehe und die Dateien anklicke, werden sie vom Musikplayer abgespielt, aber es wird kein Titel angezeigt. Merkwürdigerweise werden gelöschte Alben immer noch angezeigt, können aber (logisch) nicht abgespielt werden. Ich habe über Einstellungen - Anwendungen verwalten den Cache gelöscht, leider ohne Verbesserung. Sd-Rescan hat sich aufgefangen bzw. nach einer Stunde war immer noch der gleiche Bildschirm zu sehen.

    Also:
    - Warum werden manche mp3-Dateien nicht erkannt? Gibt es Einschränkungen beim Format?
    - Warum werden gelöschte Dateien immer noch angezeigt?
    - Gibt es irgendwo noch einen geheimen Cache?

    Ich würde mich über Hiinweise freuen. Ich mag mein Telefon echt gerne, aber das nervt ganz schön.

    Danke & schönen Abend

    Martin
     
  2. gokpog, 28.02.2010 #2
    gokpog

    gokpog Android-Ikone

    Beiträge:
    5,955
    Erhaltene Danke:
    1,386
    Registriert seit:
    12.11.2009
    Da haben sich irgendwelche Daten oder Caches quer gestellt. Probiere mal noch die MediaSync Daten und Cache zu löschen.
     
  3. kiprich, 28.02.2010 #3
    kiprich

    kiprich Android-Experte

    Beiträge:
    488
    Erhaltene Danke:
    76
    Registriert seit:
    20.11.2009
    das war bei mir auch so:
    kein update der alben im player
    sdrescan verschluckt sich
    etc.
    problem habe ich durch austausch
    der speicherkarte gelöst. hab jetzt
    eine sandisk class 2 16gb drin, die
    machts ohne probleme.
    habe seit dem kartenwechsel
    keinerlei probleme mehr!
     
  4. sL1Me, 28.02.2010 #4
    sL1Me

    sL1Me Android-Experte

    Beiträge:
    538
    Erhaltene Danke:
    23
    Registriert seit:
    17.02.2010
    Ich hätte jetzt auch auf, defekt der sd getippt... versuchs mal mit ner anderen ...
     
  5. judge99, 28.02.2010 #5
    judge99

    judge99 Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    27.02.2010
    Das werde ich mal probieren. Kann ich die ganzen Nutzerdaten der einzelnen Apps auf den PC kopieren und danach wieder zurück auf die SD-Karte? Ansonsten würde ich die karte einfach mal formatieren.

    Ansonsten habe ich Mixzing benutzt und eine Log-Datei gefunden, die folgendes sagt:

    15/2.2.3/2.6.29-omap1/
    Media mounted but still got a null cursor

    26 Feb 2010 17:25:32 GMT
    MixZing:artThumbWorker error 15/2.2.3/2.6.29-omap1/
    MusicUtils.extractArtwork: error extracting:
    java.io.FileNotFoundException
    android.database.DatabaseUtils.readExceptionWithFileNotFoundExceptionFromParcel(DatabaseUtils.java:123)
     
    Zuletzt bearbeitet: 28.02.2010
  6. gokpog, 28.02.2010 #6
    gokpog

    gokpog Android-Ikone

    Beiträge:
    5,955
    Erhaltene Danke:
    1,386
    Registriert seit:
    12.11.2009
    Also auf einen SD-Karten Defekt weist nichts hin. Da hat sich was verhakt, Daten/Cache von einem App will da nicht mehr. Kannst auch mal ScanDisk vom PC aus drüber laufen lassen (oder das Mac/Linux Programm).
    Ich hatte was ähnliches, bei mir waren alle Lieder auf einmal doppelt im Player und nachdem ich die Alben mit ASTRO gelöscht hatte, gingen sie nicht aus der Bibliothek raus. Geholfen hat bei mir die Alben noch mal mir dem Musicplayer zu löschen (lange Draufdrücken -> löschen). Das hat zwar pro Album ca. 30sec gedauert und der Player ist bei jedem Album mit einem force close abgeschmiert, danach waren sie aber raus und es ging alles wieder.
    Später habe ich von einem ähnlichen Problem gelesen und da hat es geholfen einfach die Daten und Cache des apps "MediaSync" zu löschen (Filter:alle).
     
  7. judge99, 28.02.2010 #7
    judge99

    judge99 Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    27.02.2010
    Ich habe jetzt die SD-Karte formatiert, alle Anwendungsdaten wie beschrieben gelöscht und danach den Player gestartet. Es wurde kein ALbum gefunden, auch die doppelten waren weg. Dann habe ich 13 Alben wieder auf die SD-Karte kopiert, bei allen sind die mp3-Tags in Ordnung. Von diesen 13 ALben werden nur drei erkannt. Das bringt mich echt zur Verzweiflung... Noch jemand ne Idee?
     
  8. gokpog, 28.02.2010 #8
    gokpog

    gokpog Android-Ikone

    Beiträge:
    5,955
    Erhaltene Danke:
    1,386
    Registriert seit:
    12.11.2009
    Wenn die restlichen nicht irgendwelche Alben mit DRM sind, dann leider nicht.
     
  9. judge99, 28.02.2010 #9
    judge99

    judge99 Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    27.02.2010
    Ich habe keine DRM-geschützte Musik. Das sind alles meine mit Audiograbber gerippten Original-CDs...
     
  10. @md

    @md Neuer Benutzer

    Beiträge:
    24
    Erhaltene Danke:
    0
    Registriert seit:
    25.02.2010
    also so ähnliche problem habe ich auch ween ich lieder aufden sd karte von pc raufmache steht ganze weile sd karte wird ausgelesen drauf, und ich sehe keine lieder,nach einem neu start sind alle da, vielleicht hilft es...
     
  11. sL1Me, 03.03.2010 #11
    sL1Me

    sL1Me Android-Experte

    Beiträge:
    538
    Erhaltene Danke:
    23
    Registriert seit:
    17.02.2010
    Ziehst du deinen stein einfach beim rechner raus oder richtig mit massenspeicher SICHER entfernen????

    Wenn ich meins nur ruasziehe...zeigt er mir die bilder/mp3s ect. auch nicht an...
    Gruss
     
  12. sL1Me, 04.03.2010 #12
    sL1Me

    sL1Me Android-Experte

    Beiträge:
    538
    Erhaltene Danke:
    23
    Registriert seit:
    17.02.2010
    P.S.: jedoch wird mir von der SD angezeigt das speicher verbraucht ist ... und zwar genau so virel wie ich draufgeladen hab ... hab das grad extra mal getestet...

    Vielleicht liegt das daran :)

    Gruss
     
  13. tomaxx, 04.03.2010 #13
    tomaxx

    tomaxx Neuer Benutzer

    Beiträge:
    22
    Erhaltene Danke:
    1
    Registriert seit:
    16.02.2010
    Mir passiert es gelegentlich, dass das Milestone einzelne Songs nicht richtig erkennt, die ich von Amazon direkt aufs Handy lade. Von einem Album mit 10 Songs finden sich dann z. B. nur 8 im Player wieder, obwohl die anderen beiden laut Filemanager da sind, wo sie sein sollen. Über den Filemanager kann ich die vermissten Songs auch mit dem Player starten und mir anhören. Es werden aber die ID3-Tags nicht ausgelesen, was offenbar letztlich zu dem Problem führt.

    Wenn ich dann den gesamten Album-Ordner in ein anderes Verzeichnis verschiebe, findet der Player dann meist aber auch die restlichen Tracks und erkennt dann auch die ID3-Tags korrekt.

    Schon komisch.

    tomaxx
     
  14. judge99, 04.03.2010 #14
    judge99

    judge99 Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    27.02.2010
    Trotz "sicherem Entfernen" wieder nur drei von fünf Alben erkannt....
     
  15. sL1Me, 04.03.2010 #15
    sL1Me

    sL1Me Android-Experte

    Beiträge:
    538
    Erhaltene Danke:
    23
    Registriert seit:
    17.02.2010
    hmm ... du dann bin ich wohl mit meinem latein am ende ...

    kauf dir einfach mal ne neue SD.. das ist das einzige was mir noch einfallen würde...

    ausprobieren kannste es ja ... und wenns nicht klappt formatierste die SD und gibs se zurück ...

    gruß
     
  16. DaSchelmo, 15.03.2010 #16
    DaSchelmo

    DaSchelmo Junior Mitglied

    Beiträge:
    33
    Erhaltene Danke:
    0
    Registriert seit:
    04.09.2009
    Android kann nur die MP3 Tags v1 auslesen, v2 oder v3 nicht.
    Zieht euch aus dem Netz einfach den das Tool MP3TagIt und lasst dort die Dateien nochmals einlesen/abgleichen.
    Das Programm trägt dann die Tag v1 nach und schon konnte mein android etwas mit den Titeln anfangen.
    Zum rippen nehme ich das Programm RippMe, welchen beim rippen gleich alle Tag Versionen befüllt.
     

Diese Seite empfehlen