1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Musik Player stottert wie verückt

Dieses Thema im Forum "HTC Desire Forum" wurde erstellt von Klaus Kinski, 29.04.2010.

  1. Klaus Kinski, 29.04.2010 #1
    Klaus Kinski

    Klaus Kinski Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    29.04.2010
    Hallo Leute!
    Ich habe leider das Problem, daß Musik hören mit dem integrierten Player quasi unmöglich ist, da der Player ein ganzes Lied in ein paar Sekunden "durchstottert". Das Problem tritt nicht immer auf (nach einer Zeit jedoch immer), aber wenn's losgeht, hört das auch nicht mehr auf. (Albenwechsel zwecklos). Ein anderer Player (MortPlayer) zeigt das Verhalten nicht, meiner jedoch schon seit dem ersten Tag.
    Hat jemand einen Tip? Ich kann die in's ROM integrierte Applikation ja leider nicht separat neuinstallieren...
    Ich hab das bis jetzt nur im Zusammenhang mit anderen Androiden gelesen...
    Ich hab das Modell neu im normalen Laden gekauft, jedoch in Schweden. Ich denke aber die hören die Musik auch lieber normal :)

    Beste Grüße,
    Klaus
     
  2. PeBo, 29.04.2010 #2
    PeBo

    PeBo Android-Experte

    Beiträge:
    789
    Erhaltene Danke:
    151
    Registriert seit:
    05.11.2009
    Hast Du etwas am Kopfhörerausgang angeschlosen oder hörst Du über den Lautsprecher?
     
  3. Klaus Kinski, 29.04.2010 #3
    Klaus Kinski

    Klaus Kinski Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    29.04.2010
    Sagte ich der Andere Player ist ok? Ist da jetzt auch aufgetreten, hat nur recht lang durchgehalten. Mist! Hab nur Kopfhörer probiert.
    Danke und Gruß
     
  4. PeBo, 29.04.2010 #4
    PeBo

    PeBo Android-Experte

    Beiträge:
    789
    Erhaltene Danke:
    151
    Registriert seit:
    05.11.2009
    Ok, das wollte ich erst wissen bevor ich in die falsche Richtung denke...

    Eventuell hast Du ein Problem mit der Kabelfernbedienung. Wenn da FastForward gedrückt ist (oder defekt) dann hört sich das so an wie Du beschreibst.

    Versuch mal einen anderen Kopfhörer oder höre mal eine Weile über den Lautsprecher ohne etwas anderes anzuschließen.
     
  5. Klaus Kinski, 29.04.2010 #5
    Klaus Kinski

    Klaus Kinski Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    29.04.2010
    Hallo,
    das Stottern mit dem anderen Player war gerade nur ein paar Sekunden, nicht so wie vorher beschrieben, daß die Lieder durchrattern. Danach ging es normal weiter bis jetzt, da ich Pause gedrückt hab. :)
    Wollte gerade nur möglichst schnell Bescheid geben, da ich euch nicht sinnlos beschäftigen wollte. Ich höre mit Fernbedienungslosen Kopfhörern, da die, welche dabei waren, mir Ohrenschmerzen verursachen. Die passen mir einfach nicht. Das Problem tritt auch auf, wenn ich den Player in der Hand halte, also keine Knöpfe in der Tasche drücke ;)
    Es scheint mir jetzt doch eher an dem Player zu liegen, bestimmt kann ich's aber nicht sagen.
    Dekodiert der htc Player eigentlich in Hard- oder Software?

    Kann doch nicht sein, daß ich mir für 500 Taler ein Gerät kaufe, und Probelme habe, Musik zu hören. Beim nächsten Stottern mit dem Originalplayer werd ich mal die Systemlast prüfen, hab aber nie viel Laufen. Ausserdem kann das Problem auch direkt nach einem Neustart auftreten.

    Beste Grüße,
    Klaus

    Edit: Ich meine es wäre auch mit anderen Kopfhören schon aufgetreten, hab gerade an einen defekt, oder "Leitbrücke" im Kopfhörerstecker gedacht. Das werde ich jetzt mal prüfen...

    EditEdit: Das FastForward hört sich anders an. Da spielt er jedes Lied kurz an. Bei mir hört sich's an wie "Wurstsalat" ;)
     
    Zuletzt bearbeitet: 29.04.2010
  6. Mort, 30.04.2010 #6
    Mort

    Mort Android-Lexikon

    Beiträge:
    960
    Erhaltene Danke:
    262
    Registriert seit:
    16.11.2009
    Jedes Lied kurz anspielen wäre beim Liedwechsel. Beim Vorspulen (FastForward) wird eine gewisse Zeitspanne übersprungen und dann ein kurzes Stück gespielt, bis das nächste "Weiter!" signalisiert wird.
    Allerdings: Kabelkopfhörer haben nur einen Button. Wenn der dauernd signalisiert würde, würde der MortPlayer - je nach zeitlichem Abstand - ständig pausieren und weitermachen oder die Verzeichnisse rückwärts durchblättern. Ist also eher unwahrscheinlich.
    Bleiben spontan nur zwei Möglichkeiten übrig. Entweder kommt der Decoder irgendwie durcheinander (nahezu alle Player verwenden den vom System) oder irgendeine App emuliert 'nen Vorspul-Button. Wenns ersteres ist, könnte es helfen, die Lieder testweise umzucodieren, am besten in ein anderes Format wie z.B. Ogg Vorbis. Letzteres ist ein bisschen schwieriger rauszufinden... Wenn du den MortPlayer noch drauf hast, kannst du mal ins Logcat schauen (z.B. mit aLogcat (App) oder via adb logcat (SDK-Tool)) ob der massenweise "known media button nnn" (weiß den Code fürs Vorspulen nicht auswendig) ausspuckt...
     
    Klaus Kinski bedankt sich.
  7. Klaus Kinski, 30.04.2010 #7
    Klaus Kinski

    Klaus Kinski Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    29.04.2010
    Hmm, stimmt!
    Die, die bei mir dabei waren, haben drei. Lied vor/zurück/pause.

    Ich habe jetzt allerdings sehr meine anderen Kopfhörer im Verdacht. Irgendwas scheint da wie ein Signal zu wirken. Das Problem titt häufig auf, wenn ich den Player in die Tasche stecke, also der Stecker ein bisschen bewegt und belastet wird. Um sicher zu gehen, muß ich wohl noch einen anderen Kopfhörer ausprobieren, oder ich schau gleich mal nach Tastendrücken.
    Eine Neuinstallation des Players hat jedenfalls nichts gebracht, Commander Root ist gestern mit einem neuen Image vorbei gekommen.

    Vielen Dank erstmal! Ich hoffe ich hab's dann jetzt eingegrentzt.
    Aber schon doof, die schönen Sennheiserstöpsel würde ich gerne weiter nutzen...

    Grüße,
    Klaus
     
  8. burst, 30.04.2010 #8
    burst

    burst Android-Experte

    Beiträge:
    898
    Erhaltene Danke:
    216
    Registriert seit:
    27.05.2009
    Tablet:
    Samsung Galaxy Tab 2
    schau dir mal die Stecker der Kopfhörer mit und ohne fernbedienung an.
    normalerweise haben die Ohne Fernbedienung 3 bereiche

    zum Vergleich: Klinkenstecker ? Wikipedia

    unter Symmetrische Verbindung und Stereo-Stecker mit Zusatzfunktion (4-polig)

    die mit Fernbedienung haben sicher mehr (4? hab sie gerde nicht da)
    dadurch kann es vlt. passieren das dein Kopfhörer mit einem der 3 Bereiche durch Wackeln dort anliegt wo bei den Fernbedienungs-Kopfhörern der bereich für die Buttons liegen.
    lg

    hab mal was gelesen das der HTC Touch das selbe problem hat
     
    Zuletzt bearbeitet: 30.04.2010
    Klaus Kinski bedankt sich.
  9. Klaus Kinski, 01.05.2010 #9
    Klaus Kinski

    Klaus Kinski Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    29.04.2010
    was du sagst ist ja alles richtig.
    jedoch ist es ein witz, daß ein gerät dieser preisklasse probleme mit einem stinknormalen kopfhörer hat (der jetzt nicht gerade vom discounter ist). mein erster minidiscmann von anno dazumal, und nachfolger, konnten das schon problemlos verkraften.

    grüße,
    klaus

    ps: ich glaube nicht, daß sennheiser hier vom standard abweicht. ich konnte das zumindest nicht ausmachen. da denke ich eher, daß die feder der buchse nicht exakt gearbeitet ist.

    pps: ich denke ich habe das problem jetzt tatsächlich erkannt. danke nochmal für die (an)teilnahme.
     
  10. burst, 01.05.2010 #10
    burst

    burst Android-Experte

    Beiträge:
    898
    Erhaltene Danke:
    216
    Registriert seit:
    27.05.2009
    Tablet:
    Samsung Galaxy Tab 2
    Du könntest Vlt. Versuchen den entsprechenden teil abzukleben. Ist zwar notdürftig, aber kann funktionieren. Senheiser muss ja nicht vom Standard abweichen. Es reicht wen HTC dad tut :)
     
  11. jul90, 03.05.2010 #11
    jul90

    jul90 Android-Hilfe.de Mitglied

    Beiträge:
    105
    Erhaltene Danke:
    4
    Registriert seit:
    05.03.2010
    Also ich habe das selbe problem. Bei mir rattert die musik auch hin und wieder wie verrückt durch die ganzen alben.
    Habe dasproblem jedoch mit verschiedenen kopfhörern bzw. Beim anschluss an meine aktiv boxen. Weiß echt nichtwas ich machen soll
     
  12. Klaus Kinski, 03.05.2010 #12
    Klaus Kinski

    Klaus Kinski Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    29.04.2010
    Ich habe derzeit auch kein geeignetes Werkzeug zur Hand um die Buchse zu bearbeiten. Netterweise hat sich das Problem mittlerweile soweit gelegt, daß ich es gerade nicht provozieren konnte. Hatte überlegt eine app schreiben, die den erzeugten Event abfängt.
    Falls Du eine Ahnung hast was Mort auf der verherigen Seite geschrieben hat, kannst Du das ja machen.
    Ansonsten logge ich die Tage mal auf die sd-karte und "hoffe" ;) daß es auftritt bevor die Karte voll ist. Bei Benutzung des Gerätes kommt da nämlich einiges zusammen.
    Das mach ich dann so, damit ich das später auch wiederfinde ;)
    nohup logcat >> /sdcard/logfile&
    nohup watch -n 60 '' >> /sdcard/logfile&

    Auch wenn ich mit Dir leide, hoffe ich doch, daß sich meine Buchse endgültig eingerenkt hat. Ich konnte das Problem übrigens die letzten Male durch drehen und drücken am Stecker beenden.

    Grüße,
    Klaus
     
  13. Klaus Kinski, 05.05.2010 #13
    Klaus Kinski

    Klaus Kinski Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    29.04.2010
    Bis jetzt muß ich Dich "leider" entäuschen. Das Problem ist nicht mehr aufgetreten...

    Grüße,
    Klaus
     

Diese Seite empfehlen