1. Möchtest Du unser Team im Android OS-Bereich unterstützen? Details dazu findest du hier!
  2. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

[N64 Emulator] Mupen64Plus AE

Dieses Thema im Forum "Android Spiele" wurde erstellt von jannis357, 19.12.2011.

  1. jannis357, 19.12.2011 #1
    jannis357

    jannis357 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    68
    Erhaltene Danke:
    17
    Registriert seit:
    06.11.2010
    Ich möchte euch hier gerne einen neuen N64 Emulator für Android vorstellen:

    den Mupen64Plus AE (AE=Android Edition)


    Entwickelt wird der Emulator von Paul Lamb (Paul's Forum) und er basiert auf Mupen64Plus.


    Seit 18.12.2011 befindet sich der Emulator in der BETA-Phase und er ist nun auch im Market verfügbar. (Preis: 0,77€)

    Ich benütze den Emulator schon seit der frühen Alpha-Phase und bin wirklich begeistert, wie Paul es schafft den Emulator ständig und in sehr kurzen Abstanden zu verbessern. (Updates lassen meist nur ein paar Tage auf sich warten!)

    Einige Besonderheiten des Emulators:

    • Open-Source(!)
    • läuft auch auf Low-End-Devices
    • laufend neue Updates
    • eigene Xperia Play Version

    Downloadlink: KLICK

    Downloadlink für Xperia Play: KLICK


    Einfache Fragen könnt ihr gerne hier stellen und für Bug Reports oder kompliziertere Fragen bitte Paul's Forum benützen!


    Lags/Ruckler:
    Was unternommen werden kann, wenn ein Spiel laggt/ruckelt:
    • Geduld haben und auf Updates warten
    • den Sound deaktivieren (Settings--> Audio--> X bei Enable durch antippen aus machen)
    • Frameskip ändern (Settings--> Video--> Configure--> auf Max Frameskip stellen und dort den geeignetsten Frameskip durch mehrmaliges antippen auswählen (0-5))
    • ein anderes Grafik Plugin auswählen (Settings--> Video--> Change. Zur Auswahl stehen das libgles2n64.so Plugin (ist standardmäßig aktiviert) und das libgles2rice.so Plugin.
    • andere Einstellungen ausprobieren


    Wichtig:
    1. Paul sucht noch weitere Entwickler, die ihm helfen den Emulator weiter zu verbessern (Bitte in seinem Forum melden)
    2. Der Emulator befindet sich noch in der frühen BETA-Phase! Daher sind Bugs und andere Fehler nicht ausgeschlossen! Wenn ihr einen Bug findet, bitte hier melden.
    3. Auch aufgrund der frühen BETA-Phase: Einige Roms funktionieren noch nicht oder nur sehr eingeschränkt! Bitte deswegen einfach ein wenig Geduld haben und auf weitere Updates warten! Der Emulator wird ständig verbessert!
     
    Zuletzt bearbeitet: 22.12.2011
    JustDroidIt und scorpio16v haben sich bedankt.
  2. Scorpion1983, 20.12.2011 #2
    Scorpion1983

    Scorpion1983 Erfahrener Benutzer

    Beiträge:
    220
    Erhaltene Danke:
    9
    Registriert seit:
    04.04.2010
    Wie schaut es mit der Kompatibilität auf Tegra 2 Tablets auf mit einer Auflösung von 1280ig ?

    Wie ist das Bedienoverlay ?
     
  3. dartcobra, 20.12.2011 #3
    dartcobra

    dartcobra Fortgeschrittenes Mitglied

    Beiträge:
    328
    Erhaltene Danke:
    21
    Registriert seit:
    07.08.2011
    Ich bin des Englischen nicht so mächtig. Wenn jemand meinen Beitrag in Paul Lambs Forum eintragen würde/möchte kann es ja tun.
    Also ich hab ein Xperia Play,root mit 2.3.4. Die Bedienung mit intregation der Analogfelder find ich gut und gelungen.
    Leider (getestet mit Mario Kart) ruckelts und ich hab sehr oft Lags(so nennt man doch wenn das Bild kurz einfriert aber das Spiel weiter läuft?).
    So macht es leider (noch) keinen großen Spass. Ist also nicht unbedingt ein Bug,ist halt noch Beta.
    Oder das Play hat nicht genug Power für den Emulator. ???
    Gruss dartcobra
     
  4. jannis357, 20.12.2011 #4
    jannis357

    jannis357 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    68
    Erhaltene Danke:
    17
    Registriert seit:
    06.11.2010
    @Scorpion1983: Zur Kompatibilität auf Tegra 2 Tablets kann ich leider nichts sagen, am besten du fragst selbst mal hier nach.
    Oder du lädst dir die aktuelle App einfach mal von hier runter und probierst es selbst aus.

    @dartcobra: Ich denke, dass das Xperia Play sicher genug Power hat, aber wie du schon sagst, befindet sich der Emulator noch in der Beta-Phase und die Lags (Ich würde allgemein alle Ruckler als Lags bezeichnen) sind wahrscheinlich darauf zurückzuführen.
    Gerade Mario Kart laggt bei mir leider auch noch sehr stark, Super Mario 64 hingegen läuft einwandfrei!
    Was du auch noch versuchen kannst, um die Lags zu minimieren, ist einerseits ein anderes ROM auszuprobieren (was sehr selten einen gewaltigen Unterschied ausmachen kann, normalerweise aber kaum einen Unterschied macht) oder dich ein bisschen mit den Einstellungen zu spielen. (z.B. den Sound abschalten (Settings-->Audio-->X bei enable aus machen) oder einen anderen Frameskip zu aktivieren (Settings-->Video-->Configure--> auf Max Frameskip stellen und dort den geeignetsten Frameskip durch mehrmaliges klicken auswählen (0-5) (bei mir funktioniert frameskip 1 meist ganz gut))

    @alle: Wenn ihr wollt, könnt ihr mir auch gerne schreiben, welcher Frameskip bei euch die besten Ergebnisse erzielt und wenn sich einer durchsetzt, der bei einigen am besten funktioniert, dann ergänze ich ihn im 1. Post :)
     
    Zuletzt bearbeitet: 20.12.2011
  5. scorpio16v, 20.12.2011 #5
    scorpio16v

    scorpio16v Android-Experte

    Beiträge:
    713
    Erhaltene Danke:
    126
    Registriert seit:
    30.01.2009
    Falls die Frage ist ob es grundsätzlich läuft, ist die Antwort - Ja.

    Für Tablets hat Mupen64plus z.Zt. 3 Eingabemasken.

    - Mupen64Plus-AE-Analog-Tablet
    -- der Analogstick ist animiert, verbraucht leicht mehr Resourcen.

    - Mupen64Plus-AE-Touch-Tablet
    -- das selbe Buttonlayout, aber das Pad ist nicht animiert.

    - Mupen64Plus-AE-Digital-Tablet
    -- Wird aber noch nicht vom Emulator genutzt.

    Das Eingabelayout läßt sich über ein Konfigurationsfile per Texteditor anpassen.
    (Position der Buttons und des Pads.)
    Über das Menü geht das aber nicht.
    Ebenso kann man sich auch sein eigenes Layout basteln. Wie das geht hat Paul in diesem Thread erklärt.
    Creating Custom Skins
     
  6. dartcobra, 21.12.2011 #6
    dartcobra

    dartcobra Fortgeschrittenes Mitglied

    Beiträge:
    328
    Erhaltene Danke:
    21
    Registriert seit:
    07.08.2011
    Hab noch ein wenig rumgespielt. Wipeout 64 geht nur bis Hauptmenü, danach schwarzer Schirm.
    Mario 64 leider auch Blackscreen wenn ich zu Anfang das Schloss betrete.
    Fighters Destiny 2 lief dagegen akzeptabel. Da kam der Blackout erst nach 5 Kämpfen und ich einen neuen Kämpfer auswählen wollte.
    Alles ohne sound und frameskip 1.
    Mal auf Updates hoffen.
    Gruss dartcobra
    edit@
    Nachdem ich gerade das Update aufgespielt habe,habe ich promt mein am besten laufendes Spiel - Fighters Destiny2 - getestet!
    Läuft ingesamt astrein. Die Übergänge von Menü zu Menü wirken nicht ganz so flüssig wie beim n64oid,aber Spiel selbst - Super!
    Wohlgemerkt: ohne Mukke. Mit bleibt der Schirm schwarz!
    Werde meine anderen Games auch noch austesten.
     
    Zuletzt bearbeitet: 21.12.2011
  7. scorpio16v, 21.12.2011 #7
    scorpio16v

    scorpio16v Android-Experte

    Beiträge:
    713
    Erhaltene Danke:
    126
    Registriert seit:
    30.01.2009
    Das gerade Mario nicht läuft finde ich jetzt ungewöhnlich, denn gerade das Game war ja als Referenz ROM von Anfang an in den ersten alpha Versionen mit integriert und so ziemlich alle Bugfixes wurden an diesem Spiel getestet.
    Falls das ROM eine .zip Datei ist, versuch sie mal zu entpacken und dann zu starten.
    Es macht sehr wohl Sinn ein anderes ROM zu testen.
    Manche Games kommen mit einem Frameskip auf 5 klar, andere stürzen ab, wenn FS>2.
    Welches Grafikplugin ist aktiviert, gles2n64 oder gles2rice ?

    Nachtrag:
    Der Fehler tritt wohl z.Zt. auf, wenn in einem gezipten ROM noch andere Dateien, wie z.B eine Readme, enthalten sind. Soll aber bald behoben werden. Bis dahin muß man halt die problematischen ROM entpacken.
     
    Zuletzt bearbeitet: 22.12.2011
  8. dartcobra, 22.12.2011 #8
    dartcobra

    dartcobra Fortgeschrittenes Mitglied

    Beiträge:
    328
    Erhaltene Danke:
    21
    Registriert seit:
    07.08.2011
    Ich hab alle Roms entpackt und ohne Readme. Ferner hab ich gles2n64. Kann aber auch kein anderes plug-in wählen. Auf der Homepage habe ich keinen Support/plug-ins gefunden.
    Grafikfehler hab ich noch gefunden bei:
    Ridge Racer 64 - das Hud ist komplett,aber Strecke,Autos,halt alles andere fehlt. bleibt einfach schwarz
    Wipeout64 - dito- starte Rennen gesamte Anzeige da,sonst kein Bild
    Fighters Destiny2 - es fehlen graphische Zwischensequenzen/bei n64oid werden sie gezeigt
    Allgemein zum Laufen bekomm ich alle Spiele am besten mit Frameskip 1 o. 2 sowie ohne Sound.
    Gruss dartcobra
     
  9. scorpio16v, 22.12.2011 #9
    scorpio16v

    scorpio16v Android-Experte

    Beiträge:
    713
    Erhaltene Danke:
    126
    Registriert seit:
    30.01.2009
    Das andere Plugin libgles2rice.so muß da sein. Sonst solltest Du Mupen nochmal deinstallieren und wichtig, die Daten nachladen lassen.
    Das Rice plugin ist aber Resourcenhungriger.
     
  10. jannis357, 22.12.2011 #10
    jannis357

    jannis357 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    68
    Erhaltene Danke:
    17
    Registriert seit:
    06.11.2010
    @dartcobra: das andere Plugin kannst du unter Settings--> Video--> Change auswählen. Zur Auswahl stehen das libgles2n64.so Plugin und das libgles2rice.so Plugin. Wobei das libgles2n64.so standardmäßig ausgewählt ist.
     
  11. dartcobra, 22.12.2011 #11
    dartcobra

    dartcobra Fortgeschrittenes Mitglied

    Beiträge:
    328
    Erhaltene Danke:
    21
    Registriert seit:
    07.08.2011
    Also ich hab nochmal neu installiert. Aber ein weiteres plug in hab ich nicht. Wenn ich diese Option wähle, öffnet sich zwar ein neuer Ordner, aber ohne Inhalt.
    Ist es von Vorteil die Roms im vorgesehenen Ordner zu stecken? Bisher hab ich sie in einem anderen Ordner weil ich auch n64oid darauf zugreifen lasse.
    Gruß dartcobra
     
  12. scorpio16v, 22.12.2011 #12
    scorpio16v

    scorpio16v Android-Experte

    Beiträge:
    713
    Erhaltene Danke:
    126
    Registriert seit:
    30.01.2009
    Wenn Du auf "Change" gehst, solltest Du alle 9 Plugins sehen. (sound,input usw. Plugin mit der Endung .so) .
    Der ROM Ordner ist egal. Ich nutze auch einen Ordner für beide N64 Emulatoren.

    Von Deinem Problem, das nichts angezeigt wird, habe ich noch nicht gelesen. Hast Du ein Custom ROM, Root oder irgend einen besonderen Mod auf deinem Gerät laufen ?

    Ich sehe gerade, das Du neben dem Xperia Play noch ein Tablet hast. Wie läuft der Emu darauf ?
     
  13. dartcobra, 22.12.2011 #13
    dartcobra

    dartcobra Fortgeschrittenes Mitglied

    Beiträge:
    328
    Erhaltene Danke:
    21
    Registriert seit:
    07.08.2011
    Auf dem Tablet kann ich mal testen. Im ersten meiner Posts hab ich meine Konstellation genannt. Ich hab 2.3.4 Stockrom gerootet. Unter settings stehen bei mir:
    Video
    Audio
    input
    RSP
    Core
    enable auto-save
    Wenn ich nun settings/Video/change wähle, steht dort nur "lib"/"... parent folder". Und LEER!
    Das steht dann in allen Change-Menus.
    Wie gesagt,ich teste mal auf dem Tablet. Vielleicht finden da ja dann alle plug-ins.
    Gruss dartcobra
     
  14. scorpio16v, 22.12.2011 #14
    scorpio16v

    scorpio16v Android-Experte

    Beiträge:
    713
    Erhaltene Danke:
    126
    Registriert seit:
    30.01.2009
    Und in dem Ordner lib wird auch nicht das gles2n64 Plugin angezeigt, das Du jetzt schon nutzt ?
    Hast Du den Ordner mal mit einem Filebrowser geöffnet um zu sehen ob die Plugins generell fehlen oder nur nicht angezeigt werden ?
     
  15. dartcobra, 22.12.2011 #15
    dartcobra

    dartcobra Fortgeschrittenes Mitglied

    Beiträge:
    328
    Erhaltene Danke:
    21
    Registriert seit:
    07.08.2011
    Mein filemanager zeigt mir unter data folgendes:
    saveordner
    Front.ttf
    gles2n64.conf
    gles2n64rom.conf
    glide64.ini
    gui.cfg
    inputautocfg.in
    mupen64plus.cht
    mupen64plus.ini
    mupencheat.txt
    RiceVideoLinux.ini
    In allen settings steht unter change als aus(vor)gewählt die. so Datei. Heisst bei Video gles2n64.
    Gruss dartcobra
     
  16. scorpio16v, 22.12.2011 #16
    scorpio16v

    scorpio16v Android-Experte

    Beiträge:
    713
    Erhaltene Danke:
    126
    Registriert seit:
    30.01.2009
    Der Ordner lib ist nicht auf der Speicherkarte, sondern unter
    /data/data/paulscode.android.mupen64plus/lib
    In Ihm sollten die 9 .so Dateien sein.
     
  17. dartcobra, 22.12.2011 #17
    dartcobra

    dartcobra Fortgeschrittenes Mitglied

    Beiträge:
    328
    Erhaltene Danke:
    21
    Registriert seit:
    07.08.2011
    Alles klar! Gefunden. Aber dann bleibt das Problem - wie bekomm ich die Dateien im Programm zu Gesicht?
    Wie geschrieben...ich werde vom Emulator praktisch raus geleitet bis zum Telefonspeicher. Aber jeder Ordner ist leer.
    lib/paulscode.../data/data/Ende - systemordner vor der Nase.
    Gruss dartcobra
     
  18. scorpio16v, 22.12.2011 #18
    scorpio16v

    scorpio16v Android-Experte

    Beiträge:
    713
    Erhaltene Danke:
    126
    Registriert seit:
    30.01.2009
    dartcobra bedankt sich.
  19. dartcobra, 22.12.2011 #19
    dartcobra

    dartcobra Fortgeschrittenes Mitglied

    Beiträge:
    328
    Erhaltene Danke:
    21
    Registriert seit:
    07.08.2011
    Danke dir! Wenn ich das mit meinen Englischkenntnissen richtig verstanden habe,sucht er nun nach einer Lösung die plug-ins in einem anderen Verzeichnis zu installieren indem mein System diese finden kann. Richtig???
    Gruss dartcobra
    edit:
    das sie NICHT installiert sind wie Pauls erster Gedanke war,ist ja nicht richtig. Per Filemanager seh ich sie ja. sind ergo mit installiert worden.
    Nur die App findet sie scheinbar nicht.
     
    Zuletzt bearbeitet: 22.12.2011
  20. dartcobra, 23.12.2011 #20
    dartcobra

    dartcobra Fortgeschrittenes Mitglied

    Beiträge:
    328
    Erhaltene Danke:
    21
    Registriert seit:
    07.08.2011
    scorpio16v@
    Vielen Dank nochmal für deine Hilfe/Weiterleitung. Habe mir die neue(alte?) Datei installiert.
    Alle plug-ins sind da. Mit gles2rice sind bei drei meiner Spiele weniger Grafikfehler,dafür langsamer.
    Bei Mario Karte ist dagegen mein Fahrer um 180 Grad gedreht und lässt sich nicht lenken. :)
    Mal schauen ob es noch weitere Updates gibt und was die bringen werden.
    Gruss dartcobra
     

Diese Seite empfehlen