1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Nach Ace-Hack WLAN Verbindung tot

Dieses Thema im Forum "Root / Hacking / Modding für HTC Desire HD" wurde erstellt von coolbit, 22.11.2011.

  1. coolbit, 22.11.2011 #1
    coolbit

    coolbit Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    22.11.2011
    Moin zusammen,

    habe mich schon durch die SuFu gekämpft aber leider nichts passendes gefunden.
    Gestern Abend (besser gesagt: Nacht) habe ich mich endlich dazu durchgerungen mein DHD zu rooten. Mit dem neuen Ace-Hack war das auch spielend einfach. Ubuntu CD - Script anstarten - Anweisungen folgen.

    Sah zunächst auch sehr gut aus. Allerdings fiel mir dann relativ schnell auf, dass ich wohl eine Verbindung zu meinem WLAN bekomme aber absolut keine Daten mehr drüber fließen...
    Alle anderen Verbindungen (GPRS / UMTS / GSM) scheinen aber weiter zu funktionieren.
    Meine Vermutung ist gerade folgende: für den Hack wird das Radio downgegradet. Beim erneuten Upgrade kam auf dem Computerbildschirm kurz die Meldung, dass er irgendetwas nicht korrekt lesen (oder wars entpacken? nagelt mich nicht drauf fest) konnte. Der Vorgang lief danach aber ohne weitere Probleme durch. Vermutlich hat es mir dabei das WLAN zernagelt...

    Meine Frage(n): wie gehe ich am besten weiter vor? Neues Radio flashen? Für eine ausführliche Anleitung (Link oder direkt hier im Thread) wäre ich sehr froh. Zwar habe ich Wirtschaftsinformatik studiert aber das ganze hin und hergeflashe ist mir (ohne Step-by-Step Anleitung) doch ziemlich suspekt, da man sein Handy dabei ganz schnell übern Jordan schicken kann...

    Vielen Dank schonmal!

    coolbit
     
  2. Sleepwalker, 22.11.2011 #2
    Sleepwalker

    Sleepwalker Android-Guru

    Beiträge:
    2,326
    Erhaltene Danke:
    219
    Registriert seit:
    03.12.2010
    Meines Wissens nach hat das Radio nichts mit WLAN am Hut.
    Nützlich wäre die Fehlermeldung gewesen.

    Schon versucht, die Verbindung zu löschen und neu einzurichten?
     
  3. coolbit, 22.11.2011 #3
    coolbit

    coolbit Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    22.11.2011
    Mit der kann ich leider nicht dienen. Das ganze war auf der Konsole und ziemich schnell wieder weg... Die Ausgabe habe ich (leider) auch nicht zusätzlich in eine Datei umgeleitet...

    Das Radio hat nix mit WLAN am Hut? Das wäre mir neu... Nach allem was ich bisher gelesen habe ist das Radio sogar für GPS, usw. verantwortlich.

    Nein neu eingerichtet habe ich die Verbindung noch nicht. Werde ich aber nachholen sobald ich wieder zu Hause bin.
    Blöde Frage: wo legt Android denn die Zugangsdaten fürs WLAN hin? Zufällig auf die SD-Karte? Deren Inhalt habe ich nach dem Hack nämlich noch nicht wiederhergestellt. Dann könnte es evtl. noch daran liegen...
     
  4. Nseries, 22.11.2011 #4
    Nseries

    Nseries Android-Lexikon

    Beiträge:
    972
    Erhaltene Danke:
    73
    Registriert seit:
    09.07.2011
    Dachte, das Radio sei die "treibersammlung" für alle hardwareschnittstellen, auch Kamera und WLAN... Ich würde den hack einfach nochmal durchlaufen lassen...
    Und die wlandaten sind ziemlich sicher im Geräte Speicher. Android speichert kaum/nichts auf die sdkarte, sonst müsste man die beim ROM flashen auch immer fomratieren...
    Gesendet mit der Android-Hilfe.de-App
     
  5. TimeTurn, 22.11.2011 #5
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,114
    Erhaltene Danke:
    2,895
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Das Radio IST für WLAN mit zuständig, passt schon. Kann durchaus sein, das das Radio downgrade verantwortlich ist. Einfach mal die WLAN-Verbindung neu anlegen.

    Welche Baseband-Version steht bei Dir (das ist die Radio-Version)?
     
    coolbit bedankt sich.
  6. coolbit, 22.11.2011 #6
    coolbit

    coolbit Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    22.11.2011
    Danke für die Klarstellung. Hatte mich schon gewundert... ^^

    Baseband-Version ist 12.39a.60.19U_26.06.06.30_M

    Wie gesagt: werde ich heute Abend mal versuchen.
    Die SD-Karte war übrigens definitiv nicht schuld, dass es nicht mehr funktioniert - die Inhalte sind alle noch da (auch wenn in der Anleitung eigentlich steht, dass die SD-Karte vorher automatisch formatiert wird...)
     
  7. Eneco, 22.11.2011 #7
    Eneco

    Eneco Android-Lexikon

    Beiträge:
    1,945
    Erhaltene Danke:
    510
    Registriert seit:
    20.03.2011
    Wird denn wirklich beim AAHK irgend etwas am Radio gedreht? Bei den alten Methoden war es nie notwendig, das Radio zu verändern...
     
    coolbit bedankt sich.
  8. coolbit, 22.11.2011 #8
    coolbit

    coolbit Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    22.11.2011
    @Eneco: du hast recht! Habe etwas durcheinander gebracht.

    In der Anleitung steht, dass Radio S-OFF mittels eines Exploits passiert - aber nicht, dass die Radio-Version runtergesetzt wird.
    Etwas weiter im Text steht, dass er die "Mainver" runtersetzt. Das habe ich durcheinandergeworfen.

    Neue These: das Radio funktioniert ohne Probleme (die WLAN-Verbindung wird ja noch hergestellt) aber der TCP/IP-Stack scheint das nicht mehr richtig zu verarbeiten.

    Aber schauen wir mal. Heute Abend lege ich die Verbindung neu an, dann sehen wir weiter.
     
  9. Sleepwalker, 22.11.2011 #9
    Sleepwalker

    Sleepwalker Android-Guru

    Beiträge:
    2,326
    Erhaltene Danke:
    219
    Registriert seit:
    03.12.2010
    Ja, bei AAHK wird am Radio gedreht.
    Dass das auch für WLAN zuständig ist, habe ich hier nie raus gelesen. Ging immer nur ums Mobilnetz, wenn jemand Probleme mit dem Radio hatte (bzw. umgekehrt).
     
  10. coolbit, 23.11.2011 #10
    coolbit

    coolbit Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    22.11.2011
    Habe das WLAN aus der Liste gelöscht, anschließend neu hinzugefügt und das Passwort eingegeben.
    Ergebnis: nach wie vor kann ich mich mit dem WLAN verbinden, es fließen jedoch keine Daten...

    Vorschläge wie ich weiter vorgehen soll?
     
  11. Sleepwalker, 23.11.2011 #11
    Sleepwalker

    Sleepwalker Android-Guru

    Beiträge:
    2,326
    Erhaltene Danke:
    219
    Registriert seit:
    03.12.2010
    Blockiert dein Router vllt. irgendetwas? Hast du mal versucht die komplette Sicherheit auszustellen? Ohne Verschlüsselung, kein MAC-Filter etc..

    Frage: Wenn du in "Menü, Einstellungen, Drahtlos und Netzwerke, WLAN-Einstellungen" schaust, was steht dort unter dem Punkt "WLAN"? "Verbunden mit ..."? Oder sowas wie "Beziehe Adresse von .."?
     
  12. coolbit, 23.11.2011 #12
    coolbit

    coolbit Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    22.11.2011
    Also ich bin für deine Hilfe ja sehr dankbar aber bitte beachte meine vorhergehenden Postings. Ich denke als WIler bin ich durchaus in der Lage solche Dinge wie Sicherheitseinstellungen im Router abzuklopfen bevor ich hier poste...

    Ganz abgesehen davon hat es unmittelbar vor dem Hack ohne Probleme funktioniert. Habe das Phone nun ja schon seit fast 9 Monaten. Auch das WLAN Symbol ist im oberen Infobereich sichtbar - also kann dort nicht "beziehe Adresse stehen". Und beim einwählen heute morgen stand in der Tat "Verbunden mit..." in dem von dir angesprochenen Menü.

    Ich denke nicht, dass das Problem derart oberflächlich ist sondern vermute eher, dass der Fehler etwas tiefer im Android-System steckt...
     
  13. Sleepwalker, 23.11.2011 #13
    Sleepwalker

    Sleepwalker Android-Guru

    Beiträge:
    2,326
    Erhaltene Danke:
    219
    Registriert seit:
    03.12.2010
    Na gut, ich klopfe halt lieber alles Schritt für Schritt ab. Manchmal sind es die banalsten Fehler. Dann muss dir halt wer anderes versuchen zu helfen.

    PS: Und das sage ich als u.a. gelernter FiSi ;)
     
  14. TimeTurn, 23.11.2011 #14
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,114
    Erhaltene Danke:
    2,895
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    hmmmm kann nichtmal sehen wovon das Radio stammt - ist nicht von den üblichen Verdächtigen wie 1.32, 1.72 oder 2.50. Selbst 2.36 hat schon 26.09.04.11_M2, d.H. 26.06.06.30_M muss noch älter sein. Wundert mich da nich das das zickt :)

    Nachtrag: Das Radio stammt vom 1.84.502.11 ROM, ist also noch für FroYo.

    Hast Du mal das Radio von 2.36/2.50 per Bootloader geflasht? Das hab ich damals nach dem AAHK-Hack gemacht:
    http://cmw.22aaf3.com/ace/radio/12.54.60.25_26.09.04.11/PD98IMG.zip

    Zu finden hier:
    [RADIO] HTC Desire HD Radios [PD98IMG.zip] (Updated: 7 Sept 2011) - xda-developers
     
    coolbit bedankt sich.
  15. coolbit, 23.11.2011 #15
    coolbit

    coolbit Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    22.11.2011
    Ja - ist ein Froyo mit T-Mobile Branding (was ich ganz nebenbei jetzt gerne endlich mal los werden würde weil es das ganze System total träge macht...)

    Radio flashen soll relativ riskant sein. Wenn du mir ein gutes Tutorial hättest würde ich mich da mal als nächstes ran wagen.
     
  16. TimeTurn, 23.11.2011 #16
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,114
    Erhaltene Danke:
    2,895
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Achso, Du hast noch FroYo? OK, dann ist das Radio an sich ja OK. In dem Fall vielleicht doch eher das Radio vom 2.2.1er stock ROM (1.72):
    http://cmw.22aaf3.com/ace/radio/12.28e.60.140f_26.04.02.17/PD98IMG.zip

    Wobei ich jetz nich sicher bin ob 1.7x/1.8x von T-Mobile überhaupt verfügbar war - hast Du eventuell 1.39? Dann wäre eher das von 2.2 (ohne .1) besser:
    http://cmw.22aaf3.com/ace/radio/12.28b.60.140e_26.03.02.15/PD98IMG.zip

    Wenn Du noch 1.39 hast wär das auch ne Erklärung, warum das Radio von 2.2.1 probleme macht.

    Das Flashen ist kein Problem, einfach die PD98IMG.ZIP ins Hauptverzeichnis der SD-Card packen und in den Bootloader starten - der sollte dann anbieten das zu flashen. Da kan nan sich nix passieren - ich hab schon X-mal ein Radio geflasht und nie ist was passiert - weder per Bootloader, noch manuell per Fastboot.
     
  17. coolbit, 23.11.2011 #17
    coolbit

    coolbit Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    22.11.2011
    Habe gerade mal nachgeschaut. Beim Booten in den HBoot steht bei mir in der obersten Zeile "SHIP S-OFF" und nicht (wie in den meisten Tutorials) "ENG S-OFF"
    Stellt das ein Problem dar?

    Ob ich RADIO S-OFF habe kann ich auch nicht feststellen, da ich keinen Punkt "System Info" im Bootloader finde.

    Ideen? Bevor das nicht beides korrekt eingestellt ist würde ich nur sehr ungerne rangehen...
     
  18. neandertaler19, 23.11.2011 #18
    neandertaler19

    neandertaler19 Ehrenmitglied

    Beiträge:
    10,344
    Erhaltene Danke:
    1,929
    Registriert seit:
    28.01.2011
    Ja AAHK macht nur Ship S-Off und nicht ENG S-Off. ENG S-Off kannst du nur über die "alten" Methoden erreichen, womit du dann den ENGineering Bootloader hast mit dem du dann fastboot-Befehle nutzen kannst.
    Du kannst dann Radios z.B. nur über PD98IMG.zip flashen und nicht über fastboot.
     
  19. coolbit, 23.11.2011 #19
    coolbit

    coolbit Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    22.11.2011
    Dann gleich die Frage hinterher: welches Tutorial wäre dafür (unter Berücksichtigung, dass ich bereits root habe) am besten geeignet? Die Hemmschwelle ist jetzt sowieso schon deutlich niedriger nachdem das rooten relativ reibungslos (mal abgesehen vom WLAN) funktioniert hat. Dann kann mans auch gleich "richtig" machen ;-)
     
  20. neandertaler19, 23.11.2011 #20
    neandertaler19

    neandertaler19 Ehrenmitglied

    Beiträge:
    10,344
    Erhaltene Danke:
    1,929
    Registriert seit:
    28.01.2011

Diese Seite empfehlen