1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

nach dem root geht die an/aus taste nicht

Dieses Thema im Forum "Root / Hacking / Modding für Sony Tablet S" wurde erstellt von xpickvogelx, 15.02.2012.

  1. xpickvogelx, 15.02.2012 #1
    xpickvogelx

    xpickvogelx Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    0
    Registriert seit:
    09.06.2011
    hab gerade das tablet gerootet. lief alles wunderbar. droidwall installiert etc.
    nach dem reboot funktioniert das auch alles weiterhin, aber die an/aus taste ist ohne funktion. kann das tab nicht mehr in den schlafmodus schicken und wenn das display von allein ausgeht, kann ich es nicht zurückholen. dann geht nur ein reboot. weiß jemand, was ich machen kann?
     
  2. xpickvogelx, 16.02.2012 #2
    xpickvogelx

    xpickvogelx Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    0
    Registriert seit:
    09.06.2011
    weiß sonst jemand, wie man den root wieder komplett rückgängig macht? konnte dazu bislang nichts finden... :wubwub:
     
  3. Wildsau, 16.02.2012 #3
    Wildsau

    Wildsau Fortgeschrittenes Mitglied

    Beiträge:
    396
    Erhaltene Danke:
    66
    Registriert seit:
    16.08.2010
    Phone:
    LG G4
  4. jannux, 16.02.2012 #4
    jannux

    jannux Android-Experte

    Beiträge:
    678
    Erhaltene Danke:
    84
    Registriert seit:
    22.09.2009
    Phone:
    auf Suche
    Tablet:
    Sony Xperia Tablet Z3 Compact
    Wenn ich mich richtig erinnere, hast Du auch mit einer Bluetooth Tastatur rumgespielt. Wenn du die generic.kl austauscht, funktioniert die an/aus-Taste nicht mehr.

    Gruss Jan
    Gesendet von meinem Sony Tablet S
     
  5. xpickvogelx, 16.02.2012 #5
    xpickvogelx

    xpickvogelx Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    0
    Registriert seit:
    09.06.2011
    man geil. das is es bestimmt... muss ich nachher checken. danke!!!!!!
     
  6. xpickvogelx, 16.02.2012 #6
    xpickvogelx

    xpickvogelx Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    0
    Registriert seit:
    09.06.2011
    hilfe, jetzt habe ich die ordner system/usr/keychar und system/usr/keylayout gelöscht um sie wieder mit den originalen zu überschreiben. weiß, war dumm. kann man nicht mehr ändern. leider kann ich jetzt keine einzige anwendung mehr starten. stürzen alle ab. per adb push geht auch nicht, weil er immer sagt das system wäre read only. gibt es irgend einen trick, wie ich die original firmware wieder draufbekomme? wo bekäme ich die her? man, was für ein scheiß. hab ich jetzt ein teures stück plastik, mit dem nix mehr zu machen is? KOTZ
     
  7. jannux, 16.02.2012 #7
    jannux

    jannux Android-Experte

    Beiträge:
    678
    Erhaltene Danke:
    84
    Registriert seit:
    22.09.2009
    Phone:
    auf Suche
    Tablet:
    Sony Xperia Tablet Z3 Compact
    Ich bin kein Experte, aber mir hat man mal gesagt, dass man so nen Ding immer retten kann, solange es noch angeht.
    Du hast nicht zufällig den post von obi... befolgt:

    http://www.android-hilfe.de/showthread.php?p=2711985

    Wenn nicht, kann ich Dir leider nicht helfen, such mal im xda- forum oder hoffe auf jemand anderen.

    oder:
    Vielleicht geht es aber auch mit fastboot, das weiss ich aber nicht beim Sony.

    oder:
    Wenn du mit adb noch drauf kommst, in einem meiner links zur bluetooth Tastatur wird beschrieben, wie man das keylayout auch ohne root ändern kann, vielleicht versuchst Du das. Ist eigentlich das gleiche wie bei root, nur nen anderes Verzeichnis.

    Das sind nur Gedanken und bleib ruhig bei der Geschichte. Wenn man im System rumfuscht, ist Ruhe und Genauigkeit oberstes Gebot.

    Ich drücke die Daumen.

    Gruss Jan

    Gesendet von meinem Sony Tablet S
     
  8. obicom, 17.02.2012 #8
    obicom

    obicom Android-Experte

    Beiträge:
    745
    Erhaltene Danke:
    200
    Registriert seit:
    09.03.2010
    Du kannst zwei Dinge probieren, solange du mit adb noch drauf kommst.

    1. du musst bei adb die shell öffnen und erst mal root starten ... danach erst per push den Ordner drauf kopieren ... und ggfs. die Rechte auf die Ordner und Dateien anpassen.

    also z.B.:
    adb shell
    su
    adb push keychar /system/usr/keychar
    chmod /system/usr/keychar 755
    u.s.w......

    2. du könntest versuchen per adb shell die build.prob herunterzuladen, auf dem PC zu ändern und wieder rauf zu spielen. Danach selber das Firmware Update per tab herunterladen (falls das noch ohne fc geht) oder jemanden fragen, der exakt das gleiche Modell hat, ob er dir die Datei uploaden kann. (siehe den Artikel den jannux oben verlinkt hat). Das sollte eigentlich auch funktionieren.

    Es ist noch ich alles verlohren. das sollte eigentlich zu korrigieren sein.
     
  9. jannux, 17.02.2012 #9
    jannux

    jannux Android-Experte

    Beiträge:
    678
    Erhaltene Danke:
    84
    Registriert seit:
    22.09.2009
    Phone:
    auf Suche
    Tablet:
    Sony Xperia Tablet Z3 Compact
    Auf das "su" hätte ich auch kommen können. Ist naheliegend.

    Aber ist das korrekt?
    adb push keychar /system/usr/keychar
    keychar ist nen ordner, müsste es da nicht
    adb push keychar /system/usr/
    heissen?

    Gruß Jan
     
  10. obicom, 17.02.2012 #10
    obicom

    obicom Android-Experte

    Beiträge:
    745
    Erhaltene Danke:
    200
    Registriert seit:
    09.03.2010
    klar, mit dem Ordner hast du wohl recht ...
    war auch schnell aus der Hüfte geschossen ....
    aber prinzipiell sollte es so gehen.
     
  11. xpickvogelx, 17.02.2012 #11
    xpickvogelx

    xpickvogelx Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    0
    Registriert seit:
    09.06.2011
    Registriert seit: 09.06.2011
    Beiträge: 7
    Abgegebene Danke: 0
    Erhielt 0 Danke für 0 Beiträge


    [​IMG] AW: adb shell "error: device not found"
    also der superuser scheint nicht mehr zu funzen. ich kann nichts in der shell pushen. kommt immer error: device not found. jetzt wollte ich die "build.prob" pullen, um sie zu modifizieren: angeblich ist unter system/etc/ "no such file". kann die woanders sein? kann ich da einfach eine andere hinschieben. hat jemand eine für mich und mein tablet. es ist ein "16gb wifi" build nummer THMAS0072400 .... würg. jetzt hab ich bald bock das teil mit nem hammer zu bearbeiten.
     
  12. xpickvogelx, 17.02.2012 #12
    xpickvogelx

    xpickvogelx Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    0
    Registriert seit:
    09.06.2011
    also der superuser scheint nicht mehr zu funzen. ich kann nichts in der shell pushen. kommt immer error: device not found. jetzt wollte ich die "build.prob" pullen, um sie zu modifizieren: angeblich ist unter system/etc/ "no such file". kann die woanders sein? kann ich da einfach eine andere hinschieben. hat jemand eine für mich und mein tablet. es ist ein "16gb wifi" build nummer THMAS0072400 .... würg. jetzt hab ich bald bock das teil mit nem hammer zu bearbeiten.
     
  13. obicom, 18.02.2012 #13
    obicom

    obicom Android-Experte

    Beiträge:
    745
    Erhaltene Danke:
    200
    Registriert seit:
    09.03.2010
    Was passiert denn genau?
    'adb shell' kannst du aufrufen?
    Danach gibst du 'su' ein?
    Kommt da ne Fehlermeldung?
    Wenn ja, welche?

    Ein paar mehr Angaben würden schon hilfreich sein, sonst nimm echt den Hammer. ;-)
     
  14. xpickvogelx, 18.02.2012 #14
    xpickvogelx

    xpickvogelx Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    0
    Registriert seit:
    09.06.2011
    adb shell geht. dann ist eine raute zu sehen. dann gebe ich su ein und daraus wird ein fragezeichen. wenn ich dann adb push keychars /system/usr/ eingebe kommt : error no device. vlt mach ich ja auch was falsch. uebrigens danke fuer die hilfe. weiss das sehr zu schaetzen.*superuser wird auf dem tab noch angezeigt, aber koennte defekt sein. ich habe naemlich probiert ihn zu deinstallieren und auch das busybox file geloescht um den root rueckgaengig zu machen.das war noch bevor ich den unsinn mit dem generic.kl fabriziert habe.im nachhinein alles ziemlicher kaese.havb auch nochmal probiert superuser durch wiederholen des rootscriptes zu reparien. da sagt das script aber nach dem letzten boot, das busybox und su nicht angelegt werden konnten, weil das system read only ist. hinterher wir superuser aber wieder auf dem tab angezeigt.programme wie rootexplorer habe ich ueber adb schon installiert bekommen. sie stuerzen nur sofort ab. ist echt verzwickt.
     
  15. obicom, 18.02.2012 #15
    obicom

    obicom Android-Experte

    Beiträge:
    745
    Erhaltene Danke:
    200
    Registriert seit:
    09.03.2010
    Also su scheint zu funktionieren. Scheinbar liegt der Fehler im Syntax, bzw. am Ort wo der Ordner liegt. Beschreibe bitte mal, wo bei dir auch dem Rechner genau der keychars Ordner liegt.

    Für das was du da eingibst, müsste er nämlich direkt im Verzeichnis liegen, von wo aus die adb gestartet hast. Ist dem so?
     
  16. xpickvogelx, 18.02.2012 #16
    xpickvogelx

    xpickvogelx Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    0
    Registriert seit:
    09.06.2011
    ja der ist in dem adb verzeichnis auf dem desktop. hab ich extra dahin kopiert um nicht ewige pfade eingeben zu müssen.

    kann man vielleicht keine ordner kopieren, sondern nur files?
    die alten "keychars" und "keylayout" ordner hab ich ja leider gelöscht. muss ich die vielleicht vorher anlegen?
    müsste ja mit dem befehl "adb mkdir /system/usr/keychars" etc gehen. funzt aber nicht. bediene ich das vlt. falsch?
     
  17. obicom, 18.02.2012 #17
    obicom

    obicom Android-Experte

    Beiträge:
    745
    Erhaltene Danke:
    200
    Registriert seit:
    09.03.2010
    Eigentlich kannst du Ordner kopieren.
    (Ich geh natürlich davon aus, das USB Debugging auf dem Tab aktiviert ist)
    Probiere bitte einmal folgendes:
    Öffne unter Windows die Konsole mit 'cmd'
    dann gehe zu deinem adb Ordner, bei mir z.b. mit 'cd C:\android-sdk-windows\tools'
    dann gibt dort nach einander bitte folgendes ein:

    und sag mir dann bitte was nach jedem Befehl die Ausgabe auf der Konsole war.
     
  18. xpickvogelx, 18.02.2012 #18
    xpickvogelx

    xpickvogelx Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    0
    Registriert seit:
    09.06.2011
    bin jetzt bis 15.00 bei der arbeit. danach mach ich es sofort. das stück plastik in meinem regal lässt mir keine ruhe. nochmal danke für die hilfe...
     
  19. xpickvogelx, 18.02.2012 #19
    xpickvogelx

    xpickvogelx Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    0
    Registriert seit:
    09.06.2011
    hab es ausprobiert und auch nochmal alles in einer shell ausprobiert... hab die ergebnisse als jpg in einer pm angehängt.
     
  20. xpickvogelx, 18.02.2012 #20
    xpickvogelx

    xpickvogelx Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    0
    Registriert seit:
    09.06.2011
    ok, man kann keine jpg versenden. hier also die ergebnisse als getipptes:

    adb devices
    428.... device

    adb remount
    remount failed: operation not permitted

    adb push keychars /system/usr
    faild to copy... : read only file system


    wenn ich eine shell öffne, akzeptiert er su
    beim pushen kommt aber

    daemon not running, starting it now on port...
    daemon startet successfully
    error: device not found

    hmmmm
     

Diese Seite empfehlen