1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Nandroid funktioniert mit neuer SD-Karte nicht

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von nelty, 06.02.2011.

  1. nelty, 06.02.2011 #1
    nelty

    nelty Threadstarter Android-Experte

    Beiträge:
    542
    Erhaltene Danke:
    86
    Registriert seit:
    21.03.2010
    Hallo!

    Ich nutze seit einiger Zeit in meinem Milestone nicht mehr die mitgelieferte SD-Karte, sondern eine mit 16 GB von Sandisk. Mit der Karte funktioniert auch alles reibungslos, aber ich habe ein Problem:

    Nandroid lässt sich nicht mehr nutzen!

    Wenn ich versuche ein Backup zu erstellen, bleibt Nandroid einfach bei "boot: Dumping" hängen und nichts passiert. Ob das Restoren geht habe ich bisher nicht ausprobiert, weil ich ja bisher kein Backup vom aktuellen Stand anlegen kann...

    Leider habe ich die alte SD-Karte verkauft und kann sie also nicht zeitweise nutzen, um ein Backup zu machen.

    Was kann ich tun?
     
  2. Christoffer, 06.02.2011 #2
    Christoffer

    Christoffer Android-Experte

    Beiträge:
    505
    Erhaltene Danke:
    160
    Registriert seit:
    02.02.2010
    Hast du sie schon übers Milestone formatiert?

    settings>Speicher>SD Karte löschen/formatieren

    Vorher natürlich alle Daten sichern von der Karte ;)
     
    nelty bedankt sich.
  3. k1l, 07.02.2011 #3
    k1l

    k1l Android-Lexikon

    Beiträge:
    1,317
    Erhaltene Danke:
    404
    Registriert seit:
    20.12.2009
    Tablet:
    HP Touchpad
    gibt aber scheinbar auch inkompaktibilitäten mit einigen sd-karten.
    aber ich würde erstmal formatieren und dann schauen
     
  4. -FuFu-, 07.02.2011 #4
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    erstmal die open recovery von der sdcard löschen und neu drauf kopieren, und testen ob es dann geht, wenn nicht einmal Formatieren und dann nochmal testen
     
  5. dotartist, 09.02.2011 #5
    dotartist

    dotartist Erfahrener Benutzer

    Beiträge:
    158
    Erhaltene Danke:
    25
    Registriert seit:
    26.07.2010
    Hatte die selben Probleme mit meiner 16GB Class 2 SanDisk. Habe sie mehr mals formatiert, und neu befüllt, aber Nandroid hatte immer Probleme. Der SD-Card Check von der OpenRecovery meldete auch andauernd irgendwelche kaputten Sektoren...
    Zum modden nehm ich deswegen noch meine alte.
     
  6. kllar, 09.02.2011 #6
    kllar

    kllar Android-Experte

    Beiträge:
    520
    Erhaltene Danke:
    9
    Registriert seit:
    17.08.2010
    Phone:
    Motorola Milestone
    Hatte auch das selbe Problem, hab's leider immer noch, auch nach Formatieren der SD-Card.
     
  7. szallah, 10.02.2011 #7
    szallah

    szallah Android-Lexikon

    Beiträge:
    1,009
    Erhaltene Danke:
    126
    Registriert seit:
    20.11.2009
    Phone:
    Motorola Razr i
    gab's da nicht mal was mit ner bestimmten block-size die besonders gut geeignet ist für androiden? ich hab mich nie dran gehalten und weiß da nix genaueres drüber, aber nen versuch könnt's ja wert sein... wenn da jemand mehr weiß (also ob da was dran ist oder nicht) wäre da ne passende info hilfreich... :)
     
  8. selbaer, 10.02.2011 #8
    selbaer

    selbaer Fortgeschrittenes Mitglied

    Beiträge:
    313
    Erhaltene Danke:
    30
    Registriert seit:
    10.03.2010
    Phone:
    Motorola Milestone
    Zu allererst: Wenn nandroid zickt wird das nichts mit der Cluster-Size zu tun haben.
    Ansonsten ist das ein wenig eine "Glaubensfrage".
    Ich hatte auch mal das Problem mit Nandroid und nach einem Format mit 32kiB CS geht das löschen/kopieren auf der SD-Karte via Handy spürbar schnller (SanDisk Mobile Ultra 8GB).

    HierFAT32 Performance Tradeoff: FAT32 Cluster Sizes and FAT Sizes wird ein Performance Vergleich gemacht und pro und contra abgewogen. Allerdings lässt sich das nicht so einfach 1 zu 1 auf SD-Karten im Handy übertragen.
     
  9. nelty, 10.02.2011 #9
    nelty

    nelty Threadstarter Android-Experte

    Beiträge:
    542
    Erhaltene Danke:
    86
    Registriert seit:
    21.03.2010
    Also nachdem ich formatiert habe, hat es auch alles andere als reibungslos funktioniert. Aber nach mehreren Versuchen ist das Backup jetzt tatsächlich mal durchgelaufen! Juchu!

    Finde das echt total bescheuert. Wenn ich gewusst hätte, dass das ein Problem ist hätte ich die originale SD-Karte ja behalten, aber jetzt ist es zu spät...
     

Diese Seite empfehlen