1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Nur noch APX obwohl verschiedene Backups ausprobiert. Hier die Holzhammer Methode.

Dieses Thema im Forum "Anleitungen für HANNspree HANNSpad (SN10T1)" wurde erstellt von mikaole, 28.10.2011.

  1. mikaole, 28.10.2011 #1
    mikaole

    mikaole Threadstarter Gast

    So, da dieser Beitrag in einem Thread untergegangen ist hier noch einmal eine Anleitung für die Jenigen, die schon viele Backups ausprobiert haben und trotzdem nur der APX Modus bleibt. Mit dieser Anleitung habe ich schon 5 Pads aus dem absoluten Tiefschlaf geholt, also es sollte eigentlich immer klappen.

    Alles geschieht auf eigene Gefahr. Ich bin nicht für eventuelle Schäden und Garantieverluste verantwortlich.


    Pad angeschaltet, geht automatisch in APX.
    Im Ordner Format nvflash_gtablet gestartet. Ja gtablet :)
    Nvlash laufen lassen
    Pad aus und wieder an gestellt ist wieder im APX
    Im Ordner Working_HannsPad PowerOnRepair nvflash_gtablet gestartet
    Danach bootet es durch in ein Gtablet Rom mit Gtablet Bootlogo :)
    Durchbooten lassen. Wenn im System USB Übertragung aktivieren und die Datei update-smb_a1007-4789-user(1)(vorher in update.zip unbenennen) auf das Hauptverzeichnis eures Speichers ablegen. Dort solltet ihr auch euer gewünschtes Rom und den Kernel ablegen. USB deaktivieren.
    Sollte das Gtablet Rom nicht durchbooten könnt ihr euch die 3 Sachen auch im CW Recovery draufspielen.
    Power off kurz gedrückt halten und dann auf Herunterfahren.
    Pad wieder anschalten. Sollte wieder nur im APX Laufen.
    Im Ordner Working_HannsPad PowerOnRepair nvflash_CWM bei gedrückter - Taste starten.
    - Taste gedrückt halten bis er im Recovery ist. Dort bitte 3x Wipe Data Factory reset durchführen und jeweil 1x wipe cash und unter advanced wipe Dalvik cache.
    Wenn das Gtablet Rom nicht gebootet hat könnt ihr hier jetzt unter Mounts and Storage den USB Speicher aktivieren und die Sachen rüberziehen.
    Danach apply update.zip
    Danach ausschalten. Wieder einschalten und ihr solltet wieder im APX sein.
    Im Ordner Im Ordner Working_HannsPad PowerOnRepair die Datei clockworkmod in clockworkmod1 umbenennen, dann clockworkmod2 in clockworkmod umbenennen.
    Dann wieder mit gedrückter - Taste nvflash_CWM ausführen, - Taste gedrückt halten bis er im Recovery ist. Dort bitte 3x Wipe Data Factory reset durchführen.
    Noch einmal Apply update Zip. Durchlaufen lassen.
    Aus und wieder anschalten. Sollte wieder im APX sein.
    Im Ordner Im Ordner Working_HannsPad PowerOnRepair die Datei clockworkmod in clockworkmod2 umbenennen, dann clockworkmod1 in clockworkmod umbenennen.
    Im Ordner Working_HannsPad PowerOnRepair nvflash_CWM bei gedrückter - Taste starten.
    - Taste gedrückt halten bis er im Recovery ist. Nun solltet Ihr wieder im CW recovery sein.
    Dort bitte 3x Wipe Data Factory reset durchführen und jeweil 1x wipe cash und unter advanced wipe Dalvik cache.
    Nun auf install zip from sdcard, dann choose zip from sd, dann euer Rom auswählen und flashen. danach das Gleiche mit dem Kernel.
    Dann auf Reboot und hoffen.
    [FONT=&quot]Bei mir hat es so geklappt, hoffe es hilft auch anderen.

    Keine Ahnung, ob einige Sachen doppelt und unnötig waren, aber so hat es geklappt.
    Die sachen findet ihr bei mir im Ordner Unbrick. einfach runter laden und entpacken.

    Dort ist auch noch einmal ein HOWTO in Deutsch und in English.

    [/FONT][​IMG][FONT=&quot]
    [/FONT]
     
    Zuletzt von einem Moderator bearbeitet: 17.02.2012
    Typhoon1969, Sculture, felix1711 und 5 andere haben sich bedankt.
  2. razorblade2011, 03.11.2011 #2
    razorblade2011

    razorblade2011 Threadstarter Gast

    Hallo erst einmal an alle Hannsler und großen Dank an all diejenigen, die hier schreiben und helfen.

    Ich habe mein Hanns letzten Montag bekommen und natürlich gleich alle Roms getestet. Dabei ist mir dann der Fehler unterlaufen Flashback 10 zu flashen ohne vorher die Partitionen anzupassen. Dann ging garnichts mehr.

    Danach habe ich bestimmt 20 verschiedene Backups über NVflash versucht, aber nada, immer wieder APX.

    Hatte diesen Thread schon vorher einmal gesehen, mich aber nicht getraut. Irgendwann dachte ich, naja, probiers einfach und siehe Da mein Hanns, zwischenzeitlich Gtablet :) läuft wieder.

    Danke Mikaole für diese ausführliche Beschreibung.

    Übrigens, bei mir hat das Gtablet Rom nicht durchgebootet. Habe dann in dem grünen Recovery, wie beschrieben, einfach usb gemountet und dann die Files rübergezogen und dann mit deiner Beschreibung weiter gemacht.

    Vielen Dank nochmal

    Georg
     
  3. mikaole, 03.11.2011 #3
    mikaole

    mikaole Threadstarter Gast

    Gern geschehen :)
     
  4. mikaole, 09.11.2011 #4
    mikaole

    mikaole Threadstarter Gast

    da mein unbrick file jetzt schon 200x runtergeladen wurde wollte ich mal nachfragen, ob es da Hinweise gibt. Läuft es, hat alles so geklappt, oder hat es nicht geklappt, wenn nicht, wo seit ihr hängen geblieben. Vielleicht kann man das ganze ja noch verbessern.
     
  5. Freddy_1950, 13.11.2011 #5
    Freddy_1950

    Freddy_1950 Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    08.11.2011
    Hallo, ich habe mein HANNSpad (1653) vor einer Woche von Alternate erhalten.
    Nach einem ersten Funktionstest wollte ich das Sytem mit NVFlash sichern.
    Dabei lies sich von den 13 Partitionen die Part.10-OGO (131072/16777216 bytes received) nicht sichern. Nach der Formatierung dieser Partition lief das Backup ohne Probleme durch. Nach dem Restore hatte ich aber nur noch den APX-Modus.
    Danach habe ich alle verfügbaren StockROM-Restores, ohne Erfolg ausprobiert
    (einmaliger Start mit --go dann wieder nur APX).

    Ich bin dann teilweise nach der Anleitung von mikaole vorgegangen. Nach der Formatierung (jetzt 11 Partitionen mit anderer Belegung) und Start des
    Gtablet Rom habe ich, über USB, die update.zip (Original ROM 1.3-5303) aufs
    pad kopiert. Nach dem Herunterfahren kam ich erstaunlicher weise wieder ins normale Android Recovery. Ich habe dann die update.zip installiert. Und das System lief wieder.
    Dann habe ich ein NVFlash Backup/Restore gemacht. Das pad bleibt im Hanns-Logo hängen, mann kommt aber ins Recovery und damit zur erneuten Installation des StockROM. Den aktuellen Stand kann man so wohl nicht sichern.

    Inzwischen habe ich zum Testen den CWM, Flashback_10.0_easy und ab_kernelv4Release-2-32-44-04 installiert.

    Kann mir jemand den Sinn, der bei mir jetzt fehlenden, NVC- und KLO-Partition erklären ?

    Nochmal vielen Dank

    Freddy
     
  6. hwguruks, 13.11.2011 #6
    hwguruks

    hwguruks Neuer Benutzer

    Beiträge:
    1
    Erhaltene Danke:
    0
    Registriert seit:
    13.11.2011
    Schöne Anleitung jedoch wird bei mir nur das dauerhafte logo angezeigt, in den apx modus (mit + und Power) scheint es zu gehn jedoch sagt windows immer "usb gerät wurde nicht erkannt" und wenn ich den ordner und die nvidiausb auswähle kann ich halt mehrere Geräte auswählen aber keins geht, habe dies schon auf ca. 5 rechnern ausprobiert, gibts noch eine Rettung ??? Zur Info, Gerät war abends mit FBeasy10 noch lauffähig, danach runtergefahren und morgen ging nix mehr.

    Danke im vorraus.
     
  7. espe, 15.02.2012 #7
    espe

    espe Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    4
    Registriert seit:
    09.12.2011
    Was soll man da sagen ... der Ziegelstein ist wieder zu einem Hannspad mutiert!

    Naja, das Hannspad war meine Wahl, weil man damit allerhand anstellen kann :)
    Und ich Vertrauen darauf habe, dass sich irgendwo eine Lösung finden, wenn was schiefgeht. Diesmal sah es nicht so gut aus, bis mikaoles Holzhammermethode auftauchte. Danke!!!!!!

    Zum Ablauf: Nach dem Flash im Ordner Format taucht die Meldung "Magic value mismatch" auf. Nochmal gemacht: Auch beim 2. Durchlauf. Das hat offenbar nicht zu sagen.

    Durchgestartet ist gtab bei mir nicht. Es kamen mehrere Tap'n'Tap-Anzeigen und dann ein schwarzer Bildschirm.

    Das Ganze passierte unter Windows 8 pre. Sonst läuft bei mir Linux. Ich hatte etwas mit Kontaktverlusten zu kämpfen bei nvflash_CWM. Nachdem ich die Terminalfenster nicht geschlossen habe, schien es besser zu werden. Irgendwie klappte es dann auch nicht mit dem letzten Start unter Clockworkmod1. APX Kontakt verloren. Aber das Hannspad startete durch und schnappte sich das update.zip mit dem Stockrom auf der externen SD-Karte. Alles sieht so aus wie im Originalzustand.

    Nochmal Danke -- bis zum nächsten Mal ;-)
    Ernst
     
    Zuletzt bearbeitet: 16.02.2012
  8. HannsWerner, 11.03.2012 #8
    HannsWerner

    HannsWerner Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    11.03.2012
    @mikaole

    Hab das selbe Problem mit dem APX-Modus wie Hanns, der sein Hannspad Dir zugeschickt hat und Du hast es wieder zum Laufen bekommen. Vieleicht kannst Du mir auch weiterhelfen?

    Hatte FB 10 easy auf dem Hans und ne ganze Weile die ICS-Story von Fards verfolgt. Nachdem dann jetzt der antibyte-kernel da ist, wollte ich natürlich auch auf die ICS-Version von DRH mit dem Antibyte-Kernel wechseln.

    Hab mich dann an die Anleitung von 4dro1d gehalten. Nachdem ich Fards konfiguriertes Backup ausgeführt habe, bin ich nicht in den Recovery-Modus gekommen und hänge seitdem nur noch im APX-Modus.

    Habe verschiedene NVflash-Backups versucht aufzuspielen, leider ohne Erfolg.

    Habe jetzt dein Unbrick-Package geladen und den Anweisungen gefolgt. Habe nach dem NVFlash-gtablet folgenden roten Hinweis:

    "Magic value mismatch:"

    NVFlash sendet immer erst ab Partition 4. 2 und 3 werden bei sämtlichen backups die probiert habe nicht übertragen, also so wie damals bei Hanns.



    Hast Du ne Idee?

    Danke vorab.
     
    Zuletzt bearbeitet: 11.03.2012
  9. mikaole, 11.03.2012 #9
    mikaole

    mikaole Threadstarter Gast

    das missmatch ist ganz normal nach dem format.

    einfach noch einmal das gtablet rom flashen und versuchen ins recovery zu kommen. Alternativ kannst Du auch versuchen ein anderes backup einzuspielen. wichtig ist, dass du wieder ins stock Recovery kommst und da dann das stockrom per update.zip flashen kannst, da hier alles noch einmal angepasst wird.
     
    HannsWerner bedankt sich.
  10. espe, 11.03.2012 #10
    espe

    espe Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    4
    Registriert seit:
    09.12.2011
    Hallo HannsWerner,

    ich habe das gleiche Problem. Mein Hannspad hängt bei jedem NVflash im APX Modus. Nur das gtablet rom bootet zumindest.
    Wenn Du allerdings auf ICS gehen willst, hilft Dir das nicht weiter, denn so bekommst Du nie die Partitionen hin.

    Lösung:
    Der NVflash von Fards Partitionen sollte ohne Fehlermeldung durchlaufen.
    Dann nicht den gtablet rom flashen, das überschreibt ja wieder die Partitionen, sondern so weitermachen:

    - Den Stockrom-6039 als update.zip auf die externe SD-Karte schreiben. (Falls Du ihn nicht schon auf der internen SD-Karte hast)
    - Ins Power-on-repair Verzeichnis gehen.
    - clockworkmod.img in clockworkmod1.img umbenennen
    - clockworkmod2.img in clockworkmod.img umbenennen
    - In der nvflash_CWM.bat die "9" durch "11" ersetzen.
    - Wie beschrieben nvflash_CWM mit gedrückter Vol- Taste am Pad starten. Du solltest in den recovery modus kommen.
    - Wipen (?)
    - update.zip starten.
    - Pad neu starten, geht vermutlich wieder in den APX-Modus.
    - nochmal die nvflash_CWM durchführen.
    - gegebenenfalls nochmal update.zip starten

    Das Pad sollte jetzt durchstarten mit dem Stockrom, aber den Fards Partitionen.
    - ICS installieren.

    Läuft bei mir hervorragend.
     
    HannsWerner bedankt sich.
  11. HannsWerner, 11.03.2012 #11
    HannsWerner

    HannsWerner Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    11.03.2012
    Hey, danke für die schnellen Antworten.

    @Mikaole insbesondere zu dieser späten Stunde.

    Wird denn das Stock Recovery mit NVFlash überspielt oder ist es fest im Hannsi hinterlegt?

    Und das NVFlash immer nur ab Partition 4 überträgt ist unerheblich?

    Ich werde die Hinweise gleich ausprobieren und mich dann wieder melden.
     
    Zuletzt bearbeitet: 11.03.2012
  12. HannsWerner, 11.03.2012 #12
    HannsWerner

    HannsWerner Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    11.03.2012
    So hab jetzt mehrmals wie von espe beschrieben verscucht über die geänderten Einträge ins Recovery zu kommen, leider ohne Erfolg.

    Meine Vorgehensweise:

    1.
    Fards NVFlash Patitionen durchlaufen lassen. NVFlash sendet erst ab Partition 4 und am Ende scheint auch eine Fehlermeldung zu kommen, aber die kann ich nicht erkennen, da NVFlash sich schließt.

    2. Die umbenannten cwm-Dateien mit gedrückter Minustaste die geänderte cwm.bat ausgeführt.

    Es erscheint kein Recovery, sondern folgende Fehlermeldung:


    D:\Eigene Dateien\Hannspad flashen\unbrick\Unbrick\Working_HannsPad PowerOnRepai
    r\Working_HannsPad PowerOnRepair>"nvflash.exe" --bl bootloader.bin --download 11
    clockworkmod.img --go
    Nvflash started
    rcm version 0X20001
    System Information:
    chip name: t20
    chip id: 0x20 major: 1 minor: 3
    chip sku: 0x8
    chip uid: 0x171411c0411fe197
    macrovision: disabled
    hdcp: enabled
    sbk burned: false
    dk burned: false
    boot device: nand
    operating mode: 3
    device config strap: 0
    device config fuse: 0
    sdram config strap: 0

    downloading bootloader -- load address: 0x108000 entry point: 0x108000
    download command failed NvError 0x120002
    command failure: bootloader download failed (bad data)
    bootloader status: Bct file not found (code: 21) message: flags: 1073840124



    Was mir noch aufgefallen ist, ist dass beim Überspielen von Fards Partitionen neben den Partitionen 2 und 3 auch die Partition 8 nicht übertragen wird.

    Habt ihr noch ne Idee?

    Werde nochmals nach dem Gtablet aus dem FORMAT-Ordner andere Backups probieren.
     
    Zuletzt bearbeitet: 11.03.2012
  13. HannsWerner, 11.03.2012 #13
    HannsWerner

    HannsWerner Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    11.03.2012
    Auch beim Gtablet aus Mikaole´s Unbrick wird nur Partition 4 - 10 + system.img übertragen. Ohne Fehlermeldung von NVFlash, nur dieses "Magic value match".


    D:\Eigene Dateien\Hannspad flashen\unbrick\Unbrick\FORMAT\FORMAT>"nvflash.exe"
    -bct gtablet.bct --setbct --bl bootloader.bin --configfile gtablet.cfg --creat
    --go
    Nvflash started
    rcm version 0X20001
    System Information:
    chip name: t20
    chip id: 0x20 major: 1 minor: 3
    chip sku: 0x8
    chip uid: 0x171411c0411fe197
    macrovision: disabled
    hdcp: enabled
    sbk burned: false
    dk burned: false
    boot device: nand
    operating mode: 3
    device config strap: 0
    device config fuse: 0
    sdram config strap: 0

    sending file: gtablet.bct
    - 4080/4080 bytes sent
    gtablet.bct sent successfully
    downloading bootloader -- load address: 0x108000 entry point: 0x108000
    sending file: bootloader.bin
    | 928945/928945 bytes sent
    bootloader.bin sent successfully
    waiting for bootloader to initialize
    bootloader downloaded successfully
    setting device: 1 0
    creating partition: BCT
    creating partition: PT
    creating partition: EBT
    creating partition: MBT
    creating partition: BLO
    creating partition: MSC
    creating partition: OGO
    creating partition: SOS
    creating partition: LNX
    creating partition: APP
    creating partition: CAC
    Formatting partition 2 BCT please wait.. done!
    Formatting partition 3 PT please wait.. done!
    Formatting partition 4 EBT please wait.. done!
    Formatting partition 5 MBT please wait.. done!
    Formatting partition 6 BLO please wait.. done!
    Formatting partition 7 MSC please wait.. done!
    Formatting partition 8 OGO please wait.. done!
    Formatting partition 9 SOS please wait.. done!
    Formatting partition 10 LNX please wait.. done!
    Formatting partition 11 APP please wait.. done!
    Formatting partition 12 CAC please wait.. done!
    done!
    sending file: part4.img
    / 2097152/2097152 bytes sent
    part4.img sent successfully
    sending file: part5.img
    \ 131072/131072 bytes sent
    part5.img sent successfully
    sending file: part6.img
    / 4194304/4194304 bytes sent
    part6.img sent successfully
    sending file: part7.img
    / 16777216/16777216 bytes sent
    part7.img sent successfully
    sending file: part8.img
    / 33554432/33554432 bytes sent
    part8.img sent successfully
    sending file: part9.img
    / 16777216/16777216 bytes sent
    part9.img sent successfully
    sending file: part10.img
    / 16777216/16777216 bytes sent
    part10.img sent successfully
    sending file: system.img
    \ 117292032/117292032 bytes sent
    system.img sent successfully
    Press enter to continue:

    Bekomme aber anschließend kein Backup eingespielt, weil immer die Partitionen 2 und 3 nicht übertragen werden.

    Es muss an diesen beiden fehlenden Partitionen liegen, oder?
     
    Zuletzt bearbeitet: 11.03.2012
  14. espe, 11.03.2012 #14
    espe

    espe Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    4
    Registriert seit:
    09.12.2011
    Hmmm, wenn der nvflash für Fards Partitionen eine Fehlermeldung bringt, geht es auch mit dem nvflash_CWM wohl nicht weiter. Das die Partitionen 2 und 3 nicht übertragen werden ist ok so. Bei Fards wird auch die Partition 8 nicht übertragen. Ist so vorgesehen. Am besten, erst mal den unbrick wie vorgesehen machen und das Pad wieder zum laufen bringen.

    Der nvflash für den gtablet rom sieht gut aus. Hier musst Du dann aber genau wie in der unbrick-Anleitung weitermachen. Download nach 9, die beiden clockwordmod-images nacheinander.

    Gruß
    Espe
     
    HannsWerner bedankt sich.
  15. mikaole, 11.03.2012 #15
    mikaole

    mikaole Threadstarter Gast

    du musst auch erst das GTablet Rom flashen. Kommst Du denn dort ins Recovery? Dann könnte man zumindest über eine externe SD weiter machen.
     
    HannsWerner bedankt sich.
  16. HannsWerner, 11.03.2012 #16
    HannsWerner

    HannsWerner Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    11.03.2012
    Danke für Euer Engagement. Werde heute leider nicht mehr dazu kommen weiter zu machen. Werde es nochmal die Tage mit unbrick gem. Anleitung versuchen und dann wieder posten wie es aussieht. Heute hab ich Verbot von meiner Frau :angry: und meine beiden Kids haben mich heute auch den ganzen Tag gefordert.

    Ich bleib dran. Danke für die Hilfe.
     
  17. Schnulzi 2.0, 12.03.2012 #17
    Schnulzi 2.0

    Schnulzi 2.0 Android-Experte

    Beiträge:
    468
    Erhaltene Danke:
    93
    Registriert seit:
    10.02.2011
    Nur mal so, falls jemand Probleme mit Fehlermeldungen hat, weil sich das Fenster zu schnell schließt: Ihr könnt euch aus Windows -> System 32 die cmd.exe in den Ordner mit NVFlash kopieren. Wenn ihr von da aus die Batch-Dateien startet, dann bleibt das Fenster offen.

    Man kann zwar auch über Ausführen -> cmd das DOS-Fenster starten, aber dann muss man immer erst in den richtigen Ordner navigieren. Ich habe eine Kopie der cmd.exe unter Eigene Dateien und ziehe die dann mit gedrückter Strg-Taste immer in den jeweiligen Ordner.

    Wenn man öfter mal mit der Kommandozeile zu tun hat (ADB oder eben NVFlash z.B.), dann ist das ganz praktisch.
     
    HannsWerner und Datenwolf haben sich bedankt.
  18. Datenwolf, 12.03.2012 #18
    Datenwolf

    Datenwolf Android-Experte

    Beiträge:
    723
    Erhaltene Danke:
    103
    Registriert seit:
    03.09.2011
    klingt ganz nach einschicken... mikaole du kannst doch mal deine adresse hier reinstellen denn kann jeder gleich den hannsi zu dir schicken und das forum bleibt sauber.....
    :D
     
  19. HannsWerner, 14.03.2012 #19
    HannsWerner

    HannsWerner Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    1
    Registriert seit:
    11.03.2012
    Zum Glück nicht mehr notwendig. Ich weiß zwar nicht wieso, aber nachdem ich die cmd.exe mal über geschoben habe, um mir mal die Fehlermeldung beim Einspielen von Fards Backup anzuschauen, hab ich doch seit Tagen mal wieder das Hannspree-Logo zu sehen bekommen. Wieso auch immer. Wusste schon gar nicht mehr wie es aussieht. :thumbsup:

    Danke noch mal an alle die sich bei der Fehlersuche eingeschaltet haben.

    ICS Drh-team mit antibyte-Kernel 1.0 funzt
     
  20. mikaole, 14.03.2012 #20
    mikaole

    mikaole Threadstarter Gast

    naja, jetzt habe ich ja gerade eins hier an dem ich verzweifle
     

Diese Seite empfehlen