1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Odys Loox - Ad-hoc-Netz?

Dieses Thema im Forum "Odys Loox Forum" wurde erstellt von rob.s, 07.11.2011.

  1. rob.s, 07.11.2011 #1
    rob.s

    rob.s Threadstarter Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    07.11.2011
    Hallo,

    ich bin neu bei Android und erst recht mit dem Loox.

    Ich habe folgendes Problem: Android unterstützt ja nicht Ad-Hoc Netzwerke, mein JoikuSpot PRemium auf dem Nokia kann aber nichts anderen, infrastructure Mode ist bei dem Chip nicht möglich.

    Ich habe mittlerweile auch schon mal mir eine neues system.img mit einer modifizierten wpa_supplicant (Diverse aus verschiedenen Foren) erzeugt (Danke an darkwing), aber kein Erfolg.:sad:

    In diesem Falle bekam ich immer 'error' beim Starten des WLAN. Hat damit schon jemand Erfolg gehabt?

    Danke!
     
  2. darkwing, 07.11.2011 #2
    darkwing

    darkwing Android-Experte

    Beiträge:
    516
    Erhaltene Danke:
    128
    Registriert seit:
    11.11.2010
    Problem ist... allein mit dem ändern der System.img kommst Du nicht wirklich weit da die WLAN Daten sehr zeitig in der init.sh initialisiert werden. Die kannst du nur in der Boot.img ändern. Ginge über Umwege auch über System_rw, hat aber auch wieder andere Probleme.
    Es gibt auch fertige scripte die man dann in der init.rc aufrufen könnte.
    Hat aber einen Nachteil:
    Du kannst dann nur noch Ad hoc Verbindungen eingehen..

    System als RW mounten:
    reinitialisieren des Systems und umlinken damit /system beschreibbar ist. Dann könnte man die Änderungen im Betrieb vornehmen wie es HIER zu sehen ist.

    Problem:
    die Systempartition umzulinken und damit schreibbar zu machen ist möglich, es ist auch möglich das ganze via script beim Start des Geräts zu machen.
    Dummerweise gibt es dazu 3 verschiedene Wege und ich habe alle 3 vermischt was zu unerwünschten Nebenwirkungen führte.
    Es ist also noch nicht "stable" und daher nicht zu empfehlen

    Einfacher wäre es das ganze schon im Kernel einzubringen (mein defy kann AdHoc UND Infrastructure ohne umschalten)
    Dummerweise sind bei mir alle Versuche bis jetzt am Crosscompiler gescheitert und selbst wenn ein anderer Kernel fertig ist muss man noch einen Weg finden den aufs Gerät zu bringen.


    Plan B:
    Teste mal dein Nokia als Modem am USB Host wie es hier ein User schon mit nem SE geschafft hat.
     
  3. rob.s, 07.11.2011 #3
    rob.s

    rob.s Threadstarter Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    07.11.2011
    Dann teste ich erst mal Plan B, ansonsten muss hat UMTS ran. Danke!
     
  4. netlars, 08.11.2011 #4
    netlars

    netlars Fortgeschrittenes Mitglied

    Beiträge:
    339
    Erhaltene Danke:
    92
    Registriert seit:
    05.11.2011
    Hallo,

    ich habe auch gekämpft bis ich ies hin bekommen habe. Ich habe zwar das XPRESS, ist bestimmt beim Loox nicht anders. man muss nicht die wpa_supplicant tauschen, sondern die /data/misc/wifi/wpa_supplicant.conf bearbeiten, die ist schreibbar wenn man root rechte hat.

    erst das Netzwerk manuel erstellen in den einstellungen, da die genannte datei bearbeiten und ganz oben eintragen
    ap_scan=2

    dann das WLAN neustarten
    und dann verbindet der sich mit dem ADHOC bei mir!

    MfG
     
  5. meshat, 15.11.2011 #5
    meshat

    meshat Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    15.11.2011
    Hi,

    könntet ihr mir bitte eine detailierte Anleitung schicken wie man die datei bearbeitet .

    Denn ich habe folgende Probleme;

    1. Bekomme keine richtige Verbindung zwischen Pc und Xpress. Was soll ich benuten Totalcmd? Einstellungen? Im Explorer hab ich die Systemdateien nicht.

    2. Ich kann die Datei trotz root nicht ersetzen, er sagt schreibgeschützt. Habs auch mit Root Explorer versucht.

    3. Die Datei befindet sich bei mir unter System/etc/wifi/ ist das normal?


    Ich danke jetzt schon für eure Hilfe
     
  6. hävksitol, 15.11.2011 #6
    hävksitol

    hävksitol Ehrenmitglied

    Beiträge:
    12,605
    Erhaltene Danke:
    8,873
    Registriert seit:
    11.01.2011
    Tablet:
    Lenovo Ideapad A2109A
    Mangels Xpress kann ich Dir nur etwas zum Root Explorer sagen. Wenn Du ihn startest, öffnet er er das system-Verzeichnis im aktuellem Modus (d.h. schreibgeschützt). Du siehst (alles aus dem Gedächtnis beschreiben, kleine Abweichungen sind also möglich) in einem kleinen weißen Feld "r/o"; wenn Du das anklickst, kannst Du auf "r/w" umschalten. Nach dem Editieren der Datei (die Du ebenfalls im Root Explorer vornehmen kannst: conf-Datei auswählen & länger halten, dann erscheint ein Menü, in dem z. B. Editieren auswählen kannst) musst Du dann auf jeden Fall wieder auf "r/o" zurückschalten.

    MfG

    PS: Android-Systemdateien solltest Du - wenn überhaupt - nur dann unter Windows bearbiten, wenn Du einen Editor benutzt, der die von Windows abweichendene Zeilenumbrüche in den Android-Files garantiert korrekt behandelt (das tun z. B. Notepad oder Wordpad nicht)!
     
  7. netlars, 15.11.2011 #7
    netlars

    netlars Fortgeschrittenes Mitglied

    Beiträge:
    339
    Erhaltene Danke:
    92
    Registriert seit:
    05.11.2011
    Hallo,

    mein Verfahren war zum verbinden mit dem Handy Tethering Ad-HOC damit man auch unterwegs ins internet kann mittels Handynetz (z.B. UMTS oder GSM)

    die Dateien im /etc Verzeichniss lassen sich bei mir auch trotz root Rechten nicht bearbeiten. Wird auch nicht benötigt.

    Zuerst das Tablet Xpress rooten, dann den Root Explorer installieren.
    Im Tablet Hauptmenu auf Einstellungen gehen, dann auf Wifi und das AD-HOC Netzwerk manuell anlegen.

    Dann in den Root Explorer gehen die Datei suchen /data/misc/wifi/wpa_supplicant.conf (die lässt sich nämlich mit ROOT Rechten bearbeiten), auf die Datei länger drücken, dann öffnet sich ein POPup Fenster wo irgendwo steht mit Editor bearbeiten oder so ähnlich.
    Als letzte Zeile des ersten Abschnitts eintragen AP_Scan=2.
    Dann verbindet sich das AD-HOC Netztwerk mit meinem Handy.

    Allerdings ein Nachteil besteht, dann gehen keine Netzwerke im Infrastruktur Modus mehr, erst wenn ich diesen Eintrag wieder entferne. Da bin ich noch auf der Suche nach einer Lösung.

    Aber wie gesagt so hab ich mein Handy mit dem Tablet verbunden, ich kann heute abend auch mal den gesamten Inhalt posten dieser besagten Datei.

    MfG
     
  8. meshat, 15.11.2011 #8
    meshat

    meshat Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    15.11.2011
    Bei mir ist aber /data/ leer. :sad:
     
  9. netlars, 15.11.2011 #9
    netlars

    netlars Fortgeschrittenes Mitglied

    Beiträge:
    339
    Erhaltene Danke:
    92
    Registriert seit:
    05.11.2011
  10. meshat, 15.11.2011 #10
    meshat

    meshat Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    15.11.2011
    ja genau nach dieser Anleitung bis Punkt 8 also bis es mit RKCooking los geht. Zum betrachten habe ich mehrere Programme probiert also FS-Explorer, Root Explorer und der Standard Explorer.

    Komisch oder :confused2:
     
  11. netlars, 15.11.2011 #11
    netlars

    netlars Fortgeschrittenes Mitglied

    Beiträge:
    339
    Erhaltene Danke:
    92
    Registriert seit:
    05.11.2011
    komisch, selbst auf meinem Handy ist die besagte Datei im Ordner /data/misc/wifi/

    Ich muss das heute abend mal bei meinem Tablet versuchen nachzuvollziehen.
    Hab es hier nicht zur Hand.
     
  12. netlars, 15.11.2011 #12
    netlars

    netlars Fortgeschrittenes Mitglied

    Beiträge:
    339
    Erhaltene Danke:
    92
    Registriert seit:
    05.11.2011
    Ich kann das nicht nachvollziehen. Und dein Gerät ist wirklich gerootet?
    hast du das Programm SuperUser?
     
  13. meshat, 15.11.2011 #13
    meshat

    meshat Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    15.11.2011
    Habs paar mal neugestartet und siehe da die datei ist da. Cool danke euch ihr seid echt der hammer

    :unsure::drool::drool:
     
  14. illmatic-gr, 14.12.2011 #14
    illmatic-gr

    illmatic-gr Android-Hilfe.de Mitglied

    Beiträge:
    74
    Erhaltene Danke:
    16
    Registriert seit:
    29.11.2011
    Hallo zusammen,

    gibt es mittlerweile eine Lösung für Infrastructur und Ad-hoc wifi?
    Wer kann da weiterhelfen?
     
  15. Horschtl, 30.01.2012 #15
    Horschtl

    Horschtl Android-Hilfe.de Mitglied

    Beiträge:
    69
    Erhaltene Danke:
    5
    Registriert seit:
    30.01.2012
    Hallo,

    mein Name ist Gerhard und seit 5 Tagen Loox Besitzer.
    Durch die vielen Anleitungen hier im Forum ist das Loox
    jetzt gerootet und die /data/misc/wifi/wpa_supplicant.conf
    habe ich mit Root Explorer und dem Text Editor um die
    Zeile "ap_scan=2" erweitert und...
    Nichts! Die Joiku SSID habe ich händisch eingetragen
    und das Wlan neu gestartet. Aber trotzdem findet das Loox
    das Nokia nicht. Trotz des Eintrags findet das Loox
    immer noch normale Wlans aber das Ad-hoc eben nicht.

    Was mach ich falsch?

    Viele Grüße

    gerhard
     
  16. netlars, 31.01.2012 #16
    netlars

    netlars Fortgeschrittenes Mitglied

    Beiträge:
    339
    Erhaltene Danke:
    92
    Registriert seit:
    05.11.2011
    füge mal noch in der wpa_supplicant.conf unter der SSID

    Code:
    mode=1
    ein, und starte das WLAN nochmal neu.

    Vielleicht hilft das

    MfG
     
    Horschtl bedankt sich.
  17. illmatic-gr, 31.01.2012 #17
    illmatic-gr

    illmatic-gr Android-Hilfe.de Mitglied

    Beiträge:
    74
    Erhaltene Danke:
    16
    Registriert seit:
    29.11.2011
    netlars hat recht. ich nutze auch joiku mit loox und der tipp mit mode=1 war gold wert. habe ewig rumprobiert. und als zweiter tipp: wpe verschluesselung kannst vergessen, das loox kommt nicht klar mit. und tipp nr3: es lassen sich adhoc und infrastructur netze verbinden, mit ein und der selben config
     
  18. Horschtl, 31.01.2012 #18
    Horschtl

    Horschtl Android-Hilfe.de Mitglied

    Beiträge:
    69
    Erhaltene Danke:
    5
    Registriert seit:
    30.01.2012
    Hallo,

    prima, es geht vorwärts, vielen dank.
    Meine wpa_supplicant.conf sieht jetzt so aus:

    ctrl_interface=/data/system/wpa_supplicant
    ctrl_interface_group=1000
    update_config=1
    ap_scan=2

    network={
    ssid="N97_JoikuSpot_A87E33041BF4"
    mode=1
    scan_ssid=1
    key_mgmt=NONE
    }

    network={
    ssid="grenzenlos"
    psk="****"
    key_mgmt=WPA-PSK
    priority=1
    }

    (Zeilenumbrüche sind etwas anders, mit dem Win Editor hier eingefügt)
    Da ich JoikuLight benutze stolpere ich schon mal nicht
    über Verschlüsselungen. Mein Heimnetz funktioniert immernoch
    bestens auch der JuikoSpot wird erkannt und ich kann mich verbinden.
    Leider bricht nach ein paar Minuten die Verbindung dahingehend zusammen,
    das keine Daten mehr übertragen werden :ohmy:
    Das Wlan Signal ist auch auf dem Loox Display äuserst schwach,
    mit dem Läppi zeigt es volle Pulle an.

    Unter System/etc/wifi
    gibt es noch eine Wpa_supp.conf
    muß man die auch ändern?
    (Hab ich als Tip in einem anderen Unterforum gelesen, HTC,
    Motorola oder so..)
     
  19. netlars, 01.02.2012 #19
    netlars

    netlars Fortgeschrittenes Mitglied

    Beiträge:
    339
    Erhaltene Danke:
    92
    Registriert seit:
    05.11.2011
    probiere mal den wlan Kanal zu wechseln, vielleicht hilft das
     
  20. Horschtl, 02.02.2012 #20
    Horschtl

    Horschtl Android-Hilfe.de Mitglied

    Beiträge:
    69
    Erhaltene Danke:
    5
    Registriert seit:
    30.01.2012
    Hallo,

    vielen Dank für die Tips.
    Habe bis jetzt erfolg mit folgenden Einträgen:

    ctrl_interface=/data/system/wpa_supplicant
    ctrl_interface_group=1000
    update_config=1
    ap_scan=2

    network={
    ssid="wifispot"
    scan_ssid=1
    key_mgmt=NONE
    mode=1
    }

    network={
    ssid="grenzenlos"
    psk="*****"
    key_mgmt=WPA-PSK
    priority=1
    }

    Vielleicht ist auch ein Grund, das ich JoikuSpot von Light auf Premium
    getauscht habe, so kann man die SSID ändern und vereinfachen.
    auch den WLAN Kanal habe ich von 11 auf 6 getauscht.

    So scheint es jetzt zu funktionieren :love:

    Weis jemand, warum der Eintrag ap_scan=2
    ab und an wieder aus der wpa_supplicant.conf
    verschwindet?

    Viele Grüße

    gerhard
     

Diese Seite empfehlen