1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Odys Xelio - Firmware

Dieses Thema im Forum "Root / Hacking / Modding für das Odys Xelio" wurde erstellt von Oma7144, 03.04.2012.

  1. Oma7144, 03.04.2012 #1
    Oma7144

    Oma7144 Threadstarter Android-Guru

    Beiträge:
    2,914
    Erhaltene Danke:
    1,082
    Registriert seit:
    18.12.2011
    Das Tab ist nicht nur für den Preis unschlagbar, sondern mit dieser offenen Entwicklungsumgebung
    ist ihm eine breite Marktdurchdringung sicher!

    Für den Rootzugang ist alles da:
    - in der default.prop: ro.secure=0 (root über ADB)
    - in /system/bin: die binary su

    Ein schnelles Filesystem (ext4) und gleich beschreibbar (rw):
    /dev/block/nandd /system ext4 rw
    /dev/block/nande /data ext4 rw
    /dev/block/nandh /cache ext4 rw

    Der Bootloader unterstützt Fastboot und als Recovery läßt sich CWM einsetzen.

    Jetzt fehlt nur noch die offizielle Firmware und die im Feld befindlichen Probleme
    könnten sofort abgestellt werden.

    Je schneller desto besser. Damit würden wir auch den absolut guten Ruf von Odys
    "oben halten" können ;-)

    ODYS Forum • Thema anzeigen - Root Rechte -> "Sicherheitslücke"


    Ansosten hier noch mal die Warnung:

    Mit - im Market frei verfügbaren - Apps wie Busybox, SSHDroid, Root Toolbox, Rom Toolbox,
    o.ä. kann man es schaffen, sich sein System kaputt zu machen.

    Gleiches gilt für Scripte jeglicher Art.

    Die Firmware von anderen (ähnlichen) Tabs solltet ihr auch erst mal in Ruhe lassen!
    Wir haben hier drei Threads, in denen das diskutiert wurde...


    :thumbup:
     
    Zuletzt bearbeitet: 04.04.2012
    lynxxx bedankt sich.
  2. Oma7144, 03.04.2012 #2
    Oma7144

    Oma7144 Threadstarter Android-Guru

    Beiträge:
    2,914
    Erhaltene Danke:
    1,082
    Registriert seit:
    18.12.2011

    Anhänge:

    Zuletzt bearbeitet: 25.04.2012
    lynxxx bedankt sich.
  3. BenZ, 03.04.2012 #3
    BenZ

    BenZ Erfahrener Benutzer

    Beiträge:
    162
    Erhaltene Danke:
    11
    Registriert seit:
    01.11.2010
    Wollen wir es hoffen sonst geht es zurück .
     
  4. Himmelskrieger, 03.04.2012 #4
    Himmelskrieger

    Himmelskrieger Android-Experte

    Beiträge:
    535
    Erhaltene Danke:
    104
    Registriert seit:
    02.10.2011
    Phone:
    Samsung Galaxy S5 (G900)
  5. BenZ, 03.04.2012 #5
    BenZ

    BenZ Erfahrener Benutzer

    Beiträge:
    162
    Erhaltene Danke:
    11
    Registriert seit:
    01.11.2010
    Zuletzt bearbeitet: 03.04.2012
  6. spar-dose, 04.04.2012 #6
    spar-dose

    spar-dose Erfahrener Benutzer

    Beiträge:
    214
    Erhaltene Danke:
    24
    Registriert seit:
    06.08.2010
    Hier ist das Nackte Backup von meinem Xelio Tablet.
    Zippyshare.com - 2012-04-04.13.39.36.rar

    ClockworkMod 5
    http://www25.zippyshare.com/v/60005969/file.html


    Als erstes ladet euch das Backup runter und entpackt es. Dann brauch ihr das Clockworkmod 5 für Allwinner Tablets.

    Ich empfehle euch das Backup auf die Externe SD Karte zu kopieren.
    Das entpackte Backup müsst ihr in clockworkmod/Backup Reinkopieren.

    Wenn ihr es dennoch auf die Interne SD kopieren wollt, müsst ihr auch beim Restore die Interne SD karte wählen.

    In dem CWM ordner sind auch Treiber für den Debugmodus drin.

    Unter Gerätemanager ist das Gerät nachdem ihr das USB- Debugging unter Entwickleroptionen eingeschaltet habt mit einem Gelben Ausrufezeichen versehen.
    Es steht da als Android.
    Ihr müsst erst den Treiber Installieren der im CWM Ordner drin ist.
    Nachdem der Treiber Installiert ist müsst ihr CWM 5 Installieren.

    Ich Empfehle euch den CWM Ordner so kurz wie möglich zu benennen.
    Ich benenne es 1 oder a.

    Es gibt 2 Methoden CWM zu Installieren.
    Entweder ihr startet recovery-install.bat oder nimmt Methode 2.
    Methode 1 hat bei mir nicht geklappt.

    Bei Methode 2 müsst ihr die Eingabeaufforderung aufrufen und mit cd.. zu eurem CWM Ordner gehen.
    Nachdem ihr das gemacht hab gibt ihr nach der Reihe folgendes ein.
    adb push recovery.img /data/
    dann
    adb shell "cat /data/recovery.img > /dev/block/nandg; sync"
    und zum Schluß
    adb shell "echo -n boot-recovery | busybox dd of=/dev/block/nandf count=1 conv=sync; sync; reboot"
    Das Gerät startet von neu und Bootet ins Recovery Menü
    So sieht das Recovery Menü aus
    [​IMG]
    Bevor ihr mit der Wiederherstellung beginnt müsst ihr Wipen.


    • zum Eintrag wipe data/factory reset durchklicken und ausführen lassen

    • zum Eintrag wipe cache partition klicken und ausführen lassen

    • zum Eintrag advancedMenü klicken, dann dort zum Eintrag wipe dalvik cache klicken und ausführen lassen

    • zum Eintrag mount and storage Menü klicken, dann dort zum Eintrag format system klicken und ausführen lassen
    Nach dem Fullwipe ohne Reboot neue ROM installieren.
    Jetzt geht ihr auf Backup/Restore
    anschließen wählt ihr Restore und geht zum Backup.
    Das wars.
     
    Zuletzt bearbeitet: 04.04.2012
    lynxxx, Dotsch, Microcut und 7 andere haben sich bedankt.
  7. Microcut, 09.04.2012 #7
    Microcut

    Microcut Android-Experte

    Beiträge:
    554
    Erhaltene Danke:
    73
    Registriert seit:
    14.01.2011
    Phone:
    Samsung Galaxy S7
    Wearable:
    Asus Zenwatch 2 WI501Q
    Hab die ganze Sache auch mal installiert und es funktionierte nach der Anleitung hier perfekt. Danke!

    Vielleicht nochmal ergänzend dazu, es handelt sich bei der aktuellen Firmware um die Version:

    A10_ANDROID4.0.3_ODYS_XELIO_V1.01_20120323

    MD5SUM: b2c863ab60b3eb7151317199db67fcc3


    Und bevor jemand suchen muss (wie ich) wie man ins Recovery bootet, hier nochmal zum mitschreiben:

    -Gerät herunterfahren
    -Menü-Taste gedrückt halten
    -Power-Taste gedrückt halten
    -Power-Taste los lassen
    -Menü-Taste los lassen
     
    Zuletzt bearbeitet: 09.04.2012
    dickenseck bedankt sich.
  8. SunnyxD, 09.04.2012 #8
    SunnyxD

    SunnyxD Android-Hilfe.de Mitglied

    Beiträge:
    122
    Erhaltene Danke:
    3
    Registriert seit:
    21.10.2010
    So habe mich auch mal rangesetzt komm aber ums verrecken nicht auf das Backup. Beim versuch zu starten hängt er beim Xelio Schriftzug und macht nix mehr.

    was nun?
     
  9. Microcut, 09.04.2012 #9
    Microcut

    Microcut Android-Experte

    Beiträge:
    554
    Erhaltene Danke:
    73
    Registriert seit:
    14.01.2011
    Phone:
    Samsung Galaxy S7
    Wearable:
    Asus Zenwatch 2 WI501Q
    Hast Du denn kein Backup von DEINEM System vorher gemacht?
     
  10. SunnyxD, 09.04.2012 #10
    SunnyxD

    SunnyxD Android-Hilfe.de Mitglied

    Beiträge:
    122
    Erhaltene Danke:
    3
    Registriert seit:
    21.10.2010
    Ne hab mir das backup hier geladen -.-

    ich kann auch keine rom installieren nix
     
  11. Microcut, 09.04.2012 #11
    Microcut

    Microcut Android-Experte

    Beiträge:
    554
    Erhaltene Danke:
    73
    Registriert seit:
    14.01.2011
    Phone:
    Samsung Galaxy S7
    Wearable:
    Asus Zenwatch 2 WI501Q
    Nochmal alles wipen und dann erneut das Backup aufspielen. Ne bessere Idee hab ich im Moment auch nicht :-/
     
  12. SunnyxD, 09.04.2012 #12
    SunnyxD

    SunnyxD Android-Hilfe.de Mitglied

    Beiträge:
    122
    Erhaltene Danke:
    3
    Registriert seit:
    21.10.2010
    Wenn ich das Backup aufspielen könnte, dann würde ich nicht fragen -.-
     
  13. Microcut, 09.04.2012 #13
    Microcut

    Microcut Android-Experte

    Beiträge:
    554
    Erhaltene Danke:
    73
    Registriert seit:
    14.01.2011
    Phone:
    Samsung Galaxy S7
    Wearable:
    Asus Zenwatch 2 WI501Q
    Kommst Du denn ins Recovery?
     
  14. SunnyxD, 09.04.2012 #14
    SunnyxD

    SunnyxD Android-Hilfe.de Mitglied

    Beiträge:
    122
    Erhaltene Danke:
    3
    Registriert seit:
    21.10.2010
    ja da bin ich drin
     
  15. Microcut, 09.04.2012 #15
    Microcut

    Microcut Android-Experte

    Beiträge:
    554
    Erhaltene Danke:
    73
    Registriert seit:
    14.01.2011
    Phone:
    Samsung Galaxy S7
    Wearable:
    Asus Zenwatch 2 WI501Q
    Ich verstehe das Problem nicht ganz, was funktioniert denn jetzt genau nicht? Wenn Du ins Recovery booten kannst, ist das doch die halbe Miete.
     
  16. SunnyxD, 09.04.2012 #16
    SunnyxD

    SunnyxD Android-Hilfe.de Mitglied

    Beiträge:
    122
    Erhaltene Danke:
    3
    Registriert seit:
    21.10.2010
    ich kann keine rom aufspielen, und ich kann kein backup machen

    Installation aborted.
    E: Can´t mount/sdcard


    Nach full wipe versucht über restore

    Restorin boot image...
    Restoring system...
    Restoring data...
    .android_secure.img not found. Skipping restore of /sdcard/.android_secure.
    Restoring cache...


    sd-ext.img not found. Skipping restore of /sd-ext.

    Restore complete!

    Und bleibt weiter hängen...
     
    Zuletzt bearbeitet: 09.04.2012
  17. Microcut, 09.04.2012 #17
    Microcut

    Microcut Android-Experte

    Beiträge:
    554
    Erhaltene Danke:
    73
    Registriert seit:
    14.01.2011
    Phone:
    Samsung Galaxy S7
    Wearable:
    Asus Zenwatch 2 WI501Q
    Kopier doch noch mal das Backup über den PC erneut auf die SD-Karte. Vielleicht ist da was schief gegangen?
     
  18. SunnyxD, 09.04.2012 #18
    SunnyxD

    SunnyxD Android-Hilfe.de Mitglied

    Beiträge:
    122
    Erhaltene Danke:
    3
    Registriert seit:
    21.10.2010
    Auch nicht... -.- hab ich wohl mal fett sch**** gebaut
     
  19. SunnyxD, 09.04.2012 #19
    SunnyxD

    SunnyxD Android-Hilfe.de Mitglied

    Beiträge:
    122
    Erhaltene Danke:
    3
    Registriert seit:
    21.10.2010
    Moha Gott sei Dank... Image runtergeladen mit Livesuit und es funktioniert wieder...

    Mein Abend ist gerettet
     
  20. spar-dose, 10.04.2012 #20
    spar-dose

    spar-dose Erfahrener Benutzer

    Beiträge:
    214
    Erhaltene Danke:
    24
    Registriert seit:
    06.08.2010
    Du hast image runtergeladen und es geht wieder?
    Es ging doch schon vorher:)
    Da steht doch Restore complete, du hättest nur neu booten brauchen:)

    Gesendet von meinem Xelio mit Tapatalk
     

Diese Seite empfehlen