1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Openvpn / tun.ko

Dieses Thema im Forum "Archos G9 Tablet Forum" wurde erstellt von IngoPan, 29.11.2011.

  1. IngoPan, 29.11.2011 #1
    IngoPan

    IngoPan Threadstarter Android-Experte

    Beiträge:
    887
    Erhaltene Danke:
    32
    Registriert seit:
    10.11.2010
    Hallo,

    Kann mir evtl. jmd ein tun.ko erstellen für die neueste FW / Kernel fürs G9? Oder weiss jmd. wo es eins gibt? Kann ich jedes kompilierte für A9 Cortex CPUs nehmen? Das überfordert mich komplett. Danke für
     
  2. Cynob, 29.11.2011 #2
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,745
    Erhaltene Danke:
    924
    Registriert seit:
    17.04.2011
    Öhm also kompilieren kann ich dir so auf anhieb keins.... könnte dir zwar schreiben wie es geht aber mangels Programmierkenntnisse meinerseits werden da n paar Dicke hürden zu nehmen sein *hust*
    Eigentlich kannst du jede tun.ko (ist ja sowas wien Treiber) verwenden welche für deinen Kernel kompiliert wurde (also bei meinem S+ find ich die Info unter der Telefoninfo > Kernel - Version) hier als beispiel von mir ist es die 2.6.35.7

    Ich weiß jetzt nicht welchen Kernel du auf deinem G9 drauf hast?
    Wenn du es mir sagst kann ich beim suchen helfen :)
     
  3. IngoPan, 29.11.2011 #3
    IngoPan

    IngoPan Threadstarter Android-Experte

    Beiträge:
    887
    Erhaltene Danke:
    32
    Registriert seit:
    10.11.2010
    erledigt.
     
  4. dazw, 30.11.2011 #4
    dazw

    dazw Android-Guru

    Beiträge:
    2,514
    Erhaltene Danke:
    318
    Registriert seit:
    17.08.2009
    ... und wie?
     
  5. IngoPan, 30.11.2011 #5
    IngoPan

    IngoPan Threadstarter Android-Experte

    Beiträge:
    887
    Erhaltene Danke:
    32
    Registriert seit:
    10.11.2010
    So banal kanns gehen: Die Suche mit "find -name tun.ko" ergab, daß sich schon ein fertiges in irgend nem lib ordner befindet. Zufall. Läuft prima ;)
     
  6. IngoPan, 06.12.2011 #6
    IngoPan

    IngoPan Threadstarter Android-Experte

    Beiträge:
    887
    Erhaltene Danke:
    32
    Registriert seit:
    10.11.2010
    Das ding verliert aber immer die conenction. Kann jmd .eines neues kompilieren evtl.`?
     
  7. IngoPan, 07.12.2011 #7
    IngoPan

    IngoPan Threadstarter Android-Experte

    Beiträge:
    887
    Erhaltene Danke:
    32
    Registriert seit:
    10.11.2010

    Softw. Version 3.2.69 ;)
     
  8. Cynob, 07.12.2011 #8
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,745
    Erhaltene Danke:
    924
    Registriert seit:
    17.04.2011
    Wie verliert er denn die Verbindung? vll ists auch nur einstellungssache?
     
  9. IngoPan, 07.12.2011 #9
    IngoPan

    IngoPan Threadstarter Android-Experte

    Beiträge:
    887
    Erhaltene Danke:
    32
    Registriert seit:
    10.11.2010

    Also energiesparen usw. ist alles aus. Plötzlich geht halt kein ping mehr aufn server.
     
  10. Cynob, 07.12.2011 #10
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,745
    Erhaltene Danke:
    924
    Registriert seit:
    17.04.2011
    Mmmh was gibts denn noch so für geräte aufm markt mit der selben Android version wie du hast?
    aber wenn die bei dir schon drauf ist kann es eigentlich nicht an dieser liegen.
    da du ja anscheinend rootrechte auf der mühle hast würde ich mal die ganzen einstellungsdateien anschauen oder durchsuchen.
    Kennst du dichn bisschen mit scripten aus?

    Hier ist ne Suchmaschine^^

    #!/system/bin/sh
    echo "Wo soll gesucht erden? Pfad?"
    read pfad
    cd $pfad
    echo -n "Suchbegriff eingeben:"
    read suche
    find . -type f -exec grep -qi "$suche" {} \; -print


    Bei der ersten Frage würde ich ein / eingeben und bei der zweiten kannst du kreativ sein^^
     
  11. IngoPan, 15.01.2012 #11
    IngoPan

    IngoPan Threadstarter Android-Experte

    Beiträge:
    887
    Erhaltene Danke:
    32
    Registriert seit:
    10.11.2010
    Moin,

    Seit FW Update .79 geht das von mir genutzte tun.ko nicht mehr: "invalid .. format". Man muss es wohl neu kompilieren. Hat das jmd. zufällig schon gemacht? Ich benötige diese Datei dringendst für die neue FW. Das vorhandene in /lib/modules scheint auch nicht zu funtionieren.


    Danke im Voraus,


    Lg Ingo
     
    Zuletzt bearbeitet: 15.01.2012

Diese Seite empfehlen