1. Möchtest Du unser Team im Android OS-Bereich unterstützen? Details dazu findest du hier!
  1. elknipso, 18.01.2012 #1
    elknipso

    elknipso Threadstarter Android-Ikone

    Hallo,

    welche Ports muss ich in einer (Hardware)firewall öffnen, dass die Synchronisation des Google Kalenders korrekt funktioniert?
     
  2. elknipso, 07.02.2012 #2
    elknipso

    elknipso Threadstarter Android-Ikone

    Weiß das keiner?
     
  3. scorp182, 07.02.2012 #3
    scorp182

    scorp182 Android-Lexikon

    Hi,
    versuch's mal mit Port 443 (SSL).
     
  4. elknipso, 07.02.2012 #4
    elknipso

    elknipso Threadstarter Android-Ikone

    Port 80 und Port 443 sind bereits drin.
     
  5. scorp182, 07.02.2012 #5
    scorp182

    scorp182 Android-Lexikon

    Dann versuch's mal mit'm Port 8080
    Ist ein alternativer HTTP-Port und wird gerne für Web-Services verwendet.
     
  6. elknipso, 07.02.2012 #6
    elknipso

    elknipso Threadstarter Android-Ikone

    Werde ich morgen mal testen. Wundert mich, dass das nirgends anständig dokumentiert ist. Zumal die Teile ja auch öfter in Unternehmensnetzwerken laufen.
     
  7. elknipso, 08.02.2012 #7
    elknipso

    elknipso Threadstarter Android-Ikone

    Ergebnis: Port 8080 ist es auch nicht.
     
  8. scorp182, 08.02.2012 #8
    scorp182

    scorp182 Android-Lexikon

    Ich bin zwar kein Systemadmin, aber ich glaube nicht, dass das Problem an irgendwelchen geschlossenen Ports liegt.
    I.d.R müssten die beiden Ports 80 und 443 dafür völlig ausreichen.
    Der Mangel an ausreichender Dokumentation ist wohl darin begründet, dass es kein "Google Calendar Sync"-spezifisches Problem ist, würde ich mal vermuten.

    An deiner Stelle würde mir mal die übrige Konfiguration der Firewall genauer anschauen.

    Eventuell auch mal im Forum zum Google Calendar nachschauen. Vllt hatte dort auch jemand schonmal das Problem:
    Google Calendar Help
    Google Calendar Forum
     
  9. elknipso, 08.02.2012 #9
    elknipso

    elknipso Threadstarter Android-Ikone

    Es muss ein Problem mit einem Port sein, denn wenn ich eine Regel definiere die alle Ports von 1- 65000 öffnet geht es sofort.

    Habe das Problem aber auch mal in den Support Foren von Google eingetragen. Wenn ich auf dem Weg die Lösung erfahre, teile ich euch das hier natürlich mit.
     
  10. scorp182, 08.02.2012 #10
    scorp182

    scorp182 Android-Lexikon

    Jo, das würde mich auch interessieren.

    Hier noch einige alternative HTTP-Ports zum ausprobieren: :winki:
    591, 8008, 8081, 8090
     
  11. JanF, 08.02.2012 #11
    JanF

    JanF Android-Experte

    Ich würde mal aus der adb-shell
    Code:
    netstat
    bei laufender Sync ausführen.
    Leider geht bei meinem Galaxy S (I9000) die Option [-p] nicht. Trotzdem läßt sich damit die Anzahl möglicher Ports auf wenige eindampfen.
     
  12. scorp182, 08.02.2012 #12
    scorp182

    scorp182 Android-Lexikon

    Stimmt, gute Idee!

    Das ich darauf nicht gekommen bin :glare:

    Vorher alle Ports öffnen, damit der Sync auf funzt.
     
  13. elknipso, 08.02.2012 #13
    elknipso

    elknipso Threadstarter Android-Ikone

    Wobei das natürlich nur eine sehr temporäre Lösung zum Zwecke des testens sein kann. Damit reißt man sich ja ein Scheunentor ins Netzwerk und wirft das gesamte Sicherheitskonzept über den Haufen wenn man einfach pauschal alles öffnet in einer Hardwarefirewall :).
     
  14. scorp182, 08.02.2012 #14
    scorp182

    scorp182 Android-Lexikon

    Ja klar!
    Meinte auch nur zum Testen! Danach natürlich wieder schließen. :D

    Der gesuchte Port muss ja genutzt werden, damit er über netstat identifiziert werden kann ;)

    ...getapatalked...
     
  15. JanF, 08.02.2012 #15
    JanF

    JanF Android-Experte

    Wobei Dir natürlich überlassen bleibt, wie Du die Sync laufen läßt. Kann ja auch ein anderes Netz sein. Hauptsache Du lässt uns am Erkenntnisgewinn teilhaben.
     
  16. elknipso, 08.02.2012 #16
    elknipso

    elknipso Threadstarter Android-Ikone

    Natürlich, ich könnte auch ein Subnetz aufbauen, und die entsprechenden WLAN Access Points darüber laufen lassen. Der Aufwand wäre für mich aber wesentlich höher, und das ist auch vom Gesamtkonzept des Netzwerkes betrachtet nicht Sinn und Zweck der Sache.

    Wie gesagt, sobald ich genaueres weiß, teile ich euch das natürlich gerne mit. Denke ich werde von Google schnell eine Rückmeldung erhalten.
     
  17. scorp182, 08.02.2012 #17
    scorp182

    scorp182 Android-Lexikon

  18. elknipso, 08.02.2012 #18
    elknipso

    elknipso Threadstarter Android-Ikone

    Das Gedächtnis funktioniert noch einwandfrei soweit :).

    Der Market funktioniert ja im WLAN, ich habe nur Probleme mit der Kalender Synchronisation.
     
  19. scorp182, 08.02.2012 #19
    scorp182

    scorp182 Android-Lexikon

    Und trotz geöffnetem Port 5228 läuft die Sync des Kalenders nicht?

    Hmm... dann warten wir mal die Antwort von Google ab.
     

Besucher kamen mit folgenden Begriffen auf unsere Seite:

  1. port für google kalender

    ,
  2. google kalender port

    ,
  3. google calendar welcher port

    ,
  4. port google calendar,
  5. google kalender fairphone port