Pro und Cyanogen 9 = WLAN-Authentifzierungsproblem

Dieses Thema im Forum "Root / Hacking / Modding für Sony Ericsson Xperia Pro" wurde erstellt von J-Man, 13.05.2012.

  1. J-Man, 13.05.2012 #1
    J-Man

    J-Man Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    46
    Erhaltene Danke:
    1
    Registriert seit:
    10.05.2012
    Hülfäää!

    Ich habe ein nagelneues, gerootetes Xperia Pro mit CyanogenMod9 in der aktuellen Version irgendwas17.

    Das "nagelneu" erwähne ich deshalb, weil ich im Moment noch sehr viel an dem Gerät rumspiele(n muss, um die gewünschte Funktionalität zu erreichen). Daher sind Fragen "Was hast Du gemacht?" leider vollkommen sinnlos - denn ich habe viel zu viel an dem Gerät gemacht und verändert, um alles nachvollziehen zu können. Vielleicht habe ich irgendwo ein dummes, sinnloses Häkchen gesetzt oder entfernt, das diesen Fehler jetzt verursacht. Oder mehrere davon, die jetzt in katastrophaler Kombination diesen Fehler verursachen. Aber ich kann echt nicht mehr sagen, wo ich überall rumgespielt habe - auch, um den jetzt auftretenden Fehler schon zu reparieren.


    So, jetzt zum eigentlichen Fehler: ich habe ein WLAN hier im Haus. Anfänglich klappte die Verbindung zu diesem WLAN einwandfrei. Und mit anderen Geräten klappt diese Verbindung schon seit Jahren und auch derzeit weiterhin einwandfrei. Am WLAN sollte es also nicht liegen.

    Auch das neue Xperia Pro wurde in die WLAN-Umgebung eingebunden, um nicht wertvollen Highspeed-Trafic mit dem Download von Updates oder Apps verschwenden zu müssen. Die Verbindung hat auch mehrere Tage einwandfrei funktioniert.

    "Plötzlich und unerwartet" verstarb diese WLAN-Verbindung dann aber quasi über Nacht.

    Das Symptom: eine WLAN-Verbindung kann nicht mehr aufgebaut werden. Im WLAN-Bereich zeigt sich die Fehlermeldung "Authentifizierungsproblem".

    Das WLAN ist mit WPA / WPA2 gesichert. Die Passwörter stimmen überein. Weder in der SSID noch in den Passwörtern sind Sonderzeichen oder Umlaute vorhanden - allerdings verwende ich ein Passwort mit mehr als 20 Zeichen, es variiert die Gross- und Kleinschreibung und es werden Ziffern und Buchstaben verwendet, darunter auch das "z" in Gross- und Kleinschreibung. Das erwähne ich deshalb, weil es über die Tastatur-Einstellungen vielleicht zu Kollisionen mit dem "Y" kommen könnte - aber bei der Eingabe des Passwortes auf dem Xperia wird das Z tatsächlich als Z angezeigt, nicht als Y.

    Auf dem WLAN-Router ist die MAC-Adresse des Xperia Pro als zulässiges Gerät eingetragen.

    Nachdem zunächst das Beziehen der IP via DHCP gescheitert war und eine entsprechende Fehlermeldung angezeigt wurde, versuchte ich auch die Vergabe einer festen IP - erst danach wurde definitiv der Authentifizierungsfehler angezeigt.

    Auch in andere WLANs mit kürzeren Passwörtern ohne jeglichen Schnickschnack wie Gross- und Kleinschreibung, Ziffern, ohne "Z" oder "Y" im Passwort und ohne Sonderzeichen kann ich mich nicht mehr einloggen.

    Auch ein Passwort-Wechsel des WLANs hat nicht geholfen.

    Ach ja, um entsprechenden Fragen zuvor zu kommen: Ja, natürlich ist das WLAN am XPERIA eingeschaltet. Und ich habe natürlich auch schon versucht, das WLAN mehrfach aus- und wieder einzuschalten. Und natürlich habe ich auch schon versucht, das ganze Handy mehrfach wieder aus- und einzuschalten. ;)



    Irgendwelche Ideen? Lösungsvorschläge? Ich würde mir eine Neu-Installation gerne ersparen, aber wenn es nicht anders geht, nehme ich auch die nochmal vor. ;)


    Sorry, ich hatte diese Frage bereits an anderer Stelle hier im Forum gestellt. Aber mangels Reaktion dort versuche ich es hier mal mit einem eigenen Thread. ;)
     
  2. Nobody-3, 13.05.2012 #2
    Nobody-3

    Nobody-3 Android-Hilfe.de Mitglied

    Beiträge:
    122
    Erhaltene Danke:
    11
    Registriert seit:
    07.12.2011
    Update die handy firmeware auf 119. Routersoftware bzw firmware aktuell? Mal ohne Mac filterung probiert?
     
  3. J-Man, 13.05.2012 #3
    J-Man

    J-Man Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    46
    Erhaltene Danke:
    1
    Registriert seit:
    10.05.2012
    Danke für den Tip mit der .119. Der Router ist seit Jahren auf dem "aktuellen" Firmware-Stand: Es handelt sich um eine FritzBox 7050. ;)

    Und: Ja, ich habe auch den MAC-Filter bereits abgeschaltet.


    Wie gesagt: ich versuche mal die 119, dann melde ich mich nochmal. :)
     
  4. J-Man, 13.05.2012 #4
    J-Man

    J-Man Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    46
    Erhaltene Danke:
    1
    Registriert seit:
    10.05.2012
    Tja - seit ich die .119 eingespielt habe, kann ich mich auch wieder mit dem WLAN verbinden.

    Die Frage, die sich jetzt natürlich stellt, ist:

    Lag es an der Firmware oder an irgendeiner dämlichen Einstellung, die durch das Update wieder korrigiert wurde?

    Warten wir mal ab, ob der Friede von Dauer sein wird. ;)


    Vorläufig jedenfalls mal VIELEN DANK für den rettenden Tip(p). ;)
     
  5. tacu, 14.05.2012 #5
    tacu

    tacu Junior Mitglied

    Beiträge:
    38
    Erhaltene Danke:
    9
    Registriert seit:
    10.10.2011
    Ich hab das gleiche problem schon ewig mit cm9, hab schon 3 mal deshalb ne neue version drauf gemacht :( hab mir vorhin die 120 drauf gemacht, aber auch damit gehts nicht. Werde mal 119 laden, aber auch da hab ich nicht so die hoffnung... hat noch jemand andere vorschläge?

    Gesendet von meinem Xperia Pro mit der Android-Hilfe.de App
     
  6. J-Man, 15.05.2012 #6
    J-Man

    J-Man Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    46
    Erhaltene Danke:
    1
    Registriert seit:
    10.05.2012
    Tja - Überraschung! Heute Morgen wachte ich auf, hatte nicht das Geringste an den Einstellungen meines PROs geändert, hatte sogar noch die GOOGLE PLAY-App auf dem Display - und bekam keine WLAN-Verbindung mehr.

    Fehler: der Gleiche wie oben beschrieben.


    Ich neige dazu, Cyanogen9 auf den Müll schmeissen zu wollen und zur Original-Firmware zurückkehren zu wollen. Ich habe nicht die Lust dazu, alle zwei Tage mein Handy neu aufzusetzen. :thumbdn:
     
  7. J-Man, 15.05.2012 #7
    J-Man

    J-Man Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    46
    Erhaltene Danke:
    1
    Registriert seit:
    10.05.2012
    Abschied von Cyanogen9, Original-Software wieder installiert.

    Wenn der Fehler jetzt nicht mehr auftritt, ist das für mich das Ende der Geschichte mit den Custom ROMs.

    Drei Tage Arbeit, drei Neu-Einrichtungen - Schnauze voll.
     
  8. Lubomir, 15.05.2012 #8
    Lubomir

    Lubomir Android-Lexikon

    Beiträge:
    1,311
    Erhaltene Danke:
    194
    Registriert seit:
    26.03.2009
    CM7 funktioniert hier einwandfrei.

    Übrigens ist mac filter total sinnlos!
     
  9. J-Man, 16.05.2012 #9
    J-Man

    J-Man Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    46
    Erhaltene Danke:
    1
    Registriert seit:
    10.05.2012
    Du redest von MAC-Spoofing. Aber genauso kann man sagen, dass jedes Türschloss total sinnlos ist, weil jeder Einbrecher ein Türschloss knacken kann.

    Und MAC-Filter sind noch aus einem anderen Grund NICHT sinnlos: Ich kann auf älteren Routern ohne Gast-Zugang seriöse Gäste temporär in mein WLAN lassen, ohne gleich SSID oder Passwörter etc. verändern zu müssen. Will ich den Gast wieder aussperren, deaktiviere ich seine MAC - und es kostet mich ein paar Mausclicks, sie später wieder zu aktivieren. ;)

    Aber die Diskussion führt hier zu weit - genau wie die Diskussion, ob ich mir noch einen Testballon antun muss.

    Im Moment funktioniert an meinem Pro übrigens auch alles - wie bei deinem unter Cyanogen7.

    Hoffen wir mal, dass es bei uns beiden so bleibt. ;)
     
  10. Lubomir, 16.05.2012 #10
    Lubomir

    Lubomir Android-Lexikon

    Beiträge:
    1,311
    Erhaltene Danke:
    194
    Registriert seit:
    26.03.2009
    Ich entwickel nebenbei Router als Sonderanfertigungen für besondere Zwecke und zeitgleich beschäftige ich mich mit der Sicherheit.
    Da der "Besucher" einmal das Passwort hatte und du es anscheinend nicht geändert hast, kann er kompletten Traffic mitschneiden und in Klartext lesen. Wenn er nicht ins WLAN kann - kann ihm ja egal sein. Schwarzsurfen ist wohl das geringste Interesse bei einem Angreifer wo doch jeder zweite in der Hosentasche ein Handy hat dank dem er in 30sec am Laptop online ist. Geht aber auch immer noch indem er deine mac übernimmt(kann man sofort erscannen).

    So, das war jetzt kurzer exkurs zu WLAN.
    Viel Spaß mit dein funktionierendes Handy und besorg dir nen vernünftigen WLAN-N OpenWRT Router für 11€ neu beim Händler um die ecke ;)
     
  11. J-Man, 16.05.2012 #11
    J-Man

    J-Man Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    46
    Erhaltene Danke:
    1
    Registriert seit:
    10.05.2012
    Siehst Du: genau das meinte ich mit "... führt hier zu weit.". Denn das Thema hat nicht mehr das Geringste mit Android, einem Sony Ericsson Xperia Pro oder dem CyanogenMod zu tun.

    Die Leute, die ich in mein WLAN lasse, haben keinerlei Hacker-Qualitäten. Sei versichert, dass ich solche Leute gar nicht erst in mein WLAN lassen würde - egal, ob mit oder ohne MAC-Filter.

    Und immer noch gilt die Absurdität des Satzes "Türschlösser sind sinnlos, weil jeder Einbrecher (und auch jeder Schlüsseldienst) ein Türschloss knacken kann."
     
  12. Lubomir, 18.05.2012 #12
    Lubomir

    Lubomir Android-Lexikon

    Beiträge:
    1,311
    Erhaltene Danke:
    194
    Registriert seit:
    26.03.2009
    WPA2 mit AES kann, wenn das Passwort lang genug ist und so Bruteforce ausgeschlossen wird, überhaupt nicht geknackt werden!
     
  13. J-Man, 19.05.2012 #13
    J-Man

    J-Man Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    46
    Erhaltene Danke:
    1
    Registriert seit:
    10.05.2012
    Haben wir über Verschlüsselung oder über MAC-Filter geredet?
     
  14. Dexxmor, 19.05.2012 #14
    Dexxmor

    Dexxmor Android-Ikone

    Beiträge:
    5,616
    Erhaltene Danke:
    1,158
    Registriert seit:
    29.07.2011
    Tablet:
    Samsung Galaxy Note 8.0
    Back to Topic Jungs :D
     
  15. soylentorange, 09.11.2012 #15
    soylentorange

    soylentorange Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    09.11.2012
    So, das Problem wurde im Forum bisher ja nicht gelöst; bei mir ist es nun quasi mit gleichen Symptomen auch aufgetreten:

    Xperia Mini Pro
    Cyanogen 9.1.0
    Neue Installation vor 4 Tagen

    Handy läuft 4 Tage super und dann (mitten in der Vorlesung, WLAN war verbunden) verabschiedet sich das WLAN: Soll heißen, das Handy versucht eine Verbindung auf zu bauen (schafft das auch lt. meinem Router, siehe unten) und diconnectet sich sofort wieder.

    09.11.12 16:17:59 WLAN-Station abgemeldet. Name: -, MAC-Adresse: ***.
    09.11.12 16:17:59 WLAN-Station angemeldet. Name: -, IP-Adresse: 192.168.*.*, MAC-Adresse: ***, Geschwindigkeit 54 MBit/s.

    [​IMG]

    Das Handy probiert das ein paar mal und gibt dann mit der Meldung "schlechte Verbindung" auf. So ein Mist! Vor allem tritt das Problem ohne jede Benutzerinteraktion auf (ich hab nix gemacht), wie gesagt mitten in der Vorlesung.

    Am Abend vorher hatte ich noch den Wifi Unlocker 2.0 ausprobiert und ihn dann aber wieder deinstalliert. Evtl. hat das Problem mit diesem zu tun?

    Gibts vielleicht irgend eine config in Cyanogen, die man einfach zurücksetzen kann ?

    Der ursprüngliche Beitrag von 16:36 Uhr wurde um 17:53 Uhr ergänzt:

    Haha, ok: Das Problem ist bekannt und hier ist die Lösung: Strange Wi-Fi Behaviour After Approx. 10 Days - Sony Ericsson Xperia Mini Pro Stable Mod - CyanogenMod Forum
     
  16. J-Man, 10.11.2012 #16
    J-Man

    J-Man Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    46
    Erhaltene Danke:
    1
    Registriert seit:
    10.05.2012
    Sorry, eine "Lösung" ist das eher nicht. Bestenfalls ein Workaround.

    Eine Lösung wäre eine CM9-Version, in der der Fehler nicht mehr auftritt.

    Oder sind wir mal wieder Einzelfall?
     

Diese Seite empfehlen