1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Problem: Nur noch APX

Dieses Thema im Forum "Root / Hacking / Modding für HANNspree HANNSpad (SN10T1)" wurde erstellt von marcero, 06.09.2011.

  1. marcero, 06.09.2011 #1
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    Hallo ich habe seit heute das Hannspad und nachdem ich mich zwischen Bestellung und Erhalt ein bisschen eingelesen habe, wollte ich mir das Flashback Image installieren. Nun habe ich aber das Problem das mein Pad nicht mehr startet.

    Mein Problem ist ähnlich zu dem im Thread "Schwarzer Bildschirm?". Ich schildere aber mal genau meine Vorgehensweise seit Erhalt bis zum jetzigen Stand:

    Als ersten hab ich über nvflash ein backup gemacht und mir alle partitionen runtergeladen. Dann habe ich das Tablet einmal gebootet um zu sehen wie Stock so aussieht. Dann habe ich es ausgemacht und wieder zurück in den apx Modus versetzt.
    Anschließend habe ich die modifizierte ROM von MP2005 über nvflash geflasht. Nachdem flash bootete das Pad ganz normal und ich konnte die .zip dateien für CWM und Flashback auf den internen Speicher packen. Gut soweit.
    Als ich es aber ausmachte um das recovery zu laden, tat sich nichts mehr. Der Bildschirm bleibt schwarz, egal was ich mache.
    Wenn das Pad per USB verbunden ist, wird der APX Modus aktiviert und ich kann über APX flashen. Zurück zu meinem Backuo ging aber nicht, weil die part-12.img zu groß ist, laut nvflash. Um dies zu beheben, hab ich versucht die hannsconf.cfg zu bearbeiten und die Größe auf NumSector*SectorSize zu setzen die ich aus der partionstabelle.txt kenne, aber dann wollte nvflash nicht mehr.
    Sitze nun hier vor einem teuren Briefbeschwerer...

    Kennt sich jemand mit der Situation aus und weiß was zu tun ist?
    Habe schon verschiedene ROMs probiert aber die Situation bleibt die gleiche. Sobald ich es aus und anmache bleibt es schwarz egal ob + - oder gar kein Volumeknopf gedrückt wird.

    Für alle Antworten bin ich sehr dankbar. Weitere Informationen gebe ich gerne, einfach danach fragen.


    PS: Ich habe die 1653 Version.



    Edit1:

    Ich gebe die Hoffnung bald auf :-(
    Ich habe jetzt dieses update.zip benutzt: http://www.android-hilfe.de/hannspree-hannspad-sn10t1-forum/142174-neues-stockrom-1-2-5305-a-3.html und mithilfe des Threads http://www.slatedroid.com/topic/206...estoring-from-brick-updated-25th-august-2011/ versucht es zu flashen. Der Flash funktioniert auch laut Aussage von nvflash. Aber wenn ich es wieder aus und anmache passiert immer das gleiche. Ich komme auschließlich ins APX, das von meinem Computer erkannt wird. Es erscheint direkt ein APX Gerät
     
    Zuletzt bearbeitet: 06.09.2011
  2. callemommsen, 06.09.2011 #2
    callemommsen

    callemommsen Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    09.08.2011
    Abe exakt das selbe Problem.
    Habe es beireits unter dem cwm-Thema geschildert.
    Komme ebebnfalls nur noch in den APX-Modus.
    Nach dem Flashen eines Backups startet dieses genau 1x. Danach ist wieder APX angesagt...
     
  3. marcero, 06.09.2011 #3
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    Sorry, falls ich ein Doppelpost mache. Aber ich hab ja nicht mal mehr CWM benutzt auf dem Hannspad, deswegen stehts jetzt hier, weils sehr zum Schwarzer Bildschirm Thread passt.

    Mit dem HannsPad_Restore.zip von MP2005 komme ich rein (1x) Dann steht bei mir unter Einstellungen->Über das Tablet

    Tap-Ui-Version
    1.2.1-4789

    Kernel-Version
    2.6.32.9-00001-g0e0c333-dirty
    hudson@tapntapbuild #7

    Build-Number
    FRF91

    Ist das denn wenigstens geflasht?
    Ich habe halb das Gefühl, dass manche Flashs evtl. verweigert werden aus irgendeinem Grund, den ich nicht kenne. Ich nutze Win7 64bit.

    Wenn ich aus einem update.zip extrahiere und die Stock_Restore_V3 Umgebung verwende, führt er den flash auch aus, aber bootet nicht automatisch neu und wenn ich dann aus und anmache, passiert direkt nichts....
     
  4. marcero, 06.09.2011 #4
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
  5. callemommsen, 06.09.2011 #5
    callemommsen

    callemommsen Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    09.08.2011
    Ich fürchte, ich weiss, was wir falsch gemacht haben: Mir jedenfalls ist aufgefallen, dass ich zwischen der clockworkmod und dem Flashen des Anpassungsroms keinerlei Whipes dutrchgeführt habe.
    Kann das daran liegen? (Und wie kommt man da wieder raus?)
     
  6. marcero, 07.09.2011 #6
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    Das ist nicht das Problem.

    ABER ich kann wieder booten jetzt!! Hab wieder ein laufendes Stock.
    Genaue Anleitung folgt später, erst muss der Hund raus.

    Wie kriege ich jetzt eigentlich die Partition für FB größer? Die ROM von MP2005 geht ja nicht..
     
  7. callemommsen, 07.09.2011 #7
    callemommsen

    callemommsen Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    09.08.2011
    Oh ja, ich bitte um eine (möglichst genaue) vorgehensweise!^^
    Ich habe nämlich schon wieder das genau 1x funktionierende ROM zur Größenanpassung geflasht, dort alles auf Werseinstellung gesetzt, das CWMod-Verzeichnis und die update.zip gelöscht, danach das offizielle "Live-Update" runtergeladen und installiert und einen Rücksendeschein ausgefüllt... :cool2:
    Wenn es aber noch hinzubiegen geht, so ist mir das natürlich lieber.
    Aber ich warte lieber nochmal sehnsüchtig auf Deine Beschreibung zur Lösung des Problems.

    Bis dann
    Calle
     
  8. marcero, 07.09.2011 #8
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    So nun setz ich mich mal an mein Hannspad und schreib den Artikel über die erfolgreiche Rettung des Tablets.
    Das wichtigste was ich hatte war das von mir persönlich erstellte nvflash Backup. Dies konnte ich über die Stock Restore Umgebung zunächst nicht zurück spielen.
    Also was hab ich gemacht.

    Sehr hilfreich war dieser Thread:
    http://www.android-hilfe.de/showthread.php?p=1902335

    Dort hat der Nutzer FPBoy ein vollständiges Backup hochgeladen, herzlichen Dank dafür!
    www.android-hilfe.de/hannspree-hann...ungsmassnahmen-kein-erfolg-5.html#post1902335

    Das flashen hiervon brachte jedoch nicht den direkten Erfolg, aber ein Versuch war es wert. Es soll auch schon direkt funktioniert haben.
    Ich stellte jedoch fest, dass die .img Dateien so groß wie die meines Backups waren. Kurzerhand ersetzte ich diese durch die Dateien meines Backups (img, hanns.bct)
    Nun führte ich erneut ein NVFlash durch, entfernte das APX Gerät "sicher" vom Laptop und machte es aus und anschließend wieder an...
    Und tada kein APX sondern ein hannspree Logo. Recovery ging mit +, APX mit - . Es bootete zwar so nicht hoch aber es lebte wieder.
    Das war die Rettung. Für alle mit 1653 von Alternate, die kein Backup aber die gleichen Probleme haben, schreibt mich gerne per PN an und ich stelle es gerne zur Verfügung' aber keine Garantie dafür, dass es klappt.

    Wieso konnte ich nun part-12.img flashen. Die entscheidenden Einstellungen sind in der .cfg Datei die in den Parametern innerhalb der .bat an nvflash übergeben werden. Die Unterschiede zeigen sich in den angegebenen Größen für die Partitionen. Ich hatte ebenfalls schon vorher diese Idee, aber meine Anpassungen an der .cfg führten ursprünglich dazu das nvflash nicht mehr wollte. Was es genau zu beachten gibt, kann ich also nicht beantworten.

    Das Schöne ist, dass die Größe der Partition "die Flashback 7.2 benötigt" in dieser .cfg schon richtig eingestellt ist. Ein direktes flashen von FB7.2 ist also möglich.




    Stock Recovery to CWM Recovery: ( www.android-hilfe.de/hannspree-hann...ungsmassnahmen-kein-erfolg-6.html#post1904098 )
    Leider war es nicht möglich über ein update.zip auf einer MicroSD das Recovery zu wechseln. Das Stock Recovery wollte nicht flashen.
    Lösung: Um nun zu CWM Recovery (Version 2... nicht 4!) Zu kommen habe ich die ROM von MP2005 benutzt. Dort habe ich in der .cfg nach der SOS Partition gesucht. Das zugehörige .img war part9.img
    Anschließend habe ich auch in meinem eigenen Backup nach der SOS Partition gesucht. Hier war das zugehörige .img part-11.img.
    Ich habe also das part9.img in part-11.img umbenannt und rüberkopiert. ACHTUNG! Auf keinen Fall die vorhandene ersetzn, besser in part-11.img.bak umbenennen, sonst gehen Teile eures ursprünglichen NV Backups verloren, wenn ihrs nicht noch woanders gesichert habt.
    Nun einfach erneut das Tab in den APX Modus veersetzen und ein Restore mit der hanns_guide.bat durchführen.
    Bei einem Reboot startet das System zwar immer noch nicht durch aber mit Volume+ beim Boot gings direkt ins CWM Recovery. Dort kann man den internen Speicher über USB am PC mounten und eigene .zip Dateien rüberziehen und installieren.

    Hier verweise ich auf die Anleitung von beispielsweise Flashback 7.2 hier im Forum. Kein Stock update.zip installieren wenn ihr nicht Stock wollt, dadurch ist das CWM Recovery wieder weg und bei mir ließ sich kein update.zip über das Stock Recovery installieren, sondern es war wieder ein nvflash restore nötig

    Weitere Fragen gerne hier im Thread oder als PN an mich.



    Sent from my Flashback 7.2 using Tapatalk
     
    Zuletzt bearbeitet: 07.09.2011
  9. callemommsen, 07.09.2011 #9
    callemommsen

    callemommsen Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    09.08.2011
    Hat bisher leider alles nicht geholfen.
    Hab folgendes probiert:

    - das genannte ROM lässt sich zwar direkt flashen, startet aber nicht
    - habe dann die Image-Dateien und die BCT-Datei gegen die aus meinem Stockbackup (von meinem 2. HannsPad) ausgetauscht. Brachte nichts.
    - Habe dann meine SOS-Partition (part-11.img) gegen die vom MP2005-Backup (part9.img) ausgetauscht. Das Pad startet nicht.

    Die Images lassen sich alle wunderbar zurückspielen, aber leider komme ich danach mit allen erdenklichen Tasten-Kombinationen (Power und -, Power und +, nur Power) immer nur in den APX-Modus.

    Das einzige Image, mit dem ich wenigstens das System starten kann (wenn auch nur 1x), ist das Restore-ROM, mit dem eigentlich nur die Partitionsgrößen für Flashback 7.2 angepasst werden sollen.

    Bin wirklich langsam ratlos...
     
  10. marcero, 07.09.2011 #10
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    Das Rom wird starten, wenn du hinter das nvflash Kommando in der .bat den Parameter --go hinter --create mitübergibst.
    Allerdings ebenfalls nur einmal. Das wird bei jedem ROM dummerweise so sein, außer dem originalen eigenen Backup.
    Das mit dem part9 kopieren ist zunächst nicht so wichtig, das ändert nur das recovery. Wird also nicht gehen. Wie alt ist das gebrickte Hannspad?



    Sent from my Flashback 7.2 using Tapatalk
     
    callemommsen bedankt sich.
  11. callemommsen, 07.09.2011 #11
    callemommsen

    callemommsen Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    09.08.2011
    1 Tag^^ Hat also nicht lange überlebt...
    Da das bei meinem eigenen Hannsi so gut geklappt hatte, habe ich das nvbackup irgendwie ignoriert. War wohl keine gute Idee...
     
  12. callemommsen, 07.09.2011 #12
    callemommsen

    callemommsen Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    09.08.2011
    Vielen Dank nochmal,

    Dein Backup hat mein Tab gerettet!:w00t00:

    Schöne Grüße
    Calle
     
  13. REACTION, 10.09.2011 #13
    REACTION

    REACTION Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    07.09.2011
    Leider hat es mich auch erwischt komme nur noch in den Apx Modus und habe auch kein Backup.. Hatte denn sonst noch jemand erfolg ohne original dateien? Meins ist ein 1653
     
  14. marcero, 10.09.2011 #14
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    Lösung:

    Hab mein Tab hiermit wieder in den Griff bekommen:

    http://www.multiupload.com/3JVWY0H1FE
    PW: backtolife

    Die .img sind vom Ursprungszustand (Alternate,1653, 06.09.11 geliefert),
    part-11.img(stock recovery) wurde in part-11.img.bak umbenannt, und durch CWM Recovery v2 ersetzt.

    Einfach das Tab in den APX Modus versetzen und über die hann_guide.bat aufs Pad flashen.
    Dann das Pad neu booten und im Recovery den USB Storage am PC mounten.
    Gewünschtes .zip rüberziehen.
    Wipe data/factory reset
    Wipe Cache
    Advanced/Wipe Dalvik Cache
    Und letztendlich das .zip im recovery flashen. Bei honeycomb CustomRoms evtl. zusätzlich auch noch einen extra Kernel. Also zwei .zip Dateien, wobei den Kernel erst als zweites flashen.
    Dann neustarten und alles "sollte" normal booten.
     
    Zuletzt bearbeitet: 11.09.2011
    Patt74, BlaXioN, PsychoPeach und 2 andere haben sich bedankt.
  15. randy, 10.09.2011 #15
    randy

    randy Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    10
    Registriert seit:
    04.04.2010
    Hi zusammen

    auch ich hatte mit meinem 53er beim zurückspielen per nvflash das gleiche problem mit der Grösse vom img 12. Habe es dann mit einem Mix von verschiedenen Backups wieder zum Laufen bekommen. Allerdings habe ich - so meine Befürchtung - nicht mehr die gleichen Partitionsgrössen wie im Auslieferungszustand, deshalb nehme ich gerne und dankend das Backup von @marcero mit :) Ich werde es bei Bedarf mal testen.

    Auf meiner Suche nach einer Lösung bin ich auf einige andere User gestossen, die das gleiche Problem hatten. Es wäre also sicher nicht verkehrt wenn man auf diesen Thread in einem FAQ hinweisen könnte.
     
  16. marcero, 10.09.2011 #16
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    Ich glaube, die hab ich da auch nicht mehr. Das sind die origalen .img vom Auslieferungszustand, aber eine davon völlig unabhängige Partitionskonfiguration.
    Außerdem wird die part-14.img nicht benutzt.

    Ohne zusätzlichen Flash in der recovery läuft es nicht, jedenfalls bei mir nicht.
    Es dient mehr dazu, wenn man vorher nur noch apx hat, wieder in das recovery zu kommen.
     
    Zuletzt bearbeitet: 10.09.2011
    Patt74 bedankt sich.
  17. randy, 10.09.2011 #17
    randy

    randy Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    10
    Registriert seit:
    04.04.2010
    Schade schade, demfall können wir unser Hannspad nicht zu 100% wie im Originalzustand zurücksetzen, auch wenn wir die Partitionen per nvflash vorher gesichert haben.

    Obwohl - verkaufen möchte ich es eh nicht, bin gerade zufrieden so wie es läuft, jetzt nachdem ich Hannstitan drauf habe. Ein Unterschied wie Tag und Nacht zum Stockrom :D
     
  18. PsychoPeach, 17.09.2011 #18
    PsychoPeach

    PsychoPeach Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    12
    Registriert seit:
    17.09.2011
    Marcero

    ICH DANKE DIR !!!!

    Ich hab mein Pad gestern bekommen und wollte neue rom flashen.
    Dann kam ich nicht mehr in den Recovery Modus sondern steckte im APX Modus fest.

    Dank deiner hochgeladenen Backup datei kann ich nun wieder ins
    Recovery rein und ich bin wirklich total erleichtert. Ich dachte schon
    ich kann mich von meinem Hannsi verabschieden :D

    Super arbeit!!!!

    LG
     
  19. BiermannFreund, 17.09.2011 #19
    BiermannFreund

    BiermannFreund Android-Hilfe.de Mitglied

    Beiträge:
    145
    Erhaltene Danke:
    10
    Registriert seit:
    25.08.2011
    die tablets wird man durch das apx eigentlich zu 99% wieder ans leben bekommen. kann halt nur sein, dass man ab und zu etwas mit den roms und kernels spielen muss :)
    nicht in panik verfallen und halt ein wenig testen.
    wenn ich mal zeit finde, werd ich mal nen Sammelthread mit den "retter-roms" starten :)
     
  20. RoMaHe, 01.10.2011 #20
    RoMaHe

    RoMaHe Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    01.10.2011
    Ich möchte mich auch bei marcero bedanken. Ich hatte schon einige Flashversuche mit anderen Images hinter mir und eigentlich die Hoffnung schon aufgegeben. Aber mit den Daten von marcero und der Anleitung konnte ich es wieder zum Leben erwecken.

    Dafür ein riesen Dankeschön...
     

Diese Seite empfehlen