1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Problem: Ubuntu UND Android nutzen

Dieses Thema im Forum "Linux auf Android Forum" wurde erstellt von Iksbat, 26.02.2012.

  1. Iksbat, 26.02.2012 #1
    Iksbat

    Iksbat Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    104
    Erhaltene Danke:
    25
    Registriert seit:
    25.02.2012
    Tablet:
    Sony Xperia Z3 Tablet Comapct
    Liebe Community,

    Ich habe auf mein TOSHIBA AC100 nach dieser Anleitung:

    https://wiki.ubuntu.com/ARM/TEGRA/AC100

    Ubuntu installiert.

    Wie bei "Notes on Installation" beschrieben habe ich eine leere SD-Karte angeschlossen, damit Ubuntu nur extern installiert wird, da ich auch weiterhin Android nutzen möchte.

    Allerdings finde ich nirgendwo eine Möglichkeit die Android-ROM zu booten.

    Andere Tutorials, bei denen scheinbar nur der Recovery-Bootloader verändert wird habe ich auch schon ausprobiert, dies hat jedoch noch bei keinem funktioniert, ich vermute es liegt daran, dass ich eine andere nvflash-Version benutze, da ich die alte nirgends finden kann...

    Weiß irgendjemand eine Möglichkeit mit möglichst geringem Aufwand beide Systeme nutzen zu können?

    lg Iksbat
     
  2. pibach, 27.02.2012 #2
    pibach

    pibach Gesperrt

    Beiträge:
    910
    Erhaltene Danke:
    107
    Registriert seit:
    13.02.2011
    Liess doch erst mal den entsprechenden Abschnitt in meinem Wiki. VG, Peter
     
    Iksbat bedankt sich.
  3. Iksbat, 27.02.2012 #3
    Iksbat

    Iksbat Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    104
    Erhaltene Danke:
    25
    Registriert seit:
    25.02.2012
    Tablet:
    Sony Xperia Z3 Tablet Comapct
    Erstmal danke für die Antwort, habe mir den Abschnitt hier:

    Erfahrungsbericht Toshiba AC100 - Nomads

    durchgelesen.

    Soweit ich das verstanden habe, müsste ich also auf Android 2.1 downgraden um parallel Ubuntu nutzen zu können.

    Die nächste Frage wäre nun ob dies ohne weiteres möglich ist, da ich das Gerät bereits mit Android 2.2 bekommen habe und somit keine Backups von Android 2.1 habe.

    lg Iksbat
     
  4. pibach, 27.02.2012 #4
    pibach

    pibach Gesperrt

    Beiträge:
    910
    Erhaltene Danke:
    107
    Registriert seit:
    13.02.2011
    Downgrade ist kein Problem (siehe Suche), aber 2.1 ist wenig nützlich. Du hast dann 2. schlechte Systeme (Linux von SD ist langsam). Ob dass dann so klappt mit der neusten Ubuntu Version kann ich Dir nicht versprechen, ging jedenfalls mit alten Versionen. Ideal wäre aber beides parallel auf interne MMC. Das müsste eigentlich auch gehen mit angepasster SOS Partition. Kann da aber leider nicht helfen.
     
    Iksbat bedankt sich.
  5. Iksbat, 27.02.2012 #5
    Iksbat

    Iksbat Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    104
    Erhaltene Danke:
    25
    Registriert seit:
    25.02.2012
    Tablet:
    Sony Xperia Z3 Tablet Comapct
    OK, dann sieht es also so aus, als würde ich mich entscheiden müssen zwischen Ubuntu und Android...

    Ich tendiere eigentlich eher zum Custom Android 2.2 mit google Market, da es wohl insgesamt stabiler läuft als Ubuntu...

    Vielen dank nochmal :)

    lg Iksbat
     
  6. pibach, 27.02.2012 #6
    pibach

    pibach Gesperrt

    Beiträge:
    910
    Erhaltene Danke:
    107
    Registriert seit:
    13.02.2011
    Stabiler? Wohl kaum. Aber im Multimedia Bereich hat der Tegra Treiber derzeit halt Nachteile.
     
  7. Iksbat, 28.02.2012 #7
    Iksbat

    Iksbat Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    104
    Erhaltene Danke:
    25
    Registriert seit:
    25.02.2012
    Tablet:
    Sony Xperia Z3 Tablet Comapct
    Also ich habe schon den Eindruck, das Android stabil läuft, Ubuntu hingegen fand ich eher etwas langsam...oder lag das nur daran, dass ich es auf SD-Karte installiert hatte?

    lg Iksbat
     
  8. pibach, 28.02.2012 #8
    pibach

    pibach Gesperrt

    Beiträge:
    910
    Erhaltene Danke:
    107
    Registriert seit:
    13.02.2011
    Android läuft stabil, aber Ubuntu auch. Und auch etwas flotter. Musst halt Lubuntu nehmen, auf MMC installieren und mit ZRAM. So wie beschrieben. Hard Float bringt auch noch was.
     
  9. Phasenspringer, 09.03.2012 #9
    Phasenspringer

    Phasenspringer Gast

    @ lksbat

    Hab unterdessen lebhafte Erfahrungen mit Ubuntu / Lubuntu / LXDE / Android etc. gemacht und möchte Dir nach vielfachem Hin und Her der System zu UBUNTU Unity (armel Version!!!) raten!

    Das teils noch schlankere LXDE hat sich bei mir nicht bewähren können.
    Gründe dafür waren u.a. das schlechte Netzwerkmanagement des UMTS Modems sowie die Bildfehler der Menüleiste (Icons wurden teilweise nicht oder falsch gezeigt)

    Mein Fazit:
    Wenn man das UBUNTU Betriebssystem nach der Anleitung von @pibach direkt auf das AC100 aufspielt, hat man nach Einrichtung von ZRAM, Flash, NVIDIA-Grafik, die meiner Meinung nach beste Umgebung für das AC100 geschaffen!
    Ich würde allerding die Paketverwaltung SYNAPTIC und den Filemanager PCmanFM als zwingende Ergänzug ansehen!

    Gegen Andoid spricht die teilweise schlechte Umsetzung der Padbedienung auf einem Lappi und meine Vorurteile gegen einen zu hohen Googlespähanteil in der Software:razz:
    Wichtig:
    Nach allen Tests kommst Du ggf. mit der einfachen Rückübertragung des entsprechenden Bootblocks auf das AC100 umgehend und ohne weiteren Datenverlust zu Android in der von Dir zuletzt verlassenen Form zurück!

    Ein wenig Spielen ist also erlaubt!:thumbsup:

    Gruß

    PS
     
    Zuletzt von einem Moderator bearbeitet: 09.03.2012
  10. pibach, 09.03.2012 #10
    pibach

    pibach Gesperrt

    Beiträge:
    910
    Erhaltene Danke:
    107
    Registriert seit:
    13.02.2011
    Danke phasenspringer.
    Allerdins die Bildfehler hab ich nicht, denke das liegt daran, das du Unity nicht deinstalliert hattest. UMTS Verwaltung ist ansonsten bei LXDE die selbe, habe damit keine Probleme. Synaptic ist sehr langsam, lieber über Kommandozeile, da hat man auch mehr Möglichkeiten, pcmanfm kann ich zustimmen, ist aber nicht wichtig.
     
  11. nils07, 09.03.2012 #11
    nils07

    nils07 Android-Hilfe.de Mitglied

    Beiträge:
    52
    Erhaltene Danke:
    5
    Registriert seit:
    01.06.2011
    Hi,

    da kann ich voll zustimmen, allerdings wollt ich mal fragen was Du hinsichtlich der NVIDIA-Grafik gemacht hast ? Das System sagt ja es gibt keinerlei Grafiktreiber, oder ?

    Greetz Nils
     
  12. Phasenspringer, 09.03.2012 #12
    Phasenspringer

    Phasenspringer Gast

    Hi Nils,

    ich hab die Beta Treiber genommen, die auf der Seite des WIKI verlinkt waren!
    1.) "deb http://people.debian.org/~jak/ac100/ unreleased main non-free" in die Paketquellen eingetragen
    2.) Dann im Terminalfenster erst "sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AC2A5FFE00823EC2" und dann "sudo apt-get update" eingetragen und ausgeführt
    3.) "sudo apt-get install tegra-libraries=12~alpha.1.0-0ac3" und "sudo apt-get install xserver-xorg-video-tegra=12~alpha.1.0-0ac3" im Terminalfenster eingetragen und ausgeführt
    4.) in den Paketquellen die Nvidia-Update-Quelle wieder deaktiviert (!!! sonst gibts nach dem nächsten Update Probleme da die neueren Treiber wohl noch nicht laufen!)

    That`s all!

    greats
    PS
     
    nils07 bedankt sich.

Diese Seite empfehlen