1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Probleme bei der Installation der YouTube-App

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von Neo, 12.12.2010.

  1. Neo, 12.12.2010 #1
    Neo

    Neo Threadstarter Gast

    Hallo,

    um mir die neue Youtube App zu installieren, habe ich mein Stein gerootet (mit irgendeinem 1 Click Root), die alte de-installiert und wollte die neue installieren. Das klappt aber jetzt nicht wirklich.

    Hab mir die runtergeladen und wenn ich auf installieren klicke, kommt:

    "Dies ist eine Systemanwendung. Möchten Sie sie dennoch ersetzen? Alle vorhandenen Nutzerdaten werden gespeichert."

    Klick ich auf Okay und installieren, erscheint der nette Ladebalken und am Ende kommt die Nachricht: Anwendung nicht installiert.

    Was mache ich falsch?

    Viele Grüße, Neo
     
  2. Neo, 12.12.2010 #2
    Neo

    Neo Threadstarter Gast

    Never mind, hab das Problem selbst gefunden.
     
  3. Neo, 12.12.2010 #3
    Neo

    Neo Threadstarter Gast

    Ich bins wieder.

    Gestern Nacht ging alles, hatte den Fehler selbst gefunden und danach funktionierte die App einfach wunderbar. Heute lässt sie sich partout nicht mehr starten, jedes mal forced closure.

    Kann mir jemand bitte helfen?
     
  4. k1l, 12.12.2010 #4
    k1l

    k1l Android-Lexikon

    Beiträge:
    1,317
    Erhaltene Danke:
    404
    Registriert seit:
    20.12.2009
    Tablet:
    HP Touchpad
    beschreib doch mal, was du da gemacht hast.
     
  5. Neo, 12.12.2010 #5
    Neo

    Neo Threadstarter Gast

    Ich hab mein Stein mit einem 1 Click Root gerootet, dann per Root Explorer die YT-App gelöscht und dann versucht, die neue zu installieren. Das ging dann zuerst nicht (das war mein Fehler, den ich selbst korrigiert habe) und musste zuerst die .google.com.youtube gelöscht und dann ging es.

    Nur heute war die ganze Zeit forced closure angesagt.....
     
  6. dodotech, 12.12.2010 #6
    dodotech

    dodotech Android-Lexikon

    Beiträge:
    1,426
    Erhaltene Danke:
    278
    Registriert seit:
    10.06.2010
    Hallo

    Es kann sein, das es mit deinem 1klick root zu tun hat!

    Welches Progi hast du benutzt zum rooten? Ansonsten guck mal im Market, dort ist die neue Youtube app zum Downloaden! Wenn sie sich nicht installieren lässt, musst du sie irgend wo anders runterladen, und diese dann mit neuen permissions nach /system/app kopieren!

    Sollte es am root liegen, kannst du zur not auch nochmal von Hand rooten! Dies ist zwar ein wenig länger in der Zeit, aber es funktioniert besser wie mit diesen 1stklick Methoden!

    Wenn du nicht zurecht kommst, melde dich nochmal und wir suchen eine Lösung! :)
     
  7. k1l, 12.12.2010 #7
    k1l

    k1l Android-Lexikon

    Beiträge:
    1,317
    Erhaltene Danke:
    404
    Registriert seit:
    20.12.2009
    Tablet:
    HP Touchpad
    ich würde einfach per OpenRecovery rooten.
     
  8. dodotech, 12.12.2010 #8
    dodotech

    dodotech Android-Lexikon

    Beiträge:
    1,426
    Erhaltene Danke:
    278
    Registriert seit:
    10.06.2010
    Wenn er die OR nutzt heißt das.....

    Der Threadersteller hat ja nicht geschrieben, welche Androidversion er benutzt! :)

    Aber sicher...sollte er die OR haben, kann er damit auch rooten! :)
     
  9. Neo, 12.12.2010 #9
    Neo

    Neo Threadstarter Gast

    Zuletzt von einem Moderator bearbeitet: 12.12.2010
  10. dodotech, 13.12.2010 #10
    dodotech

    dodotech Android-Lexikon

    Beiträge:
    1,426
    Erhaltene Danke:
    278
    Registriert seit:
    10.06.2010
    Hallo

    Die YouTube.apk sollte aber in /system/app da sein! Zur Not, nimmst du die YouTube.apk und kopierst sie auf deine sdcard! Dort gibst du ihr entweder mit dem RootExplorer permission 644, oder aber du machst es über den Terminal Emulator!

    Wenn du es mit RootExplorer machst, sieht es folgendermaßen aus:

    XX
    X
    X

    Dies ist permission 644!

    Wenn du es über den Terminal Emulator machst, gibst du folgenden befehl ein:

    Dann kommt das Kopieren in den Ordner /system/app:

    Du musst unbedingt vorher die permissons setzen, das ist wichtig!

    Wenn du sie mit RootExplorer Kopierst, sollte dein System Schreib und Leserechte bekommen! Dafür drückst du im RootExplorer oben auf R/w!

    Nun kopierst du die YouTube.apk von der sdcard ins System!

    Machst du es mit dem Terminal Editor gibst du folgende Befehle ein!

    Damit das System Schreib und Leserechte bekommt:
    Dann das Kopieren ins System!
    Ist dies erledigt, beendest du deinen Terminal Emulator mit der Eingabe von exit!

    Danach kannst du einen reboot machen, und die Youtube App sollte in deinem Menu erscheinen, und sich ordnungsgemäß ausführen lassen! :)

    Solltest du noch Fragen haben, melde dich...:)
     
  11. Neo

    Neo Threadstarter Gast

    Hallo,

    ich versteh nicht wirklich etwas von Root usw. Auch daher habe ich den 1 Klick Root genommen. Von daher, ich weiß nicht, was mit Terminal Emulator gemeint ist. Dass die App in system/app muss, ist mir dann auch selbst aufgefallen und ich hab sie per Root Explorer da rein kopiert.

    Du sprichst von den Permissions.

    Nun, wenn ich die App lang klicke bekomme ich ein Kontextmenu und dort gibt es den Punkt Permissions. Aber dort steht nichts von 644, sondern dort sind nur Häkchen, die man ankreuzen kann.

    User x x x
    Group x x x
    Others x x x

    Falls du mit 644 das Muster meinst, welches du gemacht hast, das habe ich gerade ausprobiert und es geht trotzdem nicht.

    MfG, Neo
     
  12. dodotech, 13.12.2010 #12
    dodotech

    dodotech Android-Lexikon

    Beiträge:
    1,426
    Erhaltene Danke:
    278
    Registriert seit:
    10.06.2010
    Also:

    Der Terminal Editor, ist eine art Eingabeaufforderung so ähnlich wie bei Windows!! Nur das hier Linux Befehle zum Einsatz kommen!

    Die Permission 644 enspricht dem Muster:
    xx
    x
    x

    Diese kannst du mit dem RootExplorer setzen!

    Wenn du die YouTube.apk aus dem System löschst, und sie mit dem Market neu Installierst, was passiert denn dan? Normalerweise sollte sie doch installiert werden!

    Bekommst du da auch Fehler?
     
  13. Neo

    Neo Threadstarter Gast

    Nochmal zum Muster:

    Also User und Read und Write = x
    Und Group und Read = x
    Und Others und Read x

    Ich habe noch nicht versucht, die YT-App zu löschen und sie über den Market neu zu installieren. Sollte ich das?
     
  14. dodotech, 13.12.2010 #14
    dodotech

    dodotech Android-Lexikon

    Beiträge:
    1,426
    Erhaltene Danke:
    278
    Registriert seit:
    10.06.2010
    Versuche dies mal ....Wenns klappt kannst du dir diese Umständlichen Sachen ersparen..;)
     
  15. Neo

    Neo Threadstarter Gast

    Aber hätte ich dann nicht wieder die alte 2.1er App? (was natürlich besser ist als keine ;) )
     
  16. dodotech, 13.12.2010 #16
    dodotech

    dodotech Android-Lexikon

    Beiträge:
    1,426
    Erhaltene Danke:
    278
    Registriert seit:
    10.06.2010
    Jupp und dann sollte er dir sagen das ein Update verfügbar ist, wenn die neue App für 2.1 im Market enthalten ist!

    Vieleicht hast du da Glück...Zur Not kann ich dir meine App extrahieren und angängen! ;)
     
  17. Neo

    Neo Threadstarter Gast

    So, die App ist nun aus system/app gelöscht. Hab im Market nach Youtube gesucht und finde dort nichts. Natürlich finde ich da schon was, aber halt nicht die offizielle YT-App.
     
  18. joh

    joh Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    0
    Registriert seit:
    12.05.2010
    so habe das problem auch. youtube app nur fc's.

    download aus dem market geht, update auf 2.1.6, danach beim start fc.

    info: got 2.2.1 inkl. OR 2.01


    nachdem ich mir nicht mehr zu helfen wusste....

    via adb shell mit find alle youtube eintraege aufgeraeumt ( /cache /data /system )

    1. version aus dem market genommen. fc's. obiges wiederholt, alles bereinigt.

    2. da es keinen download von youtube.apk irgendwo gibt, hab ich mir eine aus dem cm6 gapps archiv genommen und nach /system/app kopiert. gleiches problem.
    -rw-r--r-- 1 0 0 788998 Dec 14 09:30 youtube.apk

    koennte mir ein netter mensch mal eine youtube.apk anhaengen? danke.

    ich bin ja sonst eher nicht ratlos...:confused:
     
  19. dodotech, 14.12.2010 #19
    dodotech

    dodotech Android-Lexikon

    Beiträge:
    1,426
    Erhaltene Danke:
    278
    Registriert seit:
    10.06.2010
    Hallo

    Hier mal meine YouTupe.apk

    Diese einfach nach /system/app kopieren und dort permission 644 setzen!

    Beim RootExplorer ist das folgendes Muster:

    xx
    x
    x

    Solltest du mit ADB Kopieren oder mit einem Terminal Emulater, nutzt du folgende Befehle!


    Danach einen reboot machen, und es sollte klappen! :)
     

    Anhänge:

  20. joh

    joh Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    0
    Registriert seit:
    12.05.2010
    danke. datei liegt unter /system/app - rechte passen auch.

    habe aber kein icon fuer youtube irgendwo finden koennen?!

    und nu?
     

Diese Seite empfehlen