1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

programmieren für android (/galaxy)

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von NewIceDragon, 03.09.2009.

  1. NewIceDragon, 03.09.2009 #1
    NewIceDragon

    NewIceDragon Threadstarter Erfahrener Benutzer

    Beiträge:
    154
    Erhaltene Danke:
    1
    Registriert seit:
    23.07.2009
    Hallo,
    ich habe einen kumpel der für das galaxy was programmieren möche, ich selbst kenne mich da leider nicht so aus aber ich hab ihm gesagt ich frag mal nach^^.

    also mit programmieren usw. kennt er sich eigentlich recht gut aus nur will er wissen ob es einen emulator gibt mit dem man auf dem pc dann programmieren und testen kann... er hat zwar etwas aber da kommt wohl immer das er keine zugriffsrechte hätte... er selbst hat das handy nicht, ich hab ihn auf die idee gebracht.

    mfg Jens
     
  2. Shinigami, 03.09.2009 #2
    Shinigami

    Shinigami Fortgeschrittenes Mitglied

    Beiträge:
    436
    Erhaltene Danke:
    69
    Registriert seit:
    08.04.2009
    Hallo Jens.

    Ja das gibt's, ist Bestandteil des SDKs. Einfach mal nach Android SDK suchen. Inkl Anleitung bei Google vorhanden.

    Gruß,
    Shini
     
  3. goto, 03.09.2009 #3
    goto

    goto Android-Hilfe.de Mitglied

    Beiträge:
    91
    Erhaltene Danke:
    8
    Registriert seit:
    01.05.2009
  4. NewIceDragon, 04.09.2009 #4
    NewIceDragon

    NewIceDragon Threadstarter Erfahrener Benutzer

    Beiträge:
    154
    Erhaltene Danke:
    1
    Registriert seit:
    23.07.2009
    also mein kumpelsagt ich zitiere^^

    "
    ja das problem an diesen android sdk ist das ich das nicht in eclipse einfügen kann weil da irgendwas fehl
    t
    mir kommts so vor als ob ich das falsche eclipse hab
    "
     
  5. yahooooo, 04.09.2009 #5
    yahooooo

    yahooooo Android-Hilfe.de Mitglied

    Beiträge:
    107
    Erhaltene Danke:
    3
    Registriert seit:
    22.05.2009
  6. Scogit, 06.09.2009 #6
    Scogit

    Scogit Android-Hilfe.de Mitglied

    Beiträge:
    69
    Erhaltene Danke:
    2
    Registriert seit:
    16.08.2009
    Phone:
    Samsung Galaxy
    Die installation ist "eigentlich" relative leicht allerdings hatte ich anfangs auch Probleme das Plugin über die HTTPS Update Site zu installieren aber alternativ funktioniert auch die andere Update Site... Der Rest ist dann ziemlich simpel einfach das SDK downloaden, entpacken und in Eclipse in den Einstellungen den Pfad zum SDK angeben fertig.
     
  7. yahooooo, 06.09.2009 #7
    yahooooo

    yahooooo Android-Hilfe.de Mitglied

    Beiträge:
    107
    Erhaltene Danke:
    3
    Registriert seit:
    22.05.2009
    Sagt mal: dauert das bei Euch eigentlich auch so lange, bis der Emulator startet? Oder simuliert der sogar den lahmen Bootvorgang? *g*
     
  8. Shinigami, 06.09.2009 #8
    Shinigami

    Shinigami Fortgeschrittenes Mitglied

    Beiträge:
    436
    Erhaltene Danke:
    69
    Registriert seit:
    08.04.2009
    Hi.

    Ja, es dauert bei mir auch ähnlich lange wie der Bootvorgang meines Handys (G1) auf nem Notebook mit nem 1,66Ghz Core Duo oder Desktop-PC mit 2Ghz AMD X2.

    Gruß,
    Shini
     
  9. swordi, 06.09.2009 #9
    swordi

    swordi Gewerbliches Mitglied

    Beiträge:
    3,389
    Erhaltene Danke:
    441
    Registriert seit:
    09.05.2009
    bei mir is der emulator elends langsam. damit kann ich eher gar nicht arbeiten. machs jetzt immer direkt am händy

    denke es liegt an meinem 64 bit system. traurig dass diese nach so langer zeit noch immer nicht brauchbar unterstützt werden.
     
  10. Shinigami, 06.09.2009 #10
    Shinigami

    Shinigami Fortgeschrittenes Mitglied

    Beiträge:
    436
    Erhaltene Danke:
    69
    Registriert seit:
    08.04.2009
    Also wenn der Emulator einmal läuft ist die Geschwindigkeit in Ordnung - sowohl auf Win XP 32bit als auch unter Win 7 64bit. Läuft aber nicht ganz so smooth wie mein G1 mit CM 3.6.8.1 drauf. Zum Rumspielen langt's würde ich sagen.

    Gruß,
    Shini
     
  11. SirMArtin, 07.09.2009 #11
    SirMArtin

    SirMArtin freier Samsungsupporter

    Beiträge:
    113
    Erhaltene Danke:
    7
    Registriert seit:
    05.08.2009
    Bei mir startet der Emulator auch langsam. Allerdings schneller als mein Galaxy. Meine Systeme: MacBook (Mac OS X 10.5, DualCore 2GHz) und Vista64 (DualCore 2,5GHz).

    Allerdings braucht man ihn ja auch nur einmal zu starten. Danach wird die App immer neu in den Emulator deployt. Das geht relativ fix, könnte aber etwas schneller sein.

    zum OP: Wenn Dein Kumpel sich mit "Programmieren" auskennt, frag ich mich, warum er nicht selbst ein Forum bedienen kann... :confused:
     
  12. PAPPL, 07.09.2009 #12
    PAPPL

    PAPPL Erfahrener Benutzer

    Beiträge:
    162
    Erhaltene Danke:
    16
    Registriert seit:
    04.05.2009
    Hallo,
    ich habe Eclipse, Java, Android-Plugin und das SDK auf einem Atom-Netbook laufen und nach zehn Minuten warten bis der Emulator hochgefahren ist habe ich es abgebrochen.
    Aber:
    Wenn man das Android-Mobile ansteckt wird es beim Emulieren direkt auf dem Gerät ausgeführt und das ohne Wartezeit.
    :)
     

Diese Seite empfehlen