1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Prozess wird unerwartet beendet

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von ChrisMobile, 05.04.2011.

  1. ChrisMobile, 05.04.2011 #1
    ChrisMobile

    ChrisMobile Threadstarter Android-Experte

    Beiträge:
    529
    Erhaltene Danke:
    74
    Registriert seit:
    17.03.2010
    Phone:
    HTC One X
    Hallo zusammen,

    ich habe meine erste App heute kräftig erweitert, doch obwohl keine Fehler angezeigt werden und der Compiler auch nix sagt, läuft die App einfach nicht mehr.
    Ich suche jetzt seit Stunden die Nadel im Heuhaufen aber komme einfach nicht weiter.
    Das Debuggen hat mich nicht wirklich weitergebracht und auch Logcat sagt mir nichts konkretes..

    Die App schmiert direkt beim starten ab, daher kann es doch nur ein Problem in der ersten Aktivity und wohl auch irgendwo in der "onCreate" Methode oder sehe ich das falsch?
    Selbst wenn ich alles auskommentiere, wird der Prozess trotzdem unerwartet beendet.

    Kann mir jemand einen Tipp geben?

    Viele Grüße
     
  2. swordi, 06.04.2011 #2
    swordi

    swordi Gewerbliches Mitglied

    Beiträge:
    3,389
    Erhaltene Danke:
    441
    Registriert seit:
    09.05.2009
    ja der tipp lautet LogCat
     
  3. ramdroid, 06.04.2011 #3
    ramdroid

    ramdroid Android-Experte

    Beiträge:
    644
    Erhaltene Danke:
    89
    Registriert seit:
    20.10.2010
    vielleicht eine activity nicht im manifest eingetragen?

    Aber der dalvik debug monitor müsste dir doch die Abstürze anzeigen.
     
  4. ChrisMobile, 06.04.2011 #4
    ChrisMobile

    ChrisMobile Threadstarter Android-Experte

    Beiträge:
    529
    Erhaltene Danke:
    74
    Registriert seit:
    17.03.2010
    Phone:
    HTC One X
    Wie ich schon geschrieben hab sagt mir LogCat und der Debug-Log nichts konkretes.
    Ich sehe eben nur, dass die Activity "MainMenu" abgeschmiert ist.

    Da ich dann natürlich trotzdem nicht genau weiß, wo der Fehler liegt komme ich damit eben nicht wirklich viel weiter.
    Ich hab die GUI (xml) einfach neu angelegt und jetzt ging es wieder, evtl. hatte Eclipse da was beim Source>Format kaputt gemacht..

    Ich dachte nur, dass man evtl. sogar irgendwo die entsprechende Zeile angezeigt bekommt. :winki: Würde für die Zukunft bestimmt weiterhelfen aber jetzt geht es ja erstmal wieder.

    Danke und viele Grüße
     
  5. ramdroid, 06.04.2011 #5
    ramdroid

    ramdroid Android-Experte

    Beiträge:
    644
    Erhaltene Danke:
    89
    Registriert seit:
    20.10.2010
    Mit fällt gerade ein, bei größeren Veränderungen im Projekt stürzen meine Apps beim Starten auch manchmal unerwartet ab. Da hilft es aber in der Regel das Projekt einfach nochmal neu bauen zu lassen:

    Project -> Clean

    Wenn sowas das nächste mal Auftritt, einfach mal probieren....
     

Diese Seite empfehlen