1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Pulse bleibt nach ROM-Flash im Startbildschirm hängen...

Dieses Thema im Forum "Root / Hacking / Modding für T-Mobile Pulse" wurde erstellt von Connectodian, 01.11.2009.

  1. Connectodian, 01.11.2009 #1
    Connectodian

    Connectodian Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    66
    Erhaltene Danke:
    5
    Registriert seit:
    01.11.2009
    Hallo liebe Gemeinde,

    da ich mit dem Pulse im Auslieferungszustand unzufrieden war (insb. mangels A2SD), hab ich meinen Pulse per Superboot gerootet, anschließend AmonRAs Recovery Image drauf und schließlich das Modaco-Pulse-ROM 1.1 geflasht. Soweit, so gut, das hat auch alles funktioniert, das System hat gebootet, alles lief einwandfrei. Ich hatte die MicroSD vorher nicht partitioniert, wollte aber eben A2Sd nutzen. Da A2SD 2 die Partitionierung und Einrichtung der ext2 selbst vornehmen kann, hab ich eben A2SD 2 installiert und dort das Auslagern der Apps auf die Speicherkarte ausgewählt. Da das Programm aber anscheindend eben nicht selbständig partitioniert hat, lief die App-Auslagerung ins Leere, so dass daraufhin keine App mehr lief. Anstatt über QuickBoot dann in den Recovery Mode zu gehen, hab ich allerdings den Pulse runtergefahren und normal gestartet. Seitdem fährt das Gerät nicht mehr hoch - ich sehe den ersten T-Mobile-Screen, beim Android-Screen bleibt der Pulse dann hängen, und das war's. In den Bootloader-Modus komme ich noch, das bringt mir aber nichts. In den Recovery-Mode komme ich nicht mangels Tastenkombination nach Power-Off, eine "Hardreset-Funktion" besitzt das Gerät ja ebenfalls nicht. Auch per ADB komme ich nicht in den Recovery-Mode, da der PC den Pulse im Startbildschirm nicht erkennt. Ohne Recovery-Mode kann ich aber nicht neu flashen oder das Nandroid-Backup zurückrollen.

    Weiß jemand Rat? Ansonsten werde ich das Gerät zum T-Mobile-Shop bringen müssen zum Einschicken, was wohl ewig dauern dürfte und ich mir die "Experten-Aussagen" der T-Mobile-Mitarbeiter schon vorstellen kann. Bitte keine Antworten a la "selbst Schuld", aber bei einer derartigen Beschneidung der Systemmöglichkeiten durch Huawei / T-Mobile hat man nunmal leider schlechte Karten...

    Gruß
     
  2. winne, 01.11.2009 #2
    winne

    winne Android-Guru

    Beiträge:
    3,788
    Erhaltene Danke:
    644
    Registriert seit:
    09.05.2009
    Phone:
    S60
    Wearable:
    Pebble schwarz
    Warum :D

    Die ganze Problematik der fehlenden Möglichkeiten zum wipen u.ä. wurde hier auch schon erörtert:
    http://www.android-hilfe.de/t-mobile-pulse-forum/8304-pulse-hardreset.html
    scheinst also wirklich schlechte Karten zu haben. Da du durch den Root-Versuch "siehe oben" bist, könnte unter Umständen sogar ein Umtausch platzen. :eek: Kannst nur hoffen, das sie durch diese Unzulänglichkeiten selber keine Kontrollmöglichkeit haben und einfach tauschen. ;)
    Helfen kann ich dir nicht weiter, da ich kein "Pulse" besitze.
    Viel Glück.

    Edit : Hast du diese Startprozedur nochmal versucht :
    aus diesem Beitrag :
    http://www.android-hilfe.de/root-ha...obile-pulse-root-amonra-recovery-1-2-3-a.html
     
    Zuletzt bearbeitet: 01.11.2009
  3. Connectodian, 01.11.2009 #3
    Connectodian

    Connectodian Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    66
    Erhaltene Danke:
    5
    Registriert seit:
    01.11.2009
    Ja, mit der Prozedur kommt man in den Bootloader-Modus, aber der nützt einem auch nichts, hier kann man eben die Boatloader-Datei oder das Recovery-Image updaten. Trotzdem danke, werde dann wohl zu den Rosanen gehen müssen, im schlimmsten Fall bleibt mir ein schwarz-weißer Briefbeschwerer...

    Hat denn hier noch niemand seinen Pulse geflasht, geschweige denn gerootet und/oder Erfahrung mit App 2 SD 2? Ein Pulse ohne Root und der Möglichkeit, A2SD zu verwenden, ist in meinen Augen unbrauchbar. Das ist so wie wenn ich ein Notebook kaufe, die Festplatte aber nicht zum Installieren von Anwendungen verwenden kann, sondern mir nur (mickrige) 50 MB interner Speicher zur Verfügung stehen. Dass es eines Rootzugangs bedarf, um diesen Umstand zu beseitigen, ist m.E. an und für sich ein KO-Kriterium für bzw. gegen Android. Gemeinsam mit den gerätespezifischen Unzulänglichkeiten komme ich zu dem Schluss, wohl kein Android-Gerät mehr zu kaufen. Jedenfalls so lange nicht, wie systemseitig dem User keine Möglichkeit gegeben wird, Apps auf der Speicherkarte zu installieren. Eigentlich schade, weil das System gute Ansätze hat, aber so bleibt mir wohl nur der Schritt zurück zu WM, auch wenn ich damit nicht mehr wirklich zufrieden bin. Wenigstens ist der Zugriff auf die Speicherkarte hier ohne Eingriff ins System möglich...

    Hat trotzdem noch jemand Tipps? Wenn ich es wieder zum Laufen kriege, werd ich es wohl verkaufen...
     
  4. winne, 01.11.2009 #4
    winne

    winne Android-Guru

    Beiträge:
    3,788
    Erhaltene Danke:
    644
    Registriert seit:
    09.05.2009
    Phone:
    S60
    Wearable:
    Pebble schwarz
    eben, ich hätte gedacht, das man die Root-Prozedur hier einfach nochmal starten kann. :confused:

    Aber du wirst mit dem "Copy ins Leere" die System-Apps ins Nirvana geschickt haben, welches sich nur durch einen erneuten Flash korrigieren lässt und wenn ich es richtig verstanden habe, gibts auf dem Pulse wohl keine Möglichkeit ins Recovery zu booten. :eek:
    Damit hast du tatsache die A....karte gezogen.

    Edit: diese Pulse-Problematik Android zuzuschieben ist allerdings auch sehr einseitig. Ich würde nie wieder ein WM haben wollen. Dazu ist selbst das Standard-Android einfach zu gut.:D
     
    Zuletzt bearbeitet: 01.11.2009
  5. Connectodian, 01.11.2009 #5
    Connectodian

    Connectodian Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    66
    Erhaltene Danke:
    5
    Registriert seit:
    01.11.2009
    Bootloader-Datei ist ja drauf, ein erneuter Root bringt, wie Du auch sagst nichts, weil wohl Systemdateien nicht mehr gefunden werden können. Aber kann es überhaupt sein, dass A2SD 2 auch sämtliche systemrelevante Apps versucht, auf die Speicherkarte zu schieben bzw. müsste A2SD 2 dann nicht meckern? Womöglich ist der Programmierer gar nicht davon ausgegangen, dass jemand ohne ext2 (alle) Apps auslagern will. Aber in einem anderen Thread hier im Forum ist das auch schon mal jemandem passiert, betraf aber m.W. keine Systemdateien, er konnte "nachträglich" partitionieren, und alles ging wieder nach erneuter Installation der (externen) Apps. Evtl. hat das Bootproblem auch gar nichts mit A2SD 2 zu tun?!

    Leider ist keine Tastenkombination bekannt, die den Pulse nach Power-Off in den Recovery-Mode lädt, also weiß ich nicht, wie ich erneut flashen sollte. Aber T-Mobile dürfte das selbe Problem mit dem Gerät (und allen anderen Pulse, die nicht mehr booten) haben, so dass eine "Reparatur" ohne Eingriff in die Hardware unmöglich sein sollte.

    Ich schiebe mein spezielles Problem nicht Android zu, aber wäre Android wirklich "offen", hätte es dieses Problem erst gar nicht gegeben. Bin selbst jahrelang mit WM-Geräten rumgelaufen und alles andere als zufrieden mit der Produktpolitik von MS (vielleicht gibt es ja mit WM 7 ein letztes Aufbäumen?), aber seine Aufgabe hat es dennoch immer erfüllt, und wer nicht basteln WILL, der kriegt auch normalerweise kein Proplem, es sei denn, die Hardware passt nicht, aber dafür kann das OS nichts. Im Gegensatz dazu haben alle Android-Geräte (noch) die gleichen OS-bedingten Einschränkungen. Jedenfalls soll mir keiner was von "offenem" System oder "nie wieder basteln" erzählen. Meine Meinung.

    Gruß
     
    Zuletzt bearbeitet: 01.11.2009
  6. Connectodian, 01.11.2009 #6
    Connectodian

    Connectodian Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    66
    Erhaltene Danke:
    5
    Registriert seit:
    01.11.2009
    Äh sorry, aber wieso wurde mein Pulse-Thread ins Hero-Root-Unterforum verschoben :confused:
     
  7. Connectodian, 02.11.2009 #7
    Connectodian

    Connectodian Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    66
    Erhaltene Danke:
    5
    Registriert seit:
    01.11.2009
    Falls es jemanden interessiert, ich hab das Problem gelöst. Ich musste die Recovery-Datei im Bootloader-Mode fastbooten durch >fastboot-windows.exe boot recovery recovery-RA-pulse-v1.2.3.img. Danach im Recovery-Mode wipen und neu booten, das war's, der Pulse ist wieder am Start (in meinem Fall nun mit MCR 1.1). Nur so nebenbei - so wird man jeden Pulse, der beim Booten hängen bleibt, wieder hinkriegen - abgeben im T-Mobile-Shop und langes warten kann man sich somit sparen. Falls man recovery-RA-pulse-v1.2.3.img nicht drauf hat, einfach wie bei Modaco beschrieben im Bootloader-Mode aufspielen (vorher natürlich rooten mittels Superboot). So wird man nebenbei dank Huawei und T-Mobile in kurzer Zeit zum Linux-Kenner ;)

    P.S.: Ich übernehme keine Haftung für die Ablehnung von Garantiefällen, falls die einschlägigen T-Mobile-Techniker das mitlesen sollten :D
     
    MarcellesWolles bedankt sich.
  8. Pyrazol, 02.11.2009 #8
    Pyrazol

    Pyrazol Android-Guru

    Beiträge:
    3,250
    Erhaltene Danke:
    366
    Registriert seit:
    20.02.2009
    Phone:
    Nexus 6
    Tablet:
    Nexus 7 (2013)
    Wearable:
    Moto 360 / Sony Smartwatch 3
    Arrgh! Sorry, falls es jemanden verwirrt haben sollte: Ich habe den Thread aus Versehen ins Hero-Root-Forum verschoben, statt ins Pulse-Root-Forum. :rolleyes:

    Nächstes Mal also bitte gleich im richtigen Unterforum posten, dann passiert das gar nicht :p
     
    Connectodian bedankt sich.
  9. mievalt, 03.11.2009 #9
    mievalt

    mievalt Android-Hilfe.de Mitglied

    Beiträge:
    108
    Erhaltene Danke:
    23
    Registriert seit:
    19.10.2009
    Sagt mal ist es vielleicht möglich eine Step by Step Anleitung zu schreiben, damit auch die Linux-Noobs und Android-Neulinge das hinkriegen??? :confused:

    Danke euch!

    Ist ja schonmal super, dass es endlich eine Möglichkeit gibt das Pulse wieder auf die Beine zubekommen... Nur doof, dass meines schon seit 1,5 Wochen beim T-Punkt rumliegt und nicht getausch wird.... :mad:

    Heute mache ich mal Druck, sonst nehme ich es eben wieder mit und probiers selber...
     
  10. pandinus, 03.11.2009 #10
    pandinus

    pandinus Erfahrener Benutzer

    Beiträge:
    197
    Erhaltene Danke:
    70
    Registriert seit:
    31.10.2009
    Hallo,

    ich habe es geschafft das Pulse ROM zu installieren.

    Vorher habe ich über Quickbookdie SD Karte formtiert in ext2+swap+fat32.

    Nun erkennt das Pulse die SD Karte nicht. Auch schon vorher mit dem originalen ROM nicht. Bevor ich irgendetwas wipe, würde ich gerne wissen wie ich das hinkriege, das die SD Karte erkannt wird. Wenn ich die SD Karte normal formatiere erkennt das Pulse die Karte.

    Wo finde ich denn dieses A2SD?

    Vielen Dank!
     
  11. Haunter1982, 03.11.2009 #11
    Haunter1982

    Haunter1982 Android-Experte

    Beiträge:
    873
    Erhaltene Danke:
    134
    Registriert seit:
    08.05.2009
    Phone:
    Sony Xperia Z5 Compact
    Denke die Fat-Partition muss am Anfang der SD-Karte liegen, dann die Ext2 und anschließend die swap. Da sonst die Mount-Points die eigentlich auf die SD-Karte verweisen auf die ext-Partition verweisen.
     
  12. pandinus, 03.11.2009 #12
    pandinus

    pandinus Erfahrener Benutzer

    Beiträge:
    197
    Erhaltene Danke:
    70
    Registriert seit:
    31.10.2009
    Partioniert habe ich mit dem Recovery Image.

    So sieht die Partitionstabelle im Festplattendienstprogramm aus.

    [​IMG]

    Laut diesem Bild ist die fat32 Partition zuerst.

    Da ich meine Programme vorher nicht ausgelagert habe, musste ich diese neuinstallieren. Dabei habe ich festgestellt, das der interne Speicher nicht weniger wird. Also müssen die Programme auf der Karte installiert worden sein.

    Update: Habe die Karte nochmal komplett fat32 formatiert. Dann über das Image fat32+ext2+swap formatiert. Die Karte wird nicht erkannt. :(
     

    Anhänge:

    Zuletzt bearbeitet: 03.11.2009
  13. Haunter1982, 03.11.2009 #13
    Haunter1982

    Haunter1982 Android-Experte

    Beiträge:
    873
    Erhaltene Danke:
    134
    Registriert seit:
    08.05.2009
    Phone:
    Sony Xperia Z5 Compact
    Hm... Komisch... den namen Pulse hast du selbst eingetragen? Oder wo kommt der her. Kennt das Pulse vielleicht nur FAT und nicht FAT32?

    nach der Komplett-Formatierung auf das FAT zurück, wurde sie da vom Pulse erkannt?
     
  14. pandinus, 03.11.2009 #14
    pandinus

    pandinus Erfahrener Benutzer

    Beiträge:
    197
    Erhaltene Danke:
    70
    Registriert seit:
    31.10.2009
    Ich habe jetzt Open Suse via VMWare laufen.

    [​IMG]

    Das Pulse sagt mir dann, das eine "Beschädigte SD Karte" vorhanden ist.
    Formatieren im Pulse bringt nichts.
     

    Anhänge:

  15. pandinus, 03.11.2009 #15
    pandinus

    pandinus Erfahrener Benutzer

    Beiträge:
    197
    Erhaltene Danke:
    70
    Registriert seit:
    31.10.2009
    Folgende Vorgehensweise:

    1. SD Karte mit Recovery Image Formatiert. fat32+ext2+swap

    2. Telefon mit SD Karte gestartet. SD Karte wird nicht erkannt.

    3. SD Karte entfernet. Telefon neu gestartet.

    4. Telefon meldet keine SD Karte

    5. SD Karte eingesetzt. Telefon meldet "SD Karte wird vorbereitet" "Nach Fehlern wird gesucht". Weiss nicht wie lange ich warten soll.

    6. SD Karte aus Telefon entfernt. Karte in SD Card Adapter an PC angeschlossen. Wird vom PC als Laufwerk erkannt. Kann dort Ordner und Dateien erstellen.

    7. SD Karte wieder ausgeworfen. Erneut in Telefon gesteckt. Gleiche Meldung siehe Punkt 5.

    Weiss keinen Rat mehr.
     
  16. pandinus, 04.11.2009 #16
    pandinus

    pandinus Erfahrener Benutzer

    Beiträge:
    197
    Erhaltene Danke:
    70
    Registriert seit:
    31.10.2009
    Ich habe es geschafft! :D

    Ich hätte mir die Anleitung auf MoDaCo genau durchlesen sollen. Da steht:
    - A2SD included (fully automatic - thanks cyanogen!) - create a EXT2 partition as your second partition to use. dalvik-cache remains on device. EXT3 and EXT4 are NOT supported. You must NOT have a swap partition on your SD, or it will refuse to mount.

    Es lag daran, das ich im Recovery Image eine ext3 und eine swap Partition auf der SD Karte angelegt habe. Das war falsch.

    Wie folgt bin ich vorgegangen:

    1. Im Festplatendienstprogramm (Mac OS X) die SD Karte in MS-Dos Fat formatiert mit SD Card Adapter und Kartenlesegerät.

    2. Im Festplatendienstprogramm (Mac OS X) zwei fat32 Partitionen erstellt. Die erste ist die, die fat32 bleibt. Für Bilder, Musik etc.

    3. Über VMWare mit OpenSuse in YaST die zweite Partition gelöscht und eine ext2 Partition erstellt.

    4. Karte entfernt und in Telefon eingesteckt. Wurde auch prompt erkannt.

    5. Telefon mit Karte an den Mac gesteckt und update-pulse-1.1-core-signed.zip auf Karte kopiert.

    6. Mit QuickBoot in Recovery Modus und das ROM geflasht.

    Fertig.

    Nachdem Flash liefen ein paar Programme nicht mehr, diese habe ich über dem Market deinstalliert und neuinstalliert. Es waren einige. Jetzt kommt das Aber. Von ehemals 14MB Platz auf dem internen Speicher sind es jetzt 36MB. Das ist der Beweis, das die Programme auf der SD Karte installiert worden sind.
     
    Zuletzt bearbeitet: 04.11.2009
  17. Haunter1982, 04.11.2009 #17
    Haunter1982

    Haunter1982 Android-Experte

    Beiträge:
    873
    Erhaltene Danke:
    134
    Registriert seit:
    08.05.2009
    Phone:
    Sony Xperia Z5 Compact
    Na dann Passts doch, wusste nicht das das Pulse bzw. das Modaco ROM kein Swap-partition unterstützt... hab ja auch kein Pulse :)
     
  18. Connectodian, 08.11.2009 #18
    Connectodian

    Connectodian Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    66
    Erhaltene Danke:
    5
    Registriert seit:
    01.11.2009
    MCR 1.2 ist draußen, schreibt nun auch den dalvik-cache auf Speicherkarte und enthält bereits eine Vielzahl von APNs.

    edit:

    Gerade ausprobiert. Mit der neuen Version macht der Pulse erst wirklich Spaß, da der Cache auf die SD ausgelagert wird und somit nun die vollen 87 MB interner Speicher dauerhaft zur Verfügung stehen - zu Gunsten der Arbeitsgeschwindigkeit. Von daher unbedingt jedem zu empfehlen, allerdings sollte man auf die Geschwindigkeit der Speicherkarte achten.
     
    Zuletzt bearbeitet: 08.11.2009
  19. ludwich, 14.11.2009 #19
    ludwich

    ludwich Neuer Benutzer

    Beiträge:
    14
    Erhaltene Danke:
    0
    Registriert seit:
    10.11.2009
    Hallo,

    ich hab da noch eine Frage zum ROMupdate, ich habe es leider auch geschafft die Dauerreebootschleife hinzugekommen :-(.
    Es wir ja beschrieben das die Auslagerungsdateien auf die SD Karte wandern und deshalb eine zweite Partition mit ext2 Dateisystem notwendig wäre, nun meine Frage: Geht es denn auch nur mit einer FAT Partition und die Auslagerungen bleiben im Pulse?
    Ich möchte die SD Karte gegen einen große tauschen (später) und habe keine Lust dann wieder alles zu killen.
    Kann mir da jemand etwas dazu sagen??

    Gruß Ludwich
     
  20. pandinus, 14.11.2009 #20
    pandinus

    pandinus Erfahrener Benutzer

    Beiträge:
    197
    Erhaltene Danke:
    70
    Registriert seit:
    31.10.2009
    Du kannst mit "Backup for Root" ein komplettes Backup machen. Dort werden auch deine Apps auf der SD Karte gesichert.
    Wenn du dir später ein grössere holst, kannst du dein Backup wieder einspielen.

    Probiert habe ich es persönlich noch nicht.

    Bevor ich mir eine grösser SD Karte geholt habe, kannte ich das Programm noch nicht. Von daher kann ich nicht sagen, ob es auch funktioniert. Ich sag immer probieren geht über studieren. Ich habe auch schon mehrere Male alles neu machen müssen, weil ich zu viel probiert habe. Aber daraus lernt man dann. ;)
     

Diese Seite empfehlen