Recovery geschrottet

Dieses Thema im Forum "Root / Hacking / Modding für HANNspree HANNSpad (SN10T1)" wurde erstellt von SpaceyX, 01.10.2011.

  1. SpaceyX, 01.10.2011 #1
    SpaceyX

    SpaceyX Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    2
    Registriert seit:
    15.04.2011
    Huhu Leute,

    ich depp hab mit der CWM-App gespielt und dabei eine andere version aufs PAD geflasht. nun komm ich nicht mehr ins recovery. hab verschiedene versionen probiert. entweder geht das display aus oder er lädt am recovery vorbei ins system. gibts ne möglichkeit, das passende recovery ohne komplettes "plattmachen" wieder aufs PAD zu bekommen?

    danke, danny!

    Gesendet mit der Android-Hilfe.de-App
     
  2. SHORTY-NR1, 01.10.2011 #2
    SHORTY-NR1

    SHORTY-NR1 Fortgeschrittenes Mitglied

    Beiträge:
    342
    Erhaltene Danke:
    52
    Registriert seit:
    30.08.2011
    Ich hätte da eine Ide!

    Hier hat der User marcero ein Backup vom Original ROM, aber es hat bereits die CWM in der Part11 drin.

    Ich "glaub" wenn du in der Datei hannsconf_guide.cfg alles rausnimmst, bis auf die part11. Solltest du dann mit NVF dein CWM wiederhergestellt haben?!:sad:

    Würde mich auch interessieren ob das so klappt?:razz:


    [device]
    type=nand
    instance=0


    [partition]
    name=SOS
    id=11
    type=data
    allocation_policy=sequential
    filesystem_type=basic
    size=16777216
    file_system_attribute=0
    partition_attribute=0
    allocation_attribute=8
    percent_reserved=0
    filename=part-11.img

    Nachtrag:

    Vergiss bitte den vorschlag, denn ich weiss nicht was NVF so alle macht. Vielleich löscht es alle anderen Partitionen!
     
    Zuletzt bearbeitet: 01.10.2011
  3. gurkensalat, 01.10.2011 #3
    gurkensalat

    gurkensalat Android-Hilfe.de Mitglied

    Beiträge:
    65
    Erhaltene Danke:
    7
    Registriert seit:
    11.08.2011
    Geht schon. Ich habe dir hier mal etwas zusammengebastelt: Multiupload.com - upload your files to multiple file hosting sites! Einfach entpacken und die Linux.bat starten. Dann wenn gefordert Taste drücken und gut ist. Das gute daran ist das die vorhandene Recovery Partition gespeichert wird. Wenns es nicht geklappt hat benennst du die recovery-backup.img einfach in boot.img um und startest die Linux.bat nochmal. Dann ist alles wie es jetzt ist. Warum Linux.bat weil ich zu faul war die zweckenfremdete Batchdatei umzubennen :tongue:
     
    nik-com und Monkey haben sich bedankt.
  4. SpaceyX, 01.10.2011 #4
    SpaceyX

    SpaceyX Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    2
    Registriert seit:
    15.04.2011
    huhu,

    das ist lieb von dir. ich werds morgen testen und berrichten!

    Gesendet mit der Android-Hilfe.de-App
     
  5. SpaceyX, 10.10.2011 #5
    SpaceyX

    SpaceyX Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    2
    Registriert seit:
    15.04.2011
    huhu,

    erstmal nochmal danke für deine hilfe. ich bin leider erst jetzt dazu gekommen, es zu probieren. leider hat das ganze nicht geklappt. beim download des recovery bricht er ab. ich hab mal nen screenshot gemacht. vielleicht kannst du da ja was machen :)

    danke schön :)
     

    Anhänge:

    • error.JPG
      error.JPG
      Dateigröße:
      94.7 KB
      Aufrufe:
      153
  6. SpaceyX, 10.10.2011 #6
    SpaceyX

    SpaceyX Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    2
    Registriert seit:
    15.04.2011
    @gurkensalat.

    also, irgendwie ne seltsame sache. ich hab mir das mal angeguggt und irgendwie stimmen bei mir die partitionstabellen nicht. die boot.img ist doch nur 8mb gross. als ich deine .bat laufen lies, holte er sich die part 11 vom pad, die eigentlich die sos-partition sein soll. bei mir ist die aber 250mb gross. das kanns ja nicht sein. ich hab dann nochmal ein nv-flash-backup gemacht, um mir die partionstabellen anzuguggen. das backup bricht übrigens auch bei der part 11, an gleicher stelle ab. nun, bei mir ist die sos-partion die part 9. hab dann in deiner .bat die 9er angegeben und nun läuft das recovery wieder. wie kanns denn passieren, dass es einem die partitionen durchwürfelt? hab nun aber das problem, dass ich kein nv-flash-backup mehr machen kann. kann man da irgendwas tun?
     
  7. gurkensalat, 10.10.2011 #7
    gurkensalat

    gurkensalat Android-Hilfe.de Mitglied

    Beiträge:
    65
    Erhaltene Danke:
    7
    Registriert seit:
    11.08.2011
    Ich hab erst nur deine erste Antwort gelesen und erst mal mein Pad und das Notebook flott gemacht und das Ganze nochmal in live nachgespielt :crying: Und dabei bin ich dann auch direkt auf diese 250MB Partition bei dir gestoßen. Ich habe keine Ahnung wie so etwas passieren kann. Vieleicht irgendwann mal die Partitionsgrößen geändert? Könnte mir vorstellen das es dabei die Partitionen durcheinander würfelt oder du hast einfach eines mit anderer Partitionstabelle. Scheint ja im Forum hier mehr zu geben bei denen die Partitonstabelle anderst als bei mir ist. Wenn ich überlege was und wie oft ich mein Pad schon geflasht habe ist es eigentlich ein Wunder das es noch funktioniert :tongue: Und ich wollte es schon tauschen um das bessere Display zu bekommen. Das nvflash Backup kann natürlich jetzt auch nicht funktionieren da auch das eine andere Partitionstabelle erwartet, heißt man müßte auch das anpassen. Also nimm mal folgende Batchdatei: Multiupload.com - upload your files to multiple file hosting sites! kopier die in das gleiche Verzeichnis wie die Linux.bat aus meinem vorherigen Upload und für sie aus. Danach wird eine aktuell.cfg erstellt. Wenn man die jetzt in hannsconf.cfg umbenennt und die gleichheißende Datei im nv-flash-backup Ordner überschreibt müßte es aber klappen. Wenn nicht lade mir doch mal bitte die aktuell.cfg hoch dann kann man sich mal deine aktuelle Partitionstabelle ansehen ob die vieleicht einen Fehler hat.
     
  8. SpaceyX, 10.10.2011 #8
    SpaceyX

    SpaceyX Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    2
    Registriert seit:
    15.04.2011
    huhu,

    ahso, dann weiss ich, woher es kommt. hab, als ich das pad bekommen hab, honeycomb draufgemacht. da gabs eins, das eine 259mb partition braucht. hab auch noch ein backup hier, dass ich ganz am anfang gemacht hab, da stimmen die partitionstabellen noch. also muss es honeycomb gewesen sein. ich werd das mal gleich testen und berichten... danke derweil :)
     
  9. SpaceyX, 10.10.2011 #9
    SpaceyX

    SpaceyX Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    2
    Registriert seit:
    15.04.2011
    so, hab das mal probiert. das backup bricht nach wie vor bei part11 mit nem fehler ab. ich häng dir mal meine part-tabelle an. hab auch gesehen, die hannsconf_guide.cfg ist anders aufgebaut. vielleicht guggst du mal drüber :)
     

    Anhänge:

  10. gurkensalat, 10.10.2011 #10
    gurkensalat

    gurkensalat Android-Hilfe.de Mitglied

    Beiträge:
    65
    Erhaltene Danke:
    7
    Registriert seit:
    11.08.2011
    Hmm da war ich wohl etwas voreilig. Ich hab es mir auch gerade nochmal angesehen und auch mal mit meinem Pad ausprobiert. Ja da gibt es Unterschiede und du hast definitiv zwei partitionen weniger als ich. Bin gerade am experimentieren kann aber noch etwas dauern...
     
  11. SpaceyX, 10.10.2011 #11
    SpaceyX

    SpaceyX Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    2
    Registriert seit:
    15.04.2011
    hey, keinen stress :) wenns nicht geht, dann stell ich das ursprüngliche backup wieder her und dann sollte es ja wieder gehen. titanium-backup hab ich ja, das sollt dann halb so wild sein. lass was von dir hören, wenn du was gezimmert hast :)
     
  12. gurkensalat, 11.10.2011 #12
    gurkensalat

    gurkensalat Android-Hilfe.de Mitglied

    Beiträge:
    65
    Erhaltene Danke:
    7
    Registriert seit:
    11.08.2011
    Tja ich habe auch so ne Partition! Bei mir ist es Partition 10 die ich nicht auslesen kann. Ich habe sogar die Funktion rawdeviceread von nvflash ausprobiert auch damit geht es nicht. Der meldet immer beim gleichen Sektor bad data. Laut dem einen oder anderen Forum ist dies ein Zeichen für defekte Sektoren im Nand-Speicher, welche völlig normal sind, ich kann mir das aber nicht vorstellen ansonsten hat mein Pad schon ganz schon viele defekte Sektoren. Ich habe aber festgestellt das man mit einem anderen Bootloader vieleicht zum Ziel kommen könnte nur habe ich keine Ahnung wo man den herbekommt, die die ich gefunden habe brachten keinen Erfolg.
     
  13. Murph, 12.10.2011 #13
    Murph

    Murph Fortgeschrittenes Mitglied

    Beiträge:
    390
    Erhaltene Danke:
    15
    Registriert seit:
    23.05.2010
    Hm, habt ihr inzwischen eine Lösung?
    Ich hab auch mein Recovery geschrottet. Quasi gedankenlos den ROM-Manager installiert und dann quasi damit ClockworkMod Recovery installiert. Kam dann ne Auswahl und ich hab glaub das Point Of View ausgewählt. Seit dem komm ich nicht mehr ins Recovery.

    Mit deinen angehängten Files hat es bei mir auch nicht funktioniert. Script ging nicht weiter nach "receiving file: recovery-backup.img expected size: 259784704 bytes".

    Was kann ich noch machen, damit es wieder funktioniert?

    Gruß
    Murph
     
  14. gurkensalat, 12.10.2011 #14
    gurkensalat

    gurkensalat Android-Hilfe.de Mitglied

    Beiträge:
    65
    Erhaltene Danke:
    7
    Registriert seit:
    11.08.2011
    @Murph

    Ja das CWM ist wiederhergestellt man kann nur kein Backup mit nvflash mehr von dem Pad erstellen. Ich kann aber von meinem Pad auch kein Backup machen obwohl ich nie solche Probleme hatte. Also lade bitte folgendes Archiv herunter: http://www.multiupload.com/UZLHIEDIRP Entpacke es und führe die PartTabBack.bat aus, dann wird eine aktuell.cfg erstelllt. Diese aktuell.cfg bitte hochladen, es handelt sich dabei um die Partitionstabelle. Aber ich denke es wird auch diesmal Partition 9 sein. Das in diesem Thread verlinkte CWM-Restore beschreibt Partition 11 als Recovery-Partition. Davor wird aber die alte Partition ausgelesen was bei dir scheitert. Allerdings sehe ich anhand der Größe, ca. 250MB, das es sich hierbei nicht um die Recovery-Partition handeln kann.
     
    Zuletzt bearbeitet: 12.10.2011
  15. Murph, 12.10.2011 #15
    Murph

    Murph Fortgeschrittenes Mitglied

    Beiträge:
    390
    Erhaltene Danke:
    15
    Registriert seit:
    23.05.2010
    Dein Link geht übrigens auf eine Datei aktuell.cfg. Ich hab das Archiv und die Datei aus den vorherigen Posts genommen, sollte ja das gleiche sein.

    Hier der Inhalt der aktuellen Partitionstabelle:
    Code:
    PartitionId=2
    Name=BCT
    DeviceId=19
    StartSector=0
    NumSectors=1536
    BytesPerSector=2048
    
    
    PartitionId=3
    Name=PT
    DeviceId=19
    StartSector=1536
    NumSectors=64
    BytesPerSector=2048
    
    
    PartitionId=4
    Name=EBT
    DeviceId=19
    StartSector=1600
    NumSectors=1024
    BytesPerSector=2048
    
    
    PartitionId=5
    Name=MBT
    DeviceId=19
    StartSector=2624
    NumSectors=64
    BytesPerSector=2048
    
    
    PartitionId=6
    Name=BLO
    DeviceId=19
    StartSector=2688
    NumSectors=2048
    BytesPerSector=2048
    
    
    PartitionId=7
    Name=MSC
    DeviceId=19
    StartSector=4736
    NumSectors=8192
    BytesPerSector=2048
    
    
    PartitionId=8
    Name=OGO
    DeviceId=19
    StartSector=12928
    NumSectors=16384
    BytesPerSector=2048
    
    
    PartitionId=9
    Name=SOS
    DeviceId=19
    StartSector=29312
    NumSectors=8192
    BytesPerSector=2048
    
    
    PartitionId=10
    Name=LNX
    DeviceId=19
    StartSector=37504
    NumSectors=8192
    BytesPerSector=2048
    
    
    PartitionId=11
    Name=APP
    DeviceId=19
    StartSector=45696
    NumSectors=126848
    BytesPerSector=2048
    
    
    PartitionId=12
    Name=CAC
    DeviceId=19
    StartSector=172544
    NumSectors=86656
    BytesPerSector=2048
    Und wie gehts jetzt weiter?
     
  16. gurkensalat, 12.10.2011 #16
    gurkensalat

    gurkensalat Android-Hilfe.de Mitglied

    Beiträge:
    65
    Erhaltene Danke:
    7
    Registriert seit:
    11.08.2011
    Murph bedankt sich.
  17. Murph, 12.10.2011 #17
    Murph

    Murph Fortgeschrittenes Mitglied

    Beiträge:
    390
    Erhaltene Danke:
    15
    Registriert seit:
    23.05.2010
    Super, vielen Dank! Hat perfekt funktioniert!! :)
     

Diese Seite empfehlen