1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

[ROM] Basians EpicBlue HO!NO! CM7 Mod

Dieses Thema im Forum "Custom-ROMs für Motorola Milestone" wurde erstellt von basian mile, 07.04.2011.

  1. basian mile, 07.04.2011 #1
    basian mile

    basian mile Threadstarter Android-Lexikon

    Beiträge:
    1,658
    Erhaltene Danke:
    439
    Registriert seit:
    22.02.2011
    UPDATE:
    Weiter unten auch als "Basians EpicBlue CyanogenMod 7 Mod"!!


    Nachdem ich das EpicBlue Theme erstellt habe wagte ich mich heute an eine weitere Aufgabe:

    Und zwar wollte ich den HO!NO! Mod direkt mit diesem Theme ausstatten. Das geht so einfach aber nicht, weil HO!NO! nur als Nandroid Backup erhältlich ist.

    Ich suchte nach einem Weg HO!NO! als Update zu erstellen. So wie auch z.B. CyanogenMod7.

    Nach langem hin und her habe ich es geschafft :thumbsup:

    Ich habe mir den aktuellen HO!NO! besorgt und das aktuelle CyanogenMod7. Mit "unyaffs" habe ich das "system.img" aus dem HO!NO! Mod entpackt und dann den kompletten Ordner im CyanogenMod7 damit ersetzt.

    So konnte ich Apps, Theme, Bootanimation, Sprachdateien entfernen, Schriftarten, Bulletproof, apps2ext usw. entfernen + verändern + hinzufügen.

    Somit ist diese Version ext2 ready. Denn das habe ich bereits hinzugefügt. Leider ist es mir nicht möglich gewesen, automatisch einen "sd" Ordner im System zu erstellen. Trotz das der Ordner im Update enthalten ist wird er nicht erstellt.
    Deswegen müsst ihr ihn nach dem Update anlegen und dann Neustarten. Danach sollten alle eure Apps, die sich auf der ext2 Partition liegen, angezeigt werden.
    Bei mir funktioniert das einwandfrei.

    Der App Ordner im System sieht so aus:

    Google Talk habe ich entfernt. Als Launcher wird LauncherPro verwendet. Außerdem habe ich die LiveWallpaper komplett entfernt. Braucht eh keiner. MS ist so schon voll genug :blink:
    Cardock und Email musste auch dran glauben.

    SystemUI, Settings und framework-res wurden von mir mit dem Theme ausgestattet.

    Im Ordner "\system\tts\lang_pico" habe ich nur Deutsch und Englisch belassen.

    Die "build.prop" wurde von mir nur mit dem "ro.HOME_APP_ADJ=1" (Bulletproof Launcher) ausgestattet. Da ich das "-1" nicht getestet habe und es so sehr gut läuft habe ich es auch so gelassen.

    SDCARD Speed habe ich auf 2048 gesetzt.

    Tatstatur ist bereits "QWERTZ". Danke.

    Als Bootscreen habe ich folgende genommen:

    [​IMG]

    Auch die Klingeltöne habe ich angepasst. Einige gelöscht andere zugefügt. Lasst euch überraschen. :biggrin:

    Vorteil bei HO!NO!, Google Apps sind schon enthalten. Somit braucht man keine gapps mehr zu installieren.

    Nun zum System:

    SCREENSHOTS


    DOWNLOAD

    Leicht veränderte Version. Siehe hier.

    http://www.multiupload.com/UEC50DG9AT


    Ich habe das ganze in ein RAR File gepackt. Somit konnte ich die Größe um die Hälfte (höchste Kompression) verringern. Wenn ihr es entpackt werdet ihr einen Ordner erhalten dessen Inhalt das Update beheimatet. Ab damit in den "update" Ordner der OR und dann kanns losgehen.


    Update

    "...7.0.0-RC4.1-0.08-11.04.10"

    http://www.multiupload.com/OHP4B4M8ZF

    Das Update ist fertig angepasst und kann einfach drüber gebügelt werden.
    ABER der "sd" Ordner in "system" muss wieder alle Rechte gesetzt bekommen. Dann Neustart und alle Apps werden wieder geladen.

    Bootsound habe ich angeschaltet da der perfekt zu dem verwendeten Bootsound passt.
    Wer keinen will kann ihn ausschalten:

    In "system/build.prop" den vorletzten Wert auf "0" setzen. So: "ro.config.play.bootsound=0"


    Update

    "...0.08-11.04.18"

    http://www.multiupload.com/DVXGKPZQGD

    Der "sd" Ordner in "system" muss wieder alle Rechte gesetzt bekommen.

    Ich konnte noch nicht testen, ob das Update dieses mal ohne Probleme, bei jedem Start, die ext2 Partition lädt.
    Ich hoffe es einfach.



    Update

    Basians EpicBlue HO!NO! vom 03.05.2011

    http://www.multiupload.com/E43UM6BT02


    Es wurden dieses mal 33 apks verändert und somit erstrahlen sie in neuem Glanz.

    Die wären:

    AccountAndSyncSettings
    AndroidTerm
    Bluetooth
    Browser
    Calculator
    Calendar
    CalendarProvider
    Camera
    Contacts
    ContactsProvider
    DeskClock
    framework-res
    Gallery3D
    Gmail
    GoogleCalendarSyncAdapter
    GoogleContactsSyncAdapter
    GoogleQuickSearchBox
    LatinIME
    LauncherPro
    MediaUploader
    Mms
    Music
    PackageInstaller
    Phone
    Settings
    SettingsProvider
    SetupWizard
    SoundRecorder
    SpareParts
    Stk
    Superuser
    SystemUI
    TelephonyProvider
    ------------------


    Wie immer, Nandroid erstellen und alles Wipen und dann updaten.


    Auch ich übernehme keine Haftung für irgendwas!
    Ich kann nur sagen, dass es bei mir sehr gut geklappt hat.


    ------------------------------------------------------------------------------------------------------

    Basians EpicBlue CyanogenMod 7 Mod


    Ich habe das selbe auch mit CM7 getan. Weil es mich extrem nervt, dass die ext2 Partition nur bei jedem 2ten Start erkannt wird.
    Das gilt jedenfalls für das Update vom 10.04.11 !! Das andere klappt wunderbar.

    Auch hier gilt: Viele unnötige Apps und Sprachen entfernt.
    SystemUI, Settings und framework-res wurden von mir mit dem Theme ausgestattet.
    Ich habe andere Batteriesymbole genutzt als in der oberen HO!NO!.

    Wer das Theme umfangreicher haben möchte kann einfach v3 von hier nehmen.

    [​IMG]


    Ich habe auch das Symbol geändert welches bei eingeschaltetem Alarm kommt. Es war einfach nicht schön.


    Download:

    http://www.multiupload.com/71JYNA11I4

    Gapps

    http://wiki.cyanogenmod.com/index.php?title=Latest_Version#Google_Apps




    Danke geht an: Bandit, stetsonaw und nadlabak.

    Von Bandits ModdedBlack habe ich ein paar Buttons aus der Framework-res.
    Von stetsonaw stammt der größte Teil des Themes.
    Und nadlabak hat natürlich das CM7 erstellt.

    Anregungen und Kritik bitte schreiben...
     
    Zuletzt bearbeitet: 06.05.2011
    Foxy472, motoroller, janosik und 6 andere haben sich bedankt.
  2. Soxes, 07.04.2011 #2
    Soxes

    Soxes Gast

    Mein Respekt ^^
    Scheinst ja echt fit zu sein ^^
    Aber mir gefällt der Bootscreen nicht :p
     
  3. BelleÉpoque, 07.04.2011 #3
    BelleÉpoque

    BelleÉpoque Fortgeschrittenes Mitglied

    Beiträge:
    449
    Erhaltene Danke:
    102
    Registriert seit:
    09.08.2010
    Phone:
    Samsung Galaxy S6 Edge
    Die "bootanimation.zip" kannst du ja löschen oder ändern in /system/media/!;-)

    Edit: Ähm...Ich habe zwei Batteriesymbole in der Statusleiste...

    Edit2: Ok, einmal Batterieprozentanzeige ein- und wieder ausgeschaltet, jetzt ist eine weg (so, wie es sein sollte)! Ich sollte erst denken und machen, bevor ich schreibe...

    Edit3: Schreibst du noch dazu welche Rechte bei dem Ordner /system/sd/ gesetzt werden müssen? Der hat jetzt 777, während die anderen Ordner 655 haben?! Zu viele Rechte sind mir zu doof!:p

    Edit4: Scheinbar muss man nach jedem Reboot das zweite Batteriesymbo entfernen...Kannst du mal nachschauen, was da los ist?
     
    Zuletzt bearbeitet: 07.04.2011
  4. basian mile, 07.04.2011 #4
    basian mile

    basian mile Threadstarter Android-Lexikon

    Beiträge:
    1,658
    Erhaltene Danke:
    439
    Registriert seit:
    22.02.2011
    Welche Rechte der genau haben muss, kann ich dir nicht sagen. Ich gebe ihm die selben wie z.b. system. Oder einfach alle.

    Bei mir gibt es mit dem Batteriesymbol nicht dieses Problem. Habe eben nochmal geguckt ob was falsch benannt wurde, aber das passt alles.

    Wenn ich in den cm7 settings die Prozentanzeige einschalte dann verschwindet das Symbol und es steht nur die Zahl da. So soll es, denke ich, auch sein.
    Eigentlich rennt das Teil sogar richtig gut. Ich finds geil.

    Ich lass nachher oder morgen nochmal das Update drüber laufen und gucke mal was dann kommt.
    Mehr kann ich grad nicht tun.

    Sorry für die späte Antwort. :)

    @Soxes
    Den Bootscreen kannst du natürlich, noch bevor du das ganze installierst, gerne gegen jeden beliebigen tauschen. Ich habe genug zur Auswahl.

    Gesendet mit einem Telekommunikationsgerät und passender App
     
  5. basian mile, 08.04.2011 #5
    basian mile

    basian mile Threadstarter Android-Lexikon

    Beiträge:
    1,658
    Erhaltene Danke:
    439
    Registriert seit:
    22.02.2011
    Lade gerade eine Ersatz-Version hoch.
    Habe diesal nicht in dem "META-INF" - Ordner gespielt und ihn so belassen.
    Mir fiel auf, dass mein Batterie Symbol immer ein Fragezeichen anzeigte. Das hat sich jetzt z.B. erledigt. Außerdem habe ich die Batteriesymbole die im HONO zusätzlich drin sind auch dort gelassen, auch wenn es 5er Schritte sind und nicht genutzt werden.

    Ich habe nach dem Update, meinen "Data" - Ordner aus dem vorherigen HONO zurück gespielt und es hat geklappt. Keine Probleme.
    Sollte auch mit CM7 funktionieren und anderen 2.3 Roms.
     
  6. Lud3rChri2, 08.04.2011 #6
    Lud3rChri2

    Lud3rChri2 Junior Mitglied

    Beiträge:
    42
    Erhaltene Danke:
    0
    Registriert seit:
    27.01.2011
    hallöchen zusammen ich hab mir das rom heute morgen drauf gebügelt... es geht echt gut hab bis jetzt keine bugs finden können aber was mir aufgefallen ist das der accu ratz fatz alle ist... es ist heute das erste mal seit dem ich mein steinchen hab passiert das ich keinen saft mehr im accu hatte kann das wer bestätigen ... hatte vorher cm7 drauf da bin ich den ganzen tag mit einer ladung hingekommen und mit diesem hab ich es keine 9std gehallten :huh: wie kann das ? würde gerne bei dem epic bleiben da es mir sehr gut gefällt und echt gut rennt ;)

    mfg:chris
     
  7. basian mile, 08.04.2011 #7
    basian mile

    basian mile Threadstarter Android-Lexikon

    Beiträge:
    1,658
    Erhaltene Danke:
    439
    Registriert seit:
    22.02.2011
    Danke das freut mich.
    Das mit dem Akku wird evt vom CyanogenMod7 kommen. Denn HONO nutzt jetzt auch den Kernel von CM7.

    Guck auch mal im CM7 Faden. Da wird auch über den Akkudrain gesprochen.

    Leider ist das so.

    Aber ich finde auch, dass HONO besser rennt als CM7. Ich nutze es jetzt schon länger.
     
  8. janosik, 09.04.2011 #8
    janosik

    janosik Android-Lexikon

    Beiträge:
    1,162
    Erhaltene Danke:
    535
    Registriert seit:
    28.04.2010
    Hi.
    Mein Respekt läuft 1a machst du weiter wenn neue Version kommt.
    mfg.
     
  9. basian mile, 09.04.2011 #9
    basian mile

    basian mile Threadstarter Android-Lexikon

    Beiträge:
    1,658
    Erhaltene Danke:
    439
    Registriert seit:
    22.02.2011
    Super, freut mich wirklich.

    Ich werde weiter machen. Denn ich denke, dass ich selber bei HO!NO! bleiben werde da es bei mir sehr gut läuft.

    Ich bin zufrieden damit.
     
    janosik bedankt sich.
  10. Bandit, 09.04.2011 #10
    Bandit

    Bandit Android-Guru

    Beiträge:
    3,552
    Erhaltene Danke:
    702
    Registriert seit:
    05.02.2010
    Na schau na, da kommt ja ne Nachfolge für manche Modder/ Themer. Schön, dass du dich eingearbeitet hast und fit bist :thumbsup:

    Zum ROM: Autostarts ist doch kostenpflichtig, jedenfalls die Version von Michael Elsdörfer. Falls du diese benutzt ganz schnell raus nehmen aus deiner ROM!
     
  11. basian mile, 09.04.2011 #11
    basian mile

    basian mile Threadstarter Android-Lexikon

    Beiträge:
    1,658
    Erhaltene Danke:
    439
    Registriert seit:
    22.02.2011
    Danke. Find ich gut das man da Zuspruch bekommt.
    Es ist ja am Ende die meiste Arbeit von jemand anderem.
    Denn vom Coden oder ähnlichem bin ich noch weit weg!

    Ach du schei...e! Kein Witz, hab ich net gewusst!
    Ich werde es entfernen.
     
    Zuletzt bearbeitet: 09.04.2011
  12. Bandit, 09.04.2011 #12
    Bandit

    Bandit Android-Guru

    Beiträge:
    3,552
    Erhaltene Danke:
    702
    Registriert seit:
    05.02.2010
    Ja manche Leute sind aber auch zu faul zum kopieren ;). Mehr ist nen Porten ja im Grunde nicht, sofern man nicht tiefgründiger einsteigt und auch xml/ smalis anpasst. Insofern schon gute Arbeit sich in der kurzen Zeit soviel angeeignet zu haben und in der Lage zu sein, sowas zu schaffen.

    Kein Thema. Musst nach gucken mit den Apps und auf der Hut sein.
     
  13. basian mile, 09.04.2011 #13
    basian mile

    basian mile Threadstarter Android-Lexikon

    Beiträge:
    1,658
    Erhaltene Danke:
    439
    Registriert seit:
    22.02.2011
    Jau, sag ich ja... Aber mir macht das grad Spaß. Außerdem hab ich gedacht: mmmh warum nur für mich machen!? Lass die anderen dran Teil haben.

    So erledigt. Autostarts ist wech
     
  14. noobieandroid, 09.04.2011 #14
    noobieandroid

    noobieandroid Erfahrener Benutzer

    Beiträge:
    183
    Erhaltene Danke:
    3
    Registriert seit:
    30.11.2010
    kannst du mir ein update.zip machen wo das font standart ist ?
     
  15. basian mile, 09.04.2011 #15
    basian mile

    basian mile Threadstarter Android-Lexikon

    Beiträge:
    1,658
    Erhaltene Danke:
    439
    Registriert seit:
    22.02.2011
    Ich wünschte ich könnte. Aber ich habe keine Ahnung wie!

    -FuFu- wird die Möglichkeit es per Metamorph zu tun, wahrscheinlich in seine nächste OR einbauen. Dann ist es super einfach.
     
  16. basian mile, 10.04.2011 #16
    basian mile

    basian mile Threadstarter Android-Lexikon

    Beiträge:
    1,658
    Erhaltene Danke:
    439
    Registriert seit:
    22.02.2011
    Update ist fertig! Startpost in angepasst.

    Viel Spaß!
     
    janosik bedankt sich.
  17. basian mile, 11.04.2011 #17
    basian mile

    basian mile Threadstarter Android-Lexikon

    Beiträge:
    1,658
    Erhaltene Danke:
    439
    Registriert seit:
    22.02.2011
    Hat hier noch jemand das folgende Problem?

    Seit dem Update habe ich das Problem, dass nach jedem Neustart die ext2 nicht gemountet wird. Starte ich dann nochmal neu, ist sie aktiv.
    Ich wüsste schon gern warum das so ist.
     
  18. janosik, 11.04.2011 #18
    janosik

    janosik Android-Lexikon

    Beiträge:
    1,162
    Erhaltene Danke:
    535
    Registriert seit:
    28.04.2010
    Ich gute frage hab auch alles ausprobiert ohne Erfolg.
     
  19. basian mile, 11.04.2011 #19
    basian mile

    basian mile Threadstarter Android-Lexikon

    Beiträge:
    1,658
    Erhaltene Danke:
    439
    Registriert seit:
    22.02.2011
    Mit CM7 gibt es das Problem übrigens nicht. Läuft ohne Problem sofort mit ext2 an. Deswegen habe ich eben auch ein CM7 EpicBlue erstellt. Hat da jemand interesse dran?

    Gesendet mit einem Telekommunikationsgerät und passender App
     
  20. janosik, 11.04.2011 #20
    janosik

    janosik Android-Lexikon

    Beiträge:
    1,162
    Erhaltene Danke:
    535
    Registriert seit:
    28.04.2010
    Ja.
    mfg.
     

Diese Seite empfehlen