1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Root für 2.1!

Dieses Thema im Forum "Anleitungen für das Xperia X10 Mini / Mini Pro" wurde erstellt von Cirra, 01.11.2010.

  1. Cirra, 01.11.2010 #1
    Cirra

    Cirra Threadstarter Erfahrener Benutzer

    Beiträge:
    211
    Erhaltene Danke:
    52
    Registriert seit:
    04.06.2010
    3.7.2012: Der Anhang "z4root 1.3.0.zip" wurde entfernt da er einen Trojaner enthalten hat.

    Nabend :)

    um euer Mini mit Android 2.1 zu rooten einfach den folgenden Anhang runterladen und entpacken.
    Nicht vergessen USB Debugging zu aktivieren.
    SuperOneClick.exe starten und auf "Root" klicken.

    Dann heißt es warten :)
    Laut XDA Forum kann es bis zu 10 Minuten dauern.
    Die Meldung die immer aufploppt wie ihr euer Telefon per USB anschließen wollt könnt ihr ignorieren.
    Sollte es trotz einiger Wartezeit (+-10 Minuten) nicht erfolgreich gerootet werden könnt ihr probieren einfach das USB Debugging aus- und anzuschalten
    Geduld heißt das Zauberwort :thumbup:


    2.1 Rooted Nordic FW - xda-developers <- Der Link zum Original

    UPDATE1
    viel einfacher geht es mit dem tool z4root. einfach aus dem market laden und auf root klicken. sollte es nicht nach 1-2 minuten klappen ruhig mal das handy neustarten.(ab Post 32)

    UPDATE2
    (z4Root nicht mehr im Market,deshalb angehangen)

    UPDATE3
    Firmware: 2.0.2.A.0.24 Rooten (ab Post 62)
     

    Anhänge:

    Zuletzt von einem Moderator bearbeitet: 16.01.2011
    andten, fts, dennis46419 und 9 andere haben sich bedankt.
  2. Bueffel, 01.11.2010 #2
    Bueffel

    Bueffel Android-Hilfe.de Mitglied

    Beiträge:
    143
    Erhaltene Danke:
    77
    Registriert seit:
    16.03.2010
    Danke! :)
    Läuft zwar etwas holperig und funktionierte bei mir erst im zweiten Anlauf, aber funktioniert! :D
     
  3. ProgrammierTier, 01.11.2010 #3
    ProgrammierTier

    ProgrammierTier Android-Hilfe.de Mitglied

    Beiträge:
    89
    Erhaltene Danke:
    28
    Registriert seit:
    20.10.2010
    Phone:
    Zenfone 2 ZE551ML 4Gb 2.3Ghz
    M.Starke bedankt sich.
  4. M.Starke, 01.11.2010 #4
    M.Starke

    M.Starke Gewerbliches Mitglied

    Beiträge:
    1,280
    Erhaltene Danke:
    565
    Registriert seit:
    21.10.2009
    Danke erst einmal für das Thema.
    Ich bin gerade beim Testen.

    Liebe Grüße.
     
  5. Cirra, 01.11.2010 #5
    Cirra

    Cirra Threadstarter Erfahrener Benutzer

    Beiträge:
    211
    Erhaltene Danke:
    52
    Registriert seit:
    04.06.2010
  6. Nasetony, 01.11.2010 #6
    Nasetony

    Nasetony Android-Hilfe.de Mitglied

    Beiträge:
    144
    Erhaltene Danke:
    28
    Registriert seit:
    21.09.2010
    Phone:
    Huawei P9
    Hat Perfekt geklappt vielen dank
     
  7. Munchkin1988, 01.11.2010 #7
    Munchkin1988

    Munchkin1988 Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    29.10.2010
    Phone:
    Sony Ericsson Xperia X10 Mini Pro
    Mein Mini kann ankommen xD alles für Root und debrand angeschaut und (denke ich zumindest) verstanden :D
     
  8. pukidukie, 01.11.2010 #8
    pukidukie

    pukidukie Fortgeschrittenes Mitglied

    Beiträge:
    280
    Erhaltene Danke:
    25
    Registriert seit:
    16.06.2010
    bei xda dev gibt es eine ganz einfache Lösung, aber dauert eine Weile/ ein paar Anläufe.
     
  9. ronny33, 01.11.2010 #9
    ronny33

    ronny33 Android-Lexikon

    Beiträge:
    1,286
    Erhaltene Danke:
    214
    Registriert seit:
    25.06.2010
    Phone:
    Huawei Mate S,Huawei P8
    Hey,

    Diese Thema gibt es bereits wie Cirra netterweise schon andeutete.
    und sogar im richtigen Bereich;)


    Ich verschiebe das Thema mal nach,

    Root / Hacking / Modding für Xperia X10 Mini / Mini Pro

    und habe mal beide Threads zusammen geführt.

    Und da das Thema in den nächsten Tagen wohl auch sehr populär sein wird gleich noch oben angespinnt damit es auch jeder gleich findet.;)

    LG
     
    Zuletzt bearbeitet: 01.11.2010
  10. ilovemoney, 01.11.2010 #10
    ilovemoney

    ilovemoney Fortgeschrittenes Mitglied

    Beiträge:
    414
    Erhaltene Danke:
    81
    Registriert seit:
    11.08.2010
    Phone:
    Samsung Galaxy S6 Edge
    Tablet:
    Lenovo IdeaPad Yoga 8
    Nabend,

    hier mal mein log:
    Killing ADB Server...

    OK

    Starting ADB Server...
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *

    OK

    Waiting for device...

    OK

    Pushing rageagainstthecage...
    414 KB/s (5392 bytes in 0.012s)

    OK

    chmod rageagainstthecage...

    OK

    Running rageagainstthecage...
    OK

    Killing ADB Server...

    OK

    Starting ADB Server...
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *

    OK

    Waiting for device...

    OK

    Running rageagainstthecage...
    OK

    Killing ADB Server...

    OK

    Starting ADB Server...
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *

    OK

    Waiting for device...

    Und da hängt er nun seit gut 30 Minuten!

    Jemand eine idee?

    Lösung, so hab das Problem gelöst. USB Debugging deaktiviert und wieder Aktiviert und dann hat es geklappt.
     
    Zuletzt bearbeitet: 01.11.2010
  11. reave1992, 02.11.2010 #11
    reave1992

    reave1992 Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    01.11.2010
    @ilovemoney
    Wo lag der Fehler :/ ?
     
    Zuletzt von einem Moderator bearbeitet: 02.11.2010
  12. ProgrammierTier, 02.11.2010 #12
    ProgrammierTier

    ProgrammierTier Android-Hilfe.de Mitglied

    Beiträge:
    89
    Erhaltene Danke:
    28
    Registriert seit:
    20.10.2010
    Phone:
    Zenfone 2 ZE551ML 4Gb 2.3Ghz
    Läuft sehr holprig. 3 Versuche, beim dritten mit mehrfachem Debug off/on. Dann fror nach 5 min das Prog ein, musste über Taskmanager gekillt werden. Nach Neustart dann die Meldung, dass das Phone bereits gerootet ist.

    Thx & sG,
    das ProgrammierTier
     
    Zuletzt bearbeitet: 02.11.2010
  13. tbbmx200, 02.11.2010 #13
    tbbmx200

    tbbmx200 Android-Hilfe.de Mitglied

    Beiträge:
    114
    Erhaltene Danke:
    12
    Registriert seit:
    24.08.2009
    Phone:
    Sony Xperia X
    ich hatte gestern auch diese endlosschleife,hab dann mal folgendes ausprobiert:

    1.- Activate USB debugin (phone)
    2.- Connect the phone to PC.
    3.- Check new HSUSB driver in device manager. If not properly installed, yo will see the tipical exclamation mark.
    4.- Install PC Companion (touch the phone) middle button. This pc companion is not las version and must be updated again (driver is missing yet!).
    5.- Close PC companion. Start it again. Now, update as requested!.
    6.- Check device manager: Now adb driver is installed properly.
    7.- Excute SuperOneClick. Works like a charm!

    2.1 Root Method - Working on Nordic FW - Page 15 - xda-developers

    danach gings ohne probleme innerhalb von sekunden.
     
    hasenheide und wöba haben sich bedankt.
  14. bodensee8, 04.11.2010 #14
    bodensee8

    bodensee8 Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    7
    Registriert seit:
    04.11.2010
    Phone:
    HTC Sensation
    So nun habe ich es auch getan.. und..... die probleme gehen los....
    kann nicht rooten.....
    kann nicht die datei austauschen um die tastatur wieder richtig benutzen zu können, weil der PC Companion mich nicht auf mein handy lässt....
    was soll ich nun machen???
    ach ja, hab des X10 mini pro und nutze einen mac mit paralells....
    hiiilllffeee
     
  15. Cirra, 04.11.2010 #15
    Cirra

    Cirra Threadstarter Erfahrener Benutzer

    Beiträge:
    211
    Erhaltene Danke:
    52
    Registriert seit:
    04.06.2010
    mein glaskugel sagt mir das es morgen regnen wird.

    fehler wieso nicht gerootet wird? und kann man mit dem se comp dings überhaupt in die system folder? und selbst wenn du musst die system folder rw mounten.
     
  16. bodensee8, 04.11.2010 #16
    bodensee8

    bodensee8 Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    7
    Registriert seit:
    04.11.2010
    Phone:
    HTC Sensation
    ja wenn ich das wüsste....
    im superoneclick kommt immer nur "failed"
    oder es hängt sich auf...
    würde ja gerne den system-ordner rw mounten, aber des geht ja erst wenn gerooted ist :(
     
  17. Cirra, 05.11.2010 #17
    Cirra

    Cirra Threadstarter Erfahrener Benutzer

    Beiträge:
    211
    Erhaltene Danke:
    52
    Registriert seit:
    04.06.2010
    sicher das es sich aufhängt? einfach mal die finger von der maus lassen und warten.
     
  18. bodensee8, 05.11.2010 #18
    bodensee8

    bodensee8 Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    7
    Registriert seit:
    04.11.2010
    Phone:
    HTC Sensation
    Ja es hing tatsächlich, habs die ganze nacht drangelassen, aber ging nix.
    nun war ich vorhin bei einem freun mit einem normalen PC und siehe da alles hat geklappt und ich hab mein baby wieder ;)
    danke nochmal an alle.
    und vor allem an M.Starke, sein tip mit dem pc hat es gebracht.
    Danke
     
  19. uepzilon, 05.11.2010 #19
    uepzilon

    uepzilon Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    0
    Registriert seit:
    15.10.2010
    Also bei mir tut sich nichts. Auch nach mehrmaligem debug on/off und so.

    Es ist doch richtig das ich diese Beschreibung für ein original X10 mini pro verwenden kann, oder hab ich was überlesen?

    Super one click auf dem PC installiert - - starten - - root drücken - - warten....
     
  20. mzmz83, 05.11.2010 #20
    mzmz83

    mzmz83 Android-Experte

    Beiträge:
    510
    Erhaltene Danke:
    123
    Registriert seit:
    08.07.2010
    Wichtig ist auch das du die richtigen Treiber installiert hast.
    Sonst kommt es zu keiner Verbindung.
     

Diese Seite empfehlen